]> git.pld-linux.org Git - packages/waf.git/blob - waf.spec
up to 1.8.7
[packages/waf.git] / waf.spec
1 Summary:        The Waf build system
2 Summary(pl.UTF-8):      System budowania Waf
3 Name:           waf
4 Version:        1.8.7
5 Release:        1
6 # note: waf book is on CC-BY-NC-ND (not included in binary package)
7 License:        BSD
8 Group:          Development/Building
9 #Source0Download: http://code.google.com/p/waf/downloads/list
10 Source0:        ftp://ftp.waf.io/pub/release/%{name}-%{version}.tar.bz2
11 # Source0-md5:  223962fea8e8bfac6b259f1bd1c7b27b
12 Patch0:         %{name}-path.patch
13 URL:            http://code.google.com/p/waf/
14 BuildRequires:  python >= 1:2.6
15 BuildRequires:  python-modules >= 1:2.6
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.234
18 Requires:       python(abi) = %{py_ver}
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Waf is a general-purpose build system which was modelled from Scons.
24 Though it comes last in the arena of the build systems, we believe
25 that Waf is a vastly superior alternative to its competitors
26 (Autotools, Scons, Cmake, Ant, etc) for building software,
27
28 %description -l pl.UTF-8
29 Waf to system budowania ogólnego przeznaczenia opracowany na podstawie
30 Scons. Mimo że pojawił się jako ostatni na arenie systemów budowania,
31 autorzy wierzą, że przewyższa alternatywne narzędzia (Autotools,
32 Scons, Cmake, Ant itp.).
33
34 %prep
35 %setup -q
36 %patch0 -p1
37
38 %build
39 # check waf-light
40 extras=
41 for f in waflib/extras/*.py ; do
42         tool=$(basename "$f" .py)
43         if [ "$tool" != "__init__" ]; then
44                 extras="${extras:+$extras,}$tool"
45         fi
46 done
47 ./waf-light --make-waf --strip --tools="$extras"
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{_datadir}/waf/waflib/{Tools,extras}
52
53 cp -p waflib/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib
54 cp -p waflib/Tools/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/Tools
55 cp -p waflib/extras/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/extras
56
57 install -D -p waf-light $RPM_BUILD_ROOT%{_bindir}/waf
58
59 %py_comp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
60 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc ChangeLog README TODO
68 %attr(755,root,root) %{_bindir}/waf
69 %{_datadir}/waf
This page took 0.329274 seconds and 4 git commands to generate.