]> git.pld-linux.org Git - packages/waf.git/blob - waf.spec
a2895a2c4cfffe10c3a69af8881c06d4bd3b709b
[packages/waf.git] / waf.spec
1 Summary:        The Waf build system
2 Summary(pl.UTF-8):      System budowania Waf
3 Name:           waf
4 Version:        1.9.4
5 Release:        1
6 # note: waf book is on CC-BY-NC-ND (not included in binary package)
7 License:        BSD
8 Group:          Development/Building
9 Source0:        http://waf.io/%{name}-%{version}.tar.bz2
10 # Source0-md5:  a6b1a3e10411732e7af7f91eab6e0985
11 Patch0:         %{name}-path.patch
12 URL:            http://waf.io/
13 BuildRequires:  python >= 1:2.6
14 BuildRequires:  python-modules >= 1:2.6
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.234
17 Requires:       python(abi) = %{py_ver}
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Waf is a general-purpose build system which was modelled from Scons.
23 Though it comes last in the arena of the build systems, we believe
24 that Waf is a vastly superior alternative to its competitors
25 (Autotools, Scons, Cmake, Ant, etc) for building software,
26
27 %description -l pl.UTF-8
28 Waf to system budowania ogólnego przeznaczenia opracowany na podstawie
29 Scons. Mimo że pojawił się jako ostatni na arenie systemów budowania,
30 autorzy wierzą, że przewyższa alternatywne narzędzia (Autotools,
31 Scons, Cmake, Ant itp.).
32
33 %prep
34 %setup -q
35 %patch0 -p1
36
37 %build
38 # check waf-light
39 extras=
40 for f in waflib/extras/*.py ; do
41         tool=$(basename "$f" .py)
42         if [ "$tool" != "__init__" ]; then
43                 extras="${extras:+$extras,}$tool"
44         fi
45 done
46 ./waf-light --make-waf --strip --tools="$extras"
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{_datadir}/waf/waflib/{Tools,extras}
51
52 cp -p waflib/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib
53 cp -p waflib/Tools/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/Tools
54 cp -p waflib/extras/*.py $RPM_BUILD_ROOT%{_datadir}/waf/waflib/extras
55
56 install -D -p waf-light $RPM_BUILD_ROOT%{_bindir}/waf
57
58 %py_comp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
59 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/waf/waflib
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc ChangeLog README.md
67 %attr(755,root,root) %{_bindir}/waf
68 %{_datadir}/waf
This page took 0.0685 seconds and 2 git commands to generate.