]> git.pld-linux.org Git - packages/vtun.git/blob - vtun.spec
- updated pl description
[packages/vtun.git] / vtun.spec
1 #
2 # Conditional build:
3 %bcond_without  ssl     # build without encryption ability
4 #
5 Summary:        Virtual tunnel over TCP/IP networks
6 Summary(pl):    Wirtualne tunele poprzez sieci TCP/IP
7 Name:           vtun
8 Version:        2.6
9 Release:        2
10 Epoch:          2
11 License:        GPL
12 Group:          Networking/Daemons
13 Vendor:         Maxim Krasnyansky <max_mk@yahoo.com>
14 # Source0-md5:  309534fd03c5d13a19c43916f61f4bbf
15 Source0:        http://dl.sourceforge.net/vtun/%{name}-%{version}.tar.gz
16 Source1:        %{name}.init
17 Source2:        %{name}.sysconfig
18 Patch0:         %{name}-makefile.patch
19 Patch1:         %{name}-expect.patch
20 Patch2:         %{name}-autoheader.patch
21 Patch3:         %{name}-getpt.patch
22 Patch4:         %{name}-sslauth.patch
23 Patch5:         %{name}-ac.patch
24 URL:            http://vtun.sourceforge.net/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  bison
28 BuildRequires:  flex
29 BuildRequires:  lzo-devel
30 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
31 BuildRequires:  zlib-devel
32 PreReq:         rc-scripts
33 Requires(post,preun):   /sbin/chkconfig
34 Obsoletes:      vppp
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _localstatedir  /var
38
39 %description
40 VTun provides the method for creating Virtual Tunnels over TCP/IP
41 networks and allows to shape, compress, encrypt traffic in that
42 tunnels. Supported type of tunnels are: PPP, IP, Ethernet and most of
43 other serial protocols and programs. VTun is easily and highly
44 configurable, it can be used for various network task like VPN, Mobil
45 IP, Shaped Internet access, IP address saving, etc. It is completely
46 user space implementation and does not require modification to any
47 kernel parts. You need SSLeay-devel and lzo-devel to build it.
48
49 %description -l pl
50 VTun umo¿liwia tworzenie tuneli poprzez sieci TCP/IP wraz
51 z przydzielaniem pasma, kompresj±, szyfrowaniem danych w tunelach.
52 Wspierane typy tuneli to: PPP, IP, Ethernet i wiêkszo¶æ pozosta³ych
53 protoko³ów szeregowych. VTun jest ³atwy i elastyczny w konfiguracji.
54 Mo¿e zostaæ wykorzystany do takich sieciowych zastosowañ jak VPN, 
55 Mobil IP, ³±cza o okre¶lonym pa¶mie oraz innych. Dzia³a w warstwie
56 user space, wiêc nie wymaga dodatkowego wsparcia w j±drze.
57
58 %prep
59 %setup -q -n vtun
60 %patch2 -p1
61 %patch5 -p1
62 # must be ported
63 #%%patch4 -p1
64
65 %build
66 cp -f /usr/share/automake/config.* .
67 # aclocal.m4 is only local, don't try to rebuild
68 %{__autoheader}
69 %{__autoconf}
70 %configure \
71         %{?with_ssl:--with-crypto-headers=%{_includedir}/openssl} \
72         %{!?with_ssl:--disable-ssl} \
73         --enable-lzo
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
79         $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_localstatedir}/log/vtun}
80
81 %{__make} install \
82         DESTDIR=$RPM_BUILD_ROOT \
83         INSTALL_OWNER=""
84
85 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/vtund
86 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/vtun
87 touch $RPM_BUILD_ROOT%{_sysconfdir}/vtund.conf
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post
93 /sbin/chkconfig --add vtund
94 if [ -f /var/lock/subsys/vtund ]; then
95         /etc/rc.d/init.d/vtund restart >&2
96 else
97         echo "Run \"/etc/rc.d/init.d/vtund start\" to start vtun daemons."
98 fi
99
100 %preun
101 if [ "$1" = "0" ]; then
102         if [ -f /var/lock/subsys/vtund ]; then
103                 /etc/rc.d/init.d/vtund stop >&2
104         fi
105         /sbin/chkconfig --del vtund
106 fi
107
108 %files
109 %defattr(644,root,root,755)
110 %doc ChangeLog Credits README README.Setup README.Shaper FAQ TODO vtund.conf
111 %attr(754,root,root) /etc/rc.d/init.d/vtund
112 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/vtun
113 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vtund.conf
114 %attr(755,root,root) %{_sbindir}/vtund
115 %attr(755,root,root) %dir /var/log/vtund
116 %{_mandir}/man*/*
This page took 0.066158 seconds and 4 git commands to generate.