]> git.pld-linux.org Git - packages/vtun.git/blob - vtun.spec
- adapterized.
[packages/vtun.git] / vtun.spec
1 Summary:        Virtual tunnel over TCP/IP networks
2 Name:           vtun
3 Version:        2.3
4 Release:        1
5 License:        GPL
6 Group:          Networking/Daemons
7 Group(de):      Netzwerkwesen/Server
8 Group(pl):      Sieciowe/Serwery
9 Vendor:         Maxim Krasnyansky <max_mk@yahoo.com>
10 Source0:        ftp://vtun.sourceforge.net/pub/vtun/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 Patch0:         %{name}-makefile.patch
13 URL:            http://vtun.sourceforge.net/
14 BuildRequires:  openssl-devel
15 BuildRequires:  zlib-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17 Obsoletes:      vppp
18
19 %define         _localstatedir  /var
20
21 %description
22 VTun provides the method for creating Virtual Tunnels over TCP/IP
23 networks and allows to shape, compress, encrypt traffic in that
24 tunnels. Supported type of tunnels are: PPP, IP, Ethernet and most of
25 other serial protocols and programs. VTun is easily and highly
26 configurable, it can be used for various network task like VPN, Mobil
27 IP, Shaped Internet access, IP address saving, etc. It is completely
28 user space implementation and does not require modification to any
29 kernel parts. You need SSLeay-devel and lzo-devel to build it.
30
31 %prep
32 %setup -q
33 %patch -p1
34 %build
35 %configure \
36         --with-crypto-headers=%{_includedir}/openssl \
37         --enable-lzo
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
43         $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{_localstatedir}/log/vtun}
44
45 %{__make} install DESTDIR=$RPM_BUILD_ROOT
46
47 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/vtund
48
49 gzip -9nf ChangeLog Credits README README.Setup README.Shaper FAQ TODO
50
51 %post
52 /sbin/chkconfig --add vtund
53 if [ -f /var/lock/subsys/vtund ]; then
54         /etc/rc.d/init.d/vtund restart >&2
55 else
56         echo "Run \"/etc/rc.d/init.d/vtund start\" to start vtun daemons."
57 fi
58
59 %preun
60 if [ "$1" = "0" ]; then
61         if [ -f /var/lock/subsys/vtund ]; then
62                 /etc/rc.d/init.d/vtund stop >&2
63         fi
64         /sbin/chkconfig --del vtund
65 fi
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc {ChangeLog,Credits,README,README.Setup,README.Shaper,FAQ,TODO}.gz
73 %attr(754,root,root) %{_sysconfdir}/rc.d/init.d/vtund
74 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/vtund.conf
75 %attr(755,root,root) %{_sbindir}/vtund
76 %attr(755,root,root) %dir /var/log/vtund
77 %{_mandir}/man*/*
This page took 0.107579 seconds and 4 git commands to generate.