]> git.pld-linux.org Git - packages/vsftpd.git/commitdiff
- up to 3.0.4 auto/th/vsftpd-3.0.4-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 3 Oct 2021 18:35:27 +0000 (20:35 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 3 Oct 2021 18:35:27 +0000 (20:35 +0200)
- fix implicit enum conversion in str_open
- remove Werror due to use of deprecated openssl api

fix-str_open.patch [new file with mode: 0644]
vsftpd-amd64-findlibs.patch
vsftpd.spec

diff --git a/fix-str_open.patch b/fix-str_open.patch
new file mode 100644 (file)
index 0000000..0c17d23
--- /dev/null
@@ -0,0 +1,28 @@
+diff -ruN vsftpd-3.0.3.orig/sysstr.c vsftpd-3.0.3/sysstr.c
+--- vsftpd-3.0.3.orig/sysstr.c 2020-11-17 09:47:03.872923383 +0100
++++ vsftpd-3.0.3/sysstr.c      2020-11-17 09:48:41.219754145 +0100
+@@ -74,19 +74,11 @@
+ int
+ str_open(const struct mystr* p_str, const enum EVSFSysStrOpenMode mode)
+ {
+-  enum EVSFSysUtilOpenMode open_mode = kVSFSysUtilOpenUnknown;
+-  switch (mode)
+-  {
+-    case kVSFSysStrOpenReadOnly:
+-      open_mode = kVSFSysUtilOpenReadOnly;
+-      break;
+-    case kVSFSysStrOpenUnknown:
+-      /* Fall through */
+-    default:
+-      bug("unknown mode value in str_open");
+-      break;
+-  }
+-  return vsf_sysutil_open_file(str_getbuf(p_str), open_mode);
++  if (mode == kVSFSysStrOpenReadOnly)
++    return vsf_sysutil_open_file(str_getbuf(p_str), kVSFSysUtilOpenReadOnly);
++
++  bug("unknown mode value in str_open");
++  return -1;
+ }
+ int
index 67b22b4ab6c6dd3c6496a273ab50c3db7e852d35..d286921fbd624cc8ab3f7f72b4ddb5b33b4ec527 100644 (file)
@@ -1,10 +1,11 @@
---- vsftpd-2.3.1/vsf_findlibs.sh~      2009-10-19 04:05:21.000000000 +0200
-+++ vsftpd-2.3.1/vsf_findlibs.sh       2010-09-15 10:09:12.543414001 +0200
-@@ -13,7 +13,6 @@
+diff -urNp -x '*.orig' vsftpd-3.0.2.org/vsf_findlibs.sh vsftpd-3.0.2/vsf_findlibs.sh
+--- vsftpd-3.0.2.org/vsf_findlibs.sh   2012-03-28 04:17:41.000000000 +0200
++++ vsftpd-3.0.2/vsf_findlibs.sh       2021-10-03 20:23:24.589487997 +0200
+@@ -13,7 +13,6 @@ fi
  # Look for PAM (done weirdly due to distribution bugs (e.g. Debian) or the
  # crypt library.
  if find_func pam_start sysdeputil.o; then
 -  locate_library /lib/libpam.so.0 && echo "/lib/libpam.so.0";
    locate_library /usr/lib/libpam.so && echo "-lpam";
    locate_library /usr/lib64/libpam.so && echo "-lpam";
-   # HP-UX ends shared libraries with .sl
+   locate_library /lib/x86_64-linux-gnu/libpam.so.0 && echo "-lpam";
index c8b92d0ce24b9eeb1f620a436b8183b5310afb7c..c16a3632b2d2b7e3a148c9258be1d6f642c74850 100644 (file)
@@ -9,12 +9,12 @@ Summary:      vsftpd - Very Secure FTP Daemon
 Summary(pl.UTF-8):     Bardzo Bezpieczny Demon FTP
 Summary(pt_BR.UTF-8):  vsftpd - Daemon FTP Muito Seguro
 Name:          vsftpd
-Version:       3.0.2
-Release:       5
+Version:       3.0.4
+Release:       1
 License:       GPL v2
 Group:         Daemons
 Source0:       https://security.appspot.com/downloads/%{name}-%{version}.tar.gz
-# Source0-md5: 8b00c749719089401315bd3c44dddbb2
+# Source0-md5: 29499699e1aa85ae5fce77b9eca90826
 Source1:       %{name}.inetd
 Source2:       %{name}.pamd
 Source3:       %{name}-ftpusers
@@ -26,6 +26,7 @@ Patch1:               %{name}-amd64-findlibs.patch
 Patch2:                %{name}-clamav.patch
 Patch3:                %{name}-switch_sha256_to_sha1.patch
 Patch4:                %{name}-findlibs-egrep.patch
+Patch5:                fix-str_open.patch
 URL:           https://security.appspot.com/vsftpd.html
 BuildRequires: libcap-devel
 BuildRequires: libwrap-devel
@@ -42,7 +43,7 @@ Provides:     ftpserver
 Conflicts:     man-pages < 1.51
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define        specflags       -fpie -pipe -Wextra -Werror
+%define        specflags       -fpie -pipe -Wextra
 
 %description
 A Very Secure FTP Daemon - written from scratch - by Chris "One Man
@@ -102,6 +103,7 @@ Ten pakiet pozwala na wystartowanie vsftpd jako samodzielnego demona.
 %patch3 -p1
 %endif
 %patch4 -p1
+%patch5 -p1
 
 %build
 %{__make} \
This page took 0.063212 seconds and 4 git commands to generate.