]> git.pld-linux.org Git - packages/vim.git/commitdiff
- new auto/ac/vim-6_3_090-1
authorAdam Gołębiowski <adamg@pld-linux.org>
Mon, 3 Oct 2005 19:53:30 +0000 (19:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    6.3.087 -> 1.1
    6.3.088 -> 1.1
    6.3.089 -> 1.1
    6.3.090 -> 1.1

6.3.087 [new file with mode: 0644]
6.3.088 [new file with mode: 0644]
6.3.089 [new file with mode: 0644]
6.3.090 [new file with mode: 0644]

diff --git a/6.3.087 b/6.3.087
new file mode 100644 (file)
index 0000000..ab0e4fb
--- /dev/null
+++ b/6.3.087
@@ -0,0 +1,53 @@
+To: vim-dev@vim.org
+Subject: Patch 6.3.087
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=ISO-8859-1
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 6.3.087
+Problem:    MS-DOS: Crash. (Jason Hood)
+Solution:   Don't call fname_case() with a NULL pointer.
+Files:     src/ex_cmds.c
+
+
+*** ../vim-6.3.086/src/ex_cmds.c       Thu Jan 13 17:38:30 2005
+--- src/ex_cmds.c      Thu Jul 21 22:23:54 2005
+***************
+*** 2613,2619 ****
+  # ifdef USE_LONG_FNAME
+       if (USE_LONG_FNAME)
+  # endif
+!          fname_case(sfname, 0);   /* set correct case for short file name */
+  #endif
+  
+  #ifdef FEAT_LISTCMDS
+--- 2613,2620 ----
+  # ifdef USE_LONG_FNAME
+       if (USE_LONG_FNAME)
+  # endif
+!          if (sfname != NULL)
+!              fname_case(sfname, 0);   /* set correct case for sfname */
+  #endif
+  
+  #ifdef FEAT_LISTCMDS
+*** ../vim-6.3.086/src/version.c       Fri Jul 29 09:59:24 2005
+--- src/version.c      Sun Sep 25 13:12:44 2005
+***************
+*** 643,644 ****
+--- 643,646 ----
+  {   /* Add new patch number below this line */
++ /**/
++     87,
+  /**/
+
+-- 
+MESKIMEN'S LAW
+    There's never time to do it right, but always time to do it over.
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net   \\\
+///        Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\              Project leader for A-A-P -- http://www.A-A-P.org        ///
+ \\\     Buy LOTR 3 and help AIDS victims -- http://ICCF.nl/lotr.html   ///
diff --git a/6.3.088 b/6.3.088
new file mode 100644 (file)
index 0000000..c6cab4b
--- /dev/null
+++ b/6.3.088
@@ -0,0 +1,71 @@
+To: vim-dev@vim.org
+Subject: Patch 6.3.088
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=ISO-8859-1
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 6.3.088
+Problem:    Editing ".in" causes error E218. (Stefan Karlsson)
+Solution:   Require some characters before ".in".  Same for ".orig" and others.
+Files:     runtime/filetype.vim
+
+
+*** ../vim-6.3.087/runtime/filetype.vim        Sun Sep 25 15:07:27 2005
+--- runtime/filetype.vim       Sun Sep 25 15:06:27 2005
+***************
+*** 16,22 ****
+  augroup filetypedetect
+  
+  " Ignored extensions
+! au BufNewFile,BufRead *.orig,*.bak,*.old,*.new,*.rpmsave,*.rpmnew
+       \ exe "doau filetypedetect BufRead " . expand("<afile>:r")
+  au BufNewFile,BufRead *~
+       \ let s:name = expand("<afile>") |
+--- 16,22 ----
+  augroup filetypedetect
+  
+  " Ignored extensions
+! au BufNewFile,BufRead ?\+.orig,?\+.bak,?\+.old,?\+.new,?\+.rpmsave,?\+.rpmnew
+       \ exe "doau filetypedetect BufRead " . expand("<afile>:r")
+  au BufNewFile,BufRead *~
+       \ let s:name = expand("<afile>") |
+***************
+*** 26,32 ****
+       \ endif |
+       \ unlet s:name |
+       \ unlet s:short
+! au BufNewFile,BufRead *.in
+       \ if expand("<afile>:t") != "configure.in" |
+       \   exe "doau filetypedetect BufRead " . expand("<afile>:r") |
+       \ endif
+--- 26,32 ----
+       \ endif |
+       \ unlet s:name |
+       \ unlet s:short
+! au BufNewFile,BufRead ?\+.in
+       \ if expand("<afile>:t") != "configure.in" |
+       \   exe "doau filetypedetect BufRead " . expand("<afile>:r") |
+       \ endif
+*** ../vim-6.3.087/src/version.c       Sun Sep 25 15:07:52 2005
+--- src/version.c      Sun Sep 25 13:17:51 2005
+***************
+*** 643,644 ****
+--- 643,646 ----
+  {   /* Add new patch number below this line */
++ /**/
++     88,
+  /**/
+
+-- 
+CRONE:  Who sent you?
+ARTHUR: The Knights Who Say Ni!
+CRONE:  Aaaagh!  (she looks around in rear) No!  We have no shrubberies here.
+                 "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net   \\\
+///        Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\              Project leader for A-A-P -- http://www.A-A-P.org        ///
+ \\\     Buy LOTR 3 and help AIDS victims -- http://ICCF.nl/lotr.html   ///
diff --git a/6.3.089 b/6.3.089
new file mode 100644 (file)
index 0000000..5110fa0
--- /dev/null
+++ b/6.3.089
@@ -0,0 +1,75 @@
+To: vim-dev@vim.org
+Subject: Patch 6.3.089
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=ISO-8859-1
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 6.3.089
+Problem:    A session file doesn't work when created while the current
+           directory contains a space or the directory of the session files
+           contains a space. (Paolo Giarrusso)
+Solution:   Escape spaces with a backslash.
+Files:     src/ex_docmd.c
+
+
+*** ../vim-6.3.088/src/ex_docmd.c      Sun Feb 13 20:46:05 2005
+--- src/ex_docmd.c     Wed Sep 28 14:54:14 2005
+***************
+*** 8631,8645 ****
+       */
+      if (ssop_flags & SSOP_SESDIR)
+      {
+!      if (put_line(fd, "exe \"cd \" . expand(\"<sfile>:p:h\")") == FAIL)
+           return FAIL;
+      }
+      else if (ssop_flags & SSOP_CURDIR)
+      {
+       sname = home_replace_save(NULL, globaldir != NULL ? globaldir : dirnow);
+       if (sname == NULL
+!              || fprintf(fd, "cd %s", sname) < 0 || put_eol(fd) == FAIL)
+           return FAIL;
+       vim_free(sname);
+      }
+  
+--- 8631,8650 ----
+       */
+      if (ssop_flags & SSOP_SESDIR)
+      {
+!      if (put_line(fd, "exe \"cd \" . escape(expand(\"<sfile>:p:h\"), ' ')") == FAIL)
+           return FAIL;
+      }
+      else if (ssop_flags & SSOP_CURDIR)
+      {
+       sname = home_replace_save(NULL, globaldir != NULL ? globaldir : dirnow);
+       if (sname == NULL
+!              || fputs("cd ", fd) < 0
+!              || ses_put_fname(fd, sname, &ssop_flags) == FAIL
+!              || put_eol(fd) == FAIL)
+!      {
+!          vim_free(sname);
+           return FAIL;
++      }
+       vim_free(sname);
+      }
+  
+*** ../vim-6.3.088/src/version.c       Sun Sep 25 15:09:52 2005
+--- src/version.c      Wed Sep 28 14:56:23 2005
+***************
+*** 643,644 ****
+--- 643,646 ----
+  {   /* Add new patch number below this line */
++ /**/
++     89,
+  /**/
+
+-- 
+Permission is granted to read this message out aloud on Kings Cross Road,
+London, under the condition that the orator is properly dressed.
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net   \\\
+///        Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\              Project leader for A-A-P -- http://www.A-A-P.org        ///
+ \\\     Buy LOTR 3 and help AIDS victims -- http://ICCF.nl/lotr.html   ///
diff --git a/6.3.090 b/6.3.090
new file mode 100644 (file)
index 0000000..e482e93
--- /dev/null
+++ b/6.3.090
@@ -0,0 +1,50 @@
+To: vim-dev@vim.org
+Subject: Patch 6.3.090
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=ISO-8859-1
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 6.3.090
+Problem:    A very big value for 'columns' or 'lines' may cause a crash.
+Solution:   Limit the values to 10000 and 1000.
+Files:     src/option.c
+
+
+*** ../vim-6.3.089/src/option.c        Thu Dec 16 12:05:19 2004
+--- src/option.c       Fri Sep 30 15:02:26 2005
+***************
+*** 6821,6826 ****
+--- 6821,6831 ----
+       }
+       Columns = MIN_COLUMNS;
+      }
++     /* Limit the values to avoid an overflow in Rows * Columns. */
++     if (Columns > 10000)
++      Columns = 10000;
++     if (Rows > 1000)
++      Rows = 1000;
+  
+  #ifdef DJGPP
+      /* avoid a crash by checking for a too large value of 'columns' */
+*** ../vim-6.3.089/src/version.c       Wed Sep 28 14:58:09 2005
+--- src/version.c      Fri Sep 30 15:03:19 2005
+***************
+*** 643,644 ****
+--- 643,646 ----
+  {   /* Add new patch number below this line */
++ /**/
++     90,
+  /**/
+
+-- 
+It is illegal to rob a bank and then shoot at the bank teller with a water
+pistol.
+               [real standing law in Louisana, United States of America]
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net   \\\
+///        Sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\              Project leader for A-A-P -- http://www.A-A-P.org        ///
+ \\\     Buy LOTR 3 and help AIDS victims -- http://ICCF.nl/lotr.html   ///
This page took 0.346723 seconds and 4 git commands to generate.