]> git.pld-linux.org Git - packages/vim.git/commitdiff
do not compress docs
authorJan Palus <atler@pld-linux.org>
Mon, 1 Aug 2016 14:59:36 +0000 (16:59 +0200)
committerJan Palus <atler@pld-linux.org>
Mon, 1 Aug 2016 15:04:27 +0000 (17:04 +0200)
if you'd like to bring back compressed docs please provide full support
for them first -- modify helptags and add automatic compression to
build process

vim-vimrc.patch
vim.spec

index f0aa1b049c41061c6d32294aac31dc8a83a4c8db..698e41e6f7a84539e654ab2bf21c8fa88bb08b38 100644 (file)
@@ -1,15 +1,5 @@
 --- vim74/runtime/vimrc_example.vim~   2013-09-06 00:10:56.000000000 +0300
 +++ vim74/runtime/vimrc_example.vim    2013-09-06 00:11:24.756404306 +0300
-@@ -31,6 +31,9 @@
- set showcmd           " display incomplete commands
- set incsearch         " do incremental searching
-+" use compressed docs, see :help gzip-helpfile
-+set helpfile=$VIMRUNTIME/doc/help.txt.gz
-+
- " For Win32 GUI: remove 't' flag from 'guioptions': no tearoff menu entries
- " let &guioptions = substitute(&guioptions, "t", "", "g")
 @@ -46,13 +46,13 @@ map Q gq
  inoremap <C-U> <C-G>u<C-U>
  
index 319de7ea7eef3ca0dfa82d5a65e8aa4c27c7073a..e558143861db4dd4f50c54964d17bf47a8295b4e 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -1004,13 +1004,6 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir}/vim,%{_bindir}} \
 
 %find_lang %{name}
 
-# use compressed docs, see :help gzip-helpfile
-%{__gzip} -9 $RPM_BUILD_ROOT%{_datadir}/vim/doc/*.txt
-%{__sed} -i -e 's=\(\t.*\.txt\)\t=\1.gz\t=' $RPM_BUILD_ROOT%{_datadir}/vim/doc/tags
-
-%{__gzip} -9 $RPM_BUILD_ROOT%{_datadir}/vim/doc/*.??x
-%{__sed} -i -e 's=\(\t.*\.plx\)\t=\1.gz\t=' $RPM_BUILD_ROOT%{_datadir}/vim/doc/tags-pl
-
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/*
 
 %if %{with static}
@@ -1349,10 +1342,10 @@ rm -rf $RPM_BUILD_ROOT
 %files doc
 %defattr(644,root,root,755)
 # English
-%{_datadir}/vim/doc/*.txt.gz
+%{_datadir}/vim/doc/*.txt
 
 # Polish
-%lang(pl) %{_datadir}/vim/doc/*.plx.gz
+%lang(pl) %{_datadir}/vim/doc/*.plx
 
 %files tutor
 %defattr(644,root,root,755)
This page took 0.8009 seconds and 4 git commands to generate.