]> git.pld-linux.org Git - packages/vim.git/commitdiff
- up to 7.2.416 auto/th/vim-7_2_416-1
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 8 May 2010 23:04:05 +0000 (23:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    7.2.412 -> 1.1
    7.2.413 -> 1.1
    7.2.414 -> 1.1
    7.2.415 -> 1.1
    7.2.416 -> 1.1
    vim.spec -> 1.508

7.2.412 [new file with mode: 0644]
7.2.413 [new file with mode: 0644]
7.2.414 [new file with mode: 0644]
7.2.415 [new file with mode: 0644]
7.2.416 [new file with mode: 0644]
vim.spec

diff --git a/7.2.412 b/7.2.412
new file mode 100644 (file)
index 0000000..d467695
--- /dev/null
+++ b/7.2.412
@@ -0,0 +1,85 @@
+To: vim-dev@vim.org
+Subject: Patch 7.2.412
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 7.2.412
+Problem:    [ or ] followed by mouse click doesn't work.
+Solution:   Reverse check for key being a mouse event. (Dominique Pelle)
+Files:     src/normal.c
+
+
+*** ../vim-7.2.411/src/normal.c        2010-03-17 13:07:01.000000000 +0100
+--- src/normal.c       2010-05-07 15:46:54.000000000 +0200
+***************
+*** 3196,3202 ****
+       * There are a few special cases where we want certain combinations of
+       * characters to be considered as a single word.  These are things like
+       * "->", "/ *", "*=", "+=", "&=", "<=", ">=", "!=" etc.  Otherwise, each
+!      * character is in it's own class.
+       */
+      if (c != NUL && vim_strchr((char_u *)"-+*/%<>&|^!=", c) != NULL)
+       return 1;
+--- 3196,3202 ----
+       * There are a few special cases where we want certain combinations of
+       * characters to be considered as a single word.  These are things like
+       * "->", "/ *", "*=", "+=", "&=", "<=", ">=", "!=" etc.  Otherwise, each
+!      * character is in its own class.
+       */
+      if (c != NUL && vim_strchr((char_u *)"-+*/%<>&|^!=", c) != NULL)
+       return 1;
+***************
+*** 4085,4091 ****
+  /*
+   * Command character that's ignored.
+   * Used for CTRL-Q and CTRL-S to avoid problems with terminals that use
+!  * xon/xoff
+   */
+      static void
+  nv_ignore(cap)
+--- 4085,4091 ----
+  /*
+   * Command character that's ignored.
+   * Used for CTRL-Q and CTRL-S to avoid problems with terminals that use
+!  * xon/xoff.
+   */
+      static void
+  nv_ignore(cap)
+***************
+*** 6523,6529 ****
+       * [ or ] followed by a middle mouse click: put selected text with
+       * indent adjustment.  Any other button just does as usual.
+       */
+!     else if (cap->nchar >= K_LEFTMOUSE && cap->nchar <= K_RIGHTRELEASE)
+      {
+       (void)do_mouse(cap->oap, cap->nchar,
+                      (cap->cmdchar == ']') ? FORWARD : BACKWARD,
+--- 6523,6529 ----
+       * [ or ] followed by a middle mouse click: put selected text with
+       * indent adjustment.  Any other button just does as usual.
+       */
+!     else if (cap->nchar >= K_RIGHTRELEASE && cap->nchar <= K_LEFTMOUSE)
+      {
+       (void)do_mouse(cap->oap, cap->nchar,
+                      (cap->cmdchar == ']') ? FORWARD : BACKWARD,
+*** ../vim-7.2.411/src/version.c       2010-03-23 18:22:40.000000000 +0100
+--- src/version.c      2010-05-07 15:51:35.000000000 +0200
+***************
+*** 683,684 ****
+--- 683,686 ----
+  {   /* Add new patch number below this line */
++ /**/
++     412,
+  /**/
+
+-- 
+I have a drinking problem -- I don't have a drink!
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net   \\\
+///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\        download, build and distribute -- http://www.A-A-P.org        ///
+ \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///
diff --git a/7.2.413 b/7.2.413
new file mode 100644 (file)
index 0000000..40a6592
--- /dev/null
+++ b/7.2.413
@@ -0,0 +1,452 @@
+To: vim-dev@vim.org
+Subject: Patch 7.2.413
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 7.2.413
+Problem:    Large file support is incorrect.
+Solution:   Add AC_SYS_LARGEFILE to configure. (James Vega)
+Files:      src/configure.in, src/config.h.in, src/auto/configure
+    
+
+*** ../vim-7.2.412/src/configure.in    2010-03-10 16:27:27.000000000 +0100
+--- src/configure.in   2010-04-01 15:06:04.000000000 +0200
+***************
+*** 2669,2674 ****
+--- 2669,2678 ----
+       usleep utime utimes)
+  AC_FUNC_FSEEKO
+  
++ dnl define _LARGE_FILES, _FILE_OFFSET_BITS and _LARGEFILE_SOURCE when
++ dnl appropriate, so that off_t is 64 bits when needed.
++ AC_SYS_LARGEFILE
++ 
+  dnl fstatfs() can take 2 to 4 arguments, try to use st_blksize if possible
+  AC_MSG_CHECKING(for st_blksize)
+  AC_TRY_COMPILE(
+*** ../vim-7.2.412/src/config.h.in     2010-02-24 14:46:58.000000000 +0100
+--- src/config.h.in    2010-04-01 15:10:49.000000000 +0200
+***************
+*** 196,201 ****
+--- 196,206 ----
+  #undef HAVE_UTIME
+  #undef HAVE_BIND_TEXTDOMAIN_CODESET
+  
++ /* Define, if needed, for accessing large files. */
++ #undef _LARGE_FILES
++ #undef _FILE_OFFSET_BITS
++ #undef _LARGEFILE_SOURCE
++ 
+  /* Define if you do not have utime(), but do have the utimes() function. */
+  #undef HAVE_UTIMES
+  
+*** ../vim-7.2.412/src/auto/configure  2010-03-10 16:27:27.000000000 +0100
+--- src/auto/configure 2010-05-07 16:01:08.000000000 +0200
+***************
+*** 821,826 ****
+--- 821,827 ----
+  with_gnome
+  with_motif_lib
+  with_tlib
++ enable_largefile
+  enable_acl
+  enable_gpm
+  enable_sysmouse
+***************
+*** 1485,1490 ****
+--- 1486,1492 ----
+    --enable-nextaw-check   If auto-select GUI, check for neXtaw default=yes
+    --enable-carbon-check   If auto-select GUI, check for Carbon default=yes
+    --disable-gtktest       Do not try to compile and run a test GTK program
++   --disable-largefile     omit support for large files
+    --disable-acl           Don't check for ACL support.
+    --disable-gpm           Don't use gpm (Linux mouse daemon).
+    --disable-sysmouse    Don't use sysmouse (mouse in *BSD console).
+***************
+*** 14345,14350 ****
+--- 14347,14709 ----
+  fi
+  
+  
++ # Check whether --enable-largefile was given.
++ if test "${enable_largefile+set}" = set; then
++   enableval=$enable_largefile;
++ fi
++ 
++ if test "$enable_largefile" != no; then
++ 
++   { $as_echo "$as_me:$LINENO: checking for special C compiler options needed for large files" >&5
++ $as_echo_n "checking for special C compiler options needed for large files... " >&6; }
++ if test "${ac_cv_sys_largefile_CC+set}" = set; then
++   $as_echo_n "(cached) " >&6
++ else
++   ac_cv_sys_largefile_CC=no
++      if test "$GCC" != yes; then
++        ac_save_CC=$CC
++        while :; do
++       # IRIX 6.2 and later do not support large files by default,
++       # so use the C compiler's -n32 option if that helps.
++       cat >conftest.$ac_ext <<_ACEOF
++ /* confdefs.h.  */
++ _ACEOF
++ cat confdefs.h >>conftest.$ac_ext
++ cat >>conftest.$ac_ext <<_ACEOF
++ /* end confdefs.h.  */
++ #include <sys/types.h>
++  /* Check that off_t can represent 2**63 - 1 correctly.
++     We can't simply define LARGE_OFF_T to be 9223372036854775807,
++     since some C++ compilers masquerading as C compilers
++     incorrectly reject 9223372036854775807.  */
++ #define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
++   int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
++                     && LARGE_OFF_T % 2147483647 == 1)
++                    ? 1 : -1];
++ int
++ main ()
++ {
++ 
++   ;
++   return 0;
++ }
++ _ACEOF
++       rm -f conftest.$ac_objext
++ if { (ac_try="$ac_compile"
++ case "(($ac_try" in
++   *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++   *) ac_try_echo=$ac_try;;
++ esac
++ eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
++ $as_echo "$ac_try_echo") >&5
++   (eval "$ac_compile") 2>conftest.er1
++   ac_status=$?
++   grep -v '^ *+' conftest.er1 >conftest.err
++   rm -f conftest.er1
++   cat conftest.err >&5
++   $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
++   (exit $ac_status); } && {
++       test -z "$ac_c_werror_flag" ||
++       test ! -s conftest.err
++        } && test -s conftest.$ac_objext; then
++   break
++ else
++   $as_echo "$as_me: failed program was:" >&5
++ sed 's/^/| /' conftest.$ac_ext >&5
++ 
++ 
++ fi
++ 
++ rm -f core conftest.err conftest.$ac_objext
++       CC="$CC -n32"
++       rm -f conftest.$ac_objext
++ if { (ac_try="$ac_compile"
++ case "(($ac_try" in
++   *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++   *) ac_try_echo=$ac_try;;
++ esac
++ eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
++ $as_echo "$ac_try_echo") >&5
++   (eval "$ac_compile") 2>conftest.er1
++   ac_status=$?
++   grep -v '^ *+' conftest.er1 >conftest.err
++   rm -f conftest.er1
++   cat conftest.err >&5
++   $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
++   (exit $ac_status); } && {
++       test -z "$ac_c_werror_flag" ||
++       test ! -s conftest.err
++        } && test -s conftest.$ac_objext; then
++   ac_cv_sys_largefile_CC=' -n32'; break
++ else
++   $as_echo "$as_me: failed program was:" >&5
++ sed 's/^/| /' conftest.$ac_ext >&5
++ 
++ 
++ fi
++ 
++ rm -f core conftest.err conftest.$ac_objext
++       break
++        done
++        CC=$ac_save_CC
++        rm -f conftest.$ac_ext
++     fi
++ fi
++ { $as_echo "$as_me:$LINENO: result: $ac_cv_sys_largefile_CC" >&5
++ $as_echo "$ac_cv_sys_largefile_CC" >&6; }
++   if test "$ac_cv_sys_largefile_CC" != no; then
++     CC=$CC$ac_cv_sys_largefile_CC
++   fi
++ 
++   { $as_echo "$as_me:$LINENO: checking for _FILE_OFFSET_BITS value needed for large files" >&5
++ $as_echo_n "checking for _FILE_OFFSET_BITS value needed for large files... " >&6; }
++ if test "${ac_cv_sys_file_offset_bits+set}" = set; then
++   $as_echo_n "(cached) " >&6
++ else
++   while :; do
++   cat >conftest.$ac_ext <<_ACEOF
++ /* confdefs.h.  */
++ _ACEOF
++ cat confdefs.h >>conftest.$ac_ext
++ cat >>conftest.$ac_ext <<_ACEOF
++ /* end confdefs.h.  */
++ #include <sys/types.h>
++  /* Check that off_t can represent 2**63 - 1 correctly.
++     We can't simply define LARGE_OFF_T to be 9223372036854775807,
++     since some C++ compilers masquerading as C compilers
++     incorrectly reject 9223372036854775807.  */
++ #define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
++   int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
++                     && LARGE_OFF_T % 2147483647 == 1)
++                    ? 1 : -1];
++ int
++ main ()
++ {
++ 
++   ;
++   return 0;
++ }
++ _ACEOF
++ rm -f conftest.$ac_objext
++ if { (ac_try="$ac_compile"
++ case "(($ac_try" in
++   *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++   *) ac_try_echo=$ac_try;;
++ esac
++ eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
++ $as_echo "$ac_try_echo") >&5
++   (eval "$ac_compile") 2>conftest.er1
++   ac_status=$?
++   grep -v '^ *+' conftest.er1 >conftest.err
++   rm -f conftest.er1
++   cat conftest.err >&5
++   $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
++   (exit $ac_status); } && {
++       test -z "$ac_c_werror_flag" ||
++       test ! -s conftest.err
++        } && test -s conftest.$ac_objext; then
++   ac_cv_sys_file_offset_bits=no; break
++ else
++   $as_echo "$as_me: failed program was:" >&5
++ sed 's/^/| /' conftest.$ac_ext >&5
++ 
++ 
++ fi
++ 
++ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++   cat >conftest.$ac_ext <<_ACEOF
++ /* confdefs.h.  */
++ _ACEOF
++ cat confdefs.h >>conftest.$ac_ext
++ cat >>conftest.$ac_ext <<_ACEOF
++ /* end confdefs.h.  */
++ #define _FILE_OFFSET_BITS 64
++ #include <sys/types.h>
++  /* Check that off_t can represent 2**63 - 1 correctly.
++     We can't simply define LARGE_OFF_T to be 9223372036854775807,
++     since some C++ compilers masquerading as C compilers
++     incorrectly reject 9223372036854775807.  */
++ #define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
++   int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
++                     && LARGE_OFF_T % 2147483647 == 1)
++                    ? 1 : -1];
++ int
++ main ()
++ {
++ 
++   ;
++   return 0;
++ }
++ _ACEOF
++ rm -f conftest.$ac_objext
++ if { (ac_try="$ac_compile"
++ case "(($ac_try" in
++   *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++   *) ac_try_echo=$ac_try;;
++ esac
++ eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
++ $as_echo "$ac_try_echo") >&5
++   (eval "$ac_compile") 2>conftest.er1
++   ac_status=$?
++   grep -v '^ *+' conftest.er1 >conftest.err
++   rm -f conftest.er1
++   cat conftest.err >&5
++   $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
++   (exit $ac_status); } && {
++       test -z "$ac_c_werror_flag" ||
++       test ! -s conftest.err
++        } && test -s conftest.$ac_objext; then
++   ac_cv_sys_file_offset_bits=64; break
++ else
++   $as_echo "$as_me: failed program was:" >&5
++ sed 's/^/| /' conftest.$ac_ext >&5
++ 
++ 
++ fi
++ 
++ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++   ac_cv_sys_file_offset_bits=unknown
++   break
++ done
++ fi
++ { $as_echo "$as_me:$LINENO: result: $ac_cv_sys_file_offset_bits" >&5
++ $as_echo "$ac_cv_sys_file_offset_bits" >&6; }
++ case $ac_cv_sys_file_offset_bits in #(
++   no | unknown) ;;
++   *)
++ cat >>confdefs.h <<_ACEOF
++ #define _FILE_OFFSET_BITS $ac_cv_sys_file_offset_bits
++ _ACEOF
++ ;;
++ esac
++ rm -rf conftest*
++   if test $ac_cv_sys_file_offset_bits = unknown; then
++     { $as_echo "$as_me:$LINENO: checking for _LARGE_FILES value needed for large files" >&5
++ $as_echo_n "checking for _LARGE_FILES value needed for large files... " >&6; }
++ if test "${ac_cv_sys_large_files+set}" = set; then
++   $as_echo_n "(cached) " >&6
++ else
++   while :; do
++   cat >conftest.$ac_ext <<_ACEOF
++ /* confdefs.h.  */
++ _ACEOF
++ cat confdefs.h >>conftest.$ac_ext
++ cat >>conftest.$ac_ext <<_ACEOF
++ /* end confdefs.h.  */
++ #include <sys/types.h>
++  /* Check that off_t can represent 2**63 - 1 correctly.
++     We can't simply define LARGE_OFF_T to be 9223372036854775807,
++     since some C++ compilers masquerading as C compilers
++     incorrectly reject 9223372036854775807.  */
++ #define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
++   int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
++                     && LARGE_OFF_T % 2147483647 == 1)
++                    ? 1 : -1];
++ int
++ main ()
++ {
++ 
++   ;
++   return 0;
++ }
++ _ACEOF
++ rm -f conftest.$ac_objext
++ if { (ac_try="$ac_compile"
++ case "(($ac_try" in
++   *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++   *) ac_try_echo=$ac_try;;
++ esac
++ eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
++ $as_echo "$ac_try_echo") >&5
++   (eval "$ac_compile") 2>conftest.er1
++   ac_status=$?
++   grep -v '^ *+' conftest.er1 >conftest.err
++   rm -f conftest.er1
++   cat conftest.err >&5
++   $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
++   (exit $ac_status); } && {
++       test -z "$ac_c_werror_flag" ||
++       test ! -s conftest.err
++        } && test -s conftest.$ac_objext; then
++   ac_cv_sys_large_files=no; break
++ else
++   $as_echo "$as_me: failed program was:" >&5
++ sed 's/^/| /' conftest.$ac_ext >&5
++ 
++ 
++ fi
++ 
++ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++   cat >conftest.$ac_ext <<_ACEOF
++ /* confdefs.h.  */
++ _ACEOF
++ cat confdefs.h >>conftest.$ac_ext
++ cat >>conftest.$ac_ext <<_ACEOF
++ /* end confdefs.h.  */
++ #define _LARGE_FILES 1
++ #include <sys/types.h>
++  /* Check that off_t can represent 2**63 - 1 correctly.
++     We can't simply define LARGE_OFF_T to be 9223372036854775807,
++     since some C++ compilers masquerading as C compilers
++     incorrectly reject 9223372036854775807.  */
++ #define LARGE_OFF_T (((off_t) 1 << 62) - 1 + ((off_t) 1 << 62))
++   int off_t_is_large[(LARGE_OFF_T % 2147483629 == 721
++                     && LARGE_OFF_T % 2147483647 == 1)
++                    ? 1 : -1];
++ int
++ main ()
++ {
++ 
++   ;
++   return 0;
++ }
++ _ACEOF
++ rm -f conftest.$ac_objext
++ if { (ac_try="$ac_compile"
++ case "(($ac_try" in
++   *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
++   *) ac_try_echo=$ac_try;;
++ esac
++ eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
++ $as_echo "$ac_try_echo") >&5
++   (eval "$ac_compile") 2>conftest.er1
++   ac_status=$?
++   grep -v '^ *+' conftest.er1 >conftest.err
++   rm -f conftest.er1
++   cat conftest.err >&5
++   $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
++   (exit $ac_status); } && {
++       test -z "$ac_c_werror_flag" ||
++       test ! -s conftest.err
++        } && test -s conftest.$ac_objext; then
++   ac_cv_sys_large_files=1; break
++ else
++   $as_echo "$as_me: failed program was:" >&5
++ sed 's/^/| /' conftest.$ac_ext >&5
++ 
++ 
++ fi
++ 
++ rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
++   ac_cv_sys_large_files=unknown
++   break
++ done
++ fi
++ { $as_echo "$as_me:$LINENO: result: $ac_cv_sys_large_files" >&5
++ $as_echo "$ac_cv_sys_large_files" >&6; }
++ case $ac_cv_sys_large_files in #(
++   no | unknown) ;;
++   *)
++ cat >>confdefs.h <<_ACEOF
++ #define _LARGE_FILES $ac_cv_sys_large_files
++ _ACEOF
++ ;;
++ esac
++ rm -rf conftest*
++   fi
++ fi
++ 
++ 
+  { $as_echo "$as_me:$LINENO: checking for st_blksize" >&5
+  $as_echo_n "checking for st_blksize... " >&6; }
+  cat >conftest.$ac_ext <<_ACEOF
+*** ../vim-7.2.412/src/version.c       2010-05-07 15:51:59.000000000 +0200
+--- src/version.c      2010-05-07 16:04:29.000000000 +0200
+***************
+*** 683,684 ****
+--- 683,686 ----
+  {   /* Add new patch number below this line */
++ /**/
++     413,
+  /**/
+
+-- 
+How To Keep A Healthy Level Of Insanity:
+2. Page yourself over the intercom. Don't disguise your voice.
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net   \\\
+///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\        download, build and distribute -- http://www.A-A-P.org        ///
+ \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///
diff --git a/7.2.414 b/7.2.414
new file mode 100644 (file)
index 0000000..9d5666c
--- /dev/null
+++ b/7.2.414
@@ -0,0 +1,93 @@
+To: vim-dev@vim.org
+Subject: Patch 7.2.414
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 7.2.414
+Problem:    CTRK-K <space> <space> does not produce 0xa0 as expected. (Tony
+           Mechelynck)
+Solution:   Remove the Unicode range 0xe000 - 0xefff from digraphs, these are
+           not valid characters.
+Files:     src/digraph.c
+
+
+*** ../vim-7.2.413/src/digraph.c       2009-05-13 14:12:14.000000000 +0200
+--- src/digraph.c      2010-04-11 17:28:22.000000000 +0200
+***************
+*** 1933,1977 ****
+       {'7', 'c', 0x3226},
+       {'8', 'c', 0x3227},
+       {'9', 'c', 0x3228},
+!      {' ', ' ', 0xe000},
+!      {'/', 'c', 0xe001},
+!      {'U', 'A', 0xe002},
+!      {'U', 'B', 0xe003},
+!      {'"', '3', 0xe004},
+!      {'"', '1', 0xe005},
+!      {'"', '!', 0xe006},
+!      {'"', '\'', 0xe007},
+!      {'"', '>', 0xe008},
+!      {'"', '?', 0xe009},
+!      {'"', '-', 0xe00a},
+!      {'"', '(', 0xe00b},
+!      {'"', '.', 0xe00c},
+!      {'"', ':', 0xe00d},
+!      {'"', '0', 0xe00e},
+!      {'"', '"', 0xe00f},
+!      {'"', '<', 0xe010},
+!      {'"', ',', 0xe011},
+!      {'"', ';', 0xe012},
+!      {'"', '_', 0xe013},
+!      {'"', '=', 0xe014},
+!      {'"', '/', 0xe015},
+!      {'"', 'i', 0xe016},
+!      {'"', 'd', 0xe017},
+!      {'"', 'p', 0xe018},
+!      {';', ';', 0xe019},
+!      {',', ',', 0xe01a},
+!      {'b', '3', 0xe01b},
+!      {'C', 'i', 0xe01c},
+!      {'f', '(', 0xe01d},
+!      {'e', 'd', 0xe01e},
+!      {'a', 'm', 0xe01f},
+!      {'p', 'm', 0xe020},
+!      {'F', 'l', 0xe023},
+!      {'G', 'F', 0xe024},
+!      {'>', 'V', 0xe025},
+!      {'!', '*', 0xe026},
+!      {'?', '*', 0xe027},
+!      {'J', '<', 0xe028},
+       {'f', 'f', 0xfb00},
+       {'f', 'i', 0xfb01},
+       {'f', 'l', 0xfb02},
+--- 1933,1940 ----
+       {'7', 'c', 0x3226},
+       {'8', 'c', 0x3227},
+       {'9', 'c', 0x3228},
+!      /* code points 0xe000 - 0xefff excluded, they have no assigned
+!       * characters, only used in proposals. */
+       {'f', 'f', 0xfb00},
+       {'f', 'i', 0xfb01},
+       {'f', 'l', 0xfb02},
+*** ../vim-7.2.413/src/version.c       2010-05-07 16:05:48.000000000 +0200
+--- src/version.c      2010-05-07 16:17:26.000000000 +0200
+***************
+*** 683,684 ****
+--- 683,686 ----
+  {   /* Add new patch number below this line */
++ /**/
++     414,
+  /**/
+
+-- 
+How To Keep A Healthy Level Of Insanity:
+4. Put your garbage can on your desk and label it "in".
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net   \\\
+///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\        download, build and distribute -- http://www.A-A-P.org        ///
+ \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///
diff --git a/7.2.415 b/7.2.415
new file mode 100644 (file)
index 0000000..87e7c0b
--- /dev/null
+++ b/7.2.415
@@ -0,0 +1,69 @@
+To: vim-dev@vim.org
+Subject: Patch 7.2.415
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 7.2.415
+Problem:    Win32: Can't open a remote file when starting Vim.
+Solution:   Don't invoke cygwin_conv_path() for URLs. (Tomoya Adachi)
+Files:     src/main.c
+
+
+*** ../vim-7.2.414/src/main.c  2009-12-16 18:27:29.000000000 +0100
+--- src/main.c 2010-04-12 20:57:44.000000000 +0200
+***************
+*** 1477,1483 ****
+       ++initstr;
+      }
+  
+!     /* Avoid using evim mode for "editor". */
+      if (TOLOWER_ASC(initstr[0]) == 'e'
+           && (TOLOWER_ASC(initstr[1]) == 'v'
+               || TOLOWER_ASC(initstr[1]) == 'g'))
+--- 1477,1483 ----
+       ++initstr;
+      }
+  
+!     /* Use evim mode for "evim" and "egvim", not for "editor". */
+      if (TOLOWER_ASC(initstr[0]) == 'e'
+           && (TOLOWER_ASC(initstr[1]) == 'v'
+               || TOLOWER_ASC(initstr[1]) == 'g'))
+***************
+*** 2262,2268 ****
+            * Look for evidence of non-Cygwin paths before we bother.
+            * This is only for when using the Unix files.
+            */
+!          if (strpbrk(p, "\\:") != NULL)
+           {
+               char posix_path[PATH_MAX];
+  
+--- 2262,2268 ----
+            * Look for evidence of non-Cygwin paths before we bother.
+            * This is only for when using the Unix files.
+            */
+!          if (strpbrk(p, "\\:") != NULL && !path_with_url(p))
+           {
+               char posix_path[PATH_MAX];
+  
+*** ../vim-7.2.414/src/version.c       2010-05-07 16:18:08.000000000 +0200
+--- src/version.c      2010-05-07 16:34:22.000000000 +0200
+***************
+*** 683,684 ****
+--- 683,686 ----
+  {   /* Add new patch number below this line */
++ /**/
++     415,
+  /**/
+
+-- 
+How To Keep A Healthy Level Of Insanity:
+6. In the memo field of all your checks, write "for sexual favors".
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net   \\\
+///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\        download, build and distribute -- http://www.A-A-P.org        ///
+ \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///
diff --git a/7.2.416 b/7.2.416
new file mode 100644 (file)
index 0000000..67bb808
--- /dev/null
+++ b/7.2.416
@@ -0,0 +1,69 @@
+To: vim-dev@vim.org
+Subject: Patch 7.2.416
+Fcc: outbox
+From: Bram Moolenaar <Bram@moolenaar.net>
+Mime-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+------------
+
+Patch 7.2.416
+Problem:    Logtalk.dict is not installed.
+Solution:   Add it to the install target. (Markus Heidelberg)
+Files:      src/Makefile
+
+
+*** ../vim-7.2.415/src/Makefile        2010-05-07 16:35:12.000000000 +0200
+--- src/Makefile       2010-04-06 20:19:48.000000000 +0200
+***************
+*** 30,36 ****
+  #      want to disable using X11 libraries.  This speeds up starting Vim,
+  #      but the window title will not be set and the X11 selection can not
+  #      used.
+! #    - Uncomment the line "CONF_OPT_XSMP = --without-xsmp" if you have the
+  #      X11 Session Management Protocol (XSMP) library (libSM) but do not
+  #      want to use it.
+  #      This can speedup Vim startup but Vim loses the ability to catch the
+--- 30,36 ----
+  #      want to disable using X11 libraries.  This speeds up starting Vim,
+  #      but the window title will not be set and the X11 selection can not
+  #      used.
+! #    - Uncomment the line "CONF_OPT_XSMP = --disable-xsmp" if you have the
+  #      X11 Session Management Protocol (XSMP) library (libSM) but do not
+  #      want to use it.
+  #      This can speedup Vim startup but Vim loses the ability to catch the
+***************
+*** 1882,1888 ****
+       cd $(PLUGSOURCE); $(INSTALL_DATA) *.vim README.txt $(DEST_PLUG)
+       cd $(DEST_PLUG); chmod $(HELPMOD) *.vim README.txt
+  # install the ftplugin files
+!      cd $(FTPLUGSOURCE); $(INSTALL_DATA) *.vim README.txt $(DEST_FTP)
+       cd $(DEST_FTP); chmod $(HELPMOD) *.vim README.txt
+  # install the compiler files
+       cd $(COMPSOURCE); $(INSTALL_DATA) *.vim README.txt $(DEST_COMP)
+--- 1882,1888 ----
+       cd $(PLUGSOURCE); $(INSTALL_DATA) *.vim README.txt $(DEST_PLUG)
+       cd $(DEST_PLUG); chmod $(HELPMOD) *.vim README.txt
+  # install the ftplugin files
+!      cd $(FTPLUGSOURCE); $(INSTALL_DATA) *.vim README.txt logtalk.dict $(DEST_FTP)
+       cd $(DEST_FTP); chmod $(HELPMOD) *.vim README.txt
+  # install the compiler files
+       cd $(COMPSOURCE); $(INSTALL_DATA) *.vim README.txt $(DEST_COMP)
+*** ../vim-7.2.415/src/version.c       2010-05-07 16:34:59.000000000 +0200
+--- src/version.c      2010-05-07 16:53:17.000000000 +0200
+***************
+*** 683,684 ****
+--- 683,686 ----
+  {   /* Add new patch number below this line */
++ /**/
++     416,
+  /**/
+
+-- 
+How To Keep A Healthy Level Of Insanity:
+8. Don't use any punctuation marks.
+
+ /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net   \\\
+///        sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
+\\\        download, build and distribute -- http://www.A-A-P.org        ///
+ \\\            help me help AIDS victims -- http://ICCF-Holland.org    ///
index 5ed84dbd32011fb8ad0b7b47ada2033729a8c003..de41e2a5bb8d7f9a459d8d9536d5f8c251946ab7 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -1,3 +1,6 @@
+# TODO
+# - evim manuals not installed if no gui is built, move to -gui packages?
+#
 # Conditional build:
 %bcond_without static          # don't build static version
 %bcond_without athena          # don't build Athena Widgets-based gvim
@@ -24,7 +27,7 @@
 # wget -q -O - ftp://ftp.vim.org/pub/editors/vim/patches/7.2/MD5SUMS|grep -vF .gz|tail -n1|awk '{print $2}'
 
 %define                ver             7.2
-%define                patchlevel      411
+%define                patchlevel      416
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
 Summary(es.UTF-8):     Editor visual incrementado
@@ -37,7 +40,7 @@ Summary(tr.UTF-8):    Gelişmiş bir vi sürümü
 Summary(uk.UTF-8):     Visual editor IMproved - Єдино Вірний Редактор :)
 Name:          vim
 Version:       %{ver}.%{patchlevel}
-Release:       4
+Release:       1
 Epoch:         4
 License:       Charityware
 Group:         Applications/Editors/Vim
@@ -1122,6 +1125,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/vim/ftplugin
 %doc %{_datadir}/vim/ftplugin/README.txt
 %{_datadir}/vim/ftplugin/*.vim
+%{_datadir}/vim/ftplugin/logtalk.dict
 
 %dir %{_datadir}/vim/indent
 %doc %{_datadir}/vim/indent/README.txt
This page took 0.082185 seconds and 4 git commands to generate.