]> git.pld-linux.org Git - packages/vim.git/commitdiff
- up to 7.4.1943 auto/th/vim-7.4.1943-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 18 Jun 2016 18:38:27 +0000 (20:38 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 18 Jun 2016 18:38:27 +0000 (20:38 +0200)
desktop.patch
vim-vimrc.patch
vim-visual.patch [deleted file]
vim.spec

index 1ace85980b1b8d1e68b5598678dce2e662866ea9..ae1cbb8962d01498ab36a0079d57a794b55070c7 100644 (file)
@@ -50,7 +50,6 @@
  Comment[pt_BR]=Edite arquivos de texto
  Comment[ro]=Editare fişiere text
 @@ -70,11 +70,11 @@
- Comment[wa]=Asspougnî des fitchîs tecses
  Comment[zh_CN]=编辑文本文件
  Comment[zh_TW]=編輯文字檔
 -TryExec=gvim
@@ -59,6 +58,7 @@
 +Exec=gvim.gnome -f %F
  Terminal=false
  Type=Application
+ Keywords=Text;editor;
  Icon=gvim
 -Categories=Utility;TextEditor;
 +Categories=GTK;GNOME;TextEditor;
@@ -87,7 +87,6 @@
  Comment[pt_BR]=Edite arquivos de texto
  Comment[ro]=Editare fişiere text
 @@ -70,11 +70,11 @@
- Comment[wa]=Asspougnî des fitchîs tecses
  Comment[zh_CN]=编辑文本文件
  Comment[zh_TW]=編輯文字檔
 -TryExec=gvim
@@ -96,6 +95,7 @@
 +Exec=gvim.gtk -f %F
  Terminal=false
  Type=Application
+ Keywords=Text;editor;
  Icon=gvim
 -Categories=Utility;TextEditor;
 +Categories=GTK;TextEditor;
  Comment[pt_BR]=Edite arquivos de texto
  Comment[ro]=Editare fişiere text
 @@ -70,11 +70,11 @@
- Comment[wa]=Asspougnî des fitchîs tecses
  Comment[zh_CN]=编辑文本文件
  Comment[zh_TW]=編輯文字檔
 -TryExec=gvim
 +Exec=gvim.motif -f %F
  Terminal=false
  Type=Application
+ Keywords=Text;editor;
  Icon=gvim
 -Categories=Utility;TextEditor;
 +Categories=Motif;TextEditor;
index 7d858c102e93c93f1e2c8283c6965c1a9aecff51..f0aa1b049c41061c6d32294aac31dc8a83a4c8db 100644 (file)
@@ -10,7 +10,7 @@
  " For Win32 GUI: remove 't' flag from 'guioptions': no tearoff menu entries
  " let &guioptions = substitute(&guioptions, "t", "", "g")
  
-@@ -42,13 +45,13 @@
+@@ -46,13 +46,13 @@ map Q gq
  inoremap <C-U> <C-G>u<C-U>
  
  " In many terminal emulators the mouse works just fine, thus enable it.
 +"  set mouse=a
 +"endif
  
- " Switch syntax highlighting on, when the terminal has colors
- " Also switch on highlighting the last used search pattern.
+ " Switch syntax highlighting on when the terminal has colors or when using the
+ " GUI (which always has colors).
 -if &t_Co > 2 || has("gui_running")
 +if (&t_Co > 2 || has("gui_running")) && filereadable($VIMRUNTIME."/syntax/syntax.vim")
    syntax on
-   set hlsearch
- endif
+   " Also switch on highlighting the last used search pattern.
 @@ -93,10 +93,18 @@
  " Convenient command to see the difference between the current buffer and the
  " file it was loaded from, thus the changes you made.
diff --git a/vim-visual.patch b/vim-visual.patch
deleted file mode 100644 (file)
index 1669720..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- vim60z/src/screen.c~       Tue Apr 10 15:47:51 2001
-+++ vim60z/src/screen.c        Tue Apr 10 15:49:00 2001
-@@ -2328,7 +2328,7 @@
- #ifndef MSDOS
-       /* Check if the character under the cursor should not be inverted */
--      if (!highlight_match && lnum == curwin->w_cursor.lnum && wp == curwin
-+      if (!highlight_match && *T_VI == NUL && lnum == curwin->w_cursor.lnum && wp == curwin
- # ifdef FEAT_GUI
-               && !gui.in_use
- # endif
index edbef23e16e1d9e33093b753a9c6fc880cb19c1b..fec49f1b08ee7bb7b22b2b251743025bf2368631 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -28,8 +28,8 @@
 # tail -n1 sources | awk '{print $2}'
 # VCS Commits: https://github.com/vim/vim/commits/master
 
-%define                ver             7.4.1236
-%define                rel             4
+%define                ver             7.4.1943
+%define                rel             1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
 Summary(es.UTF-8):     Editor visual incrementado
@@ -49,7 +49,7 @@ License:      Charityware
 Group:         Applications/Editors/Vim
 #Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
 Source0:       https://github.com/vim/vim/archive/v%{ver}.tar.gz
-# Source0-md5: bca123584eb843c485c687861d54ad27
+# Source0-md5: 0ea9464041fe4b1f09e760c8ab6687ec
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
@@ -70,7 +70,7 @@ Source32:     oceandeep.vim
 # http://www.vim.org/scripts/script.php?script_id=1464 (2.6.3)
 Source33:      moria.vim
 Patch0:                %{name}-sysconfdir.patch
-Patch1:                %{name}-visual.patch
+
 Patch2:                %{name}-paths.patch
 Patch3:                %{name}-no_libelf.patch
 Patch4:                %{name}-egrep.patch
@@ -746,7 +746,7 @@ cp -p runtime/gvim.desktop gvim-gtk.desktop
 cp -p runtime/gvim.desktop gvim-motif.desktop
 
 %patch0 -p1
-%patch1 -p1
+
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
@@ -1253,6 +1253,8 @@ rm -rf $RPM_BUILD_ROOT
 %doc %{_datadir}/vim/keymap/README.txt
 %{_datadir}/vim/keymap/*.vim
 
+%{_datadir}/vim/pack
+
 %dir %{_datadir}/vim/plugin
 %doc %{_datadir}/vim/plugin/README.txt
 
This page took 0.048888 seconds and 4 git commands to generate.