]> git.pld-linux.org Git - packages/vim.git/commitdiff
- up to 7.4.2189 auto/th/vim-7.4.2189-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 9 Aug 2016 20:38:54 +0000 (22:38 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 9 Aug 2016 20:38:54 +0000 (22:38 +0200)
vim-revert-7.4.165-noundo.patch
vim-vimrc.patch
vim.spec

index f1f20aa256be9354bd8fd6452a2c2087bd0c482f..b786b66b97f1c67c673f1fa01f42d2c329563e6c 100644 (file)
@@ -1,10 +1,12 @@
---- vim74/runtime/vimrc_example.vim~   2014-02-19 09:38:17.000000000 +0100
-+++ vim74/runtime/vimrc_example.vim    2014-02-19 09:38:56.196879355 +0100
-@@ -25,7 +25,6 @@
+--- vim-7.4.2189/runtime/vimrc_example.vim~    2016-08-09 22:27:05.000000000 +0200
++++ vim-7.4.2189/runtime/vimrc_example.vim     2016-08-09 22:28:15.756581654 +0200
+@@ -21,9 +21,6 @@ if has("vms")
    set nobackup                " do not keep a backup file, use versions instead
  else
    set backup          " keep a backup file (restore to previous version)
--  set undofile                " keep an undo file (undo changes after closing)
+-  if has('persistent_undo')
+-    set undofile      " keep an undo file (undo changes after closing)
+-  endif
  endif
- set history=50                " keep 50 lines of command line history
- set ruler             " show the cursor position all the time
+ if (&t_Co > 2 || has("gui_running")) && filereadable($VIMRUNTIME."/syntax/syntax.vim")
index 698e41e6f7a84539e654ab2bf21c8fa88bb08b38..3577949361efddd8dcb38d5f6e880974b4a6ee8e 100644 (file)
@@ -1,9 +1,32 @@
---- vim74/runtime/vimrc_example.vim~   2013-09-06 00:10:56.000000000 +0300
-+++ vim74/runtime/vimrc_example.vim    2013-09-06 00:11:24.756404306 +0300
-@@ -46,13 +46,13 @@ map Q gq
- inoremap <C-U> <C-G>u<C-U>
+--- vim-7.4.2189/runtime/vimrc_example.vim~    2016-08-09 22:14:05.000000000 +0200
++++ vim-7.4.2189/runtime/vimrc_example.vim     2016-08-09 22:20:44.071303413 +0200
+@@ -26,7 +23,7 @@ else
+   endif
+ endif
+-if &t_Co > 2 || has("gui_running")
++if (&t_Co > 2 || has("gui_running")) && filereadable($VIMRUNTIME."/syntax/syntax.vim")
+   " Switch on highlighting the last used search pattern.
+   set hlsearch
+ endif
+@@ -56,3 +53,11 @@ endif " has("autocmd")
+ if has('syntax') && has('eval')
+   packadd matchit
+ endif
++
++" Use :help colorscheme for info
++"set background=dark
++
++" Source a global configuration file if available
++if filereadable("/etc/vim/vimrc.local")
++  source /etc/vim/vimrc.local
++endi
+--- vim-7.4.2189/runtime/defaults.vim~ 2016-08-09 22:14:05.000000000 +0200
++++ vim-7.4.2189/runtime/defaults.vim  2016-08-09 22:26:29.727124083 +0200
+@@ -53,9 +53,9 @@ inoremap <C-U> <C-G>u<C-U>
  
- " In many terminal emulators the mouse works just fine, thus enable it.
+ " In many terminal emulators the mouse works just fine.  By enabling it you
+ " can position the cursor, Visually select and scroll with the mouse.
 -if has('mouse')
 -  set mouse=a
 -endif
  
  " Switch syntax highlighting on when the terminal has colors or when using the
  " GUI (which always has colors).
--if &t_Co > 2 || has("gui_running")
-+if (&t_Co > 2 || has("gui_running")) && filereadable($VIMRUNTIME."/syntax/syntax.vim")
-   syntax on
-   " Also switch on highlighting the last used search pattern.
-@@ -93,10 +93,18 @@
- " Convenient command to see the difference between the current buffer and the
+@@ -99,7 +99,7 @@ endif " has("autocmd")
  " file it was loaded from, thus the changes you made.
  " Only define it when not defined already.
+ " Revert with: ":delcommand DiffOrig".
 -if !exists(":DiffOrig")
 +if v:progname =~! "vi" && !exists(":DiffOrig")
    command DiffOrig vert new | set bt=nofile | r ++edit # | 0d_ | diffthis
                  \ | wincmd p | diffthis
  endif
-+
-+" Use :help colorscheme for info
-+"set background=dark
-+
-+" Source a global configuration file if available
-+if filereadable("/etc/vim/vimrc.local")
-+  source /etc/vim/vimrc.local
-+endif
- if has('langmap') && exists('+langnoremap')
-   " Prevent that the langmap option applies to characters that result from a
index a66925c197daf3ecd9c75b7cc97862b8593718b3..f8eb9570b0145658f62ffd06ca3ceffe865fc93a 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -28,8 +28,8 @@
 # tail -n1 sources | awk '{print $2}'
 # VCS Commits: https://github.com/vim/vim/commits/master
 
-%define                ver             7.4.2054
-%define                rel             2
+%define                ver             7.4.2189
+%define                rel             1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
 Summary(es.UTF-8):     Editor visual incrementado
@@ -49,7 +49,7 @@ License:      Charityware
 Group:         Applications/Editors/Vim
 #Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
 Source0:       https://github.com/vim/vim/archive/v%{ver}.tar.gz
-# Source0-md5: 76acebdc395e57fc993d444d9e9b97df
+# Source0-md5: 7d8edf9269bb12f888f5585681e69bcc
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
@@ -1367,6 +1367,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %lang(de) %{_datadir}/vim/tutor/tutor.bar
 %lang(de) %{_datadir}/vim/tutor/tutor.bar.utf-8
+%lang(bg) %{_datadir}/vim/tutor/tutor.bg.utf-8
 %lang(ca) %{_datadir}/vim/tutor/tutor.ca
 %lang(ca) %{_datadir}/vim/tutor/tutor.ca.utf-8
 %lang(cs) %{_datadir}/vim/tutor/tutor.cs
This page took 0.045221 seconds and 4 git commands to generate.