]> git.pld-linux.org Git - packages/vim.git/commitdiff
- switched to smaller .tar.bz2 source (instead of 4 .tar.gz files) vim-6_0at-2
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 29 Aug 2001 19:21:07 +0000 (19:21 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated ispell patch
- pl patch is back! (most important fix (format string) still isn't in source)
- release 2

Changed files:
    vim-ispell.patch -> 1.3
    vim-pl.patch -> 1.3
    vim.spec -> 1.83

vim-ispell.patch
vim-pl.patch [new file with mode: 0644]
vim.spec

index ab841a182865338eca9e342f9532dbb6f0022da5..f8efcebd242b134686de8b219ff356f530b30898 100644 (file)
@@ -385,212 +385,6 @@ diff -Nur vim60am.old/src/option.h vim60am/src/option.h
  #ifdef FEAT_INS_EXPAND
  EXTERN char_u *p_dict;        /* 'dictionary' */
  #endif
-diff -Nur vim60am.old/src/os_msdos.c vim60am/src/os_msdos.c
---- vim60am.old/src/os_msdos.c Wed Jul  4 20:42:09 2001
-+++ vim60am/src/os_msdos.c     Tue Jul  3 18:39:48 2001
-@@ -78,7 +78,7 @@
-  */
- unsigned long S_ulScreenBase = 0xb8000;
--unsigned short        S_uiAttribute = 0;
-+unsigned short        S_uiAttribute =  7 << 8;
- int           S_iCurrentRow = 0;      /* These are 0 offset */
- int           S_iCurrentColumn = 0;
- int           S_iLeft = 0;    /* Scroll window; these are 1 offset */
-@@ -248,6 +248,9 @@
-     }
-     else
-     {
-+      if(iChar == ' ')
-+      uiValue = ((S_uiAttribute & 0xf700) | 0x700) | ' ';
-+      else
-       uiValue = S_uiAttribute | (unsigned char)iChar;
-       /*
-@@ -309,6 +312,7 @@
- mytextattr(int iAttribute)
- {
-     S_uiAttribute = (unsigned short)iAttribute << 8;
-+    textattr(iAttribute);             /* for delline() etc */
- }
-     static void
-@@ -322,6 +326,7 @@
- {
-     S_uiAttribute = (unsigned short)((S_uiAttribute & 0xf000)
-                                          | (unsigned short)iTextColor << 8);
-+    textattr(S_uiAttribute >> 8);     /* for delline() etc */
- }
-     static void
-@@ -329,6 +334,7 @@
- {
-     S_uiAttribute = (unsigned short)((S_uiAttribute & 0x0f00)
-                                        | (unsigned short)(iBkgColor << 12));
-+    textattr(S_uiAttribute >> 8);     /* for delline() etc */
- }
- /*
-  * Getdigits: Get a number from a string and skip over it.
-@@ -470,6 +476,7 @@
-     static union REGS     regs;
-     static int                    saved = FALSE;
-+    return;   /* WM */
-     if (restore)
-     {
-       if (saved)
-@@ -495,6 +502,7 @@
- mch_set_cursor_shape(int thickness)
- {
-     union REGS            regs;
-+    return;   /* WM */
-     regs.h.ch = 7 - thickness;            /*Starting Line*/
-     regs.h.cl = 7;                /*Ending Line*/
-@@ -508,6 +516,7 @@
-     int               idx;
-     int               thickness;
-+    return;   /* WM */
-     /*
-      * How the cursor is drawn depends on the current mode.
-      */
-@@ -2226,6 +2235,7 @@
-     char *
- djgpp_setlocale(void)
- {
-+     char *country;
-     __dpmi_regs regs;
-     struct { char id; unsigned short off, seg; } __attribute__ ((packed)) info;
-     unsigned char buffer[0x82], lower, upper;
-@@ -2267,6 +2277,127 @@
-               __dj_ctype_tolower[upper+1] = lower;
-       }
-     }
-+     if ((country = getenv("COUNTRY")) != NULL)
-+        {
-+         if(!strcmp(country, "MAZOWIA"))
-+         {
-+          __dj_ctype_flags[(unsigned char)'\86' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'\8f' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'\8d' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'\95' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'\91' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'\90' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'\92' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'\9c' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'¤' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'¥' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'¢' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'£' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'\9e' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'\98' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'¦' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)' ' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'§' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'¡' + 1] = UPCASE;
-+ 
-+          __dj_ctype_toupper[(unsigned char)'\86'+ 1] = (unsigned char)'\8f';
-+          __dj_ctype_toupper[(unsigned char)'\8f'+ 1] = (unsigned char)'\8f';
-+          __dj_ctype_toupper[(unsigned char)'\8d'+ 1] = (unsigned char)'\95';
-+          __dj_ctype_toupper[(unsigned char)'\95'+ 1] = (unsigned char)'\95';
-+          __dj_ctype_toupper[(unsigned char)'\91'+ 1] = (unsigned char)'\90';
-+          __dj_ctype_toupper[(unsigned char)'\90'+ 1] = (unsigned char)'\90';
-+          __dj_ctype_toupper[(unsigned char)'\92'+ 1] = (unsigned char)'\9c';
-+          __dj_ctype_toupper[(unsigned char)'\9c'+ 1] = (unsigned char)'\9c';
-+          __dj_ctype_toupper[(unsigned char)'¤'+ 1] = (unsigned char)'¥';
-+          __dj_ctype_toupper[(unsigned char)'¥'+ 1] = (unsigned char)'¥';
-+          __dj_ctype_toupper[(unsigned char)'¢'+ 1] = (unsigned char)'£';
-+          __dj_ctype_toupper[(unsigned char)'£'+ 1] = (unsigned char)'£';
-+          __dj_ctype_toupper[(unsigned char)'\9e'+ 1] = (unsigned char)'\98';
-+          __dj_ctype_toupper[(unsigned char)'\98'+ 1] = (unsigned char)'\98';
-+          __dj_ctype_toupper[(unsigned char)'¦'+ 1] = (unsigned char)' ';
-+          __dj_ctype_toupper[(unsigned char)' '+ 1] = (unsigned char)' ';
-+          __dj_ctype_toupper[(unsigned char)'§'+ 1] = (unsigned char)'¡';
-+          __dj_ctype_toupper[(unsigned char)'¡'+ 1] = (unsigned char)'¡';
-+ 
-+          __dj_ctype_tolower[(unsigned char)'\86'+ 1] = (unsigned char)'\86';
-+          __dj_ctype_tolower[(unsigned char)'\8f'+ 1] = (unsigned char)'\86';
-+          __dj_ctype_tolower[(unsigned char)'\8d'+ 1] = (unsigned char)'\8d';
-+          __dj_ctype_tolower[(unsigned char)'\95'+ 1] = (unsigned char)'\8d';
-+          __dj_ctype_tolower[(unsigned char)'\91'+ 1] = (unsigned char)'\91';
-+          __dj_ctype_tolower[(unsigned char)'\90'+ 1] = (unsigned char)'\91';
-+          __dj_ctype_tolower[(unsigned char)'\92'+ 1] = (unsigned char)'\92';
-+          __dj_ctype_tolower[(unsigned char)'\9c'+ 1] = (unsigned char)'\92';
-+          __dj_ctype_tolower[(unsigned char)'¤'+ 1] = (unsigned char)'¤';
-+          __dj_ctype_tolower[(unsigned char)'¥'+ 1] = (unsigned char)'¤';
-+          __dj_ctype_tolower[(unsigned char)'¢'+ 1] = (unsigned char)'¢';
-+          __dj_ctype_tolower[(unsigned char)'£'+ 1] = (unsigned char)'¢';
-+          __dj_ctype_tolower[(unsigned char)'\9e'+ 1] = (unsigned char)'\9e';
-+          __dj_ctype_tolower[(unsigned char)'\98'+ 1] = (unsigned char)'\9e';
-+          __dj_ctype_tolower[(unsigned char)'¦'+ 1] = (unsigned char)'¦';
-+          __dj_ctype_tolower[(unsigned char)' '+ 1] = (unsigned char)'¦';
-+          __dj_ctype_tolower[(unsigned char)'§'+ 1] = (unsigned char)'§';
-+          __dj_ctype_tolower[(unsigned char)'¡'+ 1] = (unsigned char)'§';
-+         }
-+       else if(!strcmp(country, "CP1250"))
-+         {
-+          __dj_ctype_flags[(unsigned char)'9' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'%' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'f' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'F' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'j' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'J' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'3' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'#' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'q' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'Q' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'s' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'S' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'\1c' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'\f' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'\1f' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'\ f' + 1] = UPCASE;
-+          __dj_ctype_flags[(unsigned char)'?' + 1] = LOCASE;
-+          __dj_ctype_flags[(unsigned char)'/' + 1] = UPCASE;
-+ 
-+          __dj_ctype_toupper[(unsigned char)'9'+ 1] = (unsigned char)'%';
-+          __dj_ctype_toupper[(unsigned char)'%'+ 1] = (unsigned char)'%';
-+          __dj_ctype_toupper[(unsigned char)'f'+ 1] = (unsigned char)'F';
-+          __dj_ctype_toupper[(unsigned char)'F'+ 1] = (unsigned char)'F';
-+          __dj_ctype_toupper[(unsigned char)'j'+ 1] = (unsigned char)'J';
-+          __dj_ctype_toupper[(unsigned char)'J'+ 1] = (unsigned char)'J';
-+          __dj_ctype_toupper[(unsigned char)'3'+ 1] = (unsigned char)'#';
-+          __dj_ctype_toupper[(unsigned char)'#'+ 1] = (unsigned char)'#';
-+          __dj_ctype_toupper[(unsigned char)'q'+ 1] = (unsigned char)'Q';
-+          __dj_ctype_toupper[(unsigned char)'Q'+ 1] = (unsigned char)'Q';
-+          __dj_ctype_toupper[(unsigned char)'s'+ 1] = (unsigned char)'S';
-+          __dj_ctype_toupper[(unsigned char)'S'+ 1] = (unsigned char)'S';
-+          __dj_ctype_toupper[(unsigned char)'\1c'+ 1] = (unsigned char)'\f';
-+          __dj_ctype_toupper[(unsigned char)'\f'+ 1] = (unsigned char)'\f';
-+          __dj_ctype_toupper[(unsigned char)'\1f'+ 1] = (unsigned char)'\ f';
-+          __dj_ctype_toupper[(unsigned char)'\ f'+ 1] = (unsigned char)'\ f';
-+          __dj_ctype_toupper[(unsigned char)'?'+ 1] = (unsigned char)'/';
-+          __dj_ctype_toupper[(unsigned char)'/'+ 1] = (unsigned char)'/';
-+ 
-+          __dj_ctype_tolower[(unsigned char)'9'+ 1] = (unsigned char)'9';
-+          __dj_ctype_tolower[(unsigned char)'%'+ 1] = (unsigned char)'9';
-+          __dj_ctype_tolower[(unsigned char)'f'+ 1] = (unsigned char)'f';
-+          __dj_ctype_tolower[(unsigned char)'F'+ 1] = (unsigned char)'f';
-+          __dj_ctype_tolower[(unsigned char)'j'+ 1] = (unsigned char)'j';
-+          __dj_ctype_tolower[(unsigned char)'J'+ 1] = (unsigned char)'j';
-+          __dj_ctype_tolower[(unsigned char)'3'+ 1] = (unsigned char)'3';
-+          __dj_ctype_tolower[(unsigned char)'#'+ 1] = (unsigned char)'3';
-+          __dj_ctype_tolower[(unsigned char)'q'+ 1] = (unsigned char)'q';
-+          __dj_ctype_tolower[(unsigned char)'Q'+ 1] = (unsigned char)'q';
-+          __dj_ctype_tolower[(unsigned char)'s'+ 1] = (unsigned char)'s';
-+          __dj_ctype_tolower[(unsigned char)'S'+ 1] = (unsigned char)'s';
-+          __dj_ctype_tolower[(unsigned char)'\1c'+ 1] = (unsigned char)'\1c';
-+          __dj_ctype_tolower[(unsigned char)'\f'+ 1] = (unsigned char)'\1c';
-+          __dj_ctype_tolower[(unsigned char)'\1f'+ 1] = (unsigned char)'\1f';
-+          __dj_ctype_tolower[(unsigned char)'\ f'+ 1] = (unsigned char)'\1f';
-+          __dj_ctype_tolower[(unsigned char)'?'+ 1] = (unsigned char)'?';
-+          __dj_ctype_tolower[(unsigned char)'/'+ 1] = (unsigned char)'?';
-+         }
-+        }
-     return "C";
- }
 diff -Nur vim60am.old/src/proto/spell.pro vim60am/src/proto/spell.pro
 --- vim60am.old/src/proto/spell.pro    Thu Jan  1 01:00:00 1970
 +++ vim60am/src/proto/spell.pro        Wed Jun 27 19:19:35 2001
@@ -7202,15 +6996,15 @@ diff -Nur vim60am.old/src/version.h vim60am/src/version.h
 +++ vim60am/src/version.h      Tue Jul  3 19:04:36 2001
 @@ -33,6 +33,10 @@
   */
- #define VIM_VERSION_NODOT     "vim60ar"
- #define VIM_VERSION_SHORT     "6.0ar"
+ #define VIM_VERSION_NODOT     "vim60at"
+ #define VIM_VERSION_SHORT     "6.0at"
 +#ifdef FEAT_SPELL_HL
-+#define VIM_VERSION_MEDIUM    "6.0ar BETA + ispell 3.1.20 WM-3"
++#define VIM_VERSION_MEDIUM    "6.0at BETA + ispell 3.1.20 WM-3"
 +#else
- #define VIM_VERSION_MEDIUM    "6.0ar BETA"
+ #define VIM_VERSION_MEDIUM    "6.0at BETA"
 +#endif
- #define VIM_VERSION_LONG      "VIM - Vi IMproved 6.0ar BETA (2001 Aug 12)"
- #define VIM_VERSION_LONG_DATE "VIM - Vi IMproved 6.0ar BETA (2001 Aug 12, compiled "
+ #define VIM_VERSION_LONG      "VIM - Vi IMproved 6.0at BETA (2001 Aug 27)"
+ #define VIM_VERSION_LONG_DATE "VIM - Vi IMproved 6.0at BETA (2001 Aug 27, compiled "
 diff -Nur vim60am.old/src/vim.h vim60am/src/vim.h
 --- vim60am.old/src/vim.h      Wed Jul  4 20:42:09 2001
 +++ vim60am/src/vim.h  Tue Jul  3 18:21:26 2001
diff --git a/vim-pl.patch b/vim-pl.patch
new file mode 100644 (file)
index 0000000..2fb94dd
--- /dev/null
@@ -0,0 +1,11 @@
+--- vim60at/src/po/pl.po.orig  Mon Jul 30 19:38:21 2001
++++ vim60at/src/po/pl.po       Fri Aug 10 21:04:48 2001
+@@ -380,7 +380,7 @@
+ #: edit.c:3349
+ #, c-format
+ msgid "match %d"
+-msgstr "pasuje %s"
++msgstr "pasuje %d"
+ #: eval.c:686
+ #, c-format
index a83e8f1e89441f37187b73918efefc6bbe2262be..57fd91ca3435935d5f24603dbe2809ce2641dccb 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -14,27 +14,25 @@ Summary(pl):        Vi IMproved - klon edytora Vi
 Summary(tr):   Geliþmiþ bir vi sürümü
 Name:          vim
 Version:       6.0at
-Release:       1
+Release:       2
 Epoch:         2
 License:       Charityware
 Group:         Applications/Editors/Vim
 Group(de):     Applikationen/Editors/Vim
 Group(pl):     Aplikacje/Edytory/Vim
-Source0:       ftp://ftp.vim.org/pub/editors/vim/unreleased/unix/%{name}-%{version}-src1.tar.gz
-Source1:       ftp://ftp.vim.org/pub/editors/vim/unreleased/unix/%{name}-%{version}-src2.tar.gz
-Source2:       ftp://ftp.vim.org/pub/editors/vim/unreleased/unix/%{name}-%{version}-rt1.tar.gz
-Source3:       ftp://ftp.vim.org/pub/editors/vim/unreleased/unix/%{name}-%{version}-rt2.tar.gz
-#Source4:      ftp://ftp.vim.org/pub/editors/vim/unreleased/extra/%{name}-%{version}-extra.tar.gz
-Source5:       ftp://ftp.vim.org/pub/editors/vim/unreleased/extra/%{name}-%{version}-lang.tar.gz
-Source6:       g%{name}-athena.desktop
-Source7:       g%{name}-motif.desktop
-Source8:       g%{name}-gtk.desktop
-Source9:       g%{name}-gnome.desktop
+Source0:       ftp://ftp.vim.org/pub/editors/vim/unreleased/unix/%{name}-%{version}.tar.bz2
+Source1:       ftp://ftp.vim.org/pub/editors/vim/unreleased/extra/%{name}-%{version}-lang.tar.gz
+#Source2:      ftp://ftp.vim.org/pub/editors/vim/unreleased/extra/%{name}-%{version}-extra.tar.gz
+Source3:       g%{name}-athena.desktop
+Source4:       g%{name}-motif.desktop
+Source5:       g%{name}-gtk.desktop
+Source6:       g%{name}-gnome.desktop
 Patch0:                %{name}-sysconfdir.patch
 Patch1:                %{name}-visual.patch
 Patch2:                %{name}-phphighlight.patch
 Patch3:                %{name}-paths.patch
 Patch4:                %{name}-ispell.patch
+Patch5:                %{name}-pl.patch
 URL:           http://www.vim.org/
 BuildRequires: gpm-devel
 BuildRequires: ncurses-devel
@@ -212,12 +210,13 @@ Wersja edytora vim pracuj
 bibliotek GNOME.
 
 %prep
-%setup -q -b1 -b2 -b3 -b5 -n %{name}%(echo %{version} | sed -e "s#\.##g")
+%setup -q -b1 -n %{name}%(echo %{version} | sed -e "s#\.##g")
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %{?_with_ispell:%patch4 -p1}
+%patch5 -p1
 
 %build
 cd src
@@ -384,10 +383,10 @@ ln -sf vi  $RPM_BUILD_ROOT/bin/rview
 %{!?_without_gtk:ln -sf gvim                   $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/gview}
 %{!?_without_gtk:ln -sf gvim                   $RPM_BUILD_ROOT%{_prefix}/X11R6/bin/rgview}
 
-%{!?_without_athena:install %{SOURCE6}         $RPM_BUILD_ROOT%{_applnkdir}/Development/Editors}
-%{!?_without_motif: install %{SOURCE7}         $RPM_BUILD_ROOT%{_applnkdir}/Development/Editors}
-%{!?_without_gtk:   install %{SOURCE8}                 $RPM_BUILD_ROOT%{_applnkdir}/Development/Editors}
-%{!?_without_gnome: install %{SOURCE9}         $RPM_BUILD_ROOT%{_applnkdir}/Development/Editors}
+%{!?_without_athena:install %{SOURCE3}         $RPM_BUILD_ROOT%{_applnkdir}/Development/Editors}
+%{!?_without_motif: install %{SOURCE4}         $RPM_BUILD_ROOT%{_applnkdir}/Development/Editors}
+%{!?_without_gtk:   install %{SOURCE5}                 $RPM_BUILD_ROOT%{_applnkdir}/Development/Editors}
+%{!?_without_gnome: install %{SOURCE6}         $RPM_BUILD_ROOT%{_applnkdir}/Development/Editors}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.067002 seconds and 4 git commands to generate.