]> git.pld-linux.org Git - packages/vim.git/commitdiff
Up to 8.2.4295. auto/th/vim-8.2.4295-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 4 Feb 2022 23:10:41 +0000 (00:10 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 4 Feb 2022 23:10:41 +0000 (00:10 +0100)
vim-ft-gyp.patch
vim-ft-mysql.patch
vim-nagios.patch
vim-smarty.patch
vim.spec

index db304b03af97bf596c7260ea25c2d2ca27d83692..e698a25384871c8b747763128c44d45c4a21ba6d 100644 (file)
@@ -1,12 +1,13 @@
 --- vim-8.2.2976/runtime/filetype.vim~ 2021-06-12 10:01:08.000000000 +0200
 +++ vim-8.2.2976/runtime/filetype.vim  2021-06-12 10:02:30.456368850 +0200
-@@ -711,6 +711,9 @@ au BufNewFile,BufRead */etc/group,*/etc/
+@@ -2347,6 +2347,9 @@ au BufNewFile,BufRead */gitolite-admin/c
  " GTK RC
- au BufNewFile,BufRead .gtkrc,gtkrc            setf gtkrc
+ au BufNewFile,BufRead .gtkrc*,gtkrc*          call s:StarSetf('gtkrc')
  
 +" GYP (Python syntax)
 +au BufNewFile,BufRead *.gyp,*.gypi,DEPS               set filetype=python expandtab tabstop=2 shiftwidth=2
 +
- " Haml
- au BufNewFile,BufRead *.haml                  setf haml
+ " Jam
+ au BufNewFile,BufRead Prl*.*,JAM*.*           call s:StarSetf('jam')
  
+
index 1149602c4e2028eb2d8823f1464aeb7e41956335..860e5009a6d8bfe599235fa6faff03b9e5bd530c 100644 (file)
@@ -1,11 +1,12 @@
 --- vim72/runtime/filetype.vim~        2010-01-21 21:47:56.000000000 +0200
 +++ vim72/runtime/filetype.vim 2010-04-22 14:27:15.550974158 +0300
-@@ -1151,7 +1151,7 @@
+@@ -1171,7 +1171,7 @@ au BufNewFile,BufRead mrxvtrc,.mrxvtrc
  au BufNewFile,BufRead *.msql                  setf msql
  
  " Mysql
 -au BufNewFile,BufRead *.mysql                 setf mysql
-+au BufNewFile,BufRead *.mysql,.*mysql_history*                        setf mysql
++au BufNewFile,BufRead *.mysql,.*mysql_history*        setf mysql
  
- " Mutt setup files (must be before catch *.rc)
- au BufNewFile,BufRead */etc/Muttrc.d/*                call s:StarSetf('muttrc')
+ " Tcl Shell RC file
+ au BufNewFile,BufRead tclsh.rc                        setf tcl
+
index ed478695bdf6b19fa484c5e03accc4fd699f7cab..876055f7ca4628a476d2c66030767432999ff46a 100644 (file)
@@ -1,11 +1,12 @@
 --- vim-7.0/runtime/filetype.vim~      2006-03-30 22:10:33.046344554 +0300
 +++ vim-7.0/runtime/filetype.vim       2006-03-30 23:14:19.721780355 +0300
-@@ -2095,6 +2095,8 @@
- au BufNewFile,BufRead .zsh*,.zlog*,.zcompdump*  call s:StarSetf('zsh')
- au BufNewFile,BufRead zsh*,zlog*              call s:StarSetf('zsh')
+@@ -2255,6 +2255,8 @@ au BufNewFile,BufRead *
+       \ | runtime! scripts.vim | endif
+ au StdinReadPost * if !did_filetype() | runtime! scripts.vim | endif
  
 +" Nagios config
 +au BufNewFile,BufRead /*etc/nagios/*.cfg,*sample-config/template-object/*.cfg{,.in},/var/lib/nagios/objects.cache set filetype=nagios
  
  " Plain text files, needs to be far down to not override others.  This avoids
  " the "conf" type being used if there is a line starting with '#'.
+
index f8c82d23b22ce2973a73265267cac3dbe712b5e5..4b8f68cfda86f1bc977838db0b0a7eb81102f5b8 100644 (file)
@@ -1,14 +1,14 @@
 --- ./runtime/filetype.vim     2006-01-12 17:26:15.000000000 +0200
 +++ /tmp/filetype.vim  2006-01-12 17:25:53.000000000 +0200
-@@ -590,6 +590,9 @@
+@@ -792,6 +792,9 @@ au BufRead,BufNewFile *.heex                       setf heex
  " HEX (Intel)
  au BufNewFile,BufRead *.hex,*.h32             setf hex
  
 +" Smarty templates (must be before HTML)
-+au BufNewFile,BufRead *.tpl.html,*.tpl                        setf smarty
++au BufNewFile,BufRead *.tpl.html,*.tpl                setf smarty
 +
- " Hollywood
- au BufRead,BufNewFile *.hws                   setf hollywood
+ " Hjson
+ au BufNewFile,BufRead *.hjson                 setf hjson
  
 @@ -1396,9 +1399,6 @@
        \  setf st |
index bce207607bcadb078cdfea578afa9c339b9038ea..b414f6da18e1cf44c587b57cc40cb5e44633d7f8 100644 (file)
--- a/vim.spec
+++ b/vim.spec
@@ -31,7 +31,7 @@
 # wget ftp://ftp.vim.org/pub/editors/vim/patches/8.0/MD5SUMS -O - | tail -n1 | awk '{print $2}'
 # VCS Commits: https://github.com/vim/vim/commits/master
 
-%define                ver             8.2.3570
+%define                ver             8.2.4295
 %define                rel             1
 Summary:       Vi IMproved - a Vi clone
 Summary(de.UTF-8):     VIsual editor iMproved
@@ -52,7 +52,7 @@ License:      Charityware
 Group:         Applications/Editors/Vim
 #Source0:      ftp://ftp.vim.org/pub/vim/unix/%{name}-%{ver}.tar.bz2
 Source0:       https://github.com/vim/vim/archive/v%{ver}.tar.gz
-# Source0-md5: 50cbcd6e830061176ab268fdedd4690a
+# Source0-md5: 4fbb220d69db1931ac4b71de340b7b73
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: bc4d1e115ca506ad7751b9bd2b773a7f
 Source2:       http://skawina.eu.org/mikolaj/usr_doc_pl.zip
This page took 0.70066 seconds and 4 git commands to generate.