]> git.pld-linux.org Git - packages/vcdimager.git/blob - vcdimager.spec
- libcdio related rebuild
[packages/vcdimager.git] / vcdimager.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        VideoCD (pre-)mastering and ripping tools
6 Summary(pl.UTF-8):      Narzędzia do tworzenia i odczytu VideoCD
7 Name:           vcdimager
8 Version:        0.7.24
9 Release:        5
10 License:        GPL v2+
11 Group:          Applications/File
12 Source0:        http://ftp.gnu.org/gnu/vcdimager/%{name}-%{version}.tar.gz
13 # Source0-md5:  3af22978fd79c79d5fda6513b6811145
14 Patch0:         %{name}-info.patch
15 Patch1:         %{name}-texinfo.patch
16 URL:            http://www.gnu.org/software/vcdimager/
17 BuildRequires:  autoconf >= 2.52
18 BuildRequires:  automake >= 1.6.0
19 BuildRequires:  help2man
20 BuildRequires:  libcdio-devel >= 0.76
21 BuildRequires:  libtool >= 1:1.4.2-9
22 BuildRequires:  libxml2-devel >= 2.6.11
23 BuildRequires:  pkgconfig
24 BuildRequires:  popt-devel >= 1.7
25 BuildRequires:  texinfo
26 Requires(post,postun):  /sbin/ldconfig
27 Requires:       libcdio >= 0.76
28 Requires:       libxml2 >= 2.6.11
29 Requires:       popt >= 1.7
30 Obsoletes:      vcdimager-cdio
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 VCDImager allows you to create VideoCD BIN/CUE CD images from mpeg
35 files which can be burned with cdrdao or any other program capable of
36 burning BIN/CUE files. VCDRip, which comes with VCDImager, does the
37 reverse operation. That is, ripping mpeg streams from images (and
38 already burned VideoCDs) and showing some information about the
39 VideoCD.
40
41 %description -l pl.UTF-8
42 VCDImager służy do tworzenia obrazów VideoCD BIN/CUE z plików mpeg,
43 które następnie mogą być wypalone za pomocą cdrdao lub innego programu
44 zdolnego do wypalania plików BIN/CUE. VCDRip dostarczany wraz z
45 VCDImager pozwala na wykonanie odwrotnej operacji tzn. zrzucenia
46 strumienia mpeg z obrazów (oraz już wypalonych płyt VideoCD).
47
48 %package devel
49 Summary:        Header files for vcd libraries
50 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek vcd
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       libcdio-devel >= 0.76
54 Obsoletes:      vcdimager-cdio-devel
55
56 %description devel
57 Header files for vcd libraries.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe bibliotek vcd.
61
62 %package static
63 Summary:        Static vcd libraries
64 Summary(pl.UTF-8):      Statyczne biblioteki vcd
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67 Obsoletes:      vcdimager-cdio-static
68
69 %description static
70 Static vcd libraries.
71
72 %description static -l pl.UTF-8
73 Statyczne biblioteki vcd.
74
75 %prep
76 %setup -q
77 %patch0 -p1
78 %patch1 -p1
79
80 cp -f libpopt.m4 acinclude.m4
81
82 %build
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__autoheader}
87 %{__automake}
88 %configure \
89         --enable-maintainer-mode \
90         %{!?with_static_libs:--disable-static}
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvcdinfo.la
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 /sbin/ldconfig
107 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
108
109 %postun
110 /sbin/ldconfig
111 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS BUGS ChangeLog FAQ NEWS README THANKS TODO
116 %attr(755,root,root) %{_bindir}/cdxa2mpeg
117 %attr(755,root,root) %{_bindir}/vcd-info
118 %attr(755,root,root) %{_bindir}/vcdimager
119 %attr(755,root,root) %{_bindir}/vcdxbuild
120 %attr(755,root,root) %{_bindir}/vcdxgen
121 %attr(755,root,root) %{_bindir}/vcdxminfo
122 %attr(755,root,root) %{_bindir}/vcdxrip
123 %attr(755,root,root) %{_libdir}/libvcdinfo.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libvcdinfo.so.0
125 %{_mandir}/man1/cdxa2mpeg.1*
126 %{_mandir}/man1/vcd-info.1*
127 %{_mandir}/man1/vcdimager.1*
128 %{_mandir}/man1/vcdxbuild.1*
129 %{_mandir}/man1/vcdxgen.1*
130 %{_mandir}/man1/vcdxminfo.1*
131 %{_mandir}/man1/vcdxrip.1*
132 %{_infodir}/vcd-info.info*
133 %{_infodir}/vcdimager.info*
134 %{_infodir}/vcdxrip.info*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libvcdinfo.so
139 %{_includedir}/libvcd
140 %{_pkgconfigdir}/libvcdinfo.pc
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libvcdinfo.a
146 %endif
This page took 0.123277 seconds and 3 git commands to generate.