]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
- updated to 0.16.1
[packages/vala.git] / vala.spec
1 %define major_ver       0.16
2 Summary:        GObject-based language compiler
3 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
4 Name:           vala
5 Version:        0.16.1
6 Release:        1
7 Epoch:          2
8 License:        LGPL v2+
9 Group:          Applications
10 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.16/%{name}-%{version}.tar.xz
11 # Source0-md5:  a270330532ae7770ca64d9f2faff4a2d
12 URL:            http://live.gnome.org/Vala
13 BuildRequires:  autoconf
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  glib2-devel >= 1:2.16.0
18 BuildRequires:  libtool
19 BuildRequires:  libxslt-progs
20 BuildRequires:  pkgconfig
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Conflicts:      gdk-pixbuf2 < 2.23.3-1
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Vala is a new programming language that aims to bring modern
28 programming language features to GNOME developers without imposing any
29 additional runtime requirements and without using a different ABI
30 compared to applications and libraries written in C.
31
32 valac, the Vala compiler, is a self-hosting compiler that translates
33 Vala source code into C source and header files. It uses the GObject
34 type system to create classes and interfaces declared in the Vala
35 source code. It's also planned to generate GIDL files when
36 gobject-introspection is ready.
37
38 The syntax of Vala is similar to C#, modified to better fit the
39 GObject type system.
40
41 %description -l pl.UTF-8
42 Vala to nowy język programowania, którego celem jest udostępnienie
43 cech nowoczesnych języków programowania programistom GNOME bez
44 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
45 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
46
47 valac - kompilator języka Vala - to napisany w sobie samym kompilator
48 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
49 C. Używa systemu typów GObject do tworzenia klas i interfejsów
50 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
51 generowanie plików GIDL, kiedy system gobject-introspection będzie
52 gotowy.
53
54 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
55 pasować do systemu typów GObject.
56
57 %package apidocs
58 Summary:        vala API documentation
59 Summary(pl.UTF-8):      Dokumentacja API vala
60 Group:          Documentation
61 Requires:       devhelp
62
63 %description apidocs
64 vala API documentation.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API vala.
68
69 %prep
70 %setup -q
71
72 %build
73 %{__libtoolize}
74 %{__aclocal} -I m4
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 %configure \
79         --disable-silent-rules \
80         --enable-vapigen
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_bindir}/*
102 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
104 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
105 %{_includedir}/vala-%{major_ver}
106 %{_pkgconfigdir}/libvala-%{major_ver}.pc
107 %{_npkgconfigdir}/vapigen-%{major_ver}.pc
108 %{_npkgconfigdir}/vapigen.pc
109 %dir %{_datadir}/vala
110 %{_datadir}/vala/Makefile.vapigen
111 %dir %{_datadir}/vala/vapi
112 %dir %{_datadir}/vala-%{major_ver}
113 %dir %{_datadir}/vala-%{major_ver}/vapi
114 %{_datadir}/vala-%{major_ver}/vapi/*.vapi
115 %{_datadir}/vala-%{major_ver}/vapi/*.deps
116 %{_mandir}/man1/valac.1*
117 %{_mandir}/man1/valac-%{major_ver}.1*
118 %dir %{_libdir}/vala-%{major_ver}
119 %attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
120 %{_mandir}/man1/vala-gen-introspect.1*
121 %{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
122 %{_mandir}/man1/vapigen.1*
123 %{_mandir}/man1/vapigen-%{major_ver}.1*
124 %{_aclocaldir}/vala.m4
125 %{_aclocaldir}/vapigen.m4
126
127 %files apidocs
128 %defattr(644,root,root,755)
129 %{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.12249 seconds and 4 git commands to generate.