]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
- updated to 0.12.1
[packages/vala.git] / vala.spec
1 %define major_ver       0.12
2 Summary:        GObject-based language compiler
3 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
4 Name:           vala
5 Version:        0.12.1
6 Release:        1
7 Epoch:          1
8 License:        LGPL v2+
9 Group:          Applications
10 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.12/%{name}-%{version}.tar.bz2
11 # Source0-md5:  bf35262cc611de447147d01cbac33767
12 URL:            http://live.gnome.org/Vala
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  glib2-devel >= 1:2.16.0
18 BuildRequires:  libtool
19 BuildRequires:  libxslt-progs
20 BuildRequires:  pkgconfig
21 Conflicts:      gdk-pixbuf2 < 2.23.3-1
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Vala is a new programming language that aims to bring modern
26 programming language features to GNOME developers without imposing any
27 additional runtime requirements and without using a different ABI
28 compared to applications and libraries written in C.
29
30 valac, the Vala compiler, is a self-hosting compiler that translates
31 Vala source code into C source and header files. It uses the GObject
32 type system to create classes and interfaces declared in the Vala
33 source code. It's also planned to generate GIDL files when
34 gobject-introspection is ready.
35
36 The syntax of Vala is similar to C#, modified to better fit the
37 GObject type system.
38
39 %description -l pl.UTF-8
40 Vala to nowy język programowania, którego celem jest udostępnienie
41 cech nowoczesnych języków programowania programistom GNOME bez
42 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
43 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
44
45 valac - kompilator języka Vala - to napisany w sobie samym kompilator
46 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
47 C. Używa systemu typów GObject do tworzenia klas i interfejsów
48 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
49 generowanie plików GIDL, kiedy system gobject-introspection będzie
50 gotowy.
51
52 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
53 pasować do systemu typów GObject.
54
55 %package apidocs
56 Summary:        vala API documentation
57 Summary(pl.UTF-8):      Dokumentacja API vala
58 Group:          Documentation
59 Requires:       devhelp
60
61 %description apidocs
62 vala API documentation.
63
64 %description apidocs -l pl.UTF-8
65 Dokumentacja API vala.
66
67 %prep
68 %setup -q
69
70 %build
71 %{__libtoolize}
72 %{__aclocal}
73 %{__autoconf}
74 %{__autoheader}
75 %{__automake}
76 %configure \
77         --disable-silent-rules \
78         --enable-vapigen
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/*
100 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
102 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
103 %{_includedir}/vala-%{major_ver}
104 %{_pkgconfigdir}/libvala-%{major_ver}.pc
105 %dir %{_datadir}/vala
106 %dir %{_datadir}/vala/vapi
107 %dir %{_datadir}/vala-%{major_ver}
108 %dir %{_datadir}/vala-%{major_ver}/vapi
109 %{_datadir}/vala-%{major_ver}/vapi/*.vapi
110 %{_datadir}/vala-%{major_ver}/vapi/*.deps
111 %{_mandir}/man1/valac.1*
112 %{_mandir}/man1/valac-%{major_ver}.1*
113 %dir %{_libdir}/vala-%{major_ver}
114 %attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
115 %{_mandir}/man1/vala-gen-introspect.1*
116 %{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
117 %{_mandir}/man1/vapigen.1*
118 %{_mandir}/man1/vapigen-%{major_ver}.1*
119 %{_aclocaldir}/vala.m4
120
121 %files apidocs
122 %defattr(644,root,root,755)
123 %{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.268606 seconds and 4 git commands to generate.