]> git.pld-linux.org Git - packages/vala.git/blob - vala.spec
Update to 0.34.5
[packages/vala.git] / vala.spec
1 %define major_ver       0.34
2 Summary:        GObject-based language compiler
3 Summary(pl.UTF-8):      Kompilator języka opartego na bibliotece GObject
4 Name:           vala
5 Version:        0.34.5
6 Release:        1
7 Epoch:          2
8 License:        LGPL v2+
9 Group:          Development/Languages
10 Source0:        http://ftp.gnome.org/pub/GNOME/sources/vala/0.34/%{name}-%{version}.tar.xz
11 # Source0-md5:  6fb798d7d988e7838d4e7a0ee2ff4cb4
12 URL:            http://live.gnome.org/Vala
13 BuildRequires:  autoconf >= 2.65
14 BuildRequires:  automake >= 1:1.11
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  glib2-devel >= 1:2.32.0
18 BuildRequires:  libtool >= 2:2.2.6
19 BuildRequires:  libxslt-progs
20 BuildRequires:  pkgconfig >= 1:0.21
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       glib2 >= 1:2.32.0
24 Conflicts:      gdk-pixbuf2 < 2.23.3-1
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Vala is a new programming language that aims to bring modern
29 programming language features to GNOME developers without imposing any
30 additional runtime requirements and without using a different ABI
31 compared to applications and libraries written in C.
32
33 valac, the Vala compiler, is a self-hosting compiler that translates
34 Vala source code into C source and header files. It uses the GObject
35 type system to create classes and interfaces declared in the Vala
36 source code. It's also planned to generate GIDL files when
37 gobject-introspection is ready.
38
39 The syntax of Vala is similar to C#, modified to better fit the
40 GObject type system.
41
42 %description -l pl.UTF-8
43 Vala to nowy język programowania, którego celem jest udostępnienie
44 cech nowoczesnych języków programowania programistom GNOME bez
45 wymuszania dodatkowych wymagań co do środowiska uruchomieniowego i
46 używania API innego niż w aplikacjach i bibliotekach napisanych w C.
47
48 valac - kompilator języka Vala - to napisany w sobie samym kompilator
49 tłumaczący kod źródłowy w języku Vala na pliki źródłowe i nagłówkowe w
50 C. Używa systemu typów GObject do tworzenia klas i interfejsów
51 zadeklarowanych w kodzie źródłowym w języku Vala. Planowane jest także
52 generowanie plików GIDL, kiedy system gobject-introspection będzie
53 gotowy.
54
55 Składnia języka Vala jest podobna do C#, zmodyfikowana tak, aby lepiej
56 pasować do systemu typów GObject.
57
58 %package apidocs
59 Summary:        vala API documentation
60 Summary(pl.UTF-8):      Dokumentacja API vala
61 Group:          Documentation
62 Requires:       devhelp
63 %if "%{_rpmversion}" >= "5"
64 BuildArch:      noarch
65 %endif
66
67 %description apidocs
68 vala API documentation.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API vala.
72
73 %prep
74 %setup -q
75
76 %build
77 %{__libtoolize}
78 %{__aclocal} -I m4
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         --disable-silent-rules
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_datadir}/vala/vapi
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS ChangeLog MAINTAINERS NEWS README THANKS
104 %attr(755,root,root) %{_bindir}/vala
105 %attr(755,root,root) %{_bindir}/vala-%{major_ver}
106 %attr(755,root,root) %{_bindir}/vala-gen-introspect
107 %attr(755,root,root) %{_bindir}/vala-gen-introspect-%{major_ver}
108 %attr(755,root,root) %{_bindir}/valac
109 %attr(755,root,root) %{_bindir}/valac-%{major_ver}
110 %attr(755,root,root) %{_bindir}/vapicheck
111 %attr(755,root,root) %{_bindir}/vapicheck-%{major_ver}
112 %attr(755,root,root) %{_bindir}/vapigen
113 %attr(755,root,root) %{_bindir}/vapigen-%{major_ver}
114 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so.*.*.*
115 %attr(755,root,root) %ghost %{_libdir}/libvala-%{major_ver}.so.0
116 %attr(755,root,root) %{_libdir}/libvala-%{major_ver}.so
117 %{_includedir}/vala-%{major_ver}
118 %{_pkgconfigdir}/libvala-%{major_ver}.pc
119 %{_pkgconfigdir}/vapigen-%{major_ver}.pc
120 %{_pkgconfigdir}/vapigen.pc
121 %dir %{_datadir}/vala
122 %{_datadir}/vala/Makefile.vapigen
123 %dir %{_datadir}/vala/vapi
124 %dir %{_datadir}/vala-%{major_ver}
125 %dir %{_datadir}/vala-%{major_ver}/vapi
126 %{_datadir}/vala-%{major_ver}/vapi/*.vapi
127 %{_datadir}/vala-%{major_ver}/vapi/*.deps
128 %dir %{_libdir}/vala-%{major_ver}
129 %attr(755,root,root) %{_libdir}/vala-%{major_ver}/gen-introspect-%{major_ver}
130 %{_mandir}/man1/vala-gen-introspect.1*
131 %{_mandir}/man1/vala-gen-introspect-%{major_ver}.1*
132 %{_mandir}/man1/valac.1*
133 %{_mandir}/man1/valac-%{major_ver}.1*
134 %{_mandir}/man1/vapigen.1*
135 %{_mandir}/man1/vapigen-%{major_ver}.1*
136 %{_aclocaldir}/vala.m4
137 %{_aclocaldir}/vapigen.m4
138
139 %files apidocs
140 %defattr(644,root,root,755)
141 %{_datadir}/devhelp/books/vala-%{major_ver}
This page took 0.366806 seconds and 3 git commands to generate.