]> git.pld-linux.org Git - packages/unbound.git/blobdiff - unbound.spec
- rebuild with libevent 2.1.11
[packages/unbound.git] / unbound.spec
index 724c56cc01295bb8589e17f0f4f52a1469acdebd..5e86763cf03953969bd65b866e346a14fa5251f0 100644 (file)
@@ -1,34 +1,52 @@
+# FIXME:
+# - stop using nobody group
 #
 # Conditional build:
 %bcond_without python  # Python binding
+%bcond_with    dnstap  # dnstap replication support
+%bcond_with    redis   # cachedb support for redis (using hiredis)
+%bcond_with    systemd # systemd support
+%bcond_without tests   # unit tests
 #
 Summary:       Recursive, validating DNS resolver
 Summary(pl.UTF-8):     Rekurencyjny, weryfikujący resolver DNS
 Name:          unbound
-Version:       1.4.22
-Release:       1
+Version:       1.9.6
+Release:       2
 License:       BSD
 Group:         Applications/Network
 Source0:       http://www.unbound.net/downloads/%{name}-%{version}.tar.gz
-# Source0-md5: 59728c74fef8783f8bad1d7451eba97f
+# Source0-md5: e6423d68e293ffec953477ef1adbbfb7
 Source1:       %{name}.init
 Source2:       %{name}.service
 Source3:       https://data.iana.org/root-anchors/icannbundle.pem
-# Source3-md5: 59774aba58dbde1049bdf4722fb4f02c
+# Source3-md5: 24a426d59b61524623695f1b849f159b
 Source4:       ftp://ftp.internic.net/domain/named.cache
-# Source4-md5: b3b07a2944d29d1f5bd58fe2fe183148
+# Source4-md5: 1e4e7c3e1ce2c5442eed998046edf548
+Patch0:                %{name}-default_trust_anchor.patch
+Patch1:                %{name}-sh.patch
+Patch2:                %{name}-pythondir.patch
+Patch3:                %{name}-flex.patch
 URL:           http://unbound.net/
-BuildRequires: expat-devel
+BuildRequires: autoconf >= 2.56
+BuildRequires: automake
+BuildRequires: bison
+BuildRequires: expat-devel >= 1.95
+BuildRequires: flex
+%{?with_dnstap:BuildRequires:  fstrm-devel}
+%{?with_redis:BuildRequires:   hiredis-devel}
 BuildRequires: libevent-devel
-BuildRequires: openssl-devel
-BuildRequires: rpmbuild(macros) >= 1.228
+BuildRequires: libtool
+BuildRequires: openssl-devel >= 1.0.0
+%{?with_dnstap:BuildRequires:  protobuf-c-devel}
+BuildRequires: rpmbuild(macros) >= 1.671
+%{?with_systemd:BuildRequires: systemd-devel}
 %if %{with python}
 BuildRequires: python-devel >= 1:2.4.0
-BuildRequires: swig-python
+BuildRequires: swig-python >= 2.0.1
 %endif
-Requires(post,preun):  /sbin/chkconfig
-BuildRequires: rpmbuild(macros) >= 1.671
 Provides:      user(unbound)
+Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
 Requires(pre): /usr/sbin/useradd
@@ -78,7 +96,7 @@ Summary:      Header files for unbound library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki unbound
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      openssl-devel
+Requires:      openssl-devel >= 1.0.0
 
 %description devel
 Header files for unbound library.
@@ -101,7 +119,7 @@ Statyczna biblioteka unbound.
 %package -n python-unbound
 Summary:       Python interface to unbound library
 Summary(pl.UTF-8):     Pythonowy interfejs do biblioteki unbound
-Group:         Python/Libraries
+Group:         Libraries/Python
 Requires:      %{name}-libs = %{version}-%{release}
 
 %description -n python-unbound
@@ -112,17 +130,36 @@ Pythonowy interfejs do biblioteki unbound.
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
 %configure \
-       %{?with_python:--with-pyunbound} \
-       --with-pidfile=/run/%{name}.pid \
+       %{?with_dnstap:--enable-dnstap} \
+       %{?with_systemd:--enable-systemd} \
+       --with-chroot-dir="" \
        --with-conf-file=%{_sysconfdir}/%{name}/%{name}.conf \
+       --with-libevent=/usr \
+       --with-libexpat=/usr \
+       %{?with_redis:--with-libhiredis=/usr} \
+       --with-pidfile=/run/%{name}.pid \
+       %{__with_without python pyunbound} \
+       %{__with_without python pythonmodule} \
        --with-rootkey-file=/var/lib/%{name}/root.key \
        --with-rootcert-file=%{_sysconfdir}/%{name}/icannbundle.pem
 
 %{__make}
 
+%if %{with tests}
+%{__make} check
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{systemdunitdir},/var/lib/%{name}}
@@ -130,15 +167,15 @@ install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,%{systemdunitdir},/var/lib/%{name}}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
-install %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
-install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/icannbundle.pem
-install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/named.cache
+cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/icannbundle.pem
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/named.cache
 
 touch $RPM_BUILD_ROOT/var/lib/%{name}/root.key
 
 %if %{with python}
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_unbound.{la,a}
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_unbound.la
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 %py_postclean
@@ -200,12 +237,13 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libunbound.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libunbound.so.2
+%attr(755,root,root) %ghost %{_libdir}/libunbound.so.8
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libunbound.so
 %{_libdir}/libunbound.la
+%{_pkgconfigdir}/libunbound.pc
 %{_includedir}/unbound.h
 %{_mandir}/man3/libunbound.3*
 %{_mandir}/man3/ub_*.3*
@@ -219,4 +257,5 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{py_sitedir}/_unbound.so*
 %{py_sitedir}/unbound.py[co]
+%{py_sitedir}/unboundmodule.py[co]
 %endif
This page took 0.060952 seconds and 4 git commands to generate.