]> git.pld-linux.org Git - packages/ufoai.git/blob - ufoai.spec
- release 6 (rebuild against libpng-1.5)
[packages/ufoai.git] / ufoai.spec
1 Summary:        "UFO: Alien Invasion" - squad-based tactical strategy game in the tradition of the old X-COM PC games
2 Summary(pl.UTF-8):      "UFO: Alien Invasion" - gra strategiczna utrzymana w tradycji starych gier X-COM z PC
3 Name:           ufoai
4 Version:        2.3.1
5 Release:        6
6 License:        GPL
7 Group:          X11/Applications/Games/Strategy
8 Source0:        http://downloads.sourceforge.net/ufoai/%{name}-%{version}-source.tar.bz2
9 # Source0-md5:  87b3e1bf3439dc6e5413936034f47d17
10 Source1:        %{name}.desktop
11 Patch0:         %{name}-link.patch
12 Patch1:         %{name}-libpng15.patch
13 URL:            http://ufoai.sourceforge.net/
14 BuildRequires:  OpenAL-devel
15 BuildRequires:  OpenGL-GLU-devel
16 BuildRequires:  SDL-devel
17 BuildRequires:  SDL_image-devel
18 BuildRequires:  SDL_mixer-devel
19 BuildRequires:  SDL_ttf-devel
20 BuildRequires:  curl-devel
21 BuildRequires:  gettext-devel
22 BuildRequires:  gtkglext-devel
23 BuildRequires:  gtksourceview2-devel
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libogg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libtheora-devel
28 BuildRequires:  libvorbis-devel
29 BuildRequires:  ncurses-devel
30 BuildRequires:  p7zip-standalone
31 BuildRequires:  pkgconfig
32 BuildRequires:  xvid-devel
33 BuildRequires:  zlib-devel
34 Requires:       ufoai-data = %{version}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 It is the year 2084. You control a secret organisation charged with
39 defending Earth from a brutal alien enemy. Build up your bases,
40 prepare your team, and dive head-first into the fast and flowing
41 turn-based combat.
42
43 "UFO: Alien Invasion" is a squad-based tactical strategy game in the
44 tradition of the old X-COM PC games, but with a twist. This game
45 combines military realism with hard science-fiction and the weirdness
46 of an alien invasion. The carefully constructed turn-based system
47 gives you pin-point control of your squad while maintaining a sense of
48 pace and danger.
49
50 Over the long term you will need to conduct research into the alien
51 threat to figure out their mysterious goals and use their powerful
52 weapons for your own ends. You will produce unique items and use them
53 in combat against your enemies. If you like, you can even use them
54 against your friends with multiplayer functionality.
55
56 "UFO: Alien Invasion". Endless hours of gameplay -- absolutely free.
57
58 %description -l pl.UTF-8
59 Jest rok 2084. Kierujesz tajną organizacją, która ma obronić Ziemię
60 przed brutalnymi wrogami. Buduj swoje bazy, przygotuj swój zespół i
61 rzuć się w wir szybkiej turowej walki.
62
63 "UFO: Alien Invasion" to oparta o oddziały gra strategiczna utrzymana
64 w tradycji starych gier X-COM z PC, ale z pewnymi zmianami. Gra łączy
65 realizm militarny z ciężkim science-fiction i dziwnością inwazji
66 wroga. Uważnie skonstruowany system turowy daje kontrolę nad oddziałem
67 zachowując poczucie kroku i niebezpieczeństwa.
68
69 W ciągu długiego czasu gracz musi prowadzić badania narażając się
70 wrogom, aby odkryć ich tajemnicze cele i użyć ich potężnych broni dla
71 własnych potrzeb. Gracz wytworzy unikalne przedmioty i wykorzysta je w
72 walce przeciwko swoim wrogom. Można także używać ich przeciwko
73 przyjaciołom w przypadku gry dla wielu graczy.
74
75 "UFO: Alien Invasion" to niekończące się godziny gry całkowicie za
76 darmo.
77
78 %prep
79 %setup -q -n %{name}-%{version}-source
80 %patch0 -p1
81 %patch1 -p1
82
83 # needed to build properly
84 mkdir base
85
86 %build
87 CFLAGS="%{rpmcflags} -I/usr/include/ncurses"
88 %configure \
89         --with-curses
90 %{__make} \
91         RADIANT_LIBS="-ltinfo"
92 %{__make} lang
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/base,%{_datadir}/%{name}/base/i18n,%{_pixmapsdir},%{_desktopdir}}
98 install base/game.so $RPM_BUILD_ROOT%{_libdir}/%{name}/base/game.so
99 install ufo $RPM_BUILD_ROOT%{_libdir}/%{name}/ufoai
100 install ufoded $RPM_BUILD_ROOT%{_libdir}/%{name}/ufoaided
101 install ufo2map $RPM_BUILD_ROOT%{_bindir}/ufoai2map
102 cp -a base/i18n $RPM_BUILD_ROOT%{_datadir}/%{name}/base
103
104 cat > ufoai << 'EOF'
105 #!/bin/sh
106 cd %{_libdir}/%{name}
107 exec ./ufoai
108 EOF
109 cat > ufoaided << 'EOF'
110 #!/bin/sh
111 cd %{_libdir}/%{name}
112 exec ./ufoaided
113 EOF
114
115 install ufoai $RPM_BUILD_ROOT%{_bindir}/ufoai
116 install ufoaided $RPM_BUILD_ROOT%{_bindir}/ufoaided
117
118 ln -s %{_datadir}/%{name}/base/i18n $RPM_BUILD_ROOT%{_libdir}/%{name}/base/i18n
119 for i in base maps materials media models music pics shaders snd ufos; do
120         ln -s %{_datadir}/%{name}/base/0$i.pk3 $RPM_BUILD_ROOT%{_libdir}/%{name}/base/0$i.pk3
121 done
122
123 # install icon and desktop file
124 install debian/ufoai.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.xpm
125 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %files
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/ufoai
133 %attr(755,root,root) %{_bindir}/ufoaided
134 %attr(755,root,root) %{_bindir}/ufoai2map
135 %dir %{_libdir}/%{name}
136 %attr(755,root,root) %{_libdir}/%{name}/ufoai
137 %attr(755,root,root) %{_libdir}/%{name}/ufoaided
138 %dir %{_libdir}/%{name}/base
139 %attr(755,root,root) %{_libdir}/%{name}/base/game.so
140 %attr(755,root,root) %{_libdir}/%{name}/base/i18n
141 %attr(755,root,root) %{_libdir}/%{name}/base/0*.pk3
142 %dir %{_datadir}/%{name}
143 %dir %{_datadir}/%{name}/base
144 %{_datadir}/%{name}/base/i18n
145 %{_pixmapsdir}/%{name}.xpm
146 %{_desktopdir}/%{name}.desktop
This page took 0.072311 seconds and 3 git commands to generate.