]> git.pld-linux.org Git - packages/ucarp.git/blob - ucarp.spec
da10478ff6b35577e49ce8ef019521080675e2cf
[packages/ucarp.git] / ucarp.spec
1 Summary:        Common Address Redundancy Protocol (CARP) for Unix
2 Summary(pl.UTF-8):      CARP (Common Address Redundancy Protocol) dla Uniksa
3 Name:           ucarp
4 Version:        1.5.1
5 Release:        2
6 License:        BSD
7 Group:          Applications/Networking
8 Source0:        ftp://ftp.ucarp.org/pub/ucarp/%{name}-%{version}.tar.gz
9 # Source0-md5:  391caa69fc17ffbc8a3543d8692021c9
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 Source3:        %{name}.config.template
13 URL:            http://www.ucarp.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  fix:%files
17 BuildRequires:  libpcap-devel
18 BuildRequires:  libtool
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 UCARP allows a couple of hosts to share common virtual IP addresses in
23 order to provide automatic failover. It is a portable userland
24 implementation of the secure and patent-free Common Address Redundancy
25 Protocol (CARP, OpenBSD's alternative to the VRRP).
26
27 Strong points of the CARP protocol are: very low overhead,
28 cryptographically signed messages, interoperability between different
29 operating systems and no need for any dedicated extra network link
30 between redundant hosts.
31
32 %description -l pl.UTF-8
33 UCARP pozwala kilku hostom na dzielenie wspólnych wirtualnych adresów
34 IP w celu automatycznego przejmowania w przypadku awarii. Jest to
35 przenośna implementacja w przestrzeni użytkownika bezpiecznego i
36 wolnego od patentów protokołu CARP (Common Address Redundancy Protocol
37 - alternatywy OpenBSD dla VRRP).
38
39 Silne punkty protokołu CARP to: bardzo mały narzut, kryptograficznie
40 podpisywanie komunikaty, współdziałanie między różnymi systemami
41 operacyjnymi i brak potrzeby dedykowanego dodatkowego połączenia
42 sieciowego między nadmiarowymi hostami.
43
44 %prep
45 %setup -q
46
47 %build
48 %{__libtoolize}
49 %{__aclocal}
50 %{__autoconf}
51 %{__autoheader}
52 %{__automake}
53 %configure
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name},/etc/{rc.d/init.d,sysconfig} $RPM_BUILD_ROOT%{_varrun}/%{name}
63 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
64 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
65 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/config.template
66 install -p examples/linux/vip-down.sh $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
67 install -p examples/linux/vip-up.sh $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 /sbin/chkconfig --add ucarp
74 %service ucarp restart "UCARP"
75
76 %preun
77 if [ "$1" = "0" ]; then
78         %service ucarp stop
79         /sbin/chkconfig --del ucarp
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
85 %attr(754,root,root) /etc/rc.d/init.d/%{name}
86 %attr(755,root,root) %{_sbindir}/*
87 # XXX fix duplicate packaging
88 %dir %{_sysconfdir}/%{name}
89 %attr(750,root,root) %{_sysconfdir}/%{name}
90 %attr(640,root,root) %{_sysconfdir}/%{name}/*
91 %attr(750,root,root) %{_sysconfdir}/%{name}/vip-down.sh
92 %attr(750,root,root) %{_sysconfdir}/%{name}/vip-up.sh
93 %{_varrun}/%{name}
This page took 0.098736 seconds and 2 git commands to generate.