]> git.pld-linux.org Git - packages/tomcat.git/commitdiff
- up to 7.0.32 auto/th/tomcat-7.0.32-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 9 Nov 2012 10:32:11 +0000 (11:32 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 9 Nov 2012 10:32:11 +0000 (11:32 +0100)
tomcat-build.xml.patch
tomcat.spec

index 6f45c082b662ce14578ec265d06b934008f3227d..feb5583774c1102d46df8c4a7d8f4b2172506f4e 100644 (file)
@@ -1,6 +1,6 @@
---- apache-tomcat-7.0.28-src/build.xml 2012-06-15 09:56:41.000000000 +0200
-+++ apache-tomcat-7.0.28-src.new/build.xml     2012-06-20 16:14:52.482244047 +0200
-@@ -438,60 +438,6 @@
+--- apache-tomcat-7.0.32-src/build.xml~        2012-10-03 09:55:49.000000000 +0200
++++ apache-tomcat-7.0.32-src/build.xml 2012-11-09 11:22:30.324804340 +0100
+@@ -439,61 +439,6 @@
      
    </target>
  
@@ -41,6 +41,7 @@
 -      </fileset>
 -      <fileset dir="modules/jdbc-pool" >
 -        <exclude name=".*/**"/>
+-        <exclude name="**/MANIFEST.MF"/>
 -        <patternset refid="text.files" />
 -      </fileset>
 -    </checkstyle>
@@ -61,7 +62,7 @@
    <target name="validate-eoln" depends="build-prepare,compile-prepare"
      description="Validate that the source files have correct line ends">
  
-@@ -551,7 +497,7 @@
+@@ -498,7 +498,7 @@
      </copy>
    </target>
  
@@ -70,7 +71,7 @@
      <!-- Compile internal server components -->
      <javac srcdir="java" destdir="${tomcat.classes}"
             debug="${compile.debug}"
-@@ -834,13 +780,6 @@
+@@ -836,13 +781,6 @@
    <target name="deploy" depends="package,build-docs"
            description="Default. Builds a working Tomcat instance">
  
@@ -84,7 +85,7 @@
      <!-- Copy scripts -->
      <copy todir="${tomcat.build}/bin">
        <fileset dir="bin">
-@@ -1105,7 +1044,7 @@
+@@ -1107,7 +1045,7 @@
  
    </target>
  
@@ -93,7 +94,7 @@
      <mkdir dir="${test.classes}"/>
      <!-- Compile -->
      <javac srcdir="test" destdir="${test.classes}"
-@@ -1210,52 +1149,10 @@
+@@ -1212,52 +1150,10 @@
      <mkdir dir="${tomcat.extras}/webservices"/>
    </target>
  
      <replace dir="${tomcat.extras}/logging/commons-logging-${commons-logging.version}-src/src/java/org/apache/commons"
          encoding="ISO-8859-1">
        <replacefilter token="org.apache.commons"
-@@ -1277,7 +1174,8 @@
+@@ -1279,7 +1175,8 @@
        file="${tomcat.extras}/logging/commons-logging-${commons-logging.version}-src/build.xml" />
  
      <copy todir="${tomcat.extras}/logging/commons-logging-${commons-logging.version}-src">
        <fileset file="${log4j.jar}" />
        <fileset file="${logkit.jar}" />
        <fileset file="${servletapi.jar}" />
-@@ -1357,18 +1255,6 @@
+@@ -1359,18 +1256,6 @@
            depends="extras-prepare"
            description="Prepare to build web services extras package">
  
      <copy file="${jaxrpc-lib.jar}"
            tofile="${tomcat.extras}/webservices/jaxrpc.jar" />
      <copy file="${wsdl4j-lib.jar}"
-@@ -1475,7 +1361,7 @@
+@@ -1477,7 +1362,7 @@
  
    </target>
  
      <mkdir dir="${tomcat.dist}"/>
      <mkdir dir="${tomcat.dist}/bin"/>
      <mkdir dir="${tomcat.dist}/conf"/>
-@@ -2261,291 +2147,7 @@
-     <!-- remove jdbc-pool documentation -->
+@@ -2268,290 +2153,6 @@
      <delete file="webapps/docs/jdbc-pool.xml"/>
    </target>
--
 -    
 -  <!-- ================ Download and dependency building =================== -->
 -
 -Read the Building page on the Apache Tomcat documentation site for details on how to configure your Eclipse workplace.</echo>
 -  </target>
 -
-+ 
    <!-- ======================= Macros, Taskdefs etc ======================== -->
  
    <macrodef name="jarIt" description="utility macro for standard JAR packaging">
index 61579701b2339f9b026ab5f37500debd5ded6503..2e63545ed27f75ad9e1ab37b65b456215776aa0a 100644 (file)
 Summary:       Web server and Servlet/JSP Engine, RI for Servlet %{servletapiver}/JSP %{jspapiver} API
 Summary(pl.UTF-8):     Serwer www i silnik Servlet/JSP będący wzorcową implementacją API Servlet %{servletapiver}/JSP %{jspapiver}
 Name:          tomcat
-Version:       7.0.28
+Version:       7.0.32
 Release:       1
 License:       Apache v2.0
 Group:         Networking/Daemons/Java
 Source0:       http://www.apache.org/dist/tomcat/tomcat-7/v%{version}/src/apache-%{name}-%{version}-src.tar.gz
-# Source0-md5: b84c51041fdd42e3e08747d6c4db6d30
+# Source0-md5: daf3de124ec09702560931e87219deb6
 Source1:       apache-%{name}.init
 Source2:       apache-%{name}.sysconfig
 Source3:       %{name}-build.properties
@@ -36,7 +36,6 @@ Patch4:               %{name}-userdir.patch
 Patch100:      jcl-build.xml.patch
 URL:           http://tomcat.apache.org/
 BuildRequires: ant >= 1.5.3
-BuildRequires: ant-trax
 BuildRequires: eclipse-jdt >= 3.2
 BuildRequires: java(JSR109)
 BuildRequires: java-avalon-logkit
This page took 0.081689 seconds and 4 git commands to generate.