]> git.pld-linux.org Git - packages/tmpwatch.git/commitdiff
drop migration from 2.11-2
authorElan Ruusamäe <glen@delfi.ee>
Mon, 10 Apr 2017 17:17:24 +0000 (20:17 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 10 Apr 2017 17:17:24 +0000 (20:17 +0300)
commit 04662a6587abddd5c6363d14b6b94ac194a809aa
Date:   Mon Mar 11 15:54:14 2013 +0200

everybody should have upgraded by now,
and if hasn't then that can't be supported.

tmpwatch.cron
tmpwatch.spec

index 61024e8871910a69dc157cd6283b498274add8ea..f0896a201cab597730944d052366e9bd5f2dcf89 100755 (executable)
@@ -8,20 +8,14 @@ if [ -f /etc/sysconfig/tmpwatch ]; then
        . /etc/sysconfig/tmpwatch
 fi
 
-# NOTE: DISABLE_TMPWATCH_* vars are not official, only here to handle migration from < 2.11-2.1
+/usr/sbin/tmpwatch ${OPTIONS} -x /tmp/.X11-unix -x /tmp/.XIM-unix -x /tmp/.font-unix \
+       -x /tmp/.ICE-unix -x /tmp/.Test-unix -X /tmp/.s.PGSQL.\* 240 /tmp
 
-if [ "$DISABLE_TMPWATCH_CRON" != "yes" ]; then
-       /usr/sbin/tmpwatch ${OPTIONS} -x /tmp/.X11-unix -x /tmp/.XIM-unix -x /tmp/.font-unix \
-               -x /tmp/.ICE-unix -x /tmp/.Test-unix -X /tmp/.s.PGSQL.\* 240 /tmp
-
-       # Cleanup amavis quarantine:
-       if [ ${AMAVIS_QUARANTINE} -gt 0 ] && [ -d /var/spool/amavis/virusmails ]; then
-               /usr/sbin/tmpwatch ${OPTIONS} ${AMAVIS_QUARANTINE} /var/spool/amavis/virusmails
-       fi
+# Cleanup amavis quarantine:
+if [ ${AMAVIS_QUARANTINE} -gt 0 ] && [ -d /var/spool/amavis/virusmails ]; then
+       /usr/sbin/tmpwatch ${OPTIONS} ${AMAVIS_QUARANTINE} /var/spool/amavis/virusmails
 fi
 
-[ "$DISABLE_TMPWATCH_CRON_DIRS" = "yes" ] && exit 0
-
 # process extra .conf files
 for file in /etc/tmpwatch/*.conf; do
        grep ^/ ${file} | while read DIRECTORY TIME OPTS; do
index 4fbfb418a159ef5765a2751932b1fcf335b7d756..f6ead9f921ac18e6f4536096c694250a727b81ac 100644 (file)
@@ -132,22 +132,6 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 %systemd_reload
 
-%triggerpostun -- %{name} < 2.9.1-4
-if [ -f /usr/sbin/amavisd ]; then
-       echo "WARNING!! Take a look at /etc/sysconfig/%{name}"
-       echo "That version has enabled amavis-spool cleaning"
-fi
-
-%triggerun -- %{name} < 2.11-2.1
-# if previous install had /etc/cron.daily/* files unlinked, disable the cronjob
-if [ ! -e /etc/cron.daily/tmpwatch ]; then
-       echo DISABLE_TMPWATCH_CRON=yes >> /etc/sysconfig/tmpwatch
-fi
-
-if [ ! -e /etc/cron.daily/tmpwatch.directories ]; then
-       echo DISABLE_TMPWATCH_CRON_DIRS=yes >> /etc/sysconfig/tmpwatch
-fi
-
 %triggerpostun -- %{name} < 2.11-10
 %systemd_service_enable cronjob-%{name}.timer
 
This page took 0.892682 seconds and 4 git commands to generate.