]> git.pld-linux.org Git - packages/tin.git/blob - tin.spec
8d71aab82000c16e0c3f32dce3189cb575f2db30
[packages/tin.git] / tin.spec
1 #
2 #   You can build tin with:
3 # --define 'domain_name your.domain'
4 # --define 'default_server default.nntp.server'
5 #
6 Summary:        tin News Reader
7 Summary(de.UTF-8):      tin News-Reader
8 Summary(fr.UTF-8):      Lecteur de news tin
9 Summary(pl.UTF-8):      tin - czytnik newsów
10 Summary(ru.UTF-8):      tin - программа для чтения телеконференций Usenet
11 Summary(tr.UTF-8):      Haber okuyucu
12 Summary(uk.UTF-8):      tin - програма для читання телеконференцій Usenet
13 Name:           tin
14 Version:        2.0.1
15 Release:        13
16 Epoch:          5
17 License:        distributable
18 Group:          Applications/News
19 Source0:        ftp://ftp.tin.org/pub/news/clients/tin/stable/%{name}-%{version}.tar.gz
20 # Source0-md5:  d05622db1712a78a2b92aa27904befc2
21 Source1:        %{name}.desktop
22 Source2:        %{name}.attributes
23 Patch0:         %{name}-enable_coloring.patch
24 Patch1:         %{name}-ncurses.patch
25 Patch2:         %{name}-range.patch
26 Patch3:         %{name}-charset.patch
27 Patch4:         %{name}-nostrip.patch
28 URL:            http://www.tin.org/
29 BuildRequires:  bison
30 BuildRequires:  gettext-tools
31 BuildRequires:  gsasl-devel
32 BuildRequires:  libicu-devel
33 BuildRequires:  libidn-devel
34 BuildRequires:  ncurses-devel >= 5.0
35 BuildRequires:  pcre-devel
36 BuildRequires:  uudeview-devel
37 Requires:       urlview
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Tin is a full-screen easy to use Netnews reader. It can read news
42 locally (i.e., /var/spool/news) or remotely (rtin or tin -r option)
43 via a NNTP (Network News Transport Protocol) server. It will
44 automatically utilize NOV (News OVerview) style index files if
45 available locally or via the NNTP XOVER command.
46
47 Tin has four separate levels of operation: Group selection level,
48 Group level, Thread level and Article level. Use the 'h' (help)
49 command to view a list of the commands available at a particular
50 level.
51
52 %description -l de.UTF-8
53 Tin ist ein Vollbild-Newsreader. Das Programm kann entweder lokal
54 (z.B. usr/spool/news) oder entfernt (Option 'rtin' bzw. 'tin -r') über
55 einen NNTP-Server (Network News Transport Protocol) eingesetzt werden.
56
57 %description -l fr.UTF-8
58 Tin est un lecteur de news plein écran facile à utiliser. Il peut lire
59 des articles localement (i.e. /usr/spool/news) ou à distance ('rtin'
60 ou 'tin -r') via un serveur NNTP (Network News Transport Protocol).
61
62 %description -l pl.UTF-8
63 Tin jest pełnoekranowym czytnikiem newsów. Umożliwia czytanie zarówno
64 z lokalnych zasobów (np. z katalogu /var/spool/news jak i ze zdalnych
65 (uruchamiając 'rtin' lub 'tin -r') serwerów NNTP (Network News
66 Transport Protocol).
67
68 %description -l ru.UTF-8
69 Tin - это простая в использовании полноэкранная программа для чтения
70 телеконференций Usenet. Она может читать телеконференции с локальной
71 (т.е. /var/spool/news) или удаленной (rtin или опция tin -r) по NNTP
72 (Network News Transport Protocol).
73
74 %description -l tr.UTF-8
75 Tin, metin ekranda çalışan kolay kullanılır bir USENET haber
76 okuyucusudur. Haberleri yerel olarak (/usr/spool/news), ya da bir NNTP
77 sunucusu aracılığıyla uzaktan ('rtin' ya da 'tin -r' seçeneği ile)
78 okuyabilir.
79
80 %description -l uk.UTF-8
81 Tin - це проста у використанні повноекранна програма для читання
82 телеконференцій Usenet. Вона дозволяє читати телеконференції як з
83 локальної машини (тобто /var/spool/news) так і з віддаленої (rtin або
84 опція tin -r) по NNTP (Network News Transport Protocol).
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91 %patch3 -p1
92 %patch4 -p1
93
94 %build
95 LDFLAGS="%{rpmldflags}"
96 %configure2_13 \
97         --disable-debug \
98         --enable-color \
99         --enable-curses \
100         --enable-ipv6 \
101         --enable-nls \
102         --with-gpg=%{_bindir}/gpg \
103         --with-ispell=%{_bindir}/ispell \
104         --with-mailer=/usr/lib/sendmail \
105         --with-metamail=%{_bindir}/metamail \
106         --with-ncurses \
107         --with-nov-dir=%{_var}/spool/news \
108         --with-pcre \
109         --with-screen=ncurses \
110         --with-spooldir=%{_var}/spool/news \
111         %{?domain_name:--with-domain-name=%{domain_name}} \
112         %{?default_server:--with-nntp-default-server=%{default_server}}
113
114 %{__make} -C src
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118 install -d $RPM_BUILD_ROOT/{etc,etc/tin,%{_bindir},%{_mandir}/man1,%{_mandir}/man5,%{_desktopdir}}
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 install doc/tin.defaults $RPM_BUILD_ROOT%{_sysconfdir}/tin/tinrc
124 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/tin/attributes
125 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rtin.1
126 echo ".so tin.1" > $RPM_BUILD_ROOT%{_mandir}/man1/rtin.1
127
128 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
129
130 # file conflict mmdf between mutt and tin
131 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man5/mmdf.5*
132
133 %find_lang %{name}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc README MANIFEST doc/{CHANGES,TODO,DEBUG_REFS,WHATSNEW,*.txt}
141 %dir %{_sysconfdir}/%{name}
142 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/tinrc
143 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/attributes
144 %attr(755,root,root) %{_bindir}/metamutt
145 %attr(755,root,root) %{_bindir}/opt-case.pl
146 %attr(755,root,root) %{_bindir}/rtin
147 %attr(755,root,root) %{_bindir}/tin
148 %attr(755,root,root) %{_bindir}/tinews.pl
149 %attr(755,root,root) %{_bindir}/url_handler.pl
150 %attr(755,root,root) %{_bindir}/w2r.pl
151 %{_mandir}/man1/opt-case.pl.1*
152 %{_mandir}/man1/rtin.1*
153 %{_mandir}/man1/tin.1*
154 %{_mandir}/man1/tinews.pl.1*
155 %{_mandir}/man1/url_handler.pl.1*
156 %{_mandir}/man1/w2r.pl.1*
157 %{_mandir}/man5/tin.5*
158 %{_desktopdir}/tin.desktop
This page took 0.036425 seconds and 3 git commands to generate.