]> git.pld-linux.org Git - packages/telepathy-gabble.git/commitdiff
- add wocky patch to fix SASL auth on jabberd2 auto/th/telepathy-gabble-0_9_2-1
authorPatryk Zawadzki <patrys@room-303.com>
Mon, 2 Nov 2009 15:46:39 +0000 (15:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    telepathy-gabble.spec -> 1.19
    wocky-sasl.patch -> 1.1

telepathy-gabble.spec
wocky-sasl.patch [new file with mode: 0644]

index cf21233206e84586d415c4ae44719df60c0f2be1..4c856263c1dcc939e9b2c2dc4b6f1d69072f97a7 100644 (file)
@@ -8,6 +8,7 @@ Group:          Libraries
 Source0:       http://telepathy.freedesktop.org/releases/telepathy-gabble/%{name}-%{version}.tar.gz
 # Source0-md5: e862fb46c0a895c6b37339459edc8ae1
 URL:           http://telepathy.freedesktop.org/wiki/
+Patch0:                wocky-sasl.patch
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1:1.9
 BuildRequires: dbus-devel >= 1.1.0
@@ -33,6 +34,9 @@ Zarządca połączeń pozwalający połączyć się Telepathy z Jabberem/XMPP.
 
 %prep
 %setup -q
+cd lib/ext/wocky
+%patch0 -p1
+cd ../../..
 
 %build
 %{__libtoolize}
diff --git a/wocky-sasl.patch b/wocky-sasl.patch
new file mode 100644 (file)
index 0000000..d787497
--- /dev/null
@@ -0,0 +1,42 @@
+From: Vivek Dasmohapatra <vivek@collabora.co.uk>
+Date: Mon, 2 Nov 2009 15:37:50 +0000 (+0000)
+Subject: SASL challenge tokens may be separated by optional whitespace, cope with these.
+X-Git-Url: http://git.collabora.co.uk/?p=user%2Fvivek%2Fwocky.git;a=commitdiff_plain;h=a3f332952c94e59d49c7d265f91cacc04eab424d
+
+SASL challenge tokens may be separated by optional whitespace, cope with these.
+---
+
+diff --git a/wocky/wocky-sasl-auth.c b/wocky/wocky-sasl-auth.c
+index a010370..925db62 100644
+--- a/wocky/wocky-sasl-auth.c
++++ b/wocky/wocky-sasl-auth.c
+@@ -429,6 +429,10 @@ digest_md5_challenge_to_hash (const gchar * challenge)
+     keyend = c;
+     c++;
++    /* eat any whitespace between the '=' and the '"' */
++    for (; isspace (*c); c++)
++      ;
++
+     if (*c == '"')
+       {
+         c++;
+@@ -450,10 +454,18 @@ digest_md5_challenge_to_hash (const gchar * challenge)
+         val = g_strndup (valstart, c - valstart);
+       }
++    /* the key is unguarded by '"' delimiters so any whitespace *
++     * at either end should be discarded as irrelevant          */
+     key = g_strndup (keystart, keyend - keystart);
++    key = g_strstrip (key);
++    DEBUG ("challenge '%s' = '%s'", key, val);
+     g_hash_table_insert (result, key, val);
++    /* eat any whitespace between the '"' and the next ',' */
++    for (; isspace (*c); c++)
++      ;
++
+     if (*c == ',')
+       c++;
+   } while (*c != '\0');
This page took 0.074115 seconds and 4 git commands to generate.