]> git.pld-linux.org Git - packages/taskwarrior.git/blob - taskwarrior.spec
up to 2.5.0
[packages/taskwarrior.git] / taskwarrior.spec
1 %define         shortname       task
2 Summary:        Taskwarrior is a command-line to do list manager
3 Summary(hu.UTF-8):      Taskwarrior egy parancssoros ToDo-kezelő
4 Summary(pl.UTF-8):      Taskwarrior - konsolowy manadżer rzeczy do zrobienia
5 Name:           taskwarrior
6 Version:        2.5.0
7 Release:        1
8 License:        MIT
9 Group:          Applications
10 Source0:        http://www.taskwarrior.org/download/%{shortname}-%{version}.tar.gz
11 # Source0-md5:  bca2a8a6f7727ccbcefd5e190d935910
12 URL:            http://taskwarrior.org/
13 BuildRequires:  cmake >= 2.8
14 BuildRequires:  gnutls-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libuuid-devel
17 BuildRequires:  pkgconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define bashdir %{_sysconfdir}/bash_completion.d
21 %define fishdir %{_datadir}/fish/completions
22 %define vimdir %{_datadir}/vim/vimfiles
23 %define zshdir %{_datadir}/zsh/site-functions
24
25 %description
26 Taskwarrior is an ambitious project to supercharge task (most
27 excellent CLI task manager by Paul Beckingham) with an interactive
28 interface, a powerful search tool, hotkeys, forms data entry, and a
29 host of new features.
30
31 %description -l hu.UTF-8
32 Taskwarrior egy törekvő project, amely a task-ot bővíti ki (a legjobb
33 CLI feladatkezelő Paul Beckingham-től) egy interaktív felületettel,
34 hatékony kereső eszközzel, hotkey-ekkel, űrlapokkal és új lehetőségek
35 tömegeivel.
36
37 %description -l pl.UTF-8
38 Taskwarrior jest ambitnym projektem mającym na celu ulepszenie
39 programu task (najlepszego konsolowego menadżera zadań stworzonego
40 przez Paula Beckinghama) poprzez dodanie interaktywnego interfejsu,
41 potężnej wyszukiwarki, skrótów klawiszowych, formularzy wprowadzania
42 danych i wielu innych ulepszeń.
43
44 %package -n bash-completion-taskwarrior
45 Summary:        bash-completion for taskwarrior
46 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla taskwarriora
47 Group:          Applications/Shells
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       bash-completion
50 %if "%{_rpmversion}" >= "5"
51 BuildArch:      noarch
52 %endif
53
54 %description -n bash-completion-taskwarrior
55 bash-completion for taskwarrior.
56
57 %description -n bash-completion-taskwarrior -l pl.UTF-8
58 Pakiet ten dostarcza bashowe uzupełnianie nazw dla taskwarriora.
59
60 %package -n fish-completion-taskwarrior
61 Summary:        fish-completion for taskwarrior
62 Summary(pl.UTF-8):      Uzupełnianie nazw w fish dla taskwarriora
63 Group:          Applications/Shells
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       fish
66 %if "%{_rpmversion}" >= "5"
67 BuildArch:      noarch
68 %endif
69
70 %description -n fish-completion-taskwarrior
71 fish-completion for taskwarrior.
72
73 %description -n fish-completion-taskwarrior -l pl.UTF-8
74 Pakiet ten dostarcza uzupełnianie nazw w fish dla taskwarriora.
75
76 %package -n vim-syntax-taskwarrior
77 Summary:        Vim-syntax: taskwarrior
78 Summary(pl.UTF-8):      Składnia dla Vima: taskwarrior
79 Group:          Applications/Editors/Vim
80 Requires:       %{name} = %{version}-%{release}
81 %if "%{_rpmversion}" >= "5"
82 BuildArch:      noarch
83 %endif
84
85 %description -n vim-syntax-taskwarrior
86 Vim-syntax: taskwarrior.
87
88 %description -n vim-syntax-taskwarrior -l pl.UTF-8
89 Ta wtyczka dostarcza podświetlanie składni dla taskwarriora.
90
91 %package -n zsh-completion-taskwarrior
92 Summary:        zsh-completion for taskwarrior
93 Summary(pl.UTF-8):      Uzupełnianie nazw w zsh dla taskwarriora
94 Group:          Applications/Shells
95 Requires:       %{name} = %{version}-%{release}
96 %if "%{_rpmversion}" >= "5"
97 BuildArch:      noarch
98 %endif
99
100 %description -n zsh-completion-taskwarrior
101 zsh-completion for taskwarrior.
102
103 %description -n zsh-completion-taskwarrior -l pl.UTF-8
104 Pakiet ten dostarcza funkcje uzupełniania nazw powłoki zsh dla
105 taskwarriora.
106
107 %prep
108 %setup -q -n %{shortname}-%{version}
109
110 %build
111 %cmake
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{shortname}
120
121 install -d $RPM_BUILD_ROOT{%{bashdir},%{fishdir},%{zshdir}}
122 install -p scripts/bash/task.sh $RPM_BUILD_ROOT%{bashdir}
123 install -p scripts/fish/task.fish $RPM_BUILD_ROOT%{fishdir}
124 install -p scripts/zsh/_task $RPM_BUILD_ROOT%{zshdir}
125
126 install -d $RPM_BUILD_ROOT%{vimdir}/{ftdetect,syntax}
127 for dir in ftdetect syntax; do
128         install -d $RPM_BUILD_ROOT%{vimdir}/$dir
129         install -p scripts/vim/$dir/* $RPM_BUILD_ROOT%{vimdir}/$dir
130 done
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog DEVELOPER EXPOSITION NEWS README.md doc/rc
138 %attr(755,root,root) %{_bindir}/%{shortname}
139 %{_mandir}/man1/*1*
140 %{_mandir}/man5/*5*
141
142 %files -n bash-completion-taskwarrior
143 %defattr(644,root,root,755)
144 %{bashdir}/task.sh
145
146 %files -n fish-completion-taskwarrior
147 %defattr(644,root,root,755)
148 %{fishdir}/task.fish
149
150 %files -n vim-syntax-taskwarrior
151 %defattr(644,root,root,755)
152 %{vimdir}/ftdetect/*.vim
153 %{vimdir}/syntax/*.vim
154
155 %files -n zsh-completion-taskwarrior
156 %defattr(644,root,root,755)
157 %{zshdir}/_task
This page took 0.061799 seconds and 3 git commands to generate.