]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- release 2
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - remove net_client_only and add db bcond (then without apache and
3 #   without db => net_client_only - spec will be more simpler, I think)
4 # - finish ruby
5 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  gnome                   # build without gnome keyring support
18 #
19 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
20 %define apxs    /usr/sbin/apxs
21 %define pdir    SVN
22 %define pnam    _Core
23 #
24 %if %{with neon}
25 %define webdavlib       neon
26 %else
27 %define webdavlib       serf
28 %endif
29 #
30 Summary:        A Concurrent Versioning system similar to but better than CVS
31 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
32 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
33 Name:           subversion
34 Version:        1.6.12
35 Release:        2
36 License:        Apache/BSD-like
37 Group:          Development/Version Control
38 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
39 # Source0-md5:  a4b1d0d7f3a4587c59da9c1acf9dedd0
40 Source1:        %{name}-dav_svn.conf
41 Source2:        %{name}-authz_svn.conf
42 Source3:        %{name}-svnserve.init
43 Source4:        %{name}-svnserve.sysconfig
44 # current subversion tarball has correct *.swg files
45 # but after regeneration these are broken again, so
46 # we still need this script
47 Source5:        %{name}-convert-typemaps-to-ifdef.py
48 Patch0:         %{name}-home_etc.patch
49 Patch1:         %{name}-DESTDIR.patch
50 Patch2:         %{name}-ruby-datadir-path.patch
51 URL:            http://subversion.apache.org/
52 %if %{with net_client_only}
53 %global apache_modules_api 0
54 %else
55 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
56 BuildRequires:  automake
57 BuildRequires:  db-devel >= 4.1.25
58 BuildRequires:  rpmbuild(macros) >= 1.559
59 %if %{with perl}
60 BuildRequires:  perl-devel >= 1:5.8.0
61 BuildRequires:  rpm-perlprov >= 4.1-13
62 BuildRequires:  swig-perl >= 1.3.24
63 %endif
64 %if %{with python}
65 BuildRequires:  python-ctypesgen
66 BuildRequires:  python-devel >= 2.2
67 BuildRequires:  swig-python >= 1.3.24
68 %endif
69 %if %{with ruby}
70 BuildRequires:  ruby-devel
71 BuildRequires:  swig-ruby >= 1.3.24
72 %endif
73 %if %{with javahl}
74 BuildRequires:  jdk
75 %endif
76 BuildRequires:  cyrus-sasl-devel
77 %endif
78 BuildRequires:  apr-devel >= 1:1.0.0
79 BuildRequires:  apr-util-devel >= 1:1.2.8-3
80 BuildRequires:  autoconf >= 2.59
81 BuildRequires:  bison
82 BuildRequires:  expat-devel
83 BuildRequires:  gettext-devel
84 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
85 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
86 BuildRequires:  libtool >= 1.4-9
87 BuildRequires:  pkgconfig
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3.6.11
90 BuildRequires:  texinfo
91 BuildRequires:  which
92 %if %{with neon}
93 BuildRequires:  neon-devel >= 0.26.0
94 %else
95 BuildRequires:  serf-devel
96 %endif
97 BuildRequires:  python >= 2.2
98 BuildRequires:  python-modules >= 2.2
99 Requires:       %{name}-libs = %{version}-%{release}
100 %requires_ge    sqlite3
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         _libexecdir             %{_libdir}/svn
104 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
105 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
106
107 %description
108 The goal of the Subversion project is to build a version control
109 system that is a compelling replacement for CVS in the open source
110 community.
111
112 Our goals are:
113 - All current CVS features.
114 - Directories, renames, and file meta-data are versioned.
115 - Symbolic links, etc, are supported
116 - Commits are truly atomic.
117 - Branching and tagging are cheap (constant time) operations
118 - Repeated merges are handled gracefully
119 - Support for plug-in client side diff programs
120 - Natively client/server
121 - Client/server protocol sends diffs in both directions
122 - Costs are proportional to change size, not project size
123 - Internationalization
124 - Progressive multi-lingual support
125
126 %description -l pl.UTF-8
127 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
128 zamiennika dla CVS.
129
130 Cele projektu to:
131 - Wszystkie aktualne możliwości CVS.
132 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
133 - Obsługa dowiązań symbolicznych itp.
134 - Commity są w pełni atomowe.
135 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
136 - Dobra obsługa powtarzanego łączenia (merge).
137 - Obsługa wtyczek diff po stronie klienta.
138 - Natywny klient/serwer.
139 - Klient/Serwer przesyłają diffy w obu kierunkach.
140 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
141 - Internacjonalizacja.
142 - Postępujące wsparcie dla wielu języków.
143
144 %description -l pt_BR.UTF-8
145 O objetivo do projeto Subversion é construir um sistema de controle de
146 versões que seja um substituto para o CVS (Concurrent Versioning
147 System) na comunidade opensource, fornecendo grandes melhorias.
148
149 %package libs
150 Summary:        Subversion libraries and modules
151 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
152 Group:          Libraries
153 %{?with_neon:Requires:  neon >= 0.26.0}
154 Obsoletes:      libsubversion0
155
156 %description libs
157 Subversion libraries and modules.
158
159 %description libs -l pl.UTF-8
160 Biblioteka subversion oraz ładowalne moduły.
161
162 %package devel
163 Summary:        Header files and develpment documentation for subversion
164 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
165 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
166 Group:          Development/Libraries
167 Requires:       %{name}-libs = %{version}-%{release}
168 Requires:       apr-util-devel >= 1:1.0.0
169 %{?with_neon:Requires:  neon-devel >= 0.26.0}
170 Obsoletes:      libsubversion0-devel
171
172 %description devel
173 Header files and develpment documentation for subversion.
174
175 %description devel -l pl.UTF-8
176 Pliki nagłówkowe i dokumetacja do subversion.
177
178 %description devel -l pt_BR.UTF-8
179 Este pacote provê os arquivos necessários para desenvolvedores
180 interagirem com o Subversion.
181
182 %package static
183 Summary:        Static subversion library
184 Summary(pl.UTF-8):      Biblioteka statyczna subversion
185 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
186 Group:          Development/Libraries
187 Requires:       %{name}-devel = %{version}
188 Obsoletes:      libsubversion0-static-devel
189
190 %description static
191 Static subversion library.
192
193 %description static -l pl.UTF-8
194 Biblioteka statyczna subversion.
195
196 %description static -l pt_BR.UTF-8
197 Este pacote provê um cliente estático do subversion.
198
199 %package svnserve
200 Summary:        Subversion svnserve
201 Summary(pl.UTF-8):      Subversion svnserve
202 Group:          Networking/Daemons
203 Requires(post,preun):   /sbin/chkconfig
204 Requires(postun):       /usr/sbin/groupdel
205 Requires(postun):       /usr/sbin/userdel
206 Requires(pre):  /bin/id
207 Requires(pre):  /usr/bin/getgid
208 Requires(pre):  /usr/lib/rpm/user_group.sh
209 Requires(pre):  /usr/sbin/groupadd
210 Requires(pre):  /usr/sbin/useradd
211 Requires(pre):  /usr/sbin/usermod
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       rc-scripts
214 Provides:       group(svn)
215 Provides:       user(svn)
216
217 %description svnserve
218 Subversion svnserve server.
219
220 %description svnserve -l pl.UTF-8
221 Serwer subversion svnserve.
222
223 %package tools
224 Summary:        Subversion tools and scripts
225 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
226 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
227 Group:          Applications
228 %pyrequires_eq  python
229 Requires:       %{name} = %{version}-%{release}
230 Requires:       python-subversion = %{version}
231
232 %description tools
233 Subversion tools and scripts.
234
235 %description tools -l pl.UTF-8
236 Narzędzia oraz skrypty dla subversion.
237
238 %package -n bash-completion-subversion
239 Summary:        bash completion for subversion
240 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
241 Group:          Applications/Shells
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       bash-completion
244 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
245
246 %description -n bash-completion-subversion
247 Bash completion for subversion.
248
249 %description -n bash-completion-subversion -l pl.UTF-8
250 Dopełnienia basha dla subversion.
251
252 %package -n java-subversion
253 Summary:        Subversion Java bindings
254 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
255 Group:          Development/Languages/Java
256 Requires:       %{name}-libs = %{version}-%{release}
257
258 %description -n java-subversion
259 This is a set of Java classes which provide the functionality of
260 subversion-libs, the Subversion libraries. It is useful if you want
261 to, for example, write a Java class that manipulates a Subversion
262 repository or working copy. See the 'subversion' package for more
263 information.
264
265 %description -n java-subversion -l pl.UTF-8
266 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
267 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
268 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
269 roboczą. Więcej informacji w pakiecie subversion.
270
271 %package -n python-subversion
272 Summary:        Subversion Python bindings
273 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
274 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
275 Group:          Development/Languages/Python
276 %pyrequires_eq  python
277 Requires:       %{name}-libs = %{version}-%{release}
278 Obsoletes:      subversion-python
279
280 %description -n python-subversion
281 Subversion Python bindings.
282
283 %description -n python-subversion -l pl.UTF-8
284 Dowiązania do Subversion dla Pythona.
285
286 %description -n python-subversion -l pt_BR.UTF-8
287 Módulos Python para acessar os recursos do Subversion.
288
289 %package -n python-csvn
290 Summary:        CTypes Subversion Python bindings
291 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
292 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
293 Group:          Development/Languages/Python
294 %pyrequires_eq  python
295 Requires:       %{name}-libs = %{version}-%{release}
296
297 %description -n python-csvn
298 Subversion CTypes Python bindings.
299
300 %description -n python-csvn -l pl.UTF-8
301 Dowiązania do Subversion dla Pythona używające CTypes.
302
303 %description -n python-csvn -l pt_BR.UTF-8
304 Módulos Python para acessar os recursos do Subversion.
305
306 %package -n perl-subversion
307 Summary:        Subversion Perl bindings
308 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
309 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
310 Group:          Development/Languages/Perl
311 Requires:       %{name}-libs = %{version}-%{release}
312 Obsoletes:      subversion-perl
313
314 %description -n perl-subversion
315 Subversion Perl bindings.
316
317 %description -n perl-subversion -l pl.UTF-8
318 Dowiązania do Subversion dla Perla.
319
320 %description -n perl-subversion -l pt_BR.UTF-8
321 Módulos Perl para acessar os recursos do Subversion.
322
323 %package -n ruby-subversion
324 Summary:        Subversion Ruby bindings
325 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
326 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
327 Group:          Development/Languages
328 Requires:       %{name}-libs = %{version}-%{release}
329 Obsoletes:      subversion-ruby
330
331 %description -n ruby-subversion
332 Subversion Ruby bindings.
333
334 %description -n ruby-subversion -l pl.UTF-8
335 Dowiązania do Subversion dla języka Ruby.
336
337 %description -n ruby-subversion -l pt_BR.UTF-8
338 Módulos Ruby para acessar os recursos do Subversion.
339
340 %package -n apache-mod_dav_svn
341 Summary:        Apache module: Subversion Server
342 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
343 Group:          Networking/Daemons
344 Requires:       %{name} = %{version}-%{release}
345 Requires:       apache(modules-api) = %apache_modules_api
346 Requires:       apache-mod_dav
347
348 %description -n apache-mod_dav_svn
349 Apache module: Subversion Server.
350
351 %description -n apache-mod_dav_svn -l pl.UTF-8
352 Moduł apache: Serwer Subversion.
353
354 %package -n apache-mod_authz_svn
355 Summary:        Apache module: Subversion Server - path-based authorization
356 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
357 Group:          Networking/Daemons
358 Requires:       apache(modules-api) = %apache_modules_api
359 Requires:       apache-mod_dav_svn = %{version}-%{release}
360
361 %description -n apache-mod_authz_svn
362 Apache module: Subversion Server - path-based authorization.
363
364 %description -n apache-mod_authz_svn -l pl.UTF-8
365 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
366
367 %package -n gnome-keyring-subversion
368 Summary:        Subversion module for Gnome Keyring
369 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
370 Group:          X11/Applications
371
372 %description -n gnome-keyring-subversion
373 Subversion module for Gnome Keyring.
374
375 %description -n gnome-keyring-subversion -l pl.UTF-8
376 Moduł subversion dla zarządcy kluczy Gnome.
377
378 %package -n kde4-kwallet-subversion
379 Summary:        Subversion module for KDE Wallet
380 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
381 Group:          X11/Applications
382
383 %description -n kde4-kwallet-subversion
384 Subversion module for KDE Wallet.
385
386 %description -n kde4-kwallet-subversion -l pl.UTF-8
387 Moduł subversion dla Portfela KDE.
388
389 %prep
390 %setup -q
391 rm -rf apr apr-util neon
392 %patch0 -p0
393 %patch1 -p1
394 %patch2 -p0
395
396 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
397
398 # serf.m4 macro is broken and ignores --without serf
399 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
400
401 %build
402 rm subversion/bindings/swig/proxy/*.swg
403 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
404 cp -f /usr/share/automake/config.sub ac-helpers
405 chmod +x ./autogen.sh && ./autogen.sh
406
407 %configure \
408         --with-editor=vi \
409         --with-zlib=%{_libdir} \
410 %if %{with net_client_only}
411         --without-apache \
412         --without-swig \
413         --without-apxs \
414         --without-berkeley-db \
415 %else
416         --disable-runtime-module-search \
417         --disable-mod-activation \
418         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
419 %if %{with apache}
420         --with-apxs=%{_sbindir}/apxs \
421 %else
422         --without-apache \
423         --without-apxs \
424 %endif
425 %if !%{with python} && !%{with perl} && !%{with ruby}
426         --without-swig \
427 %endif
428         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
429         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
430 %endif
431         --with-jdk="%{java_home}" \
432         --without-jikes \
433 %if %{with neon}
434         --without-serf \
435         --with-neon=%{_prefix} \
436         --disable-neon-version-check \
437 %else
438         --with-serf=%{_prefix} \
439         --without-neon \
440 %endif
441         --with-apr=%{_bindir}/apr-1-config \
442         --with-apr-util=%{_bindir}/apu-1-config \
443 %if %{with kwallet}
444         --with-kwallet \
445 %endif
446 %if %{with gnome}
447         --with-gnome-keyring
448 %endif
449
450 %{__make} -j1
451
452 %if !%{with net_client_only}
453 # python
454 %if %{with python}
455 # ctypes bindings
456 %{__make} ctypes-python
457 # swig bindings
458 %{__make} swig-py \
459         swig_pydir=%{py_sitedir}/libsvn \
460         swig_pydir_extra=%{py_sitedir}/svn
461 %endif
462 # perl
463 %if %{with perl}
464 %{__make} -j1 swig-pl-lib
465 odir=$(pwd)
466 cd subversion/bindings/swig/perl/native
467 %{__perl} Makefile.PL INSTALLDIRS=vendor
468 %{__make} -j1
469 cd $odir
470 %endif
471 %if %{with javahl}
472 %{__make} -j1 javahl \
473         javahl_javadir="%{_javadir}"
474 %endif
475 # ruby
476 %if %{with ruby}
477 %{__make} swig-rb
478 %endif
479 %endif
480
481 %if %{with tests}
482 %{__make} check
483 %if %{with python}
484 %{__make} check-ctypes-python
485 %{__make} check-swig-py
486 %endif
487 %if %{with perl}
488 %{__make} check-swig-pl
489 %endif
490 %if %{with ruby}
491 %{__make} check-swig-rb
492 %endif
493 %endif
494
495 %install
496 rm -rf $RPM_BUILD_ROOT
497 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
498         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
499         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
500         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
501
502 %{__make} install -j1 \
503 %if %{with javahl}
504         install-javahl \
505         javahl_javadir="%{_javadir}" \
506 %endif
507 %if !%{with net_client_only}
508 %if %{with python}
509         install-swig-py \
510         install-ctypes-python \
511 %endif
512 %if %{with ruby}
513         install-swig-rb install-swig-rb-doc \
514 %endif
515 %endif
516         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
517         DESTDIR=$RPM_BUILD_ROOT \
518         swig_pydir=%{py_sitedir}/libsvn \
519         swig_pydir_extra=%{py_sitedir}/svn
520
521 %if !%{with net_client_only} && %{with perl}
522 %{__make} install-swig-pl-lib \
523         DESTDIR=$RPM_BUILD_ROOT
524 %{__make} -C subversion/bindings/swig/perl/native install \
525         DESTDIR=$RPM_BUILD_ROOT \
526         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
527         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
528 %endif
529
530 %if %{with apache}
531 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
532 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
533 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
534 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
535 %endif
536
537 %if !%{with net_client_only}
538 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
539 %if %{with python}
540 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
541 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
542 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
543 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
544 %endif
545 %endif
546
547 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
548 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
549
550 %find_lang %{name}
551
552 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
553 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
554 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
555
556 %clean
557 rm -rf $RPM_BUILD_ROOT
558
559 %pre svnserve
560 %groupadd -g 86 svn
561 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
562
563 %post   libs -p /sbin/ldconfig
564 %postun libs -p /sbin/ldconfig
565
566 %post   devel -p /sbin/postshell
567 -/usr/sbin/fix-info-dir -c %{_infodir}
568
569 %postun devel -p /sbin/postshell
570 -/usr/sbin/fix-info-dir -c %{_infodir}
571
572 %post   -n perl-subversion -p /sbin/ldconfig
573 %postun -n perl-subversion -p /sbin/ldconfig
574
575 %post   -n python-subversion -p /sbin/ldconfig
576 %postun -n python-subversion -p /sbin/ldconfig
577
578 %post svnserve
579 /sbin/chkconfig --add svnserve
580 %service svnserve restart "svnserve daemon"
581
582 %preun svnserve
583 if [ "$1" = "0" ]; then
584         %service svnserve stop
585         /sbin/chkconfig --del svnserve
586 fi
587
588 %postun svnserve
589 if [ "$1" = "0" ]; then
590         %userremove svn
591         %groupremove svn
592 fi
593
594 %post -n apache-mod_dav_svn
595 %service -q httpd restart
596
597 %postun -n apache-mod_dav_svn
598 if [ "$1" = "0" ]; then
599         %service -q httpd restart
600 fi
601
602 %post -n apache-mod_authz_svn
603 %service -q httpd restart
604
605 %postun -n apache-mod_authz_svn
606 if [ "$1" = "0" ]; then
607         %service -q httpd restart
608 fi
609
610 %files
611 %defattr(644,root,root,755)
612 %doc BUGS CHANGES COPYING INSTALL README
613 %doc doc/*/*.html
614 %doc tools/hook-scripts/*.{pl,py,example}
615 %doc tools/hook-scripts/mailer/*.{py,example}
616 %doc tools/xslt/*
617 %attr(755,root,root) %{_bindir}/svn
618 %attr(755,root,root) %{_bindir}/svnadmin
619 %attr(755,root,root) %{_bindir}/svndumpfilter
620 %attr(755,root,root) %{_bindir}/svnlook
621 %attr(755,root,root) %{_bindir}/svnsync
622 %attr(755,root,root) %{_bindir}/svnversion
623 %{_mandir}/man1/svn.1*
624 %{_mandir}/man1/svnadmin.1*
625 %{_mandir}/man1/svndumpfilter.1*
626 %{_mandir}/man1/svnlook.1*
627 %{_mandir}/man1/svnsync.1*
628 %{_mandir}/man1/svnversion.1*
629
630 %files libs -f %{name}.lang
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
633 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
634 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
635 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
636 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
637 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
638 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
640 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
642 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
644 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
646 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
648 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
650 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
651 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
652 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
654 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
655 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
656 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
657 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
658 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
659 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
660
661 %files devel
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
664 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
665 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
666 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
667 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
668 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
669 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
670 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
671 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
672 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
673 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
674 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
675 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
676 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
677 %{_libdir}/libsvn_client-1.la
678 %{_libdir}/libsvn_delta-1.la
679 %{_libdir}/libsvn_diff-1.la
680 %{_libdir}/libsvn_fs-1.la
681 %{_libdir}/libsvn_fs_base-1.la
682 %{_libdir}/libsvn_fs_fs-1.la
683 %{_libdir}/libsvn_fs_util-1.la
684 %{_libdir}/libsvn_ra-1.la
685 %{_libdir}/libsvn_ra_local-1.la
686 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
687 %{_libdir}/libsvn_ra_svn-1.la
688 %{_libdir}/libsvn_repos-1.la
689 %{_libdir}/libsvn_subr-1.la
690 %{_libdir}/libsvn_wc-1.la
691 %{_includedir}/%{name}-1
692 %{_examplesdir}/%{name}-%{version}
693
694 %files static
695 %defattr(644,root,root,755)
696 %{_libdir}/libsvn_client-1.a
697 %{_libdir}/libsvn_delta-1.a
698 %{_libdir}/libsvn_diff-1.a
699 %{_libdir}/libsvn_fs-1.a
700 %{_libdir}/libsvn_fs_base-1.a
701 %{_libdir}/libsvn_fs_fs-1.a
702 %{_libdir}/libsvn_fs_util-1.a
703 %{_libdir}/libsvn_ra-1.a
704 %{_libdir}/libsvn_ra_local-1.a
705 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
706 %{_libdir}/libsvn_ra_svn-1.a
707 %{_libdir}/libsvn_repos-1.a
708 %{_libdir}/libsvn_subr-1.a
709 %{_libdir}/libsvn_wc-1.a
710
711 %if %{with gnome}
712 %files -n gnome-keyring-subversion
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
715 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
716 %endif
717
718 %if %{with kwallet}
719 %files -n kde4-kwallet-subversion
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
722 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
723 %endif
724
725 %if !%{with net_client_only}
726 %files svnserve
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_bindir}/svnserve
729 %{_mandir}/man5/svnserve.conf.5*
730 %{_mandir}/man8/svnserve.8*
731 %dir %attr(750,svn,svn) /home/services/subversion
732 %dir %attr(750,svn,svn) /home/services/subversion/repos
733 %if %{with apache}
734 %attr(754,root,root) /etc/rc.d/init.d/svnserve
735 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
736 %endif
737
738 %files tools
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_bindir}/svn-hot-backup
741
742 %files -n bash-completion-subversion
743 %defattr(644,root,root,755)
744 /etc/bash_completion.d/%{name}
745
746 %if %{with javahl}
747 %files -n java-subversion
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
750 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
751 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
752 %{_javadir}/svn-javahl.jar
753 %endif
754
755 %if %{with python}
756 %files -n python-subversion
757 %defattr(644,root,root,755)
758 %doc tools/backup/*.py tools/examples/*.py
759 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
760 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
761 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
762 %dir %{py_sitedir}/libsvn
763 %{py_sitedir}/libsvn/*.py[co]
764 %dir %{py_sitedir}/svn
765 %{py_sitedir}/svn/*.py[co]
766 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
767 %{_examplesdir}/python-%{name}-%{version}
768
769 %files -n python-csvn
770 %defattr(644,root,root,755)
771 %doc subversion/bindings/ctypes-python/{README,TODO}
772 %doc subversion/bindings/ctypes-python/examples/*.py
773 %dir %{py_sitescriptdir}/csvn
774 %{py_sitescriptdir}/csvn/*.py[co]
775 %dir %{py_sitescriptdir}/csvn/core
776 %{py_sitescriptdir}/csvn/core/*.py[co]
777 %dir %{py_sitescriptdir}/csvn/ext
778 %{py_sitescriptdir}/csvn/ext/*.py[co]
779 %{py_sitescriptdir}/*.egg-info
780 %endif
781
782 %if %{with perl}
783 %files -n perl-subversion
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
786 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
787 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
788 %{perl_vendorarch}/SVN
789 %dir %{perl_vendorarch}/auto/SVN
790 %dir %{perl_vendorarch}/auto/SVN/*
791 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
792 %{perl_vendorarch}/auto/SVN/*/*.bs
793 %{_mandir}/man3/*.3pm*
794 %endif
795
796 %if %{with ruby}
797 %files -n ruby-subversion
798 %defattr(644,root,root,755)
799 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
800 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
801 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
802 %dir %{ruby_sitelibdir}/svn
803 %{ruby_sitelibdir}/svn/*.rb
804 %dir %{ruby_sitearchdir}/svn
805 %dir %{ruby_sitearchdir}/svn/ext
806 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
807 %{ruby_ridir}/Svn
808 %endif
809
810 %if %{with apache}
811 %files -n apache-mod_dav_svn
812 %defattr(644,root,root,755)
813 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
814 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
815
816 %files -n apache-mod_authz_svn
817 %defattr(644,root,root,755)
818 %doc subversion/mod_authz_svn/INSTALL
819 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
820 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
821 %endif
822
823 %endif # net_client_only
This page took 0.077014 seconds and 4 git commands to generate.