]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- no duplicate packaging of python tools/examples
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - finish ruby
3 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
4 #
5 # Conditional build:
6 %bcond_with     net_client_only         # build only net client
7 %bcond_without  neon                    # use serf instead of neon
8 %bcond_without  swig                    # disable bindings generation with Swig
9 %bcond_without  python                  # build without Python bindings (broken)
10 %bcond_without  csvn                    # build Python csvn bindings
11 %bcond_without  perl                    # build without Perl bindings
12 %bcond_without  ruby                    # build without Ruby bindings
13 %bcond_without  apache                  # build without Apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 %bcond_without  kde                             # build without kde4 support (alias for kwallet)
18 %bcond_without  gnome                   # build without gnome keyring support
19 %bcond_without  db                              # disable Subversion Berkeley DB based filesystem library
20
21 %if %{with net_client_only}
22 %undefine       with_apache
23 %undefine       with_db
24 %undefine       with_swig
25 %undefine       with_javahl
26 %endif
27
28 %if %{without swig}
29 %undefine       with_perl
30 %undefine       with_python
31 %undefine       with_ruby
32 %endif
33
34 %if %{without kde}
35 %undefine       with_kwallet
36 %endif
37
38 %if %{without python} && %{without perl} && %{without ruby}
39 %define         without_swig    1
40 %endif
41
42 %define apxs    /usr/sbin/apxs
43 %define pdir    SVN
44 %define pnam    _Core
45
46 %if %{with neon}
47 %define webdavlib       neon
48 %else
49 %define webdavlib       serf
50 %endif
51 %{!?with_perl:%include  /usr/lib/rpm/macros.perl}
52 Summary:        A Concurrent Versioning system similar to but better than CVS
53 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
54 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
55 Name:           subversion
56 Version:        1.6.16
57 Release:        1
58 License:        Apache/BSD-like
59 Group:          Development/Version Control
60 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
61 # Source0-md5:  32f25a6724559fe8691d1f57a63f636e
62 Source1:        %{name}-dav_svn.conf
63 Source2:        %{name}-authz_svn.conf
64 Source3:        %{name}-svnserve.init
65 Source4:        %{name}-svnserve.sysconfig
66 # current subversion tarball has correct *.swg files
67 # but after regeneration these are broken again, so
68 # we still need this script
69 Source5:        %{name}-convert-typemaps-to-ifdef.py
70 Patch0:         %{name}-home_etc.patch
71 Patch1:         %{name}-DESTDIR.patch
72 Patch2:         %{name}-ruby-datadir-path.patch
73 Patch3:         %{name}-tests.patch
74 URL:            http://subversion.apache.org/
75 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
76 BuildRequires:  autoconf
77 BuildRequires:  automake
78 BuildRequires:  db-devel >= 4.1.25
79 BuildRequires:  libtool
80 BuildRequires:  rpmbuild(macros) >= 1.583
81 %if %{with perl}
82 BuildRequires:  perl-devel >= 1:5.8.0
83 BuildRequires:  rpm-perlprov >= 4.1-13
84 BuildRequires:  swig-perl >= 1.3.24
85 %endif
86 %if %{with csvn}
87 BuildRequires:  python-ctypesgen
88 %endif
89 %if %{with python}
90 BuildRequires:  python-devel >= 1:2.4
91 BuildRequires:  swig-python >= 1.3.24
92 %endif
93 %if %{with ruby}
94 BuildRequires:  ruby-devel
95 BuildRequires:  ruby-rubygems
96 BuildRequires:  swig-ruby >= 1.3.24
97 %endif
98 %if %{with javahl}
99 BuildRequires:  jdk
100 BuildRequires:  libstdc++-devel
101 %endif
102 BuildRequires:  apr-devel >= 1:1.0.0
103 BuildRequires:  apr-util-devel >= 1:1.2.8-3
104 BuildRequires:  autoconf >= 2.59
105 BuildRequires:  bison
106 BuildRequires:  cyrus-sasl-devel
107 BuildRequires:  expat-devel
108 BuildRequires:  gettext-devel
109 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
110 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
111 BuildRequires:  libtool >= 1.4-9
112 BuildRequires:  pkgconfig
113 BuildRequires:  rpm-pythonprov
114 BuildRequires:  sed >= 4.0
115 BuildRequires:  sqlite3-devel >= 3.6.11
116 BuildRequires:  texinfo
117 BuildRequires:  which
118 %if %{with neon}
119 BuildRequires:  neon-devel >= 0.26.0
120 %else
121 BuildRequires:  serf-devel
122 %endif
123 Requires:       %{name}-libs = %{version}-%{release}
124 %requires_ge    sqlite3
125 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
126
127 %define         _libexecdir             %{_libdir}/svn
128 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
129 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
130
131 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
132
133 %description
134 The goal of the Subversion project is to build a version control
135 system that is a compelling replacement for CVS in the open source
136 community.
137
138 Our goals are:
139 - All current CVS features.
140 - Directories, renames, and file meta-data are versioned.
141 - Symbolic links, etc, are supported
142 - Commits are truly atomic.
143 - Branching and tagging are cheap (constant time) operations
144 - Repeated merges are handled gracefully
145 - Support for plug-in client side diff programs
146 - Natively client/server
147 - Client/server protocol sends diffs in both directions
148 - Costs are proportional to change size, not project size
149 - Internationalization
150 - Progressive multi-lingual support
151
152 %description -l pl.UTF-8
153 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
154 zamiennika dla CVS.
155
156 Cele projektu to:
157 - Wszystkie aktualne możliwości CVS.
158 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
159 - Obsługa dowiązań symbolicznych itp.
160 - Commity są w pełni atomowe.
161 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
162 - Dobra obsługa powtarzanego łączenia (merge).
163 - Obsługa wtyczek diff po stronie klienta.
164 - Natywny klient/serwer.
165 - Klient/Serwer przesyłają diffy w obu kierunkach.
166 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
167 - Internacjonalizacja.
168 - Postępujące wsparcie dla wielu języków.
169
170 %description -l pt_BR.UTF-8
171 O objetivo do projeto Subversion é construir um sistema de controle de
172 versões que seja um substituto para o CVS (Concurrent Versioning
173 System) na comunidade opensource, fornecendo grandes melhorias.
174
175 %package libs
176 Summary:        Subversion libraries and modules
177 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
178 Group:          Libraries
179 %{?with_neon:Requires:  neon >= 0.26.0}
180 Obsoletes:      libsubversion0
181
182 %description libs
183 Subversion libraries and modules.
184
185 %description libs -l pl.UTF-8
186 Biblioteka subversion oraz ładowalne moduły.
187
188 %package devel
189 Summary:        Header files and develpment documentation for subversion
190 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
191 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
192 Group:          Development/Libraries
193 Requires:       %{name}-libs = %{version}-%{release}
194 Requires:       apr-util-devel >= 1:1.0.0
195 %{?with_neon:Requires:  neon-devel >= 0.26.0}
196 Obsoletes:      libsubversion0-devel
197
198 %description devel
199 Header files and develpment documentation for subversion.
200
201 %description devel -l pl.UTF-8
202 Pliki nagłówkowe i dokumetacja do subversion.
203
204 %description devel -l pt_BR.UTF-8
205 Este pacote provê os arquivos necessários para desenvolvedores
206 interagirem com o Subversion.
207
208 %package static
209 Summary:        Static subversion library
210 Summary(pl.UTF-8):      Biblioteka statyczna subversion
211 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
212 Group:          Development/Libraries
213 Requires:       %{name}-devel = %{version}
214 Obsoletes:      libsubversion0-static-devel
215
216 %description static
217 Static subversion library.
218
219 %description static -l pl.UTF-8
220 Biblioteka statyczna subversion.
221
222 %description static -l pt_BR.UTF-8
223 Este pacote provê um cliente estático do subversion.
224
225 %package svnserve
226 Summary:        Subversion svnserve
227 Summary(pl.UTF-8):      Subversion svnserve
228 Group:          Networking/Daemons
229 Requires(post,preun):   /sbin/chkconfig
230 Requires(postun):       /usr/sbin/groupdel
231 Requires(postun):       /usr/sbin/userdel
232 Requires(pre):  /bin/id
233 Requires(pre):  /usr/bin/getgid
234 Requires(pre):  /usr/lib/rpm/user_group.sh
235 Requires(pre):  /usr/sbin/groupadd
236 Requires(pre):  /usr/sbin/useradd
237 Requires(pre):  /usr/sbin/usermod
238 Requires:       %{name} = %{version}-%{release}
239 Requires:       rc-scripts
240 Provides:       group(svn)
241 Provides:       user(svn)
242
243 %description svnserve
244 Subversion svnserve server.
245
246 %description svnserve -l pl.UTF-8
247 Serwer subversion svnserve.
248
249 %package tools
250 Summary:        Subversion tools and scripts
251 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
252 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
253 Group:          Applications
254 %pyrequires_eq  python
255 Requires:       %{name} = %{version}-%{release}
256 Requires:       python-subversion = %{version}
257
258 %description tools
259 Subversion tools and scripts.
260
261 %description tools -l pl.UTF-8
262 Narzędzia oraz skrypty dla subversion.
263
264 %package -n bash-completion-subversion
265 Summary:        bash completion for subversion
266 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
267 Group:          Applications/Shells
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       bash-completion
270 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
271
272 %description -n bash-completion-subversion
273 Bash completion for subversion.
274
275 %description -n bash-completion-subversion -l pl.UTF-8
276 Dopełnienia basha dla subversion.
277
278 %package -n java-subversion
279 Summary:        Subversion Java bindings
280 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
281 Group:          Development/Languages/Java
282 Requires:       %{name}-libs = %{version}-%{release}
283
284 %description -n java-subversion
285 This is a set of Java classes which provide the functionality of
286 subversion-libs, the Subversion libraries. It is useful if you want
287 to, for example, write a Java class that manipulates a Subversion
288 repository or working copy. See the 'subversion' package for more
289 information.
290
291 %description -n java-subversion -l pl.UTF-8
292 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
293 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
294 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
295 roboczą. Więcej informacji w pakiecie subversion.
296
297 %package -n python-subversion
298 Summary:        Subversion Python bindings
299 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
300 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
301 Group:          Development/Languages/Python
302 %pyrequires_eq  python
303 Requires:       %{name}-libs = %{version}-%{release}
304 Obsoletes:      subversion-python
305
306 %description -n python-subversion
307 Subversion Python bindings.
308
309 %description -n python-subversion -l pl.UTF-8
310 Dowiązania do Subversion dla Pythona.
311
312 %description -n python-subversion -l pt_BR.UTF-8
313 Módulos Python para acessar os recursos do Subversion.
314
315 %package -n python-csvn
316 Summary:        CTypes Subversion Python bindings
317 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
318 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
319 Group:          Development/Languages/Python
320 %pyrequires_eq  python
321 Requires:       %{name}-libs = %{version}-%{release}
322
323 %description -n python-csvn
324 Subversion CTypes Python bindings.
325
326 %description -n python-csvn -l pl.UTF-8
327 Dowiązania do Subversion dla Pythona używające CTypes.
328
329 %description -n python-csvn -l pt_BR.UTF-8
330 Módulos Python para acessar os recursos do Subversion.
331
332 %package -n perl-subversion
333 Summary:        Subversion Perl bindings
334 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
335 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
336 Group:          Development/Languages/Perl
337 Requires:       %{name}-libs = %{version}-%{release}
338 Obsoletes:      subversion-perl
339
340 %description -n perl-subversion
341 Subversion Perl bindings.
342
343 %description -n perl-subversion -l pl.UTF-8
344 Dowiązania do Subversion dla Perla.
345
346 %description -n perl-subversion -l pt_BR.UTF-8
347 Módulos Perl para acessar os recursos do Subversion.
348
349 %package -n ruby-subversion
350 Summary:        Subversion Ruby bindings
351 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
352 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
353 Group:          Development/Languages
354 Requires:       %{name}-libs = %{version}-%{release}
355 Obsoletes:      subversion-ruby
356
357 %description -n ruby-subversion
358 Subversion Ruby bindings.
359
360 %description -n ruby-subversion -l pl.UTF-8
361 Dowiązania do Subversion dla języka Ruby.
362
363 %description -n ruby-subversion -l pt_BR.UTF-8
364 Módulos Ruby para acessar os recursos do Subversion.
365
366 %package -n apache-mod_dav_svn
367 Summary:        Apache module: Subversion Server
368 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
369 Group:          Networking/Daemons
370 Requires:       %{name} = %{version}-%{release}
371 Requires:       apache(modules-api) = %apache_modules_api
372 Requires:       apache-mod_dav
373
374 %description -n apache-mod_dav_svn
375 Apache module: Subversion Server.
376
377 %description -n apache-mod_dav_svn -l pl.UTF-8
378 Moduł apache: Serwer Subversion.
379
380 %package -n apache-mod_authz_svn
381 Summary:        Apache module: Subversion Server - path-based authorization
382 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
383 Group:          Networking/Daemons
384 Requires:       apache(modules-api) = %apache_modules_api
385 Requires:       apache-mod_dav_svn = %{version}-%{release}
386
387 %description -n apache-mod_authz_svn
388 Apache module: Subversion Server - path-based authorization.
389
390 %description -n apache-mod_authz_svn -l pl.UTF-8
391 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
392
393 %package -n gnome-keyring-subversion
394 Summary:        GNOME Keyring authentication provider for Subversion
395 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
396 Group:          X11/Applications
397
398 %description -n gnome-keyring-subversion
399 Authentication provider module for Subversion which allows SVN client
400 to authenticate using GNOME Keyring.
401
402 %description -n gnome-keyring-subversion -l pl.UTF-8
403 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
404 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
405
406 %package -n kde4-kwallet-subversion
407 Summary:        KDE Wallet authentication provider for Subversion
408 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
409 Group:          X11/Applications
410
411 %description -n kde4-kwallet-subversion
412 Authentication provider module for Subversion which allows SVN client
413 to authenticate using KDE Wallet.
414
415 %description -n kde4-kwallet-subversion -l pl.UTF-8
416 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
417 uwierzytelniać się przy użyciu Portfela KDE.
418
419 %prep
420 %setup -q
421 %patch0 -p0
422 %patch1 -p1
423 %patch2 -p0
424 %patch3 -p1
425
426 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
427
428 # serf.m4 macro is broken and ignores --without serf
429 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
430
431 %build
432 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
433 #%{__rm} subversion/bindings/swig/proxy/*.swg
434 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
435 chmod +x ./autogen.sh && ./autogen.sh
436 %{__libtoolize}
437 %configure \
438         --with-editor=vi \
439         --with-zlib=%{_libdir} \
440         --disable-runtime-module-search \
441         --disable-mod-activation \
442 %if %{with db}
443         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
444 %else
445         --without-berkeley-db \
446 %endif
447 %if %{with apache}
448         --with-apxs=%{_sbindir}/apxs \
449 %else
450         --without-apache \
451         --without-apxs \
452 %endif
453 %if %{without swig}
454         --without-swig \
455 %endif
456 %if %{without ruby}
457         ac_cv_path_RUBY=none \
458 %endif
459         %{?with_csvn:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
460         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
461         --with-jdk="%{java_home}" \
462         --without-jikes \
463 %if %{with neon}
464         --without-serf \
465         --with-neon=%{_prefix} \
466         --disable-neon-version-check \
467 %else
468         --with-serf=%{_prefix} \
469         --without-neon \
470 %endif
471         --with-apr=%{_bindir}/apr-1-config \
472         --with-apr-util=%{_bindir}/apu-1-config \
473 %if %{with kwallet}
474         --with-kwallet \
475 %endif
476 %if %{with gnome}
477         --with-gnome-keyring
478 %endif
479
480 %{__make} -j1
481
482 # python
483 %if %{with python}
484 %if %{with csvn}
485 # ctypes bindings
486 %{__make} ctypes-python
487 %endif
488 # swig bindings
489 %{__make} swig-py \
490         swig_pydir=%{py_sitedir}/libsvn \
491         swig_pydir_extra=%{py_sitedir}/svn
492 %endif
493 # perl
494 %if %{with perl}
495 %{__make} -j1 swig-pl-lib
496 odir=$(pwd)
497 cd subversion/bindings/swig/perl/native
498 %{__perl} Makefile.PL INSTALLDIRS=vendor
499 %{__make} -j1
500 cd $odir
501 %endif
502 %if %{with javahl}
503 %{__make} -j1 javahl \
504         javahl_javadir="%{_javadir}"
505 %endif
506 # ruby
507 %if %{with ruby}
508 %{__make} swig-rb
509 %endif
510
511 %if %{with tests}
512 %{__make} check
513 %if %{with python}
514 %if %{with csvn}
515 %{__make} check-ctypes-python
516 %endif
517 %{__make} check-swig-py
518 %endif
519 %if %{with perl}
520 %{__make} check-swig-pl
521 %endif
522 %if %{with ruby}
523 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
524 #%{__make} check-swig-rb
525 %endif
526 %endif
527
528 %install
529 rm -rf $RPM_BUILD_ROOT
530 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
531         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
532         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
533         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
534         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
535
536 %{__make} install -j1 \
537 %if %{with javahl}
538         install-javahl \
539         javahl_javadir="%{_javadir}" \
540 %endif
541 %if %{with python}
542         install-swig-py \
543 %if %{with csvn}
544         install-ctypes-python \
545 %endif
546 %endif
547 %if %{with ruby}
548         install-swig-rb install-swig-rb-doc \
549 %endif
550         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
551         DESTDIR=$RPM_BUILD_ROOT \
552         swig_pydir=%{py_sitedir}/libsvn \
553         swig_pydir_extra=%{py_sitedir}/svn
554
555 %if %{with perl}
556 %{__make} install-swig-pl-lib \
557         DESTDIR=$RPM_BUILD_ROOT
558 %{__make} -C subversion/bindings/swig/perl/native install \
559         DESTDIR=$RPM_BUILD_ROOT \
560         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
561         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
562 %endif
563
564 %if %{with apache}
565 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
566 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
567 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
568 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
569 %endif
570
571 %if %{without net_client_only}
572 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
573 %endif
574 %if %{with python}
575 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
576 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
577 %py_postclean
578 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
579 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
580 %endif
581
582 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
583 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
584
585 %{?with_javahl:%{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
586 %if %{with swig}
587 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
588 %if %{with ruby}
589 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
590 %endif
591 %endif
592 %if %{with gnome} || %{with kwallet}
593 # dlopened by soname (libsvn_auth_*-1.so.0)
594 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
595 %endif
596
597 %find_lang %{name}
598
599 %clean
600 rm -rf $RPM_BUILD_ROOT
601
602 %pre svnserve
603 %groupadd -g 86 svn
604 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
605
606 %post   libs -p /sbin/ldconfig
607 %postun libs -p /sbin/ldconfig
608
609 %post   devel -p /sbin/postshell
610 -/usr/sbin/fix-info-dir -c %{_infodir}
611
612 %postun devel -p /sbin/postshell
613 -/usr/sbin/fix-info-dir -c %{_infodir}
614
615 %post   -n java-subversion -p /sbin/ldconfig
616 %postun -n java-subversion -p /sbin/ldconfig
617
618 %post   -n perl-subversion -p /sbin/ldconfig
619 %postun -n perl-subversion -p /sbin/ldconfig
620
621 %post   -n python-subversion -p /sbin/ldconfig
622 %postun -n python-subversion -p /sbin/ldconfig
623
624 %post   -n ruby-subversion -p /sbin/ldconfig
625 %postun -n ruby-subversion -p /sbin/ldconfig
626
627 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
628 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
629
630 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
631 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
632
633 %post svnserve
634 /sbin/chkconfig --add svnserve
635 %service svnserve restart "svnserve daemon"
636
637 %preun svnserve
638 if [ "$1" = "0" ]; then
639         %service svnserve stop
640         /sbin/chkconfig --del svnserve
641 fi
642
643 %postun svnserve
644 if [ "$1" = "0" ]; then
645         %userremove svn
646         %groupremove svn
647 fi
648
649 %post -n apache-mod_dav_svn
650 %service -q httpd restart
651
652 %postun -n apache-mod_dav_svn
653 if [ "$1" = "0" ]; then
654         %service -q httpd restart
655 fi
656
657 %post -n apache-mod_authz_svn
658 %service -q httpd restart
659
660 %postun -n apache-mod_authz_svn
661 if [ "$1" = "0" ]; then
662         %service -q httpd restart
663 fi
664
665 %files
666 %defattr(644,root,root,755)
667 %doc BUGS CHANGES COPYING INSTALL README
668 %doc doc/*/*.html
669 %doc tools/hook-scripts/*.{pl,py,example}
670 %doc tools/hook-scripts/mailer/*.{py,example}
671 %doc tools/xslt/*
672 %attr(755,root,root) %{_bindir}/svn
673 %attr(755,root,root) %{_bindir}/svnadmin
674 %attr(755,root,root) %{_bindir}/svndumpfilter
675 %attr(755,root,root) %{_bindir}/svnlook
676 %attr(755,root,root) %{_bindir}/svnsync
677 %attr(755,root,root) %{_bindir}/svnversion
678 %{_mandir}/man1/svn.1*
679 %{_mandir}/man1/svnadmin.1*
680 %{_mandir}/man1/svndumpfilter.1*
681 %{_mandir}/man1/svnlook.1*
682 %{_mandir}/man1/svnsync.1*
683 %{_mandir}/man1/svnversion.1*
684
685 %files libs -f %{name}.lang
686 %defattr(644,root,root,755)
687 %dir %{_sysconfdir}/%{name}
688 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
689 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
690 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
691 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
692 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
693 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
694 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
695 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
696 %if %{without net_client_only}
697 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
698 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
699 %endif
700 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
701 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
702 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
703 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
704 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
705 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
706 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
707 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
708 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
709 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
710 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
711 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
712 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
713 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
714 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
715 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
716 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
718
719 %files devel
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
722 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
723 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
724 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
725 %if %{without net_client_only}
726 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
727 %endif
728 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
729 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
730 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
731 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
732 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
733 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
734 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
735 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
736 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
737 %{_libdir}/libsvn_client-1.la
738 %{_libdir}/libsvn_delta-1.la
739 %{_libdir}/libsvn_diff-1.la
740 %{_libdir}/libsvn_fs-1.la
741 %if %{without net_client_only}
742 %{_libdir}/libsvn_fs_base-1.la
743 %endif
744 %{_libdir}/libsvn_fs_fs-1.la
745 %{_libdir}/libsvn_fs_util-1.la
746 %{_libdir}/libsvn_ra-1.la
747 %{_libdir}/libsvn_ra_local-1.la
748 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
749 %{_libdir}/libsvn_ra_svn-1.la
750 %{_libdir}/libsvn_repos-1.la
751 %{_libdir}/libsvn_subr-1.la
752 %{_libdir}/libsvn_wc-1.la
753 %{_includedir}/%{name}-1
754 %{_examplesdir}/%{name}-%{version}
755
756 %files static
757 %defattr(644,root,root,755)
758 %{_libdir}/libsvn_client-1.a
759 %{_libdir}/libsvn_delta-1.a
760 %{_libdir}/libsvn_diff-1.a
761 %{_libdir}/libsvn_fs-1.a
762 %if %{without net_client_only}
763 %{_libdir}/libsvn_fs_base-1.a
764 %endif
765 %{_libdir}/libsvn_fs_fs-1.a
766 %{_libdir}/libsvn_fs_util-1.a
767 %{_libdir}/libsvn_ra-1.a
768 %{_libdir}/libsvn_ra_local-1.a
769 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
770 %{_libdir}/libsvn_ra_svn-1.a
771 %{_libdir}/libsvn_repos-1.a
772 %{_libdir}/libsvn_subr-1.a
773 %{_libdir}/libsvn_wc-1.a
774
775 %if %{with gnome}
776 %files -n gnome-keyring-subversion
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
779 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
780 %endif
781
782 %if %{with kwallet}
783 %files -n kde4-kwallet-subversion
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
786 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
787 %endif
788
789 %if %{without net_client_only}
790 %files svnserve
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_bindir}/svnserve
793 %{_mandir}/man5/svnserve.conf.5*
794 %{_mandir}/man8/svnserve.8*
795 %dir %attr(750,svn,svn) /home/services/subversion
796 %dir %attr(750,svn,svn) /home/services/subversion/repos
797 %if %{with apache}
798 %attr(754,root,root) /etc/rc.d/init.d/svnserve
799 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
800 %endif
801
802 %files tools
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_bindir}/svn-hot-backup
805
806 %files -n bash-completion-subversion
807 %defattr(644,root,root,755)
808 /etc/bash_completion.d/%{name}
809
810 %if %{with javahl}
811 %files -n java-subversion
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
814 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
815 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
816 %{_javadir}/svn-javahl.jar
817 %endif
818
819 %if %{with python}
820 %files -n python-subversion
821 %defattr(644,root,root,755)
822 %doc tools/backup/*.py
823 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
824 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
825 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
826 %dir %{py_sitedir}/libsvn
827 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
828 %{py_sitedir}/libsvn/*.py[co]
829 %dir %{py_sitedir}/svn
830 %{py_sitedir}/svn/*.py[co]
831 %{_examplesdir}/python-%{name}-%{version}
832
833 %if %{with csvn}
834 %files -n python-csvn
835 %defattr(644,root,root,755)
836 %doc subversion/bindings/ctypes-python/{README,TODO}
837 %doc subversion/bindings/ctypes-python/examples/*.py
838 %dir %{py_sitescriptdir}/csvn
839 %{py_sitescriptdir}/csvn/*.py[co]
840 %dir %{py_sitescriptdir}/csvn/core
841 %{py_sitescriptdir}/csvn/core/*.py[co]
842 %dir %{py_sitescriptdir}/csvn/ext
843 %{py_sitescriptdir}/csvn/ext/*.py[co]
844 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
845 %endif
846 %endif
847
848 %if %{with perl}
849 %files -n perl-subversion
850 %defattr(644,root,root,755)
851 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
852 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
853 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
854 %{perl_vendorarch}/SVN
855 %dir %{perl_vendorarch}/auto/SVN
856 %dir %{perl_vendorarch}/auto/SVN/*
857 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
858 %{perl_vendorarch}/auto/SVN/*/*.bs
859 %{_mandir}/man3/*.3pm*
860 %endif
861
862 %if %{with ruby}
863 %files -n ruby-subversion
864 %defattr(644,root,root,755)
865 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
866 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
867 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
868 %dir %{ruby_sitelibdir}/svn
869 %{ruby_sitelibdir}/svn/*.rb
870 %dir %{ruby_sitearchdir}/svn
871 %dir %{ruby_sitearchdir}/svn/ext
872 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
873 %{ruby_ridir}/Svn
874 %endif
875
876 %if %{with apache}
877 %files -n apache-mod_dav_svn
878 %defattr(644,root,root,755)
879 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
880 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
881
882 %files -n apache-mod_authz_svn
883 %defattr(644,root,root,755)
884 %doc subversion/mod_authz_svn/INSTALL
885 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
886 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
887 %endif
888
889 %endif # net_client_only
This page took 0.12348 seconds and 4 git commands to generate.