]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- javahl in bcond
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - fix java build with java-gcj-compat and s/java-sun/jdk/
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 # - finish ruby
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 #
17 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
18 %undefine       with_javahl
19 %endif
20 #
21 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
22 %define apxs    /usr/sbin/apxs
23 %define pdir    SVN
24 %define pnam    _Core
25 #
26 %if %{with neon}
27 %define webdavlib       neon
28 %else
29 %define webdavlib       serf
30 %endif
31 #
32 Summary:        A Concurrent Versioning system similar to but better than CVS
33 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
34 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
35 Name:           subversion
36 Version:        1.6.0
37 Release:        2
38 License:        Apache/BSD-like
39 Group:          Development/Version Control
40 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
41 # Source0-md5:  db9f19671c1f5286be3a930c0a7d18f3
42 Source1:        %{name}-dav_svn.conf
43 Source2:        %{name}-authz_svn.conf
44 Source3:        %{name}-svnserve.init
45 Source4:        %{name}-svnserve.sysconfig
46 # current subversion tarball has correct *.swg files
47 # but after regeneration these are broken again, so
48 # we still need this script
49 Source5:        %{name}-convert-typemaps-to-ifdef.py
50 Patch0:         %{name}-home_etc.patch
51 Patch1:         %{name}-DESTDIR.patch
52 Patch2:         %{name}-ruby-datadir-path.patch
53 URL:            http://subversion.tigris.org/
54 %if %{with net_client_only}
55 %global apache_modules_api 0
56 %else
57 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
58 BuildRequires:  automake
59 BuildRequires:  db-devel >= 4.1.25
60 BuildRequires:  rpmbuild(macros) >= 1.268
61 %if %{with perl}
62 BuildRequires:  perl-devel >= 1:5.8.0
63 BuildRequires:  rpm-perlprov >= 4.1-13
64 BuildRequires:  swig-perl >= 1.3.24
65 %endif
66 %if %{with python}
67 BuildRequires:  python-ctypesgen
68 BuildRequires:  python-devel >= 2.2
69 BuildRequires:  swig-python >= 1.3.24
70 %endif
71 %if %{with ruby}
72 BuildRequires:  ruby-devel
73 BuildRequires:  swig-ruby >= 1.3.24
74 %endif
75 %{?with_javahl:BuildRequires:   java-sun}
76 BuildRequires:  cyrus-sasl-devel
77 %endif
78 BuildRequires:  apr-devel >= 1:1.0.0
79 BuildRequires:  apr-util-devel >= 1:1.2.8-3
80 BuildRequires:  autoconf >= 2.59
81 BuildRequires:  bison
82 BuildRequires:  expat-devel
83 BuildRequires:  gettext-devel
84 BuildRequires:  gnome-keyring-devel
85 BuildRequires:  kde4-kdelibs-devel
86 BuildRequires:  libtool >= 1.4-9
87 BuildRequires:  sed >= 4.0
88 BuildRequires:  sqlite3-devel >= 3.6.11
89 BuildRequires:  texinfo
90 BuildRequires:  which
91 %if %{with neon}
92 BuildRequires:  neon-devel >= 0.26.0
93 %else
94 BuildRequires:  serf-devel
95 %endif
96 BuildRequires:  python >= 2.2
97 BuildRequires:  python-modules >= 2.2
98 Requires:       %{name}-libs = %{version}-%{release}
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _libexecdir             %{_libdir}/svn
102 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
103 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
104
105 %description
106 The goal of the Subversion project is to build a version control
107 system that is a compelling replacement for CVS in the open source
108 community.
109
110 Our goals are:
111 - All current CVS features.
112 - Directories, renames, and file meta-data are versioned.
113 - Symbolic links, etc, are supported
114 - Commits are truly atomic.
115 - Branching and tagging are cheap (constant time) operations
116 - Repeated merges are handled gracefully
117 - Support for plug-in client side diff programs
118 - Natively client/server
119 - Client/server protocol sends diffs in both directions
120 - Costs are proportional to change size, not project size
121 - Internationalization
122 - Progressive multi-lingual support
123
124 %description -l pl.UTF-8
125 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
126 zamiennika dla CVS.
127
128 Cele projektu to:
129 - Wszystkie aktualne możliwości CVS.
130 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
131 - Obsługa dowiązań symbolicznych itp.
132 - Commity są w pełni atomowe.
133 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
134 - Dobra obsługa powtarzanego łączenia (merge).
135 - Obsługa wtyczek diff po stronie klienta.
136 - Natywny klient/serwer.
137 - Klient/Serwer przesyłają diffy w obu kierunkach.
138 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
139 - Internacjonalizacja.
140 - Postępujące wsparcie dla wielu języków.
141
142 %description -l pt_BR.UTF-8
143 O objetivo do projeto Subversion é construir um sistema de controle de
144 versões que seja um substituto para o CVS (Concurrent Versioning
145 System) na comunidade opensource, fornecendo grandes melhorias.
146
147 %package libs
148 Summary:        Subversion libraries and modules
149 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
150 Group:          Libraries
151 %{?with_neon:Requires:  neon >= 0.26.0}
152 Obsoletes:      libsubversion0
153
154 %description libs
155 Subversion libraries and modules.
156
157 %description libs -l pl.UTF-8
158 Biblioteka subversion oraz ładowalne moduły.
159
160 %package devel
161 Summary:        Header files and develpment documentation for subversion
162 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
163 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
164 Group:          Development/Libraries
165 Requires:       %{name}-libs = %{version}-%{release}
166 Requires:       apr-util-devel >= 1:1.0.0
167 %{?with_neon:Requires:  neon-devel >= 0.26.0}
168 Obsoletes:      libsubversion0-devel
169
170 %description devel
171 Header files and develpment documentation for subversion.
172
173 %description devel -l pl.UTF-8
174 Pliki nagłówkowe i dokumetacja do subversion.
175
176 %description devel -l pt_BR.UTF-8
177 Este pacote provê os arquivos necessários para desenvolvedores
178 interagirem com o Subversion.
179
180 %package static
181 Summary:        Static subversion library
182 Summary(pl.UTF-8):      Biblioteka statyczna subversion
183 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
184 Group:          Development/Libraries
185 Requires:       %{name}-devel = %{version}
186 Obsoletes:      libsubversion0-static-devel
187
188 %description static
189 Static subversion library.
190
191 %description static -l pl.UTF-8
192 Biblioteka statyczna subversion.
193
194 %description static -l pt_BR.UTF-8
195 Este pacote provê um cliente estático do subversion.
196
197 %package svnserve
198 Summary:        Subversion svnserve
199 Summary(pl.UTF-8):      Subversion svnserve
200 Group:          Networking/Daemons
201 Requires(post,preun):   /sbin/chkconfig
202 Requires(postun):       /usr/sbin/groupdel
203 Requires(postun):       /usr/sbin/userdel
204 Requires(pre):  /bin/id
205 Requires(pre):  /usr/bin/getgid
206 Requires(pre):  /usr/lib/rpm/user_group.sh
207 Requires(pre):  /usr/sbin/groupadd
208 Requires(pre):  /usr/sbin/useradd
209 Requires(pre):  /usr/sbin/usermod
210 Requires:       %{name} = %{version}-%{release}
211 Requires:       rc-scripts
212 Provides:       group(svn)
213 Provides:       user(svn)
214
215 %description svnserve
216 Subversion svnserve server.
217
218 %description svnserve -l pl.UTF-8
219 Serwer subversion svnserve.
220
221 %package tools
222 Summary:        Subversion tools and scripts
223 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
224 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
225 Group:          Applications
226 %pyrequires_eq  python
227 Requires:       %{name} = %{version}-%{release}
228 Requires:       python-rcsparse >= 0.1-0.20031026.0
229 Requires:       python-subversion = %{version}
230
231 %description tools
232 Subversion tools and scripts.
233
234 %description tools -l pl.UTF-8
235 Narzędzia oraz skrypty dla subversion.
236
237 %package -n bash-completion-subversion
238 Summary:        bash completion for subversion
239 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
240 Group:          Applications/Shells
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       bash-completion
243 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
244
245 %description -n bash-completion-subversion
246 Bash completion for subversion.
247
248 %description -n bash-completion-subversion -l pl.UTF-8
249 Dopełnienia basha dla subversion.
250
251 %package -n java-subversion
252 Summary:        Subversion Java bindings
253 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
254 Group:          Development/Languages/Java
255 Requires:       %{name}-libs = %{version}-%{release}
256
257 %description -n java-subversion
258 This is a set of Java classes which provide the functionality of
259 subversion-libs, the Subversion libraries. It is useful if you want
260 to, for example, write a Java class that manipulates a Subversion
261 repository or working copy. See the 'subversion' package for more
262 information.
263
264 %description -n java-subversion -l pl.UTF-8
265 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
266 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
267 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
268 roboczą. Więcej informacji w pakiecie subversion.
269
270 %package -n python-subversion
271 Summary:        Subversion Python bindings
272 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
273 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
274 Group:          Development/Languages/Python
275 %pyrequires_eq  python
276 Requires:       %{name}-libs = %{version}-%{release}
277 Obsoletes:      subversion-python
278
279 %description -n python-subversion
280 Subversion Python bindings.
281
282 %description -n python-subversion -l pl.UTF-8
283 Dowiązania do Subversion dla Pythona.
284
285 %description -n python-subversion -l pt_BR.UTF-8
286 Módulos Python para acessar os recursos do Subversion.
287
288 %package -n python-csvn
289 Summary:        CTypes Subversion Python bindings
290 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
291 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
292 Group:          Development/Languages/Python
293 %pyrequires_eq  python
294 Requires:       %{name}-libs = %{version}-%{release}
295
296 %description -n python-csvn
297 Subversion CTypes Python bindings.
298
299 %description -n python-csvn -l pl.UTF-8
300 Dowiązania do Subversion dla Pythona używające CTypes.
301
302 %description -n python-csvn -l pt_BR.UTF-8
303 Módulos Python para acessar os recursos do Subversion.
304
305 %package -n perl-subversion
306 Summary:        Subversion Perl bindings
307 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
308 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
309 Group:          Development/Languages/Perl
310 Requires:       %{name}-libs = %{version}-%{release}
311 Obsoletes:      subversion-perl
312
313 %description -n perl-subversion
314 Subversion Perl bindings.
315
316 %description -n perl-subversion -l pl.UTF-8
317 Dowiązania do Subversion dla Perla.
318
319 %description -n perl-subversion -l pt_BR.UTF-8
320 Módulos Perl para acessar os recursos do Subversion.
321
322 %package -n ruby-subversion
323 Summary:        Subversion Ruby bindings
324 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
325 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
326 Group:          Development/Languages
327 Requires:       %{name}-libs = %{version}-%{release}
328 Obsoletes:      subversion-ruby
329
330 %description -n ruby-subversion
331 Subversion Ruby bindings.
332
333 %description -n ruby-subversion -l pl.UTF-8
334 Dowiązania do Subversion dla języka Ruby.
335
336 %description -n ruby-subversion -l pt_BR.UTF-8
337 Módulos Ruby para acessar os recursos do Subversion.
338
339 %package -n apache-mod_dav_svn
340 Summary:        Apache module: Subversion Server
341 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
342 Group:          Networking/Daemons
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       apache(modules-api) = %apache_modules_api
345 Requires:       apache-mod_dav
346
347 %description -n apache-mod_dav_svn
348 Apache module: Subversion Server.
349
350 %description -n apache-mod_dav_svn -l pl.UTF-8
351 Moduł apache: Serwer Subversion.
352
353 %package -n apache-mod_authz_svn
354 Summary:        Apache module: Subversion Server - path-based authorization
355 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
356 Group:          Networking/Daemons
357 Requires:       apache(modules-api) = %apache_modules_api
358 Requires:       apache-mod_dav_svn = %{version}-%{release}
359
360 %description -n apache-mod_authz_svn
361 Apache module: Subversion Server - path-based authorization.
362
363 %description -n apache-mod_authz_svn -l pl.UTF-8
364 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
365
366 %package -n gnome-keyring-subversion
367 Summary:        Subversion module for Gnome Keyring
368 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
369 Group:          X11/Applications
370
371 %description -n gnome-keyring-subversion
372 Subversion module for Gnome Keyring.
373
374 %description -n gnome-keyring-subversion -l pl.UTF-8
375 Moduł subversion dla zarządcy kluczy Gnome.
376
377 %package -n kde4-kwallet-subversion
378 Summary:        Subversion module for KDE Wallet
379 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
380 Group:          X11/Applications
381
382 %description -n kde4-kwallet-subversion
383 Subversion module for KDE Wallet.
384
385 %description -n kde4-kwallet-subversion -l pl.UTF-8
386 Moduł subversion dla Portfela KDE.
387
388 %prep
389 %setup -q
390 rm -rf apr apr-util neon
391 %patch0 -p0
392 %patch1 -p1
393 %patch2 -p0
394
395 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
396
397 # serf.m4 macro is broken and ignores --without serf
398 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
399
400 %build
401 rm subversion/bindings/swig/proxy/*.swg
402 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
403 cp -f /usr/share/automake/config.sub ac-helpers
404 chmod +x ./autogen.sh && ./autogen.sh
405
406 %configure \
407         --with-editor=vi \
408         --with-zlib=%{_libdir} \
409 %if %{with net_client_only}
410         --without-apache \
411         --without-swig \
412         --without-apxs \
413         --without-berkeley-db \
414 %else
415         --disable-runtime-module-search \
416         --disable-mod-activation \
417 %if %{with apache}
418         --with-apxs=%{_sbindir}/apxs \
419 %else
420         --without-apache \
421         --without-apxs \
422         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
423 %endif
424 %if !%{with python} && !%{with perl} && !%{with ruby}
425         --without-swig \
426 %endif
427         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
428         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
429 %endif
430         --with-jdk="%{java_home}" \
431 %if %{with neon}
432         --without-serf \
433         --with-neon=%{_prefix} \
434         --disable-neon-version-check \
435 %else
436         --with-serf=%{_prefix} \
437         --without-neon \
438 %endif
439         --with-apr=%{_bindir}/apr-1-config \
440         --with-apr-util=%{_bindir}/apu-1-config \
441         --with-kwallet \
442         --with-gnome-keyring
443
444 %{__make} -j1
445
446 %if !%{with net_client_only}
447 # python
448 %if %{with python}
449 # ctypes bindings
450 %{__make} ctypes-python
451 # swig bindings
452 %{__make} swig-py \
453         swig_pydir=%{py_sitedir}/libsvn \
454         swig_pydir_extra=%{py_sitedir}/svn
455 %endif
456 # perl
457 %if %{with perl}
458 %{__make} -j1 swig-pl-lib
459 odir=$(pwd)
460 cd subversion/bindings/swig/perl/native
461 %{__perl} Makefile.PL INSTALLDIRS=vendor
462 %{__make} -j1
463 cd $odir
464 %endif
465 %if %{with javahl}
466 %{__make} -j1 javahl \
467         javahl_javadir="%{_javadir}"
468 %endif
469 # ruby
470 %if %{with ruby}
471 %{__make} swig-rb
472 %endif
473 %endif
474
475 %if %{with tests}
476 %{__make} check
477 %if %{with python}
478 %{__make} check-ctypes-python
479 %{__make} check-swig-py
480 %endif
481 %if %{with perl}
482 %{__make} check-swig-pl
483 %endif
484 %if %{with ruby}
485 %{__make} check-swig-rb
486 %endif
487 %endif
488
489 %install
490 rm -rf $RPM_BUILD_ROOT
491 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
492         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
493         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
494         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
495
496 %{__make} install -j1 \
497 %if %{with javahl}
498         install-javahl \
499         javahl_javadir="%{_javadir}" \
500 %endif
501 %if !%{with net_client_only}
502 %if %{with python}
503         install-swig-py \
504         install-ctypes-python \
505 %endif
506 %if %{with ruby}
507         install-swig-rb install-swig-rb-doc \
508 %endif
509 %endif
510         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
511         DESTDIR=$RPM_BUILD_ROOT \
512         swig_pydir=%{py_sitedir}/libsvn \
513         swig_pydir_extra=%{py_sitedir}/svn
514
515 %if !%{with net_client_only} && %{with perl}
516 %{__make} install-swig-pl-lib \
517         DESTDIR=$RPM_BUILD_ROOT
518 %{__make} -C subversion/bindings/swig/perl/native install \
519         DESTDIR=$RPM_BUILD_ROOT \
520         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
521         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
522 %endif
523
524 %if %{with apache}
525 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
526 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
527 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
528 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
529 %endif
530
531 %if !%{with net_client_only}
532 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
533 %if %{with python}
534 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
535 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
536 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
537 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
538 %endif
539 %endif
540
541 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
542 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
543
544 %find_lang %{name}
545
546 rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
547 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}}
548 rm $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
549
550 %clean
551 rm -rf $RPM_BUILD_ROOT
552
553 %pre svnserve
554 %groupadd -g 86 svn
555 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
556
557 %post   libs -p /sbin/ldconfig
558 %postun libs -p /sbin/ldconfig
559
560 %post   devel -p /sbin/postshell
561 -/usr/sbin/fix-info-dir -c %{_infodir}
562
563 %postun devel -p /sbin/postshell
564 -/usr/sbin/fix-info-dir -c %{_infodir}
565
566 %post   -n perl-subversion -p /sbin/ldconfig
567 %postun -n perl-subversion -p /sbin/ldconfig
568
569 %post   -n python-subversion -p /sbin/ldconfig
570 %postun -n python-subversion -p /sbin/ldconfig
571
572 %post svnserve
573 /sbin/chkconfig --add svnserve
574 %service svnserve restart "svnserve daemon"
575
576 %preun svnserve
577 if [ "$1" = "0" ]; then
578         %service svnserve stop
579         /sbin/chkconfig --del svnserve
580 fi
581
582 %postun svnserve
583 if [ "$1" = "0" ]; then
584         %userremove svn
585         %groupremove svn
586 fi
587
588 %post -n apache-mod_dav_svn
589 %service -q httpd restart
590
591 %preun -n apache-mod_dav_svn
592 if [ "$1" = "0" ]; then
593         %service -q httpd restart
594 fi
595
596 %files
597 %defattr(644,root,root,755)
598 %doc BUGS CHANGES COPYING INSTALL README
599 %doc doc/*/*.html
600 %doc tools/hook-scripts/*.{pl,py,example}
601 %doc tools/hook-scripts/mailer/*.{py,example}
602 %doc tools/xslt/*
603 %attr(755,root,root) %{_bindir}/svn
604 %attr(755,root,root) %{_bindir}/svnadmin
605 %attr(755,root,root) %{_bindir}/svndumpfilter
606 %attr(755,root,root) %{_bindir}/svnlook
607 %attr(755,root,root) %{_bindir}/svnsync
608 %attr(755,root,root) %{_bindir}/svnversion
609 %{_mandir}/man1/svn.1*
610 %{_mandir}/man1/svnadmin.1*
611 %{_mandir}/man1/svndumpfilter.1*
612 %{_mandir}/man1/svnlook.1*
613 %{_mandir}/man1/svnsync.1*
614 %{_mandir}/man1/svnversion.1*
615
616 %files libs -f %{name}.lang
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
619 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
620 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
621 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
622 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
623 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
624 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
625 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
626 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
627 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
628 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
629 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
630 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
631 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
632 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
633 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
634 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
635 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
636 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
637 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
638 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
640 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
642 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
644 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
646
647 %files devel
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
650 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
651 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
652 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
653 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
654 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
655 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
656 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
657 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
658 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
659 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
660 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
661 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
662 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
663 %{_libdir}/libsvn_client-1.la
664 %{_libdir}/libsvn_delta-1.la
665 %{_libdir}/libsvn_diff-1.la
666 %{_libdir}/libsvn_fs-1.la
667 %{_libdir}/libsvn_fs_base-1.la
668 %{_libdir}/libsvn_fs_fs-1.la
669 %{_libdir}/libsvn_fs_util-1.la
670 %{_libdir}/libsvn_ra-1.la
671 %{_libdir}/libsvn_ra_local-1.la
672 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
673 %{_libdir}/libsvn_ra_svn-1.la
674 %{_libdir}/libsvn_repos-1.la
675 %{_libdir}/libsvn_subr-1.la
676 %{_libdir}/libsvn_wc-1.la
677 %{_includedir}/%{name}-1
678 %{_examplesdir}/%{name}-%{version}
679
680 %files static
681 %defattr(644,root,root,755)
682 %{_libdir}/libsvn_client-1.a
683 %{_libdir}/libsvn_delta-1.a
684 %{_libdir}/libsvn_diff-1.a
685 %{_libdir}/libsvn_fs-1.a
686 %{_libdir}/libsvn_fs_base-1.a
687 %{_libdir}/libsvn_fs_fs-1.a
688 %{_libdir}/libsvn_fs_util-1.a
689 %{_libdir}/libsvn_ra-1.a
690 %{_libdir}/libsvn_ra_local-1.a
691 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
692 %{_libdir}/libsvn_ra_svn-1.a
693 %{_libdir}/libsvn_repos-1.a
694 %{_libdir}/libsvn_subr-1.a
695 %{_libdir}/libsvn_wc-1.a
696
697 %files -n gnome-keyring-subversion
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
700 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
701
702 %files -n kde4-kwallet-subversion
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
705 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
706
707 %if !%{with net_client_only}
708 %files svnserve
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_bindir}/svnserve
711 %{_mandir}/man5/svnserve.conf.5*
712 %{_mandir}/man8/svnserve.8*
713 %dir %attr(750,svn,svn) /home/services/subversion
714 %dir %attr(750,svn,svn) /home/services/subversion/repos
715 %if %{with apache}
716 %attr(754,root,root) /etc/rc.d/init.d/svnserve
717 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
718 %endif
719
720 %files tools
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_bindir}/svn-hot-backup
723
724 %files -n bash-completion-subversion
725 %defattr(644,root,root,755)
726 /etc/bash_completion.d/%{name}
727
728 %if %{with javahl}
729 %files -n java-subversion
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
732 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
733 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
734 %{_javadir}/svn-javahl.jar
735 %endif
736
737 %if %{with python}
738 %files -n python-subversion
739 %defattr(644,root,root,755)
740 %doc tools/backup/*.py tools/examples/*.py
741 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
742 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
743 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
744 %dir %{py_sitedir}/libsvn
745 %{py_sitedir}/libsvn/*.py[co]
746 %dir %{py_sitedir}/svn
747 %{py_sitedir}/svn/*.py[co]
748 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
749 %{_examplesdir}/python-%{name}-%{version}
750
751 %files -n python-csvn
752 %defattr(644,root,root,755)
753 %doc subversion/bindings/ctypes-python/{README,TODO}
754 %doc subversion/bindings/ctypes-python/examples/*.py
755 %dir %{py_sitescriptdir}/csvn
756 %{py_sitescriptdir}/csvn/*.py[co]
757 %dir %{py_sitescriptdir}/csvn/core
758 %{py_sitescriptdir}/csvn/core/*.py[co]
759 %dir %{py_sitescriptdir}/csvn/ext
760 %{py_sitescriptdir}/csvn/ext/*.py[co]
761 %{py_sitescriptdir}/*.egg-info
762 %endif
763
764 %if %{with perl}
765 %files -n perl-subversion
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
768 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
769 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
770 %{perl_vendorarch}/SVN
771 %dir %{perl_vendorarch}/auto/SVN
772 %dir %{perl_vendorarch}/auto/SVN/*
773 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
774 %{perl_vendorarch}/auto/SVN/*/*.bs
775 %{_mandir}/man3/*.3pm*
776 %endif
777
778 %if %{with ruby}
779 %files -n ruby-subversion
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
782 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
783 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
784 %dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
785 %dir %{_libdir}/ruby/site_ruby/*/svn
786 %{_libdir}/ruby/site_ruby/*/svn/*.rb
787 %dir %{_libdir}/ruby/site_ruby/*/*-*
788 %dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
789 %attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
790 %{_datadir}/ri/*.*/system/OptionParser
791 %{_datadir}/ri/*.*/system/Svn
792 %{_datadir}/ri/*.*/system/Time
793 %{_datadir}/ri/*.*/system/Uconv
794 %{_datadir}/ri/*.*/system/*.rid
795 %{_datadir}/ri/*.*/system/Kernel/*
796 %endif
797
798 %if %{with apache}
799 %files -n apache-mod_dav_svn
800 %defattr(644,root,root,755)
801 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
802 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
803
804 %files -n apache-mod_authz_svn
805 %defattr(644,root,root,755)
806 %doc subversion/mod_authz_svn/INSTALL
807 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
808 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
809 %endif
810
811 %endif # net_client_only
This page took 0.105988 seconds and 4 git commands to generate.