]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- up to 1.6.3
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - fix java build with java-gcj-compat and s/java-sun/jdk/
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 # - finish ruby
6 #
7 # Conditional build:
8 %bcond_with     net_client_only         # build only net client
9 %bcond_without  neon                    # use serf instead of neon
10 %bcond_without  python                  # build without python bindings (broken)
11 %bcond_without  perl                    # build without perl bindings
12 %bcond_without  ruby                    # build without ruby bindings
13 %bcond_without  apache                  # build without apache support (webdav, etc)
14 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
15 %bcond_without  tests                   # don't perform "make check"
16 %bcond_without  kwallet                 # build without kde4 wallet support
17 #
18 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
19 %undefine       with_javahl
20 %endif
21 #
22 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
23 %define apxs    /usr/sbin/apxs
24 %define pdir    SVN
25 %define pnam    _Core
26 #
27 %if %{with neon}
28 %define webdavlib       neon
29 %else
30 %define webdavlib       serf
31 %endif
32 #
33 Summary:        A Concurrent Versioning system similar to but better than CVS
34 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
35 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
36 Name:           subversion
37 Version:        1.6.3
38 Release:        1
39 License:        Apache/BSD-like
40 Group:          Development/Version Control
41 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  8bf7637ac99368db0890e3f085fa690d
43 Source1:        %{name}-dav_svn.conf
44 Source2:        %{name}-authz_svn.conf
45 Source3:        %{name}-svnserve.init
46 Source4:        %{name}-svnserve.sysconfig
47 # current subversion tarball has correct *.swg files
48 # but after regeneration these are broken again, so
49 # we still need this script
50 Source5:        %{name}-convert-typemaps-to-ifdef.py
51 Patch0:         %{name}-home_etc.patch
52 Patch1:         %{name}-DESTDIR.patch
53 Patch2:         %{name}-ruby-datadir-path.patch
54 URL:            http://subversion.tigris.org/
55 %if %{with net_client_only}
56 %global apache_modules_api 0
57 %else
58 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
59 BuildRequires:  automake
60 BuildRequires:  db-devel >= 4.1.25
61 BuildRequires:  rpmbuild(macros) >= 1.268
62 %if %{with perl}
63 BuildRequires:  perl-devel >= 1:5.8.0
64 BuildRequires:  rpm-perlprov >= 4.1-13
65 BuildRequires:  swig-perl >= 1.3.24
66 %endif
67 %if %{with python}
68 BuildRequires:  python-ctypesgen
69 BuildRequires:  python-devel >= 2.2
70 BuildRequires:  swig-python >= 1.3.24
71 %endif
72 %if %{with ruby}
73 BuildRequires:  ruby-devel
74 BuildRequires:  swig-ruby >= 1.3.24
75 %endif
76 %{?with_javahl:BuildRequires:   java-sun}
77 BuildRequires:  cyrus-sasl-devel
78 %endif
79 BuildRequires:  apr-devel >= 1:1.0.0
80 BuildRequires:  apr-util-devel >= 1:1.2.8-3
81 BuildRequires:  autoconf >= 2.59
82 BuildRequires:  bison
83 BuildRequires:  expat-devel
84 BuildRequires:  gettext-devel
85 BuildRequires:  gnome-keyring-devel
86 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
87 BuildRequires:  libtool >= 1.4-9
88 BuildRequires:  sed >= 4.0
89 BuildRequires:  sqlite3-devel >= 3.6.11
90 BuildRequires:  texinfo
91 BuildRequires:  which
92 %if %{with neon}
93 BuildRequires:  neon-devel >= 0.26.0
94 %else
95 BuildRequires:  serf-devel
96 %endif
97 BuildRequires:  python >= 2.2
98 BuildRequires:  python-modules >= 2.2
99 Requires:       %{name}-libs = %{version}-%{release}
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _libexecdir             %{_libdir}/svn
103 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
104 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
105
106 %description
107 The goal of the Subversion project is to build a version control
108 system that is a compelling replacement for CVS in the open source
109 community.
110
111 Our goals are:
112 - All current CVS features.
113 - Directories, renames, and file meta-data are versioned.
114 - Symbolic links, etc, are supported
115 - Commits are truly atomic.
116 - Branching and tagging are cheap (constant time) operations
117 - Repeated merges are handled gracefully
118 - Support for plug-in client side diff programs
119 - Natively client/server
120 - Client/server protocol sends diffs in both directions
121 - Costs are proportional to change size, not project size
122 - Internationalization
123 - Progressive multi-lingual support
124
125 %description -l pl.UTF-8
126 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
127 zamiennika dla CVS.
128
129 Cele projektu to:
130 - Wszystkie aktualne możliwości CVS.
131 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
132 - Obsługa dowiązań symbolicznych itp.
133 - Commity są w pełni atomowe.
134 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
135 - Dobra obsługa powtarzanego łączenia (merge).
136 - Obsługa wtyczek diff po stronie klienta.
137 - Natywny klient/serwer.
138 - Klient/Serwer przesyłają diffy w obu kierunkach.
139 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
140 - Internacjonalizacja.
141 - Postępujące wsparcie dla wielu języków.
142
143 %description -l pt_BR.UTF-8
144 O objetivo do projeto Subversion é construir um sistema de controle de
145 versões que seja um substituto para o CVS (Concurrent Versioning
146 System) na comunidade opensource, fornecendo grandes melhorias.
147
148 %package libs
149 Summary:        Subversion libraries and modules
150 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
151 Group:          Libraries
152 %{?with_neon:Requires:  neon >= 0.26.0}
153 Obsoletes:      libsubversion0
154
155 %description libs
156 Subversion libraries and modules.
157
158 %description libs -l pl.UTF-8
159 Biblioteka subversion oraz ładowalne moduły.
160
161 %package devel
162 Summary:        Header files and develpment documentation for subversion
163 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
164 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
165 Group:          Development/Libraries
166 Requires:       %{name}-libs = %{version}-%{release}
167 Requires:       apr-util-devel >= 1:1.0.0
168 %{?with_neon:Requires:  neon-devel >= 0.26.0}
169 Obsoletes:      libsubversion0-devel
170
171 %description devel
172 Header files and develpment documentation for subversion.
173
174 %description devel -l pl.UTF-8
175 Pliki nagłówkowe i dokumetacja do subversion.
176
177 %description devel -l pt_BR.UTF-8
178 Este pacote provê os arquivos necessários para desenvolvedores
179 interagirem com o Subversion.
180
181 %package static
182 Summary:        Static subversion library
183 Summary(pl.UTF-8):      Biblioteka statyczna subversion
184 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
185 Group:          Development/Libraries
186 Requires:       %{name}-devel = %{version}
187 Obsoletes:      libsubversion0-static-devel
188
189 %description static
190 Static subversion library.
191
192 %description static -l pl.UTF-8
193 Biblioteka statyczna subversion.
194
195 %description static -l pt_BR.UTF-8
196 Este pacote provê um cliente estático do subversion.
197
198 %package svnserve
199 Summary:        Subversion svnserve
200 Summary(pl.UTF-8):      Subversion svnserve
201 Group:          Networking/Daemons
202 Requires(post,preun):   /sbin/chkconfig
203 Requires(postun):       /usr/sbin/groupdel
204 Requires(postun):       /usr/sbin/userdel
205 Requires(pre):  /bin/id
206 Requires(pre):  /usr/bin/getgid
207 Requires(pre):  /usr/lib/rpm/user_group.sh
208 Requires(pre):  /usr/sbin/groupadd
209 Requires(pre):  /usr/sbin/useradd
210 Requires(pre):  /usr/sbin/usermod
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       rc-scripts
213 Provides:       group(svn)
214 Provides:       user(svn)
215
216 %description svnserve
217 Subversion svnserve server.
218
219 %description svnserve -l pl.UTF-8
220 Serwer subversion svnserve.
221
222 %package tools
223 Summary:        Subversion tools and scripts
224 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
225 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
226 Group:          Applications
227 %pyrequires_eq  python
228 Requires:       %{name} = %{version}-%{release}
229 Requires:       python-subversion = %{version}
230
231 %description tools
232 Subversion tools and scripts.
233
234 %description tools -l pl.UTF-8
235 Narzędzia oraz skrypty dla subversion.
236
237 %package -n bash-completion-subversion
238 Summary:        bash completion for subversion
239 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
240 Group:          Applications/Shells
241 Requires:       %{name} = %{version}-%{release}
242 Requires:       bash-completion
243 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
244
245 %description -n bash-completion-subversion
246 Bash completion for subversion.
247
248 %description -n bash-completion-subversion -l pl.UTF-8
249 Dopełnienia basha dla subversion.
250
251 %package -n java-subversion
252 Summary:        Subversion Java bindings
253 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
254 Group:          Development/Languages/Java
255 Requires:       %{name}-libs = %{version}-%{release}
256
257 %description -n java-subversion
258 This is a set of Java classes which provide the functionality of
259 subversion-libs, the Subversion libraries. It is useful if you want
260 to, for example, write a Java class that manipulates a Subversion
261 repository or working copy. See the 'subversion' package for more
262 information.
263
264 %description -n java-subversion -l pl.UTF-8
265 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
266 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
267 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
268 roboczą. Więcej informacji w pakiecie subversion.
269
270 %package -n python-subversion
271 Summary:        Subversion Python bindings
272 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
273 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
274 Group:          Development/Languages/Python
275 %pyrequires_eq  python
276 Requires:       %{name}-libs = %{version}-%{release}
277 Obsoletes:      subversion-python
278
279 %description -n python-subversion
280 Subversion Python bindings.
281
282 %description -n python-subversion -l pl.UTF-8
283 Dowiązania do Subversion dla Pythona.
284
285 %description -n python-subversion -l pt_BR.UTF-8
286 Módulos Python para acessar os recursos do Subversion.
287
288 %package -n python-csvn
289 Summary:        CTypes Subversion Python bindings
290 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
291 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
292 Group:          Development/Languages/Python
293 %pyrequires_eq  python
294 Requires:       %{name}-libs = %{version}-%{release}
295
296 %description -n python-csvn
297 Subversion CTypes Python bindings.
298
299 %description -n python-csvn -l pl.UTF-8
300 Dowiązania do Subversion dla Pythona używające CTypes.
301
302 %description -n python-csvn -l pt_BR.UTF-8
303 Módulos Python para acessar os recursos do Subversion.
304
305 %package -n perl-subversion
306 Summary:        Subversion Perl bindings
307 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
308 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
309 Group:          Development/Languages/Perl
310 Requires:       %{name}-libs = %{version}-%{release}
311 Obsoletes:      subversion-perl
312
313 %description -n perl-subversion
314 Subversion Perl bindings.
315
316 %description -n perl-subversion -l pl.UTF-8
317 Dowiązania do Subversion dla Perla.
318
319 %description -n perl-subversion -l pt_BR.UTF-8
320 Módulos Perl para acessar os recursos do Subversion.
321
322 %package -n ruby-subversion
323 Summary:        Subversion Ruby bindings
324 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
325 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
326 Group:          Development/Languages
327 Requires:       %{name}-libs = %{version}-%{release}
328 Obsoletes:      subversion-ruby
329
330 %description -n ruby-subversion
331 Subversion Ruby bindings.
332
333 %description -n ruby-subversion -l pl.UTF-8
334 Dowiązania do Subversion dla języka Ruby.
335
336 %description -n ruby-subversion -l pt_BR.UTF-8
337 Módulos Ruby para acessar os recursos do Subversion.
338
339 %package -n apache-mod_dav_svn
340 Summary:        Apache module: Subversion Server
341 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
342 Group:          Networking/Daemons
343 Requires:       %{name} = %{version}-%{release}
344 Requires:       apache(modules-api) = %apache_modules_api
345 Requires:       apache-mod_dav
346
347 %description -n apache-mod_dav_svn
348 Apache module: Subversion Server.
349
350 %description -n apache-mod_dav_svn -l pl.UTF-8
351 Moduł apache: Serwer Subversion.
352
353 %package -n apache-mod_authz_svn
354 Summary:        Apache module: Subversion Server - path-based authorization
355 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
356 Group:          Networking/Daemons
357 Requires:       apache(modules-api) = %apache_modules_api
358 Requires:       apache-mod_dav_svn = %{version}-%{release}
359
360 %description -n apache-mod_authz_svn
361 Apache module: Subversion Server - path-based authorization.
362
363 %description -n apache-mod_authz_svn -l pl.UTF-8
364 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
365
366 %package -n gnome-keyring-subversion
367 Summary:        Subversion module for Gnome Keyring
368 Summary(pl.UTF-8):      Moduł subversion dla zarządcy kluczy Gnome
369 Group:          X11/Applications
370
371 %description -n gnome-keyring-subversion
372 Subversion module for Gnome Keyring.
373
374 %description -n gnome-keyring-subversion -l pl.UTF-8
375 Moduł subversion dla zarządcy kluczy Gnome.
376
377 %package -n kde4-kwallet-subversion
378 Summary:        Subversion module for KDE Wallet
379 Summary(pl.UTF-8):      Moduł subversion dla Portfela KDE
380 Group:          X11/Applications
381
382 %description -n kde4-kwallet-subversion
383 Subversion module for KDE Wallet.
384
385 %description -n kde4-kwallet-subversion -l pl.UTF-8
386 Moduł subversion dla Portfela KDE.
387
388 %prep
389 %setup -q
390 rm -rf apr apr-util neon
391 %patch0 -p0
392 %patch1 -p1
393 %patch2 -p0
394
395 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
396
397 # serf.m4 macro is broken and ignores --without serf
398 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
399
400 %build
401 rm subversion/bindings/swig/proxy/*.swg
402 cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
403 cp -f /usr/share/automake/config.sub ac-helpers
404 chmod +x ./autogen.sh && ./autogen.sh
405
406 %configure \
407         --with-editor=vi \
408         --with-zlib=%{_libdir} \
409 %if %{with net_client_only}
410         --without-apache \
411         --without-swig \
412         --without-apxs \
413         --without-berkeley-db \
414 %else
415         --disable-runtime-module-search \
416         --disable-mod-activation \
417 %if %{with apache}
418         --with-apxs=%{_sbindir}/apxs \
419 %else
420         --without-apache \
421         --without-apxs \
422         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
423 %endif
424 %if !%{with python} && !%{with perl} && !%{with ruby}
425         --without-swig \
426 %endif
427         %{?with_python:--with-ctypesgen=%{_bindir}/ctypesgen.py} \
428         --%{?with_javahl:en}%{!?with_javahl:dis}able-javahl \
429 %endif
430         --with-jdk="%{java_home}" \
431 %if %{with neon}
432         --without-serf \
433         --with-neon=%{_prefix} \
434         --disable-neon-version-check \
435 %else
436         --with-serf=%{_prefix} \
437         --without-neon \
438 %endif
439         --with-apr=%{_bindir}/apr-1-config \
440         --with-apr-util=%{_bindir}/apu-1-config \
441 %if %{with kwallet}
442         --with-kwallet \
443 %endif
444         --with-gnome-keyring
445
446 %{__make} -j1
447
448 %if !%{with net_client_only}
449 # python
450 %if %{with python}
451 # ctypes bindings
452 %{__make} ctypes-python
453 # swig bindings
454 %{__make} swig-py \
455         swig_pydir=%{py_sitedir}/libsvn \
456         swig_pydir_extra=%{py_sitedir}/svn
457 %endif
458 # perl
459 %if %{with perl}
460 %{__make} -j1 swig-pl-lib
461 odir=$(pwd)
462 cd subversion/bindings/swig/perl/native
463 %{__perl} Makefile.PL INSTALLDIRS=vendor
464 %{__make} -j1
465 cd $odir
466 %endif
467 %if %{with javahl}
468 %{__make} -j1 javahl \
469         javahl_javadir="%{_javadir}"
470 %endif
471 # ruby
472 %if %{with ruby}
473 %{__make} swig-rb
474 %endif
475 %endif
476
477 %if %{with tests}
478 %{__make} check
479 %if %{with python}
480 %{__make} check-ctypes-python
481 %{__make} check-swig-py
482 %endif
483 %if %{with perl}
484 %{__make} check-swig-pl
485 %endif
486 %if %{with ruby}
487 %{__make} check-swig-rb
488 %endif
489 %endif
490
491 %install
492 rm -rf $RPM_BUILD_ROOT
493 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
494         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
495         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
496         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
497
498 %{__make} install -j1 \
499 %if %{with javahl}
500         install-javahl \
501         javahl_javadir="%{_javadir}" \
502 %endif
503 %if !%{with net_client_only}
504 %if %{with python}
505         install-swig-py \
506         install-ctypes-python \
507 %endif
508 %if %{with ruby}
509         install-swig-rb install-swig-rb-doc \
510 %endif
511 %endif
512         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
513         DESTDIR=$RPM_BUILD_ROOT \
514         swig_pydir=%{py_sitedir}/libsvn \
515         swig_pydir_extra=%{py_sitedir}/svn
516
517 %if !%{with net_client_only} && %{with perl}
518 %{__make} install-swig-pl-lib \
519         DESTDIR=$RPM_BUILD_ROOT
520 %{__make} -C subversion/bindings/swig/perl/native install \
521         DESTDIR=$RPM_BUILD_ROOT \
522         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
523         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
524 %endif
525
526 %if %{with apache}
527 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
528 install %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
529 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
530 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
531 %endif
532
533 %if !%{with net_client_only}
534 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
535 %if %{with python}
536 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
537 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
538 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
539 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
540 %endif
541 %endif
542
543 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
544 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
545
546 %find_lang %{name}
547
548 %{?with_javahl:rm $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}}
549 rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
550 rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
551
552 %clean
553 rm -rf $RPM_BUILD_ROOT
554
555 %pre svnserve
556 %groupadd -g 86 svn
557 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
558
559 %post   libs -p /sbin/ldconfig
560 %postun libs -p /sbin/ldconfig
561
562 %post   devel -p /sbin/postshell
563 -/usr/sbin/fix-info-dir -c %{_infodir}
564
565 %postun devel -p /sbin/postshell
566 -/usr/sbin/fix-info-dir -c %{_infodir}
567
568 %post   -n perl-subversion -p /sbin/ldconfig
569 %postun -n perl-subversion -p /sbin/ldconfig
570
571 %post   -n python-subversion -p /sbin/ldconfig
572 %postun -n python-subversion -p /sbin/ldconfig
573
574 %post svnserve
575 /sbin/chkconfig --add svnserve
576 %service svnserve restart "svnserve daemon"
577
578 %preun svnserve
579 if [ "$1" = "0" ]; then
580         %service svnserve stop
581         /sbin/chkconfig --del svnserve
582 fi
583
584 %postun svnserve
585 if [ "$1" = "0" ]; then
586         %userremove svn
587         %groupremove svn
588 fi
589
590 %post -n apache-mod_dav_svn
591 %service -q httpd restart
592
593 %preun -n apache-mod_dav_svn
594 if [ "$1" = "0" ]; then
595         %service -q httpd restart
596 fi
597
598 %files
599 %defattr(644,root,root,755)
600 %doc BUGS CHANGES COPYING INSTALL README
601 %doc doc/*/*.html
602 %doc tools/hook-scripts/*.{pl,py,example}
603 %doc tools/hook-scripts/mailer/*.{py,example}
604 %doc tools/xslt/*
605 %attr(755,root,root) %{_bindir}/svn
606 %attr(755,root,root) %{_bindir}/svnadmin
607 %attr(755,root,root) %{_bindir}/svndumpfilter
608 %attr(755,root,root) %{_bindir}/svnlook
609 %attr(755,root,root) %{_bindir}/svnsync
610 %attr(755,root,root) %{_bindir}/svnversion
611 %{_mandir}/man1/svn.1*
612 %{_mandir}/man1/svnadmin.1*
613 %{_mandir}/man1/svndumpfilter.1*
614 %{_mandir}/man1/svnlook.1*
615 %{_mandir}/man1/svnsync.1*
616 %{_mandir}/man1/svnversion.1*
617
618 %files libs -f %{name}.lang
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
621 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
622 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
623 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
624 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
625 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
626 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
627 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
628 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
629 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
630 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
631 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
632 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
633 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
634 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
635 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
636 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
637 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
638 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
640 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
642 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
644 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
646 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
648
649 %files devel
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
652 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
653 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
654 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
655 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
656 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
657 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
658 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
659 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
660 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
661 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
662 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
663 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
664 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
665 %{_libdir}/libsvn_client-1.la
666 %{_libdir}/libsvn_delta-1.la
667 %{_libdir}/libsvn_diff-1.la
668 %{_libdir}/libsvn_fs-1.la
669 %{_libdir}/libsvn_fs_base-1.la
670 %{_libdir}/libsvn_fs_fs-1.la
671 %{_libdir}/libsvn_fs_util-1.la
672 %{_libdir}/libsvn_ra-1.la
673 %{_libdir}/libsvn_ra_local-1.la
674 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
675 %{_libdir}/libsvn_ra_svn-1.la
676 %{_libdir}/libsvn_repos-1.la
677 %{_libdir}/libsvn_subr-1.la
678 %{_libdir}/libsvn_wc-1.la
679 %{_includedir}/%{name}-1
680 %{_examplesdir}/%{name}-%{version}
681
682 %files static
683 %defattr(644,root,root,755)
684 %{_libdir}/libsvn_client-1.a
685 %{_libdir}/libsvn_delta-1.a
686 %{_libdir}/libsvn_diff-1.a
687 %{_libdir}/libsvn_fs-1.a
688 %{_libdir}/libsvn_fs_base-1.a
689 %{_libdir}/libsvn_fs_fs-1.a
690 %{_libdir}/libsvn_fs_util-1.a
691 %{_libdir}/libsvn_ra-1.a
692 %{_libdir}/libsvn_ra_local-1.a
693 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
694 %{_libdir}/libsvn_ra_svn-1.a
695 %{_libdir}/libsvn_repos-1.a
696 %{_libdir}/libsvn_subr-1.a
697 %{_libdir}/libsvn_wc-1.a
698
699 %files -n gnome-keyring-subversion
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
702 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
703
704 %if %{with kwallet}
705 %files -n kde4-kwallet-subversion
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
708 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
709 %endif
710
711 %if !%{with net_client_only}
712 %files svnserve
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_bindir}/svnserve
715 %{_mandir}/man5/svnserve.conf.5*
716 %{_mandir}/man8/svnserve.8*
717 %dir %attr(750,svn,svn) /home/services/subversion
718 %dir %attr(750,svn,svn) /home/services/subversion/repos
719 %if %{with apache}
720 %attr(754,root,root) /etc/rc.d/init.d/svnserve
721 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
722 %endif
723
724 %files tools
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_bindir}/svn-hot-backup
727
728 %files -n bash-completion-subversion
729 %defattr(644,root,root,755)
730 /etc/bash_completion.d/%{name}
731
732 %if %{with javahl}
733 %files -n java-subversion
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
736 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
737 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
738 %{_javadir}/svn-javahl.jar
739 %endif
740
741 %if %{with python}
742 %files -n python-subversion
743 %defattr(644,root,root,755)
744 %doc tools/backup/*.py tools/examples/*.py
745 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
746 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
747 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
748 %dir %{py_sitedir}/libsvn
749 %{py_sitedir}/libsvn/*.py[co]
750 %dir %{py_sitedir}/svn
751 %{py_sitedir}/svn/*.py[co]
752 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
753 %{_examplesdir}/python-%{name}-%{version}
754
755 %files -n python-csvn
756 %defattr(644,root,root,755)
757 %doc subversion/bindings/ctypes-python/{README,TODO}
758 %doc subversion/bindings/ctypes-python/examples/*.py
759 %dir %{py_sitescriptdir}/csvn
760 %{py_sitescriptdir}/csvn/*.py[co]
761 %dir %{py_sitescriptdir}/csvn/core
762 %{py_sitescriptdir}/csvn/core/*.py[co]
763 %dir %{py_sitescriptdir}/csvn/ext
764 %{py_sitescriptdir}/csvn/ext/*.py[co]
765 %{py_sitescriptdir}/*.egg-info
766 %endif
767
768 %if %{with perl}
769 %files -n perl-subversion
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
772 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
773 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
774 %{perl_vendorarch}/SVN
775 %dir %{perl_vendorarch}/auto/SVN
776 %dir %{perl_vendorarch}/auto/SVN/*
777 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
778 %{perl_vendorarch}/auto/SVN/*/*.bs
779 %{_mandir}/man3/*.3pm*
780 %endif
781
782 %if %{with ruby}
783 %files -n ruby-subversion
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
786 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
787 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
788 %dir %{_libdir}/ruby/site_ruby/[0-9].[0-9]
789 %dir %{_libdir}/ruby/site_ruby/*/svn
790 %{_libdir}/ruby/site_ruby/*/svn/*.rb
791 %dir %{_libdir}/ruby/site_ruby/*/*-*
792 %dir %{_libdir}/ruby/site_ruby/*/*-*/svn
793 %dir %{_libdir}/ruby/site_ruby/*/*-*/svn/ext
794 %attr(755,root,root) %{_libdir}/ruby/site_ruby/*/*-*/svn/ext/*.so
795 %{_datadir}/ri/*.*/system/OptionParser
796 %{_datadir}/ri/*.*/system/Svn
797 %{_datadir}/ri/*.*/system/Time
798 %{_datadir}/ri/*.*/system/Uconv
799 %{_datadir}/ri/*.*/system/*.rid
800 %{_datadir}/ri/*.*/system/Kernel/*
801 %endif
802
803 %if %{with apache}
804 %files -n apache-mod_dav_svn
805 %defattr(644,root,root,755)
806 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
807 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
808
809 %files -n apache-mod_authz_svn
810 %defattr(644,root,root,755)
811 %doc subversion/mod_authz_svn/INSTALL
812 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
813 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
814 %endif
815
816 %endif # net_client_only
This page took 0.134799 seconds and 4 git commands to generate.