]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- missing \
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
3 #
4 # Conditional build:
5 %bcond_with     net_client_only         # build only net client
6 %bcond_without  neon                    # use serf instead of neon
7 %bcond_without  swig                    # disable bindings generation with Swig
8 %bcond_without  python                  # build without Python bindings (broken)
9 %bcond_without  csvn                    # build Python csvn bindings
10 %bcond_without  perl                    # build without Perl bindings
11 %bcond_without  ruby                    # build without Ruby bindings
12 %bcond_without  apache                  # build without Apache support (webdav, etc)
13 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
14 %bcond_without  tests                   # don't perform "make check"
15 %bcond_without  kwallet                 # build without kde4 wallet support
16 %bcond_without  kde                             # build without kde4 support (alias for kwallet)
17 %bcond_without  gnome                   # build without gnome keyring support
18 %bcond_without  db                              # disable Subversion Berkeley DB based filesystem library
19
20 %if %{with net_client_only}
21 %undefine       with_apache
22 %undefine       with_db
23 %undefine       with_swig
24 %undefine       with_javahl
25 %endif
26
27 %if %{without swig}
28 %undefine       with_perl
29 %undefine       with_python
30 %undefine       with_ruby
31 %endif
32
33 %if %{without kde}
34 %undefine       with_kwallet
35 %endif
36
37 %if %{without python} && %{without perl} && %{without ruby}
38 %define         without_swig    1
39 %endif
40
41 %define apxs    /usr/sbin/apxs
42 %define pdir    SVN
43 %define pnam    _Core
44
45 %if %{with neon}
46 %define webdavlib       neon
47 %else
48 %define webdavlib       serf
49 %endif
50 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
51 Summary:        A Concurrent Versioning system similar to but better than CVS
52 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
53 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
54 Name:           subversion
55 Version:        1.6.16
56 Release:        1
57 License:        Apache/BSD-like
58 Group:          Development/Version Control
59 Source0:        http://subversion.tigris.org/downloads/%{name}-%{version}.tar.bz2
60 # Source0-md5:  32f25a6724559fe8691d1f57a63f636e
61 Source1:        %{name}-dav_svn.conf
62 Source2:        %{name}-authz_svn.conf
63 Source3:        %{name}-svnserve.init
64 Source4:        %{name}-svnserve.sysconfig
65 # current subversion tarball has correct *.swg files
66 # but after regeneration these are broken again, so
67 # we still need this script
68 Source5:        %{name}-convert-typemaps-to-ifdef.py
69 Patch0:         %{name}-home_etc.patch
70 Patch1:         %{name}-DESTDIR.patch
71 Patch2:         %{name}-ruby-datadir-path.patch
72 Patch3:         %{name}-tests.patch
73 URL:            http://subversion.apache.org/
74 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
75 BuildRequires:  autoconf
76 BuildRequires:  automake
77 BuildRequires:  db-devel >= 4.1.25
78 BuildRequires:  libtool
79 BuildRequires:  rpmbuild(macros) >= 1.583
80 %if %{with perl}
81 BuildRequires:  perl-devel >= 1:5.8.0
82 BuildRequires:  rpm-perlprov >= 4.1-13
83 BuildRequires:  swig-perl >= 1.3.24
84 %endif
85 %if %{with csvn}
86 BuildRequires:  python-ctypesgen
87 %endif
88 %if %{with python}
89 BuildRequires:  python-devel >= 1:2.4
90 BuildRequires:  swig-python >= 1.3.24
91 %endif
92 %if %{with ruby}
93 BuildRequires:  ruby-devel
94 BuildRequires:  ruby-rubygems
95 BuildRequires:  swig-ruby >= 1.3.24
96 %endif
97 %if %{with javahl}
98 BuildRequires:  jdk
99 BuildRequires:  libstdc++-devel
100 %endif
101 BuildRequires:  apr-devel >= 1:1.0.0
102 BuildRequires:  apr-util-devel >= 1:1.2.8-3
103 BuildRequires:  autoconf >= 2.59
104 BuildRequires:  bison
105 BuildRequires:  cyrus-sasl-devel
106 BuildRequires:  expat-devel
107 BuildRequires:  gettext-devel
108 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
109 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
110 BuildRequires:  libtool >= 1.4-9
111 BuildRequires:  pkgconfig
112 BuildRequires:  rpm-pythonprov
113 BuildRequires:  sed >= 4.0
114 BuildRequires:  sqlite3-devel >= 3.6.11
115 BuildRequires:  texinfo
116 BuildRequires:  which
117 %if %{with neon}
118 BuildRequires:  neon-devel >= 0.26.0
119 %else
120 BuildRequires:  serf-devel
121 %endif
122 Requires:       %{name}-libs = %{version}-%{release}
123 %requires_ge    sqlite3
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 %define         _libexecdir             %{_libdir}/svn
127 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
128 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
129
130 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.*
131
132 %description
133 The goal of the Subversion project is to build a version control
134 system that is a compelling replacement for CVS in the open source
135 community.
136
137 Our goals are:
138 - All current CVS features.
139 - Directories, renames, and file meta-data are versioned.
140 - Symbolic links, etc, are supported
141 - Commits are truly atomic.
142 - Branching and tagging are cheap (constant time) operations
143 - Repeated merges are handled gracefully
144 - Support for plug-in client side diff programs
145 - Natively client/server
146 - Client/server protocol sends diffs in both directions
147 - Costs are proportional to change size, not project size
148 - Internationalization
149 - Progressive multi-lingual support
150
151 %description -l pl.UTF-8
152 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
153 zamiennika dla CVS.
154
155 Cele projektu to:
156 - Wszystkie aktualne możliwości CVS.
157 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
158 - Obsługa dowiązań symbolicznych itp.
159 - Commity są w pełni atomowe.
160 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
161 - Dobra obsługa powtarzanego łączenia (merge).
162 - Obsługa wtyczek diff po stronie klienta.
163 - Natywny klient/serwer.
164 - Klient/Serwer przesyłają diffy w obu kierunkach.
165 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
166 - Internacjonalizacja.
167 - Postępujące wsparcie dla wielu języków.
168
169 %description -l pt_BR.UTF-8
170 O objetivo do projeto Subversion é construir um sistema de controle de
171 versões que seja um substituto para o CVS (Concurrent Versioning
172 System) na comunidade opensource, fornecendo grandes melhorias.
173
174 %package libs
175 Summary:        Subversion libraries and modules
176 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
177 Group:          Libraries
178 %{?with_neon:Requires:  neon >= 0.26.0}
179 Obsoletes:      libsubversion0
180
181 %description libs
182 Subversion libraries and modules.
183
184 %description libs -l pl.UTF-8
185 Biblioteka subversion oraz ładowalne moduły.
186
187 %package devel
188 Summary:        Header files and develpment documentation for subversion
189 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
190 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
191 Group:          Development/Libraries
192 Requires:       %{name}-libs = %{version}-%{release}
193 Requires:       apr-util-devel >= 1:1.0.0
194 %{?with_neon:Requires:  neon-devel >= 0.26.0}
195 Obsoletes:      libsubversion0-devel
196
197 %description devel
198 Header files and develpment documentation for subversion.
199
200 %description devel -l pl.UTF-8
201 Pliki nagłówkowe i dokumetacja do subversion.
202
203 %description devel -l pt_BR.UTF-8
204 Este pacote provê os arquivos necessários para desenvolvedores
205 interagirem com o Subversion.
206
207 %package static
208 Summary:        Static subversion library
209 Summary(pl.UTF-8):      Biblioteka statyczna subversion
210 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
211 Group:          Development/Libraries
212 Requires:       %{name}-devel = %{version}
213 Obsoletes:      libsubversion0-static-devel
214
215 %description static
216 Static subversion library.
217
218 %description static -l pl.UTF-8
219 Biblioteka statyczna subversion.
220
221 %description static -l pt_BR.UTF-8
222 Este pacote provê um cliente estático do subversion.
223
224 %package svnserve
225 Summary:        Subversion svnserve
226 Summary(pl.UTF-8):      Subversion svnserve
227 Group:          Networking/Daemons
228 Requires(post,preun):   /sbin/chkconfig
229 Requires(postun):       /usr/sbin/groupdel
230 Requires(postun):       /usr/sbin/userdel
231 Requires(pre):  /bin/id
232 Requires(pre):  /usr/bin/getgid
233 Requires(pre):  /usr/lib/rpm/user_group.sh
234 Requires(pre):  /usr/sbin/groupadd
235 Requires(pre):  /usr/sbin/useradd
236 Requires(pre):  /usr/sbin/usermod
237 Requires:       %{name} = %{version}-%{release}
238 Requires:       rc-scripts
239 Provides:       group(svn)
240 Provides:       user(svn)
241
242 %description svnserve
243 Subversion svnserve server.
244
245 %description svnserve -l pl.UTF-8
246 Serwer subversion svnserve.
247
248 %package tools
249 Summary:        Subversion tools and scripts
250 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
251 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
252 Group:          Applications
253 %pyrequires_eq  python
254 Requires:       %{name} = %{version}-%{release}
255 Requires:       python-subversion = %{version}
256
257 %description tools
258 Subversion tools and scripts.
259
260 %description tools -l pl.UTF-8
261 Narzędzia oraz skrypty dla subversion.
262
263 %package -n bash-completion-subversion
264 Summary:        bash completion for subversion
265 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
266 Group:          Applications/Shells
267 Requires:       %{name} = %{version}-%{release}
268 Requires:       bash-completion
269 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
270
271 %description -n bash-completion-subversion
272 Bash completion for subversion.
273
274 %description -n bash-completion-subversion -l pl.UTF-8
275 Dopełnienia basha dla subversion.
276
277 %package -n java-subversion
278 Summary:        Subversion Java bindings
279 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
280 Group:          Development/Languages/Java
281 Requires:       %{name}-libs = %{version}-%{release}
282
283 %description -n java-subversion
284 This is a set of Java classes which provide the functionality of
285 subversion-libs, the Subversion libraries. It is useful if you want
286 to, for example, write a Java class that manipulates a Subversion
287 repository or working copy. See the 'subversion' package for more
288 information.
289
290 %description -n java-subversion -l pl.UTF-8
291 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
292 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
293 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
294 roboczą. Więcej informacji w pakiecie subversion.
295
296 %package -n python-subversion
297 Summary:        Subversion Python bindings
298 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
299 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
300 Group:          Development/Languages/Python
301 %pyrequires_eq  python
302 Requires:       %{name}-libs = %{version}-%{release}
303 Obsoletes:      subversion-python
304
305 %description -n python-subversion
306 Subversion Python bindings.
307
308 %description -n python-subversion -l pl.UTF-8
309 Dowiązania do Subversion dla Pythona.
310
311 %description -n python-subversion -l pt_BR.UTF-8
312 Módulos Python para acessar os recursos do Subversion.
313
314 %package -n python-csvn
315 Summary:        CTypes Subversion Python bindings
316 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
317 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
318 Group:          Development/Languages/Python
319 %pyrequires_eq  python
320 Requires:       %{name}-libs = %{version}-%{release}
321
322 %description -n python-csvn
323 Subversion CTypes Python bindings.
324
325 %description -n python-csvn -l pl.UTF-8
326 Dowiązania do Subversion dla Pythona używające CTypes.
327
328 %description -n python-csvn -l pt_BR.UTF-8
329 Módulos Python para acessar os recursos do Subversion.
330
331 %package -n perl-subversion
332 Summary:        Subversion Perl bindings
333 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
334 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
335 Group:          Development/Languages/Perl
336 Requires:       %{name}-libs = %{version}-%{release}
337 Obsoletes:      subversion-perl
338
339 %description -n perl-subversion
340 Subversion Perl bindings.
341
342 %description -n perl-subversion -l pl.UTF-8
343 Dowiązania do Subversion dla Perla.
344
345 %description -n perl-subversion -l pt_BR.UTF-8
346 Módulos Perl para acessar os recursos do Subversion.
347
348 %package -n ruby-subversion
349 Summary:        Subversion Ruby bindings
350 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
351 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
352 Group:          Development/Languages
353 Requires:       %{name}-libs = %{version}-%{release}
354 Obsoletes:      subversion-ruby
355
356 %description -n ruby-subversion
357 Subversion Ruby bindings.
358
359 %description -n ruby-subversion -l pl.UTF-8
360 Dowiązania do Subversion dla języka Ruby.
361
362 %description -n ruby-subversion -l pt_BR.UTF-8
363 Módulos Ruby para acessar os recursos do Subversion.
364
365 %package -n apache-mod_dav_svn
366 Summary:        Apache module: Subversion Server
367 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
368 Group:          Networking/Daemons
369 Requires:       %{name} = %{version}-%{release}
370 Requires:       apache(modules-api) = %apache_modules_api
371 Requires:       apache-mod_dav
372
373 %description -n apache-mod_dav_svn
374 Apache module: Subversion Server.
375
376 %description -n apache-mod_dav_svn -l pl.UTF-8
377 Moduł apache: Serwer Subversion.
378
379 %package -n apache-mod_authz_svn
380 Summary:        Apache module: Subversion Server - path-based authorization
381 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
382 Group:          Networking/Daemons
383 Requires:       apache(modules-api) = %apache_modules_api
384 Requires:       apache-mod_dav_svn = %{version}-%{release}
385
386 %description -n apache-mod_authz_svn
387 Apache module: Subversion Server - path-based authorization.
388
389 %description -n apache-mod_authz_svn -l pl.UTF-8
390 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
391
392 %package -n gnome-keyring-subversion
393 Summary:        GNOME Keyring authentication provider for Subversion
394 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
395 Group:          X11/Applications
396
397 %description -n gnome-keyring-subversion
398 Authentication provider module for Subversion which allows SVN client
399 to authenticate using GNOME Keyring.
400
401 %description -n gnome-keyring-subversion -l pl.UTF-8
402 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
403 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
404
405 %package -n kde4-kwallet-subversion
406 Summary:        KDE Wallet authentication provider for Subversion
407 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
408 Group:          X11/Applications
409
410 %description -n kde4-kwallet-subversion
411 Authentication provider module for Subversion which allows SVN client
412 to authenticate using KDE Wallet.
413
414 %description -n kde4-kwallet-subversion -l pl.UTF-8
415 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
416 uwierzytelniać się przy użyciu Portfela KDE.
417
418 %prep
419 %setup -q
420 %patch0 -p0
421 %patch1 -p1
422 %patch2 -p0
423 %patch3 -p1
424
425 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
426
427 # serf.m4 macro is broken and ignores --without serf
428 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
429
430 %build
431 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
432 #%{__rm} subversion/bindings/swig/proxy/*.swg
433 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
434 chmod +x ./autogen.sh && ./autogen.sh
435 %{__libtoolize}
436 %configure \
437         --with-editor=vi \
438         --with-zlib=%{_libdir} \
439         --disable-runtime-module-search \
440         --disable-mod-activation \
441 %if %{with db}
442         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
443 %else
444         --without-berkeley-db \
445 %endif
446 %if %{with apache}
447         --with-apxs=%{_sbindir}/apxs \
448 %else
449         --without-apxs \
450 %endif
451 %if %{without swig}
452         --without-swig \
453 %endif
454 %if %{without ruby}
455         ac_cv_path_RUBY=none \
456 %endif
457 %if %{with csvn}
458         --with-ctypesgen=%{_bindir}/ctypesgen.py \
459 %endif
460 %if %{with javahl}
461         --enable-javahl \
462         --with-jdk="%{java_home}" \
463         --without-jikes \
464 %else
465         --disable-javahl \
466 %endif
467 %if %{with neon}
468         --without-serf \
469         --with-neon=%{_prefix} \
470         --disable-neon-version-check \
471 %else
472         --with-serf=%{_prefix} \
473         --without-neon \
474 %endif
475         --with-apr=%{_bindir}/apr-1-config \
476         --with-apr-util=%{_bindir}/apu-1-config \
477 %if %{with kwallet}
478         --with-kwallet \
479 %endif
480 %if %{with gnome}
481         --with-gnome-keyring
482 %endif
483
484 %{__make} -j1
485
486 %if %{with csvn}
487 # Python ctypes bindings
488 %{__make} ctypes-python
489 %endif
490 %if %{with python}
491 # Python swig bindings
492 %{__make} swig-py \
493         swig_pydir=%{py_sitedir}/libsvn \
494         swig_pydir_extra=%{py_sitedir}/svn
495 %endif
496 %if %{with perl}
497 # Perl swig bindings
498 %{__make} -j1 swig-pl-lib
499 cd subversion/bindings/swig/perl/native
500 %{__perl} Makefile.PL INSTALLDIRS=vendor
501 %{__make} -j1
502 cd -
503 %endif
504 %if %{with javahl}
505 %{__make} -j1 javahl \
506         javahl_javadir="%{_javadir}"
507 %endif
508 # ruby
509 %if %{with ruby}
510 %{__make} swig-rb
511 %endif
512
513 %if %{with tests}
514 %{__make} check
515 %if %{with csvn}
516 %{__make} check-ctypes-python
517 %endif
518 %if %{with python}
519 %{__make} check-swig-py
520 %endif
521 %if %{with perl}
522 %{__make} check-swig-pl
523 %endif
524 %if %{with ruby}
525 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
526 #%{__make} check-swig-rb
527 %endif
528 %endif
529
530 %install
531 rm -rf $RPM_BUILD_ROOT
532 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
533         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
534         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
535         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
536         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
537
538 %{__make} install -j1 \
539         DESTDIR=$RPM_BUILD_ROOT \
540         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
541 %if %{with javahl}
542         install-javahl \
543         javahl_javadir="%{_javadir}" \
544 %endif
545 %if %{with python}
546         install-swig-py \
547         swig_pydir=%{py_sitedir}/libsvn \
548         swig_pydir_extra=%{py_sitedir}/svn \
549 %endif
550 %if %{with csvn}
551         install-ctypes-python \
552 %endif
553
554 %if %{with ruby}
555 %{__make} install -j1 \
556         DESTDIR=$RPM_BUILD_ROOT \
557         install-swig-rb install-swig-rb-doc \
558
559 # not our package
560 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Kernel
561 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
562 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
563 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Uconv
564 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
565 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
566 %endif
567
568 %if %{with perl}
569 %{__make} install-swig-pl-lib \
570         DESTDIR=$RPM_BUILD_ROOT
571 %{__make} -C subversion/bindings/swig/perl/native install \
572         DESTDIR=$RPM_BUILD_ROOT \
573         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
574         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
575 %endif
576
577 %if %{with apache}
578 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
579 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
580 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
581 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
582 %endif
583
584 %if %{without net_client_only}
585 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
586 %endif
587 %if %{with python} || %{with csvn}
588 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
589 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
590 %py_postclean
591 %endif
592 %if %{with python}
593 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
594 # .a created on ac only
595 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
596 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
597 %endif
598
599 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
600 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
601
602 %if %{with javahl}
603 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
604 %endif
605 %if %{with swig}
606 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
607 %if %{with ruby}
608 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
609 %endif
610 %endif
611 %if %{with gnome} || %{with kwallet}
612 # dlopened by soname (libsvn_auth_*-1.so.0)
613 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
614 %endif
615
616 %find_lang %{name}
617
618 %clean
619 rm -rf $RPM_BUILD_ROOT
620
621 %pre svnserve
622 %groupadd -g 86 svn
623 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
624
625 %post   libs -p /sbin/ldconfig
626 %postun libs -p /sbin/ldconfig
627
628 %post   devel -p /sbin/postshell
629 -/usr/sbin/fix-info-dir -c %{_infodir}
630
631 %postun devel -p /sbin/postshell
632 -/usr/sbin/fix-info-dir -c %{_infodir}
633
634 %post   -n java-subversion -p /sbin/ldconfig
635 %postun -n java-subversion -p /sbin/ldconfig
636
637 %post   -n perl-subversion -p /sbin/ldconfig
638 %postun -n perl-subversion -p /sbin/ldconfig
639
640 %post   -n python-subversion -p /sbin/ldconfig
641 %postun -n python-subversion -p /sbin/ldconfig
642
643 %post   -n ruby-subversion -p /sbin/ldconfig
644 %postun -n ruby-subversion -p /sbin/ldconfig
645
646 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
647 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
648
649 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
650 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
651
652 %post svnserve
653 /sbin/chkconfig --add svnserve
654 %service svnserve restart "svnserve daemon"
655
656 %preun svnserve
657 if [ "$1" = "0" ]; then
658         %service svnserve stop
659         /sbin/chkconfig --del svnserve
660 fi
661
662 %postun svnserve
663 if [ "$1" = "0" ]; then
664         %userremove svn
665         %groupremove svn
666 fi
667
668 %post -n apache-mod_dav_svn
669 %service -q httpd restart
670
671 %postun -n apache-mod_dav_svn
672 if [ "$1" = "0" ]; then
673         %service -q httpd restart
674 fi
675
676 %post -n apache-mod_authz_svn
677 %service -q httpd restart
678
679 %postun -n apache-mod_authz_svn
680 if [ "$1" = "0" ]; then
681         %service -q httpd restart
682 fi
683
684 %files
685 %defattr(644,root,root,755)
686 %doc BUGS CHANGES COPYING INSTALL README
687 %doc doc/*/*.html
688 %doc tools/hook-scripts/*.{pl,py,example}
689 %doc tools/hook-scripts/mailer/*.{py,example}
690 %doc tools/xslt/*
691 %attr(755,root,root) %{_bindir}/svn
692 %attr(755,root,root) %{_bindir}/svnadmin
693 %attr(755,root,root) %{_bindir}/svndumpfilter
694 %attr(755,root,root) %{_bindir}/svnlook
695 %attr(755,root,root) %{_bindir}/svnsync
696 %attr(755,root,root) %{_bindir}/svnversion
697 %{_mandir}/man1/svn.1*
698 %{_mandir}/man1/svnadmin.1*
699 %{_mandir}/man1/svndumpfilter.1*
700 %{_mandir}/man1/svnlook.1*
701 %{_mandir}/man1/svnsync.1*
702 %{_mandir}/man1/svnversion.1*
703
704 %files libs -f %{name}.lang
705 %defattr(644,root,root,755)
706 %dir %{_sysconfdir}/%{name}
707 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
708 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
709 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
710 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
711 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
712 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
713 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
714 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
715 %if %{without net_client_only}
716 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
717 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
718 %endif
719 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
720 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
721 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
722 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
723 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
724 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
725 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
726 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
727 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
728 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
729 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
730 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
731 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
732 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
733 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
734 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
735 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
736 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
737
738 %files devel
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
741 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
742 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
743 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
744 %if %{without net_client_only}
745 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
746 %endif
747 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
748 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
749 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
750 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
751 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
752 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
753 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
754 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
755 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
756 %{_libdir}/libsvn_client-1.la
757 %{_libdir}/libsvn_delta-1.la
758 %{_libdir}/libsvn_diff-1.la
759 %{_libdir}/libsvn_fs-1.la
760 %if %{without net_client_only}
761 %{_libdir}/libsvn_fs_base-1.la
762 %endif
763 %{_libdir}/libsvn_fs_fs-1.la
764 %{_libdir}/libsvn_fs_util-1.la
765 %{_libdir}/libsvn_ra-1.la
766 %{_libdir}/libsvn_ra_local-1.la
767 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
768 %{_libdir}/libsvn_ra_svn-1.la
769 %{_libdir}/libsvn_repos-1.la
770 %{_libdir}/libsvn_subr-1.la
771 %{_libdir}/libsvn_wc-1.la
772 %{_includedir}/%{name}-1
773 %{_examplesdir}/%{name}-%{version}
774
775 %files static
776 %defattr(644,root,root,755)
777 %{_libdir}/libsvn_client-1.a
778 %{_libdir}/libsvn_delta-1.a
779 %{_libdir}/libsvn_diff-1.a
780 %{_libdir}/libsvn_fs-1.a
781 %if %{without net_client_only}
782 %{_libdir}/libsvn_fs_base-1.a
783 %endif
784 %{_libdir}/libsvn_fs_fs-1.a
785 %{_libdir}/libsvn_fs_util-1.a
786 %{_libdir}/libsvn_ra-1.a
787 %{_libdir}/libsvn_ra_local-1.a
788 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
789 %{_libdir}/libsvn_ra_svn-1.a
790 %{_libdir}/libsvn_repos-1.a
791 %{_libdir}/libsvn_subr-1.a
792 %{_libdir}/libsvn_wc-1.a
793
794 %if %{with gnome}
795 %files -n gnome-keyring-subversion
796 %defattr(644,root,root,755)
797 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
798 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
799 %endif
800
801 %if %{with kwallet}
802 %files -n kde4-kwallet-subversion
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
805 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
806 %endif
807
808 %if %{without net_client_only}
809 %files svnserve
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_bindir}/svnserve
812 %{_mandir}/man5/svnserve.conf.5*
813 %{_mandir}/man8/svnserve.8*
814 %dir %attr(750,svn,svn) /home/services/subversion
815 %dir %attr(750,svn,svn) /home/services/subversion/repos
816 %if %{with apache}
817 %attr(754,root,root) /etc/rc.d/init.d/svnserve
818 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
819 %endif
820
821 %files tools
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_bindir}/svn-hot-backup
824
825 %files -n bash-completion-subversion
826 %defattr(644,root,root,755)
827 /etc/bash_completion.d/%{name}
828
829 %endif # net_client_only
830
831 %if %{with javahl}
832 %files -n java-subversion
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
835 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
836 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
837 %{_javadir}/svn-javahl.jar
838 %endif
839
840 %if %{with python}
841 %files -n python-subversion
842 %defattr(644,root,root,755)
843 %doc tools/backup/*.py
844 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
845 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
846 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
847 %dir %{py_sitedir}/libsvn
848 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
849 %{py_sitedir}/libsvn/*.py[co]
850 %dir %{py_sitedir}/svn
851 %{py_sitedir}/svn/*.py[co]
852 %{_examplesdir}/python-%{name}-%{version}
853 %endif
854
855 %if %{with csvn}
856 %files -n python-csvn
857 %defattr(644,root,root,755)
858 %doc subversion/bindings/ctypes-python/{README,TODO}
859 %doc subversion/bindings/ctypes-python/examples/*.py
860 %dir %{py_sitescriptdir}/csvn
861 %{py_sitescriptdir}/csvn/*.py[co]
862 %dir %{py_sitescriptdir}/csvn/core
863 %{py_sitescriptdir}/csvn/core/*.py[co]
864 %dir %{py_sitescriptdir}/csvn/ext
865 %{py_sitescriptdir}/csvn/ext/*.py[co]
866 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
867 %endif
868
869 %if %{with perl}
870 %files -n perl-subversion
871 %defattr(644,root,root,755)
872 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
873 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
874 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
875 %{perl_vendorarch}/SVN
876 %dir %{perl_vendorarch}/auto/SVN
877 %dir %{perl_vendorarch}/auto/SVN/*
878 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
879 %{perl_vendorarch}/auto/SVN/*/*.bs
880 %{_mandir}/man3/*.3pm*
881 %endif
882
883 %if %{with ruby}
884 %files -n ruby-subversion
885 %defattr(644,root,root,755)
886 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
887 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
888 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
889 %dir %{ruby_sitelibdir}/svn
890 %{ruby_sitelibdir}/svn/*.rb
891 %dir %{ruby_sitearchdir}/svn
892 %dir %{ruby_sitearchdir}/svn/ext
893 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
894 %{ruby_ridir}/Svn
895 %endif
896
897 %if %{with apache}
898 %files -n apache-mod_dav_svn
899 %defattr(644,root,root,755)
900 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
901 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
902
903 %files -n apache-mod_authz_svn
904 %defattr(644,root,root,755)
905 %doc subversion/mod_authz_svn/INSTALL
906 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
907 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
908 %endif
This page took 0.120264 seconds and 4 git commands to generate.