]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- working source0 url
[packages/subversion.git] / subversion.spec
1 # TODO:
2 # - http://subversion.tigris.org/issues/show_bug.cgi?id=2753
3 #
4 # Conditional build:
5 %bcond_with     net_client_only         # build only net client
6 %bcond_without  neon                    # use serf instead of neon
7 %bcond_without  swig                    # disable bindings generation with Swig
8 %bcond_without  python                  # build without Python bindings (broken)
9 %bcond_without  perl                    # build without Perl bindings
10 %bcond_without  apache                  # build without Apache support (webdav, etc)
11 %bcond_without  tests                   # don't perform "make check"
12 %bcond_without  kwallet                 # build without kde4 wallet support
13 %bcond_without  db                              # disable Subversion Berkeley DB based filesystem library
14
15 %if "%{pld_release}" == "ac"
16 %bcond_with     csvn                    # build Python csvn bindings
17 %bcond_with     gnome                   # build without gnome keyring support
18 %bcond_with     javahl                  # build without javahl support (Java high-level bindings)
19 %bcond_with     kde                             # build without kde4 support (alias for kwallet)
20 %bcond_with     ruby                    # build without Ruby bindings
21 %else
22 %bcond_without  csvn                    # build Python csvn bindings
23 %bcond_without  gnome                   # build without gnome keyring support
24 %bcond_without  javahl                  # build without javahl support (Java high-level bindings)
25 %bcond_without  kde                             # build without kde4 support (alias for kwallet)
26 %bcond_without  ruby                    # build without Ruby bindings
27 %endif
28
29 %if %{with net_client_only}
30 %undefine       with_apache
31 %undefine       with_db
32 %undefine       with_swig
33 %undefine       with_javahl
34 %endif
35
36 %if %{without swig}
37 %undefine       with_perl
38 %undefine       with_python
39 %undefine       with_ruby
40 %endif
41
42 %if %{without kde}
43 %undefine       with_kwallet
44 %endif
45
46 %if %{without python} && %{without perl} && %{without ruby}
47 %undefine       with_swig
48 %endif
49
50 %define apxs    /usr/sbin/apxs
51 %define pdir    SVN
52 %define pnam    _Core
53
54 %if %{with neon}
55 %define webdavlib       neon
56 %else
57 %define webdavlib       serf
58 %endif
59 %{?with_perl:%include   /usr/lib/rpm/macros.perl}
60 Summary:        A Concurrent Versioning system similar to but better than CVS
61 Summary(pl.UTF-8):      System kontroli wersji podobny, ale lepszy, niż CVS
62 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
63 Name:           subversion
64 Version:        1.6.18
65 Release:        1
66 License:        Apache/BSD-like
67 Group:          Development/Version Control
68 Source0:        http://archive.apache.org/dist/subversion/%{name}-%{version}.tar.bz2
69 # Source0-md5:  c5c662a5d19d047256fa333bd890a925
70 Source1:        %{name}-dav_svn.conf
71 Source2:        %{name}-authz_svn.conf
72 Source3:        %{name}-svnserve.init
73 Source4:        %{name}-svnserve.sysconfig
74 # current subversion tarball has correct *.swg files
75 # but after regeneration these are broken again, so
76 # we still need this script
77 Source5:        %{name}-convert-typemaps-to-ifdef.py
78 Patch0:         %{name}-home_etc.patch
79 Patch1:         %{name}-DESTDIR.patch
80 Patch2:         %{name}-ruby-datadir-path.patch
81 Patch3:         %{name}-tests.patch
82 URL:            http://subversion.apache.org/
83 %{?with_apache:BuildRequires:   apache-devel >= 2.2.0-8}
84 BuildRequires:  autoconf
85 BuildRequires:  automake
86 BuildRequires:  db-devel >= 4.1.25
87 BuildRequires:  libtool
88 BuildRequires:  rpm >= 4.4.9-56
89 BuildRequires:  rpmbuild(macros) >= 1.583
90 %if %{with perl}
91 BuildRequires:  perl-devel >= 1:5.8.0
92 BuildRequires:  rpm-perlprov >= 4.1-13
93 BuildRequires:  swig-perl >= 1.3.24
94 %endif
95 %if %{with csvn}
96 BuildRequires:  python-ctypesgen
97 %endif
98 %if %{with python}
99 BuildRequires:  python-devel >= 1:2.4
100 BuildRequires:  swig-python >= 1.3.24
101 %endif
102 %if %{with ruby}
103 BuildRequires:  ruby-devel
104 BuildRequires:  ruby-rubygems
105 BuildRequires:  swig-ruby >= 1.3.24
106 %endif
107 %if %{with javahl}
108 BuildRequires:  jdk
109 BuildRequires:  libstdc++-devel
110 %endif
111 BuildRequires:  apr-devel >= 1:1.0.0
112 BuildRequires:  apr-util-devel >= 1:1.2.8-3
113 BuildRequires:  autoconf >= 2.59
114 BuildRequires:  bison
115 BuildRequires:  cyrus-sasl-devel
116 BuildRequires:  expat-devel
117 BuildRequires:  gettext-devel
118 %{?with_kwallet:BuildRequires:  kde4-kdelibs-devel}
119 %{?with_gnome:BuildRequires:    libgnome-keyring-devel}
120 BuildRequires:  libtool >= 1.4-9
121 BuildRequires:  pkgconfig
122 BuildRequires:  rpm-pythonprov
123 BuildRequires:  sed >= 4.0
124 BuildRequires:  sqlite3-devel >= 3.6.11
125 BuildRequires:  texinfo
126 BuildRequires:  which
127 %if %{with neon}
128 BuildRequires:  neon-devel >= 0.26.0
129 %else
130 BuildRequires:  serf-devel
131 %endif
132 Requires:       %{name}-libs = %{version}-%{release}
133 %requires_ge    sqlite3
134 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
135
136 %define         _libexecdir             %{_libdir}/svn
137 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
138 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
139
140 %define         skip_post_check_so      libsvn_swig_py-1.so.* libsvn_swig_perl-1.so.* libsvn_fs-1.so.0.0.0
141 # libsvn_fs-1.so.0.0.0  - "apr_uuid_parse" symbol
142
143 %description
144 The goal of the Subversion project is to build a version control
145 system that is a compelling replacement for CVS in the open source
146 community.
147
148 Our goals are:
149 - All current CVS features.
150 - Directories, renames, and file meta-data are versioned.
151 - Symbolic links, etc, are supported
152 - Commits are truly atomic.
153 - Branching and tagging are cheap (constant time) operations
154 - Repeated merges are handled gracefully
155 - Support for plug-in client side diff programs
156 - Natively client/server
157 - Client/server protocol sends diffs in both directions
158 - Costs are proportional to change size, not project size
159 - Internationalization
160 - Progressive multi-lingual support
161
162 %description -l pl.UTF-8
163 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
164 zamiennika dla CVS.
165
166 Cele projektu to:
167 - Wszystkie aktualne możliwości CVS.
168 - Katalogi, zmiany nazw oraz metadane plików są wersjonowane.
169 - Obsługa dowiązań symbolicznych itp.
170 - Commity są w pełni atomowe.
171 - Branchowanie oraz tagowanie są tanimi (stałymi w czasie) operacjami.
172 - Dobra obsługa powtarzanego łączenia (merge).
173 - Obsługa wtyczek diff po stronie klienta.
174 - Natywny klient/serwer.
175 - Klient/Serwer przesyłają diffy w obu kierunkach.
176 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
177 - Internacjonalizacja.
178 - Postępujące wsparcie dla wielu języków.
179
180 %description -l pt_BR.UTF-8
181 O objetivo do projeto Subversion é construir um sistema de controle de
182 versões que seja um substituto para o CVS (Concurrent Versioning
183 System) na comunidade opensource, fornecendo grandes melhorias.
184
185 %package libs
186 Summary:        Subversion libraries and modules
187 Summary(pl.UTF-8):      Biblioteka subversion oraz ładowalne moduły
188 Group:          Libraries
189 %{?with_neon:Requires:  neon >= 0.26.0}
190 Obsoletes:      libsubversion0
191
192 %description libs
193 Subversion libraries and modules.
194
195 %description libs -l pl.UTF-8
196 Biblioteka subversion oraz ładowalne moduły.
197
198 %package devel
199 Summary:        Header files and develpment documentation for subversion
200 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumetacja do subversion
201 Summary(pt_BR.UTF-8):   Arquivos de desenvolvimento para o Subversion
202 Group:          Development/Libraries
203 Requires:       %{name}-libs = %{version}-%{release}
204 Requires:       apr-util-devel >= 1:1.0.0
205 %{?with_neon:Requires:  neon-devel >= 0.26.0}
206 Obsoletes:      libsubversion0-devel
207
208 %description devel
209 Header files and develpment documentation for subversion.
210
211 %description devel -l pl.UTF-8
212 Pliki nagłówkowe i dokumetacja do subversion.
213
214 %description devel -l pt_BR.UTF-8
215 Este pacote provê os arquivos necessários para desenvolvedores
216 interagirem com o Subversion.
217
218 %package static
219 Summary:        Static subversion library
220 Summary(pl.UTF-8):      Biblioteka statyczna subversion
221 Summary(pt_BR.UTF-8):   Sistema de versionamento concorrente
222 Group:          Development/Libraries
223 Requires:       %{name}-devel = %{version}
224 Obsoletes:      libsubversion0-static-devel
225
226 %description static
227 Static subversion library.
228
229 %description static -l pl.UTF-8
230 Biblioteka statyczna subversion.
231
232 %description static -l pt_BR.UTF-8
233 Este pacote provê um cliente estático do subversion.
234
235 %package svnserve
236 Summary:        Subversion svnserve
237 Summary(pl.UTF-8):      Subversion svnserve
238 Group:          Networking/Daemons
239 Requires(post,preun):   /sbin/chkconfig
240 Requires(postun):       /usr/sbin/groupdel
241 Requires(postun):       /usr/sbin/userdel
242 Requires(pre):  /bin/id
243 Requires(pre):  /usr/bin/getgid
244 Requires(pre):  /usr/lib/rpm/user_group.sh
245 Requires(pre):  /usr/sbin/groupadd
246 Requires(pre):  /usr/sbin/useradd
247 Requires(pre):  /usr/sbin/usermod
248 Requires:       %{name} = %{version}-%{release}
249 Requires:       rc-scripts
250 Provides:       group(svn)
251 Provides:       user(svn)
252
253 %description svnserve
254 Subversion svnserve server.
255
256 %description svnserve -l pl.UTF-8
257 Serwer subversion svnserve.
258
259 %package tools
260 Summary:        Subversion tools and scripts
261 Summary(pl.UTF-8):      Narzędzia oraz skrypty dla subversion
262 Summary(pt_BR.UTF-8):   Módulos python para acessar os recursos do Subversion
263 Group:          Applications
264 %pyrequires_eq  python
265 Requires:       %{name} = %{version}-%{release}
266 Requires:       python-subversion = %{version}
267
268 %description tools
269 Subversion tools and scripts.
270
271 %description tools -l pl.UTF-8
272 Narzędzia oraz skrypty dla subversion.
273
274 %package -n bash-completion-subversion
275 Summary:        bash completion for subversion
276 Summary(pl.UTF-8):      Dopełnienia basha dla subversion
277 Group:          Applications/Shells
278 Requires:       %{name} = %{version}-%{release}
279 Requires:       bash-completion
280 Conflicts:      %{name}-tools <= 1.1.0-0.rc6.1
281
282 %description -n bash-completion-subversion
283 Bash completion for subversion.
284
285 %description -n bash-completion-subversion -l pl.UTF-8
286 Dopełnienia basha dla subversion.
287
288 %package -n java-subversion
289 Summary:        Subversion Java bindings
290 Summary(pl.UTF-8):      Dowiązania do Subversion dla Javy
291 Group:          Development/Languages/Java
292 Requires:       %{name}-libs = %{version}-%{release}
293
294 %description -n java-subversion
295 This is a set of Java classes which provide the functionality of
296 subversion-libs, the Subversion libraries. It is useful if you want
297 to, for example, write a Java class that manipulates a Subversion
298 repository or working copy. See the 'subversion' package for more
299 information.
300
301 %description -n java-subversion -l pl.UTF-8
302 Ten pakiet zawiera zestaw klas Javy udostępniających funkcjonalność
303 subversion-libs, czyli bibliotek Subversion. Jest przydatny przy
304 pisaniu klas Javy np. modyfikujących repozytorium Subversion lub kopię
305 roboczą. Więcej informacji w pakiecie subversion.
306
307 %package -n python-subversion
308 Summary:        Subversion Python bindings
309 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
310 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
311 Group:          Development/Languages/Python
312 %pyrequires_eq  python
313 Requires:       %{name}-libs = %{version}-%{release}
314 Obsoletes:      subversion-python
315
316 %description -n python-subversion
317 Subversion Python bindings.
318
319 %description -n python-subversion -l pl.UTF-8
320 Dowiązania do Subversion dla Pythona.
321
322 %description -n python-subversion -l pt_BR.UTF-8
323 Módulos Python para acessar os recursos do Subversion.
324
325 %package -n python-csvn
326 Summary:        CTypes Subversion Python bindings
327 Summary(pl.UTF-8):      Dowiązania do Subversion dla Pythona
328 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do Subversion
329 Group:          Development/Languages/Python
330 %pyrequires_eq  python
331 Requires:       %{name}-libs = %{version}-%{release}
332
333 %description -n python-csvn
334 Subversion CTypes Python bindings.
335
336 %description -n python-csvn -l pl.UTF-8
337 Dowiązania do Subversion dla Pythona używające CTypes.
338
339 %description -n python-csvn -l pt_BR.UTF-8
340 Módulos Python para acessar os recursos do Subversion.
341
342 %package -n perl-subversion
343 Summary:        Subversion Perl bindings
344 Summary(pl.UTF-8):      Dowiązania do Subversion dla Perla
345 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do Subversion
346 Group:          Development/Languages/Perl
347 Requires:       %{name}-libs = %{version}-%{release}
348 Obsoletes:      subversion-perl
349
350 %description -n perl-subversion
351 Subversion Perl bindings.
352
353 %description -n perl-subversion -l pl.UTF-8
354 Dowiązania do Subversion dla Perla.
355
356 %description -n perl-subversion -l pt_BR.UTF-8
357 Módulos Perl para acessar os recursos do Subversion.
358
359 %package -n ruby-subversion
360 Summary:        Subversion Ruby bindings
361 Summary(pl.UTF-8):      Dowiązania do Subversion dla języka Ruby
362 Summary(pt_BR.UTF-8):   Módulos Ruby para acessar os recursos do Subversion
363 Group:          Development/Languages
364 Requires:       %{name}-libs = %{version}-%{release}
365 Obsoletes:      subversion-ruby
366
367 %description -n ruby-subversion
368 Subversion Ruby bindings.
369
370 %description -n ruby-subversion -l pl.UTF-8
371 Dowiązania do Subversion dla języka Ruby.
372
373 %description -n ruby-subversion -l pt_BR.UTF-8
374 Módulos Ruby para acessar os recursos do Subversion.
375
376 %package -n apache-mod_dav_svn
377 Summary:        Apache module: Subversion Server
378 Summary(pl.UTF-8):      Moduł apache: Serwer Subversion
379 Group:          Networking/Daemons
380 Requires:       %{name} = %{version}-%{release}
381 Requires:       apache(modules-api) = %apache_modules_api
382 Requires:       apache-mod_dav
383
384 %description -n apache-mod_dav_svn
385 Apache module: Subversion Server.
386
387 %description -n apache-mod_dav_svn -l pl.UTF-8
388 Moduł apache: Serwer Subversion.
389
390 %package -n apache-mod_authz_svn
391 Summary:        Apache module: Subversion Server - path-based authorization
392 Summary(pl.UTF-8):      Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion
393 Group:          Networking/Daemons
394 Requires:       apache(modules-api) = %apache_modules_api
395 Requires:       apache-mod_dav_svn = %{version}-%{release}
396
397 %description -n apache-mod_authz_svn
398 Apache module: Subversion Server - path-based authorization.
399
400 %description -n apache-mod_authz_svn -l pl.UTF-8
401 Moduł apache: autoryzacja na podstawie ścieżki dla serwera Subversion.
402
403 %package -n gnome-keyring-subversion
404 Summary:        GNOME Keyring authentication provider for Subversion
405 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Subversion
406 Group:          X11/Applications
407
408 %description -n gnome-keyring-subversion
409 Authentication provider module for Subversion which allows SVN client
410 to authenticate using GNOME Keyring.
411
412 %description -n gnome-keyring-subversion -l pl.UTF-8
413 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
414 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
415
416 %package -n kde4-kwallet-subversion
417 Summary:        KDE Wallet authentication provider for Subversion
418 Summary(pl.UTF-8):      Moduł uwierzytelniający dla Subversion wykorzystujący Portfel KDE
419 Group:          X11/Applications
420
421 %description -n kde4-kwallet-subversion
422 Authentication provider module for Subversion which allows SVN client
423 to authenticate using KDE Wallet.
424
425 %description -n kde4-kwallet-subversion -l pl.UTF-8
426 Moduł uwierzytelniający dla Subversion pozwalający klientom SVN
427 uwierzytelniać się przy użyciu Portfela KDE.
428
429 %prep
430 %setup -q
431 %patch0 -p0
432 %patch1 -p1
433 %patch2 -p0
434 %patch3 -p1
435
436 sed -i -e 's#serf_prefix/lib#serf_prefix/%{_lib}#g' build/ac-macros/serf.m4
437
438 # serf.m4 macro is broken and ignores --without serf
439 %{?with_neon:sed -i -e 's#serf_found="yes"#serf_found="no"#g' build/ac-macros/serf.m4}
440
441 %build
442 # disabled regeneration - subversion 1.6.13 is not ready for swig 2.0.x
443 #%{__rm} subversion/bindings/swig/proxy/*.swg
444 #cd subversion/bindings/swig && python "%{SOURCE5}" && cd ../../..
445 chmod +x ./autogen.sh && ./autogen.sh
446 %{__libtoolize}
447 %configure \
448         --with-editor=vi \
449         --with-zlib=%{_libdir} \
450         --disable-runtime-module-search \
451         --disable-mod-activation \
452 %if %{with db}
453         --with-berkeley-db="db.h:%{_includedir}:%{_libdir}:db" \
454 %else
455         --without-berkeley-db \
456 %endif
457 %if %{with apache}
458         --with-apxs=%{_sbindir}/apxs \
459 %else
460         --without-apxs \
461 %endif
462 %if %{without swig}
463         --without-swig \
464 %endif
465 %if %{without ruby}
466         ac_cv_path_RUBY=none \
467 %endif
468 %if %{with csvn}
469         --with-ctypesgen=%{_bindir}/ctypesgen.py \
470 %endif
471 %if %{with javahl}
472         --enable-javahl \
473         --with-jdk="%{java_home}" \
474         --without-jikes \
475 %else
476         --disable-javahl \
477 %endif
478 %if %{with neon}
479         --without-serf \
480         --with-neon=%{_prefix} \
481         --disable-neon-version-check \
482 %else
483         --with-serf=%{_prefix} \
484         --without-neon \
485 %endif
486         --with-apr=%{_bindir}/apr-1-config \
487         --with-apr-util=%{_bindir}/apu-1-config \
488 %if %{with kwallet}
489         --with-kwallet \
490 %endif
491 %if %{with gnome}
492         --with-gnome-keyring
493 %endif
494
495 %{__make} -j1
496
497 %if %{with csvn}
498 # Python ctypes bindings
499 %{__make} ctypes-python
500 %endif
501 %if %{with python}
502 # Python swig bindings
503 %{__make} swig-py \
504         swig_pydir=%{py_sitedir}/libsvn \
505         swig_pydir_extra=%{py_sitedir}/svn
506 %endif
507 %if %{with perl}
508 # Perl swig bindings
509 %{__make} -j1 swig-pl-lib
510 cd subversion/bindings/swig/perl/native
511 %{__perl} Makefile.PL INSTALLDIRS=vendor
512 %{__make} -j1
513 cd -
514 %endif
515 %if %{with javahl}
516 %{__make} -j1 javahl \
517         javahl_javadir="%{_javadir}"
518 %endif
519 # ruby
520 %if %{with ruby}
521 %{__make} swig-rb
522 %endif
523
524 %if %{with tests}
525 %{__make} check
526 %if %{with csvn}
527 %{__make} check-ctypes-python
528 %endif
529 %if %{with python}
530 %{__make} check-swig-py
531 %endif
532 %if %{with perl}
533 %{__make} check-swig-pl
534 %endif
535 %if %{with ruby}
536 # disabled, see https://bugs.launchpad.net/pld-linux/+bug/734340
537 #%{__make} check-swig-rb
538 %endif
539 %endif
540
541 %install
542 rm -rf $RPM_BUILD_ROOT
543 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
544         $RPM_BUILD_ROOT{%{apacheconfdir},%{apachelibdir},%{_infodir}} \
545         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
546         $RPM_BUILD_ROOT%{_sysconfdir}/%{name} \
547         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
548
549 %{__make} install -j1 \
550         DESTDIR=$RPM_BUILD_ROOT \
551         APACHE_LIBEXECDIR="$(%{_sbindir}/apxs -q LIBEXECDIR)" \
552 %if %{with javahl}
553         install-javahl \
554         javahl_javadir="%{_javadir}" \
555 %endif
556 %if %{with python}
557         install-swig-py \
558         swig_pydir=%{py_sitedir}/libsvn \
559         swig_pydir_extra=%{py_sitedir}/svn \
560 %endif
561 %if %{with csvn}
562         install-ctypes-python \
563 %endif
564
565 %if %{with ruby}
566 %{__make} install -j1 \
567         DESTDIR=$RPM_BUILD_ROOT \
568         install-swig-rb install-swig-rb-doc \
569
570 # not our package
571 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Kernel
572 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/OptionParser
573 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Time
574 %{__rm} -r $RPM_BUILD_ROOT%{ruby_ridir}/Uconv
575 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
576 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
577 %endif
578
579 %if %{with perl}
580 %{__make} install-swig-pl-lib \
581         DESTDIR=$RPM_BUILD_ROOT
582 %{__make} -C subversion/bindings/swig/perl/native install \
583         DESTDIR=$RPM_BUILD_ROOT \
584         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
585         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
586 %endif
587
588 %if %{with apache}
589 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/65_mod_dav_svn.conf
590 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{apacheconfdir}/66_mod_authz_svn.conf
591 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
592 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
593 %endif
594
595 %if %{without net_client_only}
596 install -p tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
597 %endif
598 %if %{with python} || %{with csvn}
599 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
600 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
601 %py_postclean
602 %endif
603 %if %{with python}
604 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.la
605 # .a created on ac only
606 %{__rm} -f $RPM_BUILD_ROOT%{py_sitedir}/libsvn/*.a
607 cp -p tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
608 %endif
609
610 cp -p tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
611 cp -p tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
612
613 %if %{with javahl}
614 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvnjavahl*.{la,a}
615 %endif
616 %if %{with swig}
617 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_swig*.{la,a}
618 %if %{with ruby}
619 %{__rm} $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*/svn/ext/*.la
620 %endif
621 %endif
622 %if %{with gnome} || %{with kwallet}
623 # dlopened by soname (libsvn_auth_*-1.so.0)
624 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsvn_auth_*-1.{so,la,a}
625 %endif
626
627 %find_lang %{name}
628
629 %clean
630 rm -rf $RPM_BUILD_ROOT
631
632 %pre svnserve
633 %groupadd -g 86 svn
634 %useradd -u 180 -d /home/services/subversion -c "Subversion svnserve" -g svn svn
635
636 %post   libs -p /sbin/ldconfig
637 %postun libs -p /sbin/ldconfig
638
639 %post   devel -p /sbin/postshell
640 -/usr/sbin/fix-info-dir -c %{_infodir}
641
642 %postun devel -p /sbin/postshell
643 -/usr/sbin/fix-info-dir -c %{_infodir}
644
645 %post   -n java-subversion -p /sbin/ldconfig
646 %postun -n java-subversion -p /sbin/ldconfig
647
648 %post   -n perl-subversion -p /sbin/ldconfig
649 %postun -n perl-subversion -p /sbin/ldconfig
650
651 %post   -n python-subversion -p /sbin/ldconfig
652 %postun -n python-subversion -p /sbin/ldconfig
653
654 %post   -n ruby-subversion -p /sbin/ldconfig
655 %postun -n ruby-subversion -p /sbin/ldconfig
656
657 %post   -n gnome-keyring-subversion -p /sbin/ldconfig
658 %postun -n gnome-keyring-subversion -p /sbin/ldconfig
659
660 %post   -n kde4-kwallet-subversion -p /sbin/ldconfig
661 %postun -n kde4-kwallet-subversion -p /sbin/ldconfig
662
663 %post svnserve
664 /sbin/chkconfig --add svnserve
665 %service svnserve restart "svnserve daemon"
666
667 %preun svnserve
668 if [ "$1" = "0" ]; then
669         %service svnserve stop
670         /sbin/chkconfig --del svnserve
671 fi
672
673 %postun svnserve
674 if [ "$1" = "0" ]; then
675         %userremove svn
676         %groupremove svn
677 fi
678
679 %post -n apache-mod_dav_svn
680 %service -q httpd restart
681
682 %postun -n apache-mod_dav_svn
683 if [ "$1" = "0" ]; then
684         %service -q httpd restart
685 fi
686
687 %post -n apache-mod_authz_svn
688 %service -q httpd restart
689
690 %postun -n apache-mod_authz_svn
691 if [ "$1" = "0" ]; then
692         %service -q httpd restart
693 fi
694
695 %files
696 %defattr(644,root,root,755)
697 %doc BUGS CHANGES COPYING INSTALL README
698 %doc doc/*/*.html
699 %doc tools/hook-scripts/*.{pl,py,example}
700 %doc tools/hook-scripts/mailer/*.{py,example}
701 %doc tools/xslt/*
702 %attr(755,root,root) %{_bindir}/svn
703 %attr(755,root,root) %{_bindir}/svnadmin
704 %attr(755,root,root) %{_bindir}/svndumpfilter
705 %attr(755,root,root) %{_bindir}/svnlook
706 %attr(755,root,root) %{_bindir}/svnsync
707 %attr(755,root,root) %{_bindir}/svnversion
708 %{_mandir}/man1/svn.1*
709 %{_mandir}/man1/svnadmin.1*
710 %{_mandir}/man1/svndumpfilter.1*
711 %{_mandir}/man1/svnlook.1*
712 %{_mandir}/man1/svnsync.1*
713 %{_mandir}/man1/svnversion.1*
714
715 %files libs -f %{name}.lang
716 %defattr(644,root,root,755)
717 %dir %{_sysconfdir}/%{name}
718 %attr(755,root,root) %{_libdir}/libsvn_client-1.so.*.*.*
719 %attr(755,root,root) %ghost %{_libdir}/libsvn_client-1.so.0
720 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so.*.*.*
721 %attr(755,root,root) %ghost %{_libdir}/libsvn_delta-1.so.0
722 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so.*.*.*
723 %attr(755,root,root) %ghost %{_libdir}/libsvn_diff-1.so.0
724 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so.*.*.*
725 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs-1.so.0
726 %if %{without net_client_only}
727 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so.*.*.*
728 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_base-1.so.0
729 %endif
730 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so.*.*.*
731 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_fs-1.so.0
732 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so.*.*.*
733 %attr(755,root,root) %ghost %{_libdir}/libsvn_fs_util-1.so.0
734 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so.*.*.*
735 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra-1.so.0
736 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so.*.*.*
737 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_local-1.so.0
738 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so.*.*.*
739 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_%{webdavlib}-1.so.0
740 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so.*.*.*
741 %attr(755,root,root) %ghost %{_libdir}/libsvn_ra_svn-1.so.0
742 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so.*.*.*
743 %attr(755,root,root) %ghost %{_libdir}/libsvn_repos-1.so.0
744 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so.*.*.*
745 %attr(755,root,root) %ghost %{_libdir}/libsvn_subr-1.so.0
746 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so.*.*.*
747 %attr(755,root,root) %ghost %{_libdir}/libsvn_wc-1.so.0
748
749 %files devel
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/libsvn_client-1.so
752 %attr(755,root,root) %{_libdir}/libsvn_delta-1.so
753 %attr(755,root,root) %{_libdir}/libsvn_diff-1.so
754 %attr(755,root,root) %{_libdir}/libsvn_fs-1.so
755 %if %{without net_client_only}
756 %attr(755,root,root) %{_libdir}/libsvn_fs_base-1.so
757 %endif
758 %attr(755,root,root) %{_libdir}/libsvn_fs_fs-1.so
759 %attr(755,root,root) %{_libdir}/libsvn_fs_util-1.so
760 %attr(755,root,root) %{_libdir}/libsvn_ra-1.so
761 %attr(755,root,root) %{_libdir}/libsvn_ra_local-1.so
762 %attr(755,root,root) %{_libdir}/libsvn_ra_%{webdavlib}-1.so
763 %attr(755,root,root) %{_libdir}/libsvn_ra_svn-1.so
764 %attr(755,root,root) %{_libdir}/libsvn_repos-1.so
765 %attr(755,root,root) %{_libdir}/libsvn_subr-1.so
766 %attr(755,root,root) %{_libdir}/libsvn_wc-1.so
767 %{_libdir}/libsvn_client-1.la
768 %{_libdir}/libsvn_delta-1.la
769 %{_libdir}/libsvn_diff-1.la
770 %{_libdir}/libsvn_fs-1.la
771 %if %{without net_client_only}
772 %{_libdir}/libsvn_fs_base-1.la
773 %endif
774 %{_libdir}/libsvn_fs_fs-1.la
775 %{_libdir}/libsvn_fs_util-1.la
776 %{_libdir}/libsvn_ra-1.la
777 %{_libdir}/libsvn_ra_local-1.la
778 %{_libdir}/libsvn_ra_%{webdavlib}-1.la
779 %{_libdir}/libsvn_ra_svn-1.la
780 %{_libdir}/libsvn_repos-1.la
781 %{_libdir}/libsvn_subr-1.la
782 %{_libdir}/libsvn_wc-1.la
783 %{_includedir}/%{name}-1
784 %{_examplesdir}/%{name}-%{version}
785
786 %files static
787 %defattr(644,root,root,755)
788 %{_libdir}/libsvn_client-1.a
789 %{_libdir}/libsvn_delta-1.a
790 %{_libdir}/libsvn_diff-1.a
791 %{_libdir}/libsvn_fs-1.a
792 %if %{without net_client_only}
793 %{_libdir}/libsvn_fs_base-1.a
794 %endif
795 %{_libdir}/libsvn_fs_fs-1.a
796 %{_libdir}/libsvn_fs_util-1.a
797 %{_libdir}/libsvn_ra-1.a
798 %{_libdir}/libsvn_ra_local-1.a
799 %{_libdir}/libsvn_ra_%{webdavlib}-1.a
800 %{_libdir}/libsvn_ra_svn-1.a
801 %{_libdir}/libsvn_repos-1.a
802 %{_libdir}/libsvn_subr-1.a
803 %{_libdir}/libsvn_wc-1.a
804
805 %if %{with gnome}
806 %files -n gnome-keyring-subversion
807 %defattr(644,root,root,755)
808 %attr(755,root,root) %{_libdir}/libsvn_auth_gnome_keyring-1.so.*.*.*
809 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_gnome_keyring-1.so.0
810 %endif
811
812 %if %{with kwallet}
813 %files -n kde4-kwallet-subversion
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/libsvn_auth_kwallet-1.so.*.*.*
816 %attr(755,root,root) %ghost %{_libdir}/libsvn_auth_kwallet-1.so.0
817 %endif
818
819 %if %{without net_client_only}
820 %files svnserve
821 %defattr(644,root,root,755)
822 %attr(755,root,root) %{_bindir}/svnserve
823 %{_mandir}/man5/svnserve.conf.5*
824 %{_mandir}/man8/svnserve.8*
825 %dir %attr(750,svn,svn) /home/services/subversion
826 %dir %attr(750,svn,svn) /home/services/subversion/repos
827 %if %{with apache}
828 %attr(754,root,root) /etc/rc.d/init.d/svnserve
829 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
830 %endif
831
832 %files tools
833 %defattr(644,root,root,755)
834 %attr(755,root,root) %{_bindir}/svn-hot-backup
835
836 %files -n bash-completion-subversion
837 %defattr(644,root,root,755)
838 /etc/bash_completion.d/%{name}
839
840 %endif # net_client_only
841
842 %if %{with javahl}
843 %files -n java-subversion
844 %defattr(644,root,root,755)
845 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so.*.*.*
846 %attr(755,root,root) %ghost %{_libdir}/libsvnjavahl-1.so.0
847 %attr(755,root,root) %{_libdir}/libsvnjavahl-1.so
848 %{_javadir}/svn-javahl.jar
849 %endif
850
851 %if %{with python}
852 %files -n python-subversion
853 %defattr(644,root,root,755)
854 %doc tools/backup/*.py
855 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so.*.*.*
856 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_py-1.so.0
857 %attr(755,root,root) %{_libdir}/libsvn_swig_py-1.so
858 %dir %{py_sitedir}/libsvn
859 %attr(755,root,root) %{py_sitedir}/libsvn/_*.so
860 %{py_sitedir}/libsvn/*.py[co]
861 %dir %{py_sitedir}/svn
862 %{py_sitedir}/svn/*.py[co]
863 %{_examplesdir}/python-%{name}-%{version}
864 %endif
865
866 %if %{with csvn}
867 %files -n python-csvn
868 %defattr(644,root,root,755)
869 %doc subversion/bindings/ctypes-python/{README,TODO}
870 %doc subversion/bindings/ctypes-python/examples/*.py
871 %dir %{py_sitescriptdir}/csvn
872 %{py_sitescriptdir}/csvn/*.py[co]
873 %dir %{py_sitescriptdir}/csvn/core
874 %{py_sitescriptdir}/csvn/core/*.py[co]
875 %dir %{py_sitescriptdir}/csvn/ext
876 %{py_sitescriptdir}/csvn/ext/*.py[co]
877 %{py_sitescriptdir}/svn_ctypes_python_bindings-0.1-py*.egg-info
878 %endif
879
880 %if %{with perl}
881 %files -n perl-subversion
882 %defattr(644,root,root,755)
883 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so.*.*.*
884 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_perl-1.so.0
885 %attr(755,root,root) %{_libdir}/libsvn_swig_perl-1.so
886 %{perl_vendorarch}/SVN
887 %dir %{perl_vendorarch}/auto/SVN
888 %dir %{perl_vendorarch}/auto/SVN/*
889 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
890 %{perl_vendorarch}/auto/SVN/*/*.bs
891 %{_mandir}/man3/*.3pm*
892 %endif
893
894 %if %{with ruby}
895 %files -n ruby-subversion
896 %defattr(644,root,root,755)
897 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so.*.*.*
898 %attr(755,root,root) %ghost %{_libdir}/libsvn_swig_ruby-1.so.0
899 %attr(755,root,root) %{_libdir}/libsvn_swig_ruby-1.so
900 %dir %{ruby_sitelibdir}/svn
901 %{ruby_sitelibdir}/svn/*.rb
902 %dir %{ruby_sitearchdir}/svn
903 %dir %{ruby_sitearchdir}/svn/ext
904 %attr(755,root,root) %{ruby_sitearchdir}/svn/ext/*.so
905 %{ruby_ridir}/Svn
906 %endif
907
908 %if %{with apache}
909 %files -n apache-mod_dav_svn
910 %defattr(644,root,root,755)
911 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_dav_svn.conf
912 %attr(755,root,root) %{apachelibdir}/mod_dav_svn.so
913
914 %files -n apache-mod_authz_svn
915 %defattr(644,root,root,755)
916 %doc subversion/mod_authz_svn/INSTALL
917 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_authz_svn.conf
918 %attr(755,root,root) %{apachelibdir}/mod_authz_svn.so
919 %endif
This page took 0.087795 seconds and 4 git commands to generate.