]> git.pld-linux.org Git - packages/subversion.git/blob - subversion.spec
- BR: gettext-devel
[packages/subversion.git] / subversion.spec
1 #
2 # todo:
3 # - remove net_client_only and add db bcond (then without apache and
4 #   without db => net_client_only - spec will be more simpler, I think)
5 #
6 # Conditional build:
7 %bcond_with     internal_neon                   # build with internal neon
8 %bcond_with     net_client_only                 # build only net client
9 %bcond_without  python                          # build without python bindings
10 %bcond_without  perl                            # build without perl bindings
11 %bcond_without  apache                          # build without apache support (webdav, etc)
12 #       
13 %{!?with_net_client_only:%include       /usr/lib/rpm/macros.perl}
14 Summary:        A Concurrent Versioning system similar to but better than CVS
15 Summary(pl):    System kontroli wersji podobny, ale lepszy, ni¿ CVS
16 Summary(pt_BR): Sistema de versionamento concorrente
17 Name:           subversion
18 Version:        1.2.0
19 Release:        2
20 License:        Apache/BSD Style
21 Group:          Development/Version Control
22 Source0:        http://subversion.tigris.org/tarballs/%{name}-%{version}.tar.bz2
23 # Source0-md5:  f25c0c884201f411e99a6cb6c25529ff
24 Source1:        %{name}-dav_svn.conf
25 Source2:        %{name}-authz_svn.conf
26 Source3:        %{name}-svnserve.init
27 Source4:        %{name}-svnserve.sysconfig
28 Patch0:         %{name}-home_etc.patch
29 URL:            http://subversion.tigris.org/
30 %if %{with net_client_only}
31 %global apache_modules_api 0
32 %else
33 BuildRequires:  automake
34 %{?with_apache:BuildRequires:   apache-devel >= 2.0.47-0.6}
35 BuildRequires:  db-devel >= 4.1.25
36 BuildRequires:  rpmbuild(macros) >= 1.120
37 %if %{with python} || %{with perl}
38 BuildRequires:  swig >= 1.3.19
39 %endif
40 %{?with_python:BuildRequires:   swig-python >= 1.3.21}
41 %if %{with perl}
42 BuildRequires:  swig-perl >= 1.3.21
43 BuildRequires:  perl-devel >= 1:5.8.0
44 BuildRequires:  rpm-perlprov >= 4.1-13
45 %endif
46 %endif
47 BuildRequires:  apr-devel >= 1:1.0.0
48 BuildRequires:  apr-util-devel >= 1:1.0.0
49 BuildRequires:  autoconf >= 2.59
50 BuildRequires:  bison
51 BuildRequires:  expat-devel
52 BuildRequires:  gettext-devel
53 BuildRequires:  libtool >= 1.4-9
54 %{!?with_internal_neon:BuildRequires:   neon-devel >= 0.24.7}
55 %if %{with python}
56 BuildRequires:  python >= 2.2
57 BuildRequires:  python-devel >= 2.2
58 BuildRequires:  python-modules >= 2.2
59 %endif
60 BuildRequires:  texinfo
61 BuildRequires:  which
62 Requires:       %{name}-libs = %{version}-%{release}
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _apachelibdir   /usr/%{_lib}/apache
66 %define         _libexecdir     %{_libdir}/svn
67
68 %description
69 The goal of the Subversion project is to build a version control
70 system that is a compelling replacement for CVS in the open source
71 community.
72
73 Our goals are:
74 - All current CVS features.
75 - Directories, renames, and file meta-data are versioned.
76 - Symbolic links, etc, are supported
77 - Commits are truly atomic.
78 - Branching and tagging are cheap (constant time) operations
79 - Repeated merges are handled gracefully
80 - Support for plug-in client side diff programs
81 - Natively client/server
82 - Client/server protocol sends diffs in both directions
83 - Costs are proportional to change size, not project size
84 - Internationalization
85 - Progressive multi-lingual support
86
87 %description -l pl
88 Celem projektu Subversion jest stworzenie systemu kontroli wersji jako
89 zamiennika dla CVS.
90
91 Cele projektu to:
92 - Wszystkie aktualne mo¿liwo¶ci CVS.
93 - Katalogi, zmiany nazw oraz meta-dane plików s± wersjonowane.
94 - Wsparcie dla linków symbolicznych itp.
95 - Commity s± w pe³ni atomowe.
96 - Branchowanie oraz tagowanie s± tanimi (sta³ymi w czasie) operacjami.
97 - Powtarzaj±ce merge.
98 - Wsparcie dla pluginów diff'a po stronie klienta.
99 - Natywny klient/serwer.
100 - Klient/Serwer przesy³aj± diffy w obu kierunkach.
101 - Koszty proporcjonalne do rozmiaru zmiany, a nie rozmiaru projektu.
102 - Internacjonalizacja.
103 - Postêpuj±ce wsparcie dla wielu jêzyków.
104
105 %description -l pt_BR
106 O objetivo do projeto Subversion é construir um sistema de controle de
107 versões que seja um substituto para o CVS (Concurrent Versioning
108 System) na comunidade opensource, fornecendo grandes melhorias.
109
110 %package libs
111 Summary:        Subversion libraries and modules
112 Summary(pl):    Biblioteka subversion oraz ³adowalne modu³y
113 Group:          Libraries
114 Obsoletes:      libsubversion0
115 %{!?with_internal_neon:Requires:        neon >= 0.24.6}
116
117 %description libs
118 Subversion libraries and modules.
119
120 %description libs -l pl
121 Biblioteka subversion oraz ³adowalne modu³y.
122
123 %package devel
124 Summary:        Header files and develpment documentation for subversion
125 Summary(pl):    Pliki nag³ówkowe i dokumetacja do subversion
126 Summary(pt_BR): Arquivos de desenvolvimento para o Subversion
127 Group:          Development/Libraries
128 Requires:       %{name}-libs = %{version}-%{release}
129 Requires:       apr-util-devel >= 1:1.0.0
130 %{!?with_internal_neon:Requires:        neon-devel >= 0.24.6}
131 Obsoletes:      libsubversion0-devel
132
133 %description devel
134 Header files and develpment documentation for subversion.
135
136 %description devel -l pl
137 Pliki nag³ówkowe i dokumetacja do subversion.
138
139 %description devel -l pt_BR
140 Este pacote provê os arquivos necessários para desenvolvedores
141 interagirem com o Subversion.
142
143 %package static
144 Summary:        Static subversion library
145 Summary(pl):    Biblioteka statyczna subversion
146 Summary(pt_BR): Sistema de versionamento concorrente
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}
149 Obsoletes:      libsubversion0-static-devel
150
151 %description static
152 Static subversion library.
153
154 %description static -l pl
155 Biblioteka statyczna subversion.
156
157 %description static -l pt_BR
158 Este pacote provê um cliente estático do subversion.
159
160 %package svnserve
161 Summary:        Subversion svnserve
162 Summary(pl):    Subversion svnserve
163 Group:          Networking/Daemons
164 PreReq:         rc-scripts
165 Requires(post,preun):   /sbin/chkconfig
166 Requires:       %{name} = %{version}-%{release}
167
168 %description svnserve
169 Subversion svnserve server.
170
171 %description svnserve -l pl
172 Serwer subversion svnserve.
173
174 %package tools
175 Summary:        Subversion tools and scripts
176 Summary(pl):    Narzêdzia oraz skrypty dla subversion
177 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
178 Group:          Applications
179 %pyrequires_eq  python
180 Requires:       python-rcsparse >= 0.1-0.20031026.0
181 Requires:       python-subversion = %{version}
182 Requires:       %{name} = %{version}-%{release}
183
184 %description tools
185 Subversion tools and scripts.
186
187 %description tools -l pl
188 Narzêdzia oraz skrypty dla subversion.
189
190 %package -n bash-completion-subversion
191 Summary:        bash completion for subversion
192 Summary(pl):    Dope³nienia basha dla subversion
193 Group:          Applications/Shells
194 Requires:       bash-completion
195 Requires:       %{name} = %{version}-%{release}
196 Conflicts:      %{name}-tools <= 1.1.0-0.rc2.1
197
198 %description -n bash-completion-subversion
199 Bash completion for subversion.
200
201 %description -n bash-completion-subversion -l pl
202 Dope³nienia basha dla subversion.
203
204 %package -n python-subversion
205 Summary:        Subversion python bindings
206 Summary(pl):    Dowi±zania do subversion dla pythona
207 Summary(pt_BR): Módulos python para acessar os recursos do Subversion
208 Group:          Development/Languages/Python
209 %pyrequires_eq  python
210 Obsoletes:      subversion-python
211 Requires:       %{name}-libs = %{version}-%{release}
212
213 %description -n python-subversion
214 Subversion python bindings.
215
216 %description -n python-subversion -l pl
217 Dowi±zania do subversion dla pythona.
218
219 %description -n python-subversion -l pt_BR
220 Módulos python para acessar os recursos do Subversion.
221
222 %package -n perl-subversion
223 Summary:        Subversion perl bindings
224 Summary(pl):    Dowi±zania do subversion dla perla
225 Summary(pt_BR): Módulos perl para acessar os recursos do Subversion
226 Group:          Development/Languages/Perl
227 Obsoletes:      subversion-perl
228 Requires:       %{name}-libs = %{version}-%{release}
229
230 %description -n perl-subversion
231 Subversion perl bindings.
232
233 %description -n perl-subversion -l pl
234 Dowi±zania do subversion dla perl.
235
236 %description -n perl-subversion -l pt_BR
237 Módulos perl para acessar os recursos do Subversion.
238
239 %package -n apache-mod_dav_svn
240 Summary:        Apache module: Subversion Server
241 Summary(pl):    Modu³ apache: Serwer Subversion
242 Group:          Networking/Daemons
243 Requires:       apache >= 2.0.47
244 Requires:       apache(modules-api) = %{apache_modules_api}
245 Requires:       apache-mod_dav
246 Requires:       %{name} = %{version}-%{release}
247
248 %description -n apache-mod_dav_svn
249 Apache module: Subversion Server.
250
251 %description -n apache-mod_dav_svn -l pl
252 Modu³ apache: Serwer Subversion.
253
254 %package -n apache-mod_authz_svn
255 Summary:        Apache module: Subversion Server - path-based authorization
256 Summary(pl):    Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion
257 Group:          Networking/Daemons
258 Requires:       apache-mod_dav_svn = %{version}-%{release}
259 Requires:       apache >= 2.0.47
260 Requires:       apache(modules-api) = %{apache_modules_api}
261
262 %description -n apache-mod_authz_svn
263 Apache module: Subversion Server - path-based authorization.
264
265 %description -n apache-mod_authz_svn -l pl
266 Modu³ apache: autoryzacja na podstawie ¶cie¿ki dla serwera Subversion.
267
268 %prep
269 %setup -q
270 %patch0 -p0
271
272 rm -rf apr-util{,/xml/expat}/autom4te.cache
273
274 %build
275 cp -f /usr/share/automake/config.sub ac-helpers
276 chmod +x ./autogen.sh && ./autogen.sh
277
278 # don't enable dso - currently it's broken
279 %configure \
280         --with-editor=vi \
281         --with-zlib \
282         --with-python=%{_bindir}/python \
283         --with-perl5=%{_bindir}/perl \
284 %if %{with net_client_only}
285         --without-apache \
286         --without-swig \
287         --without-apxs \
288         --without-berkeley-db \
289 %else
290         --disable-dso \
291         --disable-mod-activation \
292 %if %{with apache}
293         --with-apxs=%{_sbindir}/apxs \
294 %else
295         --without-apache \
296         --without-apxs \
297         --with-berkeley-db=%{_includedir}/db4:%{_libdir} \
298 %endif
299 %if !%{with python} && !%{with perl}
300         --without-swig \
301 %endif
302 %endif
303         %{!?with_internal_neon:--with-neon=%{_prefix}} \
304         --with-apr=%{_bindir}/apr-1-config \
305         --with-apr-util=%{_bindir}/apu-1-config
306
307 %{__make}
308
309 %if !%{with net_client_only}
310 # python
311 %if %{with python}
312 %{__make} swig-py \
313         swig_pydir=%{py_sitedir}/libsvn \
314         swig_pydir_extra=%{py_sitedir}/svn
315 %endif
316 # perl
317 %if %{with perl}
318 %{__make} swig-pl-lib
319 odir=$(pwd)
320 cd subversion/bindings/swig/perl/native
321 %{__perl} Makefile.PL INSTALLDIRS=vendor
322 %{__make}
323 cd $odir
324 %endif
325 %endif
326
327 %install
328 rm -rf $RPM_BUILD_ROOT
329 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,bash_completion.d} \
330         $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_apachelibdir},%{_infodir}} \
331         $RPM_BUILD_ROOT%{_examplesdir}/{%{name}-%{version},python-%{name}-%{version}} \
332         $RPM_BUILD_ROOT/home/services/subversion{,/repos}
333
334 %{__make} install \
335 %if !%{with net_client_only} && %{with python}
336         install-swig-py \
337 %endif
338         DESTDIR=$RPM_BUILD_ROOT \
339         swig_pydir=%{py_sitedir}/libsvn \
340         swig_pydir_extra=%{py_sitedir}/svn
341
342 %if !%{with net_client_only} && %{with perl}
343 %{__make} install-swig-pl-lib \
344         DESTDIR=$RPM_BUILD_ROOT
345 odir=$(pwd)
346 cd subversion/bindings/swig/perl/native
347 %{__make} install \
348         DESTDIR=$RPM_BUILD_ROOT \
349         PREFIX=$RPM_BUILD_ROOT%{_prefix} \
350         LIBDIR=$RPM_BUILD_ROOT%{_libdir}
351 cd $odir
352 %endif
353
354 %if %{with apache}
355 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/65_mod_dav_svn.conf
356 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/66_mod_authz_svn.conf
357 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/svnserve
358 install %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/svnserve
359 %endif
360
361 %if !%{with net_client_only}
362 install tools/backup/hot-backup.py $RPM_BUILD_ROOT%{_bindir}/svn-hot-backup
363 %if %{with python}
364 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
365 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
366 find $RPM_BUILD_ROOT%{py_sitedir} -name "*.py" -o -name "*.a" -o -name "*.la" | xargs rm -f
367 install tools/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
368 %endif
369 %endif
370
371 install tools/client-side/bash_completion $RPM_BUILD_ROOT/etc/bash_completion.d/%{name}
372 install tools/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
373
374 %find_lang %{name}
375
376 %clean
377 rm -rf $RPM_BUILD_ROOT
378
379 %post devel
380 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
381
382 %postun devel
383 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
384
385 %post   libs -p /sbin/ldconfig
386 %postun libs -p /sbin/ldconfig
387 %post   -n python-subversion -p /sbin/ldconfig
388 %postun -n perl-subversion -p /sbin/ldconfig
389
390 %post svnserve
391 if [ -f /var/lock/subsys/svnserve ]; then
392         /etc/rc.d/init.d/svnserve restart 1>&2
393 else
394         echo "Run \"/etc/rc.d/init.d/svnserve start\" to start subversion svnserve daemon."
395 fi
396 %preun svnserve
397 if [ "$1" = "0" ]; then
398         if [ -f /var/lock/subsys/svnserve ]; then
399                 /etc/rc.d/init.d/svnserve restart 1>&2
400         fi
401 fi
402
403
404 %post -n apache-mod_dav_svn
405 if [ -f /var/lock/subsys/httpd ]; then
406         /etc/rc.d/init.d/httpd restart 1>&2
407 else
408         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache HTTP daemon."
409 fi
410
411 %preun -n apache-mod_dav_svn
412 if [ "$1" = "0" ]; then
413         if [ -f /var/lock/subsys/httpd ]; then
414                 /etc/rc.d/init.d/httpd restart 1>&2
415         fi
416 fi
417
418 %files
419 %defattr(644,root,root,755)
420 %doc BUGS CHANGES COPYING INSTALL README
421 %doc doc/*/*.html
422 %doc tools/hook-scripts/*.{pl,py,example}
423 %doc tools/hook-scripts/mailer/*.{py,example}
424 %doc tools/xslt/*
425 %attr(755,root,root) %{_bindir}/svn*
426 %exclude %{_bindir}/svnserve
427 %exclude %{_bindir}/svn-hot-backup
428 %{_mandir}/man1/*
429 %{_mandir}/man5/*
430 %{_mandir}/man8/*
431 %exclude %{_mandir}/man?/svnserve*
432 %{?with_internal_neon:%exclude %{_mandir}/man1/neon*}
433
434 %files libs -f %{name}.lang
435 %defattr(644,root,root,755)
436 %attr(755,root,root) %{_libdir}/lib*.so.*
437 %if %{with perl} || %{with python}
438 %exclude %{_libdir}/lib*_swig_*.so.*
439 %endif
440
441 %files devel
442 %defattr(644,root,root,755)
443 %{_includedir}/%{name}*
444 %attr(755,root,root) %{_libdir}/lib*.so
445 %{_libdir}/lib*.la
446 %{_examplesdir}/%{name}-%{version}
447
448 %files static
449 %defattr(644,root,root,755)
450 %{_libdir}/lib*.a
451
452 %if !%{with net_client_only}
453 %files svnserve
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{_bindir}/svnserve
456 %{_mandir}/man?/svnserve*
457 %dir /home/services/subversion
458 %dir /home/services/subversion/repos
459 %if %{with apache}
460 %attr(754,root,root) /etc/rc.d/init.d/svnserve
461 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/svnserve
462 %endif
463
464 %files tools
465 %defattr(644,root,root,755)
466 %attr(755,root,root) %{_bindir}/svn-hot-backup
467
468 %files -n bash-completion-subversion
469 %defattr(644,root,root,755)
470 /etc/bash_completion.d/%{name}
471
472 %if %{with python}
473 %files -n python-subversion
474 %defattr(644,root,root,755)
475 %doc tools/backup/*.py tools/examples/*.py
476 %dir %{py_sitedir}/svn
477 %dir %{py_sitedir}/libsvn
478 %{py_sitedir}/svn/*.py[co]
479 %{py_sitedir}/libsvn/*.py[co]
480 %attr(755,root,root) %{py_sitedir}/libsvn/*.so
481 %{_examplesdir}/python-%{name}-%{version}
482 %attr(755,root,root) %{_libdir}/lib*_swig_py*.so.*
483 %endif
484
485 %if %{with perl}
486 %files -n perl-subversion
487 %defattr(644,root,root,755)
488 %{perl_vendorarch}/SVN
489 %dir %{perl_vendorarch}/auto/SVN
490 %dir %{perl_vendorarch}/auto/SVN/*
491 %attr(755,root,root) %{perl_vendorarch}/auto/SVN/*/*.so
492 %{perl_vendorarch}/auto/SVN/*/*.bs
493 %{_mandir}/man3/*.3pm*
494 %attr(755,root,root) %{_libdir}/lib*_swig_perl*.so.*
495 %endif
496
497 %if %{with apache}
498 %files -n apache-mod_dav_svn
499 %defattr(644,root,root,755)
500 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_dav_svn.conf
501 %attr(755,root,root) %{_apachelibdir}/mod_dav_svn.so
502
503 %files -n apache-mod_authz_svn
504 %defattr(644,root,root,755)
505 %doc subversion/mod_authz_svn/INSTALL
506 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd/httpd.conf/*_mod_authz_svn.conf
507 %attr(755,root,root) %{_apachelibdir}/mod_authz_svn.so
508 %endif
509 %endif
This page took 0.077205 seconds and 3 git commands to generate.