]> git.pld-linux.org Git - packages/ssldump.git/commitdiff
- added AES support (patch by Adam Osuchowski) auto/th/ssldump-0_9b3-7
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Wed, 9 Mar 2011 13:13:58 +0000 (13:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fixed build with openssl on x86_64
- release 7

Changed files:
    aes-support.patch -> 1.1
    ssldump.spec -> 1.12

aes-support.patch [new file with mode: 0644]
ssldump.spec

diff --git a/aes-support.patch b/aes-support.patch
new file mode 100644 (file)
index 0000000..7d9ced6
--- /dev/null
@@ -0,0 +1,163 @@
+                                                                     
+                                                                     
+                                                                     
+                                             
+diff -ruN ssldump-0.9b3.orig/ssl/ciphersuites.c ssl/ciphersuites.c
+--- ssldump-0.9b3.orig/ssl/ciphersuites.c      2002-08-16 19:33:17.000000000 -0600
++++ ssldump-0.9b3/ssl/ciphersuites.c   2003-04-25 11:30:44.000000000 -0600
+@@ -78,10 +78,25 @@
+      {25,KEX_DH,SIG_NONE,ENC_DES,8,64,40,DIG_MD5,16,1},
+      {26,KEX_DH,SIG_NONE,ENC_DES,8,64,64,DIG_MD5,16,0},
+      {27,KEX_DH,SIG_NONE,ENC_3DES,8,192,192,DIG_MD5,16,0},
++
++     {47,KEX_RSA,SIG_RSA,ENC_AES128,16,128,128,DIG_SHA,20,0},
++     {48,KEX_DH,SIG_DSS,ENC_AES128,16,128,128,DIG_SHA,20,0},
++     {49,KEX_DH,SIG_RSA,ENC_AES128,16,128,128,DIG_SHA,20,0},
++     {50,KEX_DH,SIG_DSS,ENC_AES128,16,128,128,DIG_SHA,20,0},
++     {51,KEX_DH,SIG_RSA,ENC_AES128,16,128,128,DIG_SHA,20,0},
++     {52,KEX_DH,SIG_NONE,ENC_AES128,16,128,128,DIG_SHA,20,0},
++
++     {53,KEX_RSA,SIG_RSA,ENC_AES256,16,256,256,DIG_SHA,20,0},
++     {54,KEX_DH,SIG_DSS,ENC_AES256,16,256,256,DIG_SHA,20,0},
++     {55,KEX_DH,SIG_RSA,ENC_AES256,16,256,256,DIG_SHA,20,0},
++     {56,KEX_DH,SIG_DSS,ENC_AES256,16,256,256,DIG_SHA,20,0},
++     {57,KEX_DH,SIG_RSA,ENC_AES256,16,256,256,DIG_SHA,20,0},
++     {58,KEX_DH,SIG_NONE,ENC_AES256,16,256,256,DIG_SHA,20,0},
++
+      {96,KEX_RSA,SIG_RSA,ENC_RC4,1,128,56,DIG_MD5,16,1},
+      {97,KEX_RSA,SIG_RSA,ENC_RC2,1,128,56,DIG_MD5,16,1},
+      {98,KEX_RSA,SIG_RSA,ENC_DES,8,64,64,DIG_SHA,20,1},
+-     {99,KEX_DH,SIG_DSS,ENC_DES,8,64,64,DIG_SHA,16,1},
++     {99,KEX_DH,SIG_DSS,ENC_DES,8,64,64,DIG_SHA,20,1},
+      {100,KEX_RSA,SIG_RSA,ENC_RC4,1,128,56,DIG_SHA,20,1},
+      {101,KEX_DH,SIG_DSS,ENC_RC4,1,128,56,DIG_SHA,20,1},     
+      {102,KEX_DH,SIG_DSS,ENC_RC4,1,128,128,DIG_SHA,20,0},
+diff -ruN ssldump-0.9b3.orig/ssl/sslciphers.h ssldump-0.9b3/ssl/sslciphers.h
+--- ssldump-0.9b3.orig/ssl/sslciphers.h        2002-08-16 19:33:17.000000000 -0600
++++ ssldump-0.9b3/ssl/sslciphers.h     2003-04-25 11:30:46.000000000 -0600
+@@ -71,7 +71,9 @@
+ #define ENC_RC4               0x32
+ #define ENC_RC2               0x33
+ #define ENC_IDEA      0x34
+-#define ENC_NULL      0x35
++#define ENC_AES128      0x35
++#define ENC_AES256      0x36
++#define ENC_NULL      0x37
+ #define DIG_MD5               0x40
+ #define DIG_SHA               0x41
+diff -ruN ssldump-0.9b3.orig/ssl/ssl.enums ssldump-0.9b3/ssl/ssl.enums
+--- ssldump-0.9b3.orig/ssl/ssl.enums   2001-07-20 10:44:32.000000000 -0600
++++ ssldump-0.9b3/ssl/ssl.enums        2003-04-25 11:30:45.000000000 -0600
+@@ -356,6 +356,18 @@
+     CipherSuite TLS_DH_anon_EXPORT_WITH_DES40_CBC_SHA  = { 0x00,0x19 };
+     CipherSuite TLS_DH_anon_WITH_DES_CBC_SHA           = { 0x00,0x1A };
+     CipherSuite TLS_DH_anon_WITH_3DES_EDE_CBC_SHA      = { 0x00,0x1B };
++    CipherSuite TLS_RSA_WITH_AES_128_CBC_SHA           = { 0x00,0x2F };
++    CipherSuite TLS_DH_DSS_WITH_AES_128_CBC_SHA        = { 0x00,0x30 };
++    CipherSuite TLS_DH_RSA_WITH_AES_128_CBC_SHA        = { 0x00,0x31 };
++    CipherSuite TLS_DHE_DSS_WITH_AES_128_CBC_SHA       = { 0x00,0x32 };
++    CipherSuite TLS_DHE_RSA_WITH_AES_128_CBC_SHA       = { 0x00,0x33 };
++    CipherSuite TLS_DH_anon_WITH_AES_128_CBC_SHA       = { 0x00,0x34 };
++    CipherSuite TLS_RSA_WITH_AES_256_CBC_SHA           = { 0x00,0x35 };
++    CipherSuite TLS_DH_DSS_WITH_AES_256_CBC_SHA        = { 0x00,0x36 };
++    CipherSuite TLS_DH_RSA_WITH_AES_256_CBC_SHA        = { 0x00,0x37 };
++    CipherSuite TLS_DHE_DSS_WITH_AES_256_CBC_SHA       = { 0x00,0x38 };
++    CipherSuite TLS_DHE_RSA_WITH_AES_256_CBC_SHA       = { 0x00,0x39 };
++    CipherSuite TLS_DH_anon_WITH_AES_256_CBC_SHA       = { 0x00,0x3A };
+     CipherSuite TLS_RSA_EXPORT1024_WITH_RC4_56_MD5     = { 0x00,0x60 };
+     CipherSuite TLS_RSA_EXPORT1024_WITH_RC2_CBC_56_MD5   = { 0x00,0x61 };
+     CipherSuite TLS_RSA_EXPORT1024_WITH_DES_CBC_SHA     = { 0x00,0x62 };
+diff -ruN ssldump-0.9b3.orig/ssl/ssl.enums.c ssldump-0.9b3/ssl/ssl.enums.c
+--- ssldump-0.9b3.orig/ssl/ssl.enums.c 2001-07-20 10:44:36.000000000 -0600
++++ ssldump-0.9b3/ssl/ssl.enums.c      2003-04-25 11:30:45.000000000 -0600
+@@ -611,6 +611,54 @@
+               "TLS_DH_anon_WITH_3DES_EDE_CBC_SHA",
+               0       },
+       {
++              47,
++              "TLS_RSA_WITH_AES_128_CBC_SHA",
++              0       },
++      {
++              48,
++              "TLS_DH_DSS_WITH_AES_128_CBC_SHA",
++              0       },
++      {
++              49,
++              "TLS_DH_RSA_WITH_AES_128_CBC_SHA",
++              0       },
++      {
++              50,
++              "TLS_DHE_DSS_WITH_AES_128_CBC_SHA",
++              0       },
++      {
++              51,
++              "TLS_DHE_RSA_WITH_AES_128_CBC_SHA",
++              0       },
++      {
++              52,
++              "TLS_DH_anon_WITH_AES_128_CBC_SHA",
++              0       },
++      {
++              53,
++              "TLS_RSA_WITH_AES_256_CBC_SHA",
++              0       },
++      {
++              54,
++              "TLS_DH_DSS_WITH_AES_256_CBC_SHA",
++              0       },
++      {
++              55,
++              "TLS_DH_RSA_WITH_AES_256_CBC_SHA",
++              0       },
++      {
++              56,
++              "TLS_DHE_DSS_WITH_AES_256_CBC_SHA",
++              0       },
++      {
++              57,
++              "TLS_DHE_RSA_WITH_AES_256_CBC_SHA",
++              0       },
++      {
++              58,
++              "TLS_DH_anon_WITH_AES_256_CBC_SHA",
++              0       },
++      {
+               96,
+               "TLS_RSA_EXPORT1024_WITH_RC4_56_MD5",
+               0       },
+diff -ruN ssldump-0.9b3.orig/ssl/ssl_rec.c ssldump-0.9b3/ssl/ssl_rec.c
+--- ssldump-0.9b3.orig/ssl/ssl_rec.c   2000-11-02 23:38:06.000000000 -0700
++++ ssldump-0.9b3/ssl/ssl_rec.c        2003-04-25 11:30:46.000000000 -0600
+@@ -78,7 +78,9 @@
+      "DES3",
+      "RC4",
+      "RC2",
+-     "IDEA"
++     "IDEA",
++     "AES128",
++     "AES256"
+ };
+@@ -101,6 +103,11 @@
+     /* Find the SSLeay cipher */
+     if(cs->enc!=ENC_NULL){
+       ciph=(EVP_CIPHER *)EVP_get_cipherbyname(ciphers[cs->enc-0x30]);
++      if(!ciph)
++      ABORT(R_INTERNAL);
++    }
++    else {
++      ciph=EVP_enc_null();
+     }
+     if(!(dec=(ssl_rec_decoder *)calloc(sizeof(ssl_rec_decoder),1)))
+@@ -169,7 +176,7 @@
+     *outl=inl;
+     
+     /* Now strip off the padding*/
+-    if(d->cs->block!=1){
++    if(d->cs->block>1){
+       pad=out[inl-1];
+       *outl-=(pad+1);
+     }
index 65ef3670ce6c716c2bb95b12477cc8b8d104ef26..80a530a1457ea6d3edca001ba9e1bce41c8872c5 100644 (file)
@@ -2,13 +2,13 @@ Summary:      SSLv3/TLS network protocol analyzer
 Summary(pl.UTF-8):     Analizator protokołu sieciowego SSLv3/TLS
 Name:          ssldump
 Version:       0.9b3
-Release:       6
-Epoch:         0
+Release:       7
 License:       BSD
 Group:         Networking/Utilities
 Source0:       http://www.rtfm.com/ssldump/%{name}-%{version}.tar.gz
 # Source0-md5: ac8c28fe87508d6bfb06344ec496b1dd
 Patch0:        %{name}-openssl.patch
+Patch1:                aes-support.patch
 URL:           http://www.rtfm.com/ssldump/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -36,6 +36,7 @@ będzie także dekodował połączenia i wyświetlał ruch danych aplikacji.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 sed -i -e 's#libpcap.a#libpcap.so#g' configure*
 sed -i -e 's#net/bpf.h#pcap-bpf.h#g' base/pcap-snoop.c
@@ -46,7 +47,8 @@ cp -f %{_datadir}/automake/config.* .
 %{__autoconf}
 %configure \
        --with-pcap-inc=%{_includedir} \
-       --with-pcap-lib=%{_libdir}
+       --with-pcap-lib=%{_libdir} \
+       --with-openssl-lib=%{_libdir}
 %{__make}
 
 %install
This page took 0.066232 seconds and 4 git commands to generate.