]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- disabled virtuoso support on 32bit archs
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# Conditional build:
2%bcond_without serializer # with raptor serializer. need to figure out proper BR
81788912 3%bcond_without sesame2 # with sesame2backend
e8d4b674 4%bcond_without virtuoso # with virtuosobackend
c7018ab4 5
81ed0294 6%define qtbrver 4.7.3
e8d4b674 7%define snap svn1042011
855ec3f8 8
21572f09
JR
9%ifarch %{ix86}
10# current virtuoso (7.1.0) works only on 64bit archs
11%unglobal with_virtuoso
12%endif
13
8667f3ab
JB
14Summary: Soprano - Qt wrapper API to librdf
15Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 16Name: soprano
e75bcc64 17Version: 2.9.4
21572f09 18Release: 2
5b9e452e 19License: GPL v2
195f432c 20Group: X11/Applications
25b958ac 21Source0: http://downloads.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
e75bcc64 22# Source0-md5: 91413e5783efeee0beb747ea4c5c9ef0
e8d4b674 23#Source0: %{name}-%{version}-%{snap}.tar.gz
5a8ef18c 24URL: http://sourceforge.net/projects/soprano
855ec3f8 25BuildRequires: QtCore-devel >= %{qtbrver}
26BuildRequires: QtDBus-devel >= %{qtbrver}
2ba17820 27BuildRequires: QtGui-devel >= %{qtbrver}
855ec3f8 28BuildRequires: QtNetwork-devel >= %{qtbrver}
2b1fcc2c 29BuildRequires: clucene-core-devel >= 0.9.16a-2
214d4c81 30BuildRequires: cmake >= 2.8.0
ba131f66 31BuildRequires: doxygen
84df784d 32%{?with_sesame2:BuildRequires: libgcj-devel}
e432317c 33%{?with_serializer:BuildRequires: libraptor2-devel >= 2.0.0}
25b958ac 34BuildRequires: pkgconfig
855ec3f8 35BuildRequires: qt4-build >= %{qtbrver}
36BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e 37BuildRequires: rasqal-devel
81ed0294 38BuildRequires: redland-devel >= 1.0.14
d2faa209 39BuildRequires: rpmbuild(macros) >= 1.600
2ba17820 40BuildRequires: xorg-lib-libX11-devel
41BuildRequires: xorg-lib-libXext-devel
e8d4b674 42%if %{with virtuoso}
43BuildRequires: libiodbc-devel
44Requires: virtuoso >= 6.1.0
45%endif
195f432c 46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
8667f3ab
JB
49Soprano (formally known as QRDF) is a library which provides a Qt
50wrapper API to different RDF storage solutions. It features named
51graphs (contexts) and has a modular plug-in structure which allows to
52use different RDF storage implementations.
195f432c 53
8667f3ab 54%description -l pl.UTF-8
2ba17820 55Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
56wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
57nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
58pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 59
60%package devel
61Summary: Header files for soprano
62Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description devel
67Header files for soprano.
68
69%description devel -l pl.UTF-8
70Pliki nagłówkowe dla soprano.
71
72%prep
a4a085c3 73%setup -q
435be701 74# Sesame2 backend doesn't really use the new JNI-1.6 feature -> GetObjectRefType.
84df784d 75#sed -i 's:JNI_VERSION_1_6:JNI_VERSION_1_4:g' CMakeLists.txt
435be701 76# cleanup.
84df784d 77#sed -i 's:${JAVA_INCLUDE_PATH2}::' backends/sesame2/CMakeLists.txt
195f432c 78
79%build
80install -d build
81cd build
84df784d 82# add this to get verbose output
83# -DCMAKE_VERBOSE_MAKEFILE=1
195f432c 84%cmake \
84df784d 85 -DJAVA_INCLUDE_PATH=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
86 -DJAVA_INCLUDE_PATH2=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
78ba8e2d 87%if "%{pld_release}" == "ti"
214d4c81 88 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-11/libjvm.so \
78ba8e2d 89%else
81ed0294 90 -DJAVA_JVM_LIBRARY=$(ls -1 %{_libdir}/gcj-%{cc_version}-*/libjvm.so | head -n 1) \
78ba8e2d 91%endif
84df784d 92 ../
195f432c 93
94%{__make}
95
96%install
97rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
98
99%{__make} -C build install \
195f432c 100 DESTDIR=$RPM_BUILD_ROOT
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
107
108%files
109%defattr(644,root,root,755)
2fc92623
RT
110%attr(755,root,root) %{_bindir}/sopranocmd
111%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 112%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 113%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 114%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 115%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 116%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 117%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 118%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
119%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
120%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 121%dir %{_libdir}/soprano
0b2cd574 122%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
123%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
124%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
125%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
c4571e50 126%{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
127%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
e8d4b674 128%{?with_virtuoso:%attr(755,root,root) %{_libdir}/soprano/libsoprano_virtuosobackend.so}
5b9e452e 129%{_datadir}/soprano
2fc92623
RT
130%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
131%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
132%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
133%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
134%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
135
195f432c 136%files devel
137%defattr(644,root,root,755)
0b2cd574 138%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
139%attr(755,root,root) %{_libdir}/libsopranoserver.so
140%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 141%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 142%dir %{_includedir}/soprano
143%{_includedir}/soprano/*.h
2fc92623 144%{_includedir}/Soprano
5b9e452e 145%{_pkgconfigdir}/soprano.pc
0835c44e
AM
146%{_pkgconfigdir}/sopranoserver.pc
147%{_pkgconfigdir}/sopranoclient.pc
148%{_pkgconfigdir}/sopranoindex.pc
This page took 0.178354 seconds and 4 git commands to generate.