]> git.pld-linux.org Git - packages/soprano.git/blame - soprano.spec
- BR: libraptor-devel >= 2.0.0
[packages/soprano.git] / soprano.spec
CommitLineData
dbea7b1e
ER
1# TODO
2# - missing deps:
3# * Sesame2 storage backend (java-based)
4# * Raptor RDF serializer
dbea7b1e
ER
5#
6# Conditional build:
7%bcond_without serializer # with raptor serializer. need to figure out proper BR
81788912 8%bcond_without sesame2 # with sesame2backend
e8d4b674 9%bcond_without virtuoso # with virtuosobackend
c7018ab4 10
81ed0294 11%define qtbrver 4.7.3
e8d4b674 12%define snap svn1042011
855ec3f8 13
8667f3ab
JB
14Summary: Soprano - Qt wrapper API to librdf
15Summary(pl.UTF-8): Soprano - wrapper Qt do librdf
195f432c 16Name: soprano
04bbefab 17Version: 2.8.0
0835c44e 18Release: 1
5b9e452e 19License: GPL v2
195f432c 20Group: X11/Applications
25b958ac 21Source0: http://downloads.sourceforge.net/soprano/%{name}-%{version}.tar.bz2
04bbefab 22# Source0-md5: 273c3403aeb6d8a43e78a4887f50a385
e8d4b674 23#Source0: %{name}-%{version}-%{snap}.tar.gz
5a8ef18c 24URL: http://sourceforge.net/projects/soprano
855ec3f8 25BuildRequires: QtCore-devel >= %{qtbrver}
26BuildRequires: QtDBus-devel >= %{qtbrver}
2ba17820 27BuildRequires: QtGui-devel >= %{qtbrver}
855ec3f8 28BuildRequires: QtNetwork-devel >= %{qtbrver}
2b1fcc2c 29BuildRequires: clucene-core-devel >= 0.9.16a-2
214d4c81 30BuildRequires: cmake >= 2.8.0
84df784d 31%{?with_sesame2:BuildRequires: libgcj-devel}
98703f30 32%{?with_serializer:BuildRequires: libraptor-devel >= 2.0.0}
25b958ac 33BuildRequires: pkgconfig
855ec3f8 34BuildRequires: qt4-build >= %{qtbrver}
35BuildRequires: qt4-qmake >= %{qtbrver}
dbea7b1e 36BuildRequires: rasqal-devel
81ed0294 37BuildRequires: redland-devel >= 1.0.14
d2faa209 38BuildRequires: rpmbuild(macros) >= 1.600
2ba17820 39BuildRequires: xorg-lib-libX11-devel
40BuildRequires: xorg-lib-libXext-devel
e8d4b674 41%if %{with virtuoso}
42BuildRequires: libiodbc-devel
43Requires: virtuoso >= 6.1.0
44%endif
195f432c 45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
8667f3ab
JB
48Soprano (formally known as QRDF) is a library which provides a Qt
49wrapper API to different RDF storage solutions. It features named
50graphs (contexts) and has a modular plug-in structure which allows to
51use different RDF storage implementations.
195f432c 52
8667f3ab 53%description -l pl.UTF-8
2ba17820 54Soprano (wcześniej znane jako QRDF) to biblioteka udostępniająca API
55wrappera Qt do różnych rozwiązań przechowywania danych RDF. Obsługuje
56nazwane grafy (konteksty) i ma strukturę modularnych wtyczek, co
57pozwala na używanie różnych implementacji przechowywania danych RDF.
195f432c 58
59%package devel
60Summary: Header files for soprano
61Summary(pl.UTF-8): Pliki nagłówkowe dla soprano
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description devel
66Header files for soprano.
67
68%description devel -l pl.UTF-8
69Pliki nagłówkowe dla soprano.
70
71%prep
a4a085c3 72%setup -q
435be701 73# Sesame2 backend doesn't really use the new JNI-1.6 feature -> GetObjectRefType.
84df784d 74#sed -i 's:JNI_VERSION_1_6:JNI_VERSION_1_4:g' CMakeLists.txt
435be701 75# cleanup.
84df784d 76#sed -i 's:${JAVA_INCLUDE_PATH2}::' backends/sesame2/CMakeLists.txt
195f432c 77
78%build
79install -d build
80cd build
84df784d 81# add this to get verbose output
82# -DCMAKE_VERBOSE_MAKEFILE=1
195f432c 83%cmake \
84df784d 84 -DJAVA_INCLUDE_PATH=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
85 -DJAVA_INCLUDE_PATH2=%{_libdir}/gcc/%{_target_platform}/%{cc_version}/include \
78ba8e2d 86%if "%{pld_release}" == "ti"
214d4c81 87 -DJAVA_JVM_LIBRARY=%{_libdir}/gcj-%{cc_version}-11/libjvm.so \
78ba8e2d 88%else
81ed0294 89 -DJAVA_JVM_LIBRARY=$(ls -1 %{_libdir}/gcj-%{cc_version}-*/libjvm.so | head -n 1) \
78ba8e2d 90%endif
84df784d 91 ../
195f432c 92
93%{__make}
94
95%install
96rm -rf $RPM_BUILD_ROOT
8667f3ab
JB
97
98%{__make} -C build install \
195f432c 99 DESTDIR=$RPM_BUILD_ROOT
100
101%clean
102rm -rf $RPM_BUILD_ROOT
103
104%post -p /sbin/ldconfig
105%postun -p /sbin/ldconfig
106
107%files
108%defattr(644,root,root,755)
2fc92623
RT
109%attr(755,root,root) %{_bindir}/sopranocmd
110%attr(755,root,root) %{_bindir}/sopranod
3dd5cf66 111%attr(755,root,root) %{_bindir}/onto2vocabularyclass
0b2cd574 112%attr(755,root,root) %{_libdir}/libsoprano.so.*.*.*
2fc92623 113%attr(755,root,root) %ghost %{_libdir}/libsoprano.so.4
5b9e452e 114%attr(755,root,root) %{_libdir}/libsopranoclient.so.*.*.*
2fc92623 115%attr(755,root,root) %ghost %{_libdir}/libsopranoclient.so.1
5b9e452e 116%attr(755,root,root) %{_libdir}/libsopranoserver.so.*.*.*
2fc92623 117%attr(755,root,root) %ghost %{_libdir}/libsopranoserver.so.1
3d311b00
RT
118%attr(755,root,root) %{_libdir}/libsopranoindex.so.*.*.*
119%attr(755,root,root) %ghost %{_libdir}/libsopranoindex.so.1
5b9e452e 120%dir %{_libdir}/soprano
0b2cd574 121%attr(755,root,root) %{_libdir}/soprano/libsoprano_redlandbackend.so
2fc92623
RT
122%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadparser.so
123%attr(755,root,root) %{_libdir}/soprano/libsoprano_nquadserializer.so
124%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorparser.so
c4571e50 125%{?with_sesame2:%attr(755,root,root) %{_libdir}/soprano/libsoprano_sesame2backend.so}
126%{?with_serializer:%attr(755,root,root) %{_libdir}/soprano/libsoprano_raptorserializer.so}
e8d4b674 127%{?with_virtuoso:%attr(755,root,root) %{_libdir}/soprano/libsoprano_virtuosobackend.so}
5b9e452e 128%{_datadir}/soprano
2fc92623
RT
129%{_datadir}/dbus-1/interfaces/org.soprano.Model.xml
130%{_datadir}/dbus-1/interfaces/org.soprano.NodeIterator.xml
131%{_datadir}/dbus-1/interfaces/org.soprano.QueryResultIterator.xml
132%{_datadir}/dbus-1/interfaces/org.soprano.Server.xml
133%{_datadir}/dbus-1/interfaces/org.soprano.StatementIterator.xml
134
195f432c 135%files devel
136%defattr(644,root,root,755)
0b2cd574 137%attr(755,root,root) %{_libdir}/libsoprano.so
2fc92623
RT
138%attr(755,root,root) %{_libdir}/libsopranoserver.so
139%attr(755,root,root) %{_libdir}/libsopranoclient.so
3d311b00 140%attr(755,root,root) %{_libdir}/libsopranoindex.so
195f432c 141%dir %{_includedir}/soprano
142%{_includedir}/soprano/*.h
2fc92623 143%{_includedir}/Soprano
5b9e452e 144%{_pkgconfigdir}/soprano.pc
0835c44e
AM
145%{_pkgconfigdir}/sopranoserver.pc
146%{_pkgconfigdir}/sopranoclient.pc
147%{_pkgconfigdir}/sopranoindex.pc
This page took 0.128512 seconds and 4 git commands to generate.