]> git.pld-linux.org Git - packages/sipp.git/commitdiff
- up to 3.5.1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 15 Feb 2017 08:57:21 +0000 (09:57 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 15 Feb 2017 08:57:21 +0000 (09:57 +0100)
sipp-headers.patch [deleted file]
sipp-sprintf.patch [deleted file]
sipp-stats_crash.patch [deleted file]
sipp.spec

diff --git a/sipp-headers.patch b/sipp-headers.patch
deleted file mode 100644 (file)
index 0e7c292..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -urN sipp-3.0.src.org/call.cpp sipp-3.0.src/call.cpp
---- sipp-3.0.src.org/call.cpp  2007-11-06 11:18:07.000000000 +0100
-+++ sipp-3.0.src/call.cpp      2008-08-21 14:31:22.054118798 +0200
-@@ -41,6 +41,7 @@
- #include <iostream>
- #include <sys/types.h>
- #include <sys/wait.h>
-+#include <limits.h>
- #ifdef PCAPPLAY
- #include "send_packets.h"
-diff -urN sipp-3.0.src.org/scenario.cpp sipp-3.0.src/scenario.cpp
---- sipp-3.0.src.org/scenario.cpp      2007-07-26 12:16:49.000000000 +0200
-+++ sipp-3.0.src/scenario.cpp  2008-08-21 14:30:20.810792636 +0200
-@@ -27,6 +27,7 @@
-  */
- #include <stdlib.h>
-+#include <limits.h>
- #include "sipp.hpp"
- #ifdef HAVE_GSL
- #include <gsl/gsl_rng.h>
diff --git a/sipp-sprintf.patch b/sipp-sprintf.patch
deleted file mode 100644 (file)
index 176065a..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -dur sipp-3.3.orig/stat.cpp sipp-3.3/stat.cpp
---- sipp-3.3.orig/stat.cpp     2012-12-22 02:50:15.000000000 +0100
-+++ sipp-3.3/stat.cpp  2013-05-17 12:11:26.000000000 +0200
-@@ -1148,7 +1148,7 @@
-     {
-       // if a repartition is present, this field match the repartition name
-       repartitionInfo = (char *)realloc(repartitionInfo, dlen + 1);
--      sprintf(repartitionInfo, stat_delimiter);
-+      strcpy(stat_delimiter, repartitionInfo);
-       for(int i=0; i<(sizeOfTab-1); i++)
-         {   
-           sprintf(buffer, "%lu%s", tabRepartition[i].nbInThisBorder, stat_delimiter);
diff --git a/sipp-stats_crash.patch b/sipp-stats_crash.patch
deleted file mode 100644 (file)
index ba8b883..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -dur sipp-3.3.orig/stat.cpp sipp-3.3/stat.cpp
---- sipp-3.3.orig/stat.cpp     2013-05-27 10:48:19.000000000 +0200
-+++ sipp-3.3/stat.cpp  2013-05-27 11:00:15.000000000 +0200
-@@ -1140,7 +1140,7 @@
- char* CStat::sRepartitionInfo(T_dynamicalRepartition * tabRepartition, 
-                               int sizeOfTab)
- {
--  static char *repartitionInfo;
-+  static char *repartitionInfo = NULL;
-   char buffer[MAX_CHAR_BUFFER_SIZE];
-   int dlen = strlen(stat_delimiter);
-@@ -1148,7 +1148,7 @@
-     {
-       // if a repartition is present, this field match the repartition name
-       repartitionInfo = (char *)realloc(repartitionInfo, dlen + 1);
--      strcpy(stat_delimiter, repartitionInfo);
-+      strcpy(repartitionInfo, stat_delimiter);
-       for(int i=0; i<(sizeOfTab-1); i++)
-         {   
-           sprintf(buffer, "%lu%s", tabRepartition[i].nbInThisBorder, stat_delimiter);
index a8f405667983cc4780ac542c589a22c298603d0f..ae901f701493d076c15e17702b7476c3a0a0c037 100644 (file)
--- a/sipp.spec
+++ b/sipp.spec
@@ -5,17 +5,15 @@
 
 Summary:       SIPp - a performance testing tool for the SIP protocol
 Name:          sipp
-Version:       3.3
+Version:       3.5.1
 Release:       1
 License:       GPL v2+ except two files under BSD
 Group:         Applications
-Source0:       http://download.sourceforge.net/sipp/%{name}-%{version}.tar.xz
-# Source0-md5: f0c4f472fa86de8a528cb91616323617
-Patch0:                %{name}-headers.patch
-Patch1:                %{name}-sprintf.patch
-Patch2:                %{name}-stats_crash.patch
-Patch3:                %{name}-OPTIONS_is_ping.patch
+Source0:       https://github.com/SIPp/sipp/releases/download/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: dcc658e735c28055d6052a36b331964f
+Patch0:                %{name}-OPTIONS_is_ping.patch
 URL:           http://sipp.sourceforge.net/
+BuildRequires: gsl-devel
 BuildRequires: libpcap-devel
 BuildRequires: libstdc++-devel
 BuildRequires: ncurses-devel
@@ -40,31 +38,29 @@ system.
 
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%{?with_options_is_ping:%patch3 -p1}
+%{?with_options_is_ping:%patch0 -p1}
 
 %build
-
-%{__make} pcapplay_ossl \
-       CC="%{__cc}" \
-       CPP="%{__cxx}" \
-       CCLINK="%{__cxx}" \
-       EXTRACFLAGS="%{rpmcflags}" \
-       EXTRACPPFLAGS="%{rpmcxxflags}" \
-       EXTRALFLAGS="%{rpmldflags}" \
-       INCDIR="-I. -I/usr/include/ncurses"
+%configure \
+       --disable-silent-rules \
+       --enable-epoll \
+       --with-openssl \
+       --with-pcap \
+       --with-sctp \
+       --with-gsl
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_bindir}
-install sipp $RPM_BUILD_ROOT%{_bindir}
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc LICENSE.txt MEDIA.txt README.txt pcap tools
-%attr(755,root,root) %{_bindir}/*
+%doc CHANGES.md FAQ.md README.md THANKS
+%attr(755,root,root) %{_bindir}/sipp
+%{_mandir}/man1/sipp.1*
This page took 0.061316 seconds and 4 git commands to generate.