]> git.pld-linux.org Git - packages/serf.git/blob - serf.spec
- x32 rebuild
[packages/serf.git] / serf.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # GSSAPI support
4 %bcond_with     tests           # perform "scons check" (uses localhost network, fails on apr side when IPV6 is enabled and localhost resolves only to IPV4 addresses)
5 #
6 Summary:        A high-performance asynchronous HTTP client library
7 Summary(pl.UTF-8):      Wysokowydajna biblioteka asynchronicznego klienta HTTP
8 Name:           serf
9 Version:        1.3.8
10 Release:        2
11 License:        Apache v2.0
12 Group:          Libraries
13 #Source0Download: http://code.google.com/p/serf/downloads/list
14 Source0:        http://serf.googlecode.com/svn/src_releases/%{name}-%{version}.tar.bz2
15 # Source0-md5:  2e4efe57ff28cb3202a112e90f0c2889
16 Patch0:         %{name}-scons.patch
17 URL:            http://code.google.com/p/serf/
18 BuildRequires:  apr-devel
19 BuildRequires:  apr-util-devel
20 %{?with_kerberos5:BuildRequires:        heimdal-devel}
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  scons >= 2.3.0
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The serf library is a C-based HTTP client library built upon the
28 Apache Portable Runtime (APR) library. It multiplexes connections,
29 running the read/write communication asynchronously. Memory copies and
30 transformations are kept to a minimum to provide high performance
31 operation.
32
33 %description -l pl.UTF-8
34 Biblioteka serf to napisana w C biblioteka klienta HTTP stworzona w
35 oparciu o bibliotekę Apache Portable Runtime (APR). Obsługuje
36 połączenia naprzemiennie, wywołując asynchronicznie komunikację
37 odczyt-zapis. Kopiowanie i transformacje w pamięci są ograniczone do
38 minimum w celu zapewnienia wydajnego działania.
39
40 %package devel
41 Summary:        Header files for serf
42 Summary(pl.UTF-8):      Pliki nagłówkowe serf
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       apr-devel
46 Requires:       apr-util-devel
47 %{?with_kerberos5:Requires:     heimdal-devel}
48 Requires:       openssl-devel >= 0.9.7d
49
50 %description devel
51 C header files for the serf library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe dla biblioteki serf.
55
56 %package static
57 Summary:        Static libraries for serf
58 Summary(pl.UTF-8):      Biblioteki statyczne serf
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static serf libraries.
64
65 %description static -l pl.UTF-8
66 Statyczne biblioteki serf.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 %scons \
74         PREFIX=%{_prefix} \
75         LIBDIR=%{_libdir} \
76         GSSAPI=/usr
77
78 %if %{with tests}
79 %scons check
80 %endif
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %scons install \
86         PREFIX=%{_prefix} \
87         LIBDIR=%{_libdir} \
88         --install-sandbox=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc CHANGES NOTICE README
99 %attr(755,root,root) %{_libdir}/libserf-1.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libserf-1.so.1
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libserf-1.so
105 %{_includedir}/serf-1
106 %{_pkgconfigdir}/serf-1.pc
107
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libserf-1.a
This page took 0.029055 seconds and 3 git commands to generate.