]> git.pld-linux.org Git - packages/sdcc.git/blob - sdcc.spec
5c6e7cb4b505231a2c211d4ae40263c35047875c
[packages/sdcc.git] / sdcc.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # don't rebuild documentation
4
5 Summary:        C compiler for Intel 8051 and Zilog Z80
6 Summary(pl.UTF-8):      Kompilator C dla Intel 8051 i Zilog Z80
7 Name:           sdcc
8 Version:        3.5.0
9 Release:        1
10 License:        GPL v2+ (tools), GPL v2+ with linking exception (runtime)
11 Group:          Development/Languages
12 Source0:        http://downloads.sourceforge.net/sdcc/%{name}-src-%{version}.tar.bz2
13 # Source0-md5:  e0a1df72747c481cdedbbd328b0fceae
14 URL:            http://sdcc.sourceforge.net/
15 BuildRequires:  bison
16 BuildRequires:  boost-devel
17 BuildRequires:  flex
18 BuildRequires:  gc-devel
19 BuildRequires:  gputils
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  sed >= 4.0
22 %if %{with doc}
23 BuildRequires:  latex2html
24 BuildRequires:  lyx >= 1.4.4
25 BuildRequires:  texlive-fonts-cmsuper
26 BuildRequires:  texlive-fonts-type1-urw
27 BuildRequires:  texlive-format-pdflatex
28 BuildRequires:  texlive-latex-ams
29 BuildRequires:  texlive-makeindex
30 BuildRequires:  texlive-tex-babel
31 BuildRequires:  texlive-xetex
32 %endif
33 Obsoletes:      ucsim
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautostrip    .*%{_datadir}/%{name}/.*
37
38 %description
39 SDCC is retargettable, optimizing ANSI-C compiler. The current version
40 targets the Intel 8051 and recently the Zilog Z80 based MCUs. SDCC can
41 be retargeted for other 8 bit MCUs or PICs and some day soon will be.
42 Supported data types are short (8 bits, 1 byte), char (8 bits, 1
43 byte), int (16 bits, 2 bytes), long (32 bit, 4 bytes) and float (4
44 byte IEEE). SDCC also comes with the source level debugger SDCDB.
45
46 %description -l pl.UTF-8
47 SDCC jest optymalizującym kompilatorem ANSI C dla wielu platform.
48 Aktualna wersja obsługuje procesory Intel 8051 oraz Zilog Z80. SDCC
49 może być łatwo zmodyfikowany by obsługiwać inne 8-bitowe jednostki.
50 Obsługiwane typy danych to short (8 bitów, 1 bajt), char (8 bitów, 1
51 bajt), int (16 bitów, 2 bajty), long (32 bity, 4 bajty) oraz float (4
52 bajty IEEE). SDCC dostarcza również debugger oparty na emulatorze
53 ucsim.
54
55 %package -n emacs-sdcdb
56 Summary:        SDCDB debugger support for Emacs
57 Summary(pl.UTF-8):      Obsługa debuggera SDCDB dla Emacsa
58 Group:          Development/Tools
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       emacs
61
62 %description -n emacs-sdcdb
63 SDCDB debugger support for Emacs.
64
65 %description -n emacs-sdcdb -l pl.UTF-8
66 Obsługa debuggera SDCDB dla Emacsa.
67
68 %prep
69 %setup -q
70
71 %{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' support/scripts/as2gbmap.py
72
73 %build
74 %configure \
75         PDFOPT=/bin/cp \
76         %{__enable_disable doc} \
77         --enable-libgc \
78         --enable-ucsim \
79         --enable-xa \
80         --enable-serio \
81         --enable-statistic
82
83 %{__make} -j1
84
85 %{__make} -C device/lib -j1 model-mcs51-stack-auto model-mcs51-xstack-auto
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
90
91 %{__make} install \
92         "DESTDIR=$RPM_BUILD_ROOT" \
93         "docdir=%{_docdir}/%{name}-%{version}" \
94         "STRIP=/bin/true"
95
96 %{__mv} $RPM_BUILD_ROOT%{_bindir}/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files
102 %defattr(644,root,root,755)
103 %doc %{_docdir}/%{name}-%{version}
104 %attr(755,root,root) %{_bindir}/as2gbmap
105 %attr(755,root,root) %{_bindir}/makebin
106 %attr(755,root,root) %{_bindir}/packihx
107 %attr(755,root,root) %{_bindir}/s51
108 %attr(755,root,root) %{_bindir}/sdar
109 %attr(755,root,root) %{_bindir}/sdas*
110 %attr(755,root,root) %{_bindir}/sdcc
111 %attr(755,root,root) %{_bindir}/sdcclib
112 %attr(755,root,root) %{_bindir}/sdcdb
113 %attr(755,root,root) %{_bindir}/sdcpp
114 %attr(755,root,root) %{_bindir}/sdld*
115 %attr(755,root,root) %{_bindir}/sdnm
116 %attr(755,root,root) %{_bindir}/sdobjcopy
117 %attr(755,root,root) %{_bindir}/sdranlib
118 %attr(755,root,root) %{_bindir}/shc08
119 %attr(755,root,root) %{_bindir}/sstm8
120 %attr(755,root,root) %{_bindir}/sz80
121 %{_datadir}/%{name}
122
123 %files -n emacs-sdcdb
124 %defattr(644,root,root,755)
125 %{_datadir}/emacs/site-lisp/sdcdb.el
126 %{_datadir}/emacs/site-lisp/sdcdbsrc.el
This page took 0.128987 seconds and 3 git commands to generate.