]> git.pld-linux.org Git - packages/scribus.git/commitdiff
- recognize sparc processors
authortommat <tommat@pld-linux.org>
Sun, 11 May 2008 18:54:58 +0000 (18:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- recognize sparc64 as 64bit arch

Changed files:
    scribus-sparc.patch -> 1.1

scribus-sparc.patch [new file with mode: 0644]

diff --git a/scribus-sparc.patch b/scribus-sparc.patch
new file mode 100644 (file)
index 0000000..6ea3fdf
--- /dev/null
@@ -0,0 +1,28 @@
+--- scribus-1.3.3.11/CMakeLists.txt.orig       2008-05-11 15:01:48.000000000 +0000
++++ scribus-1.3.3.11/CMakeLists.txt    2008-05-11 15:06:05.000000000 +0000
+@@ -74,6 +74,25 @@
+     SET(ARCH_PPC 1)
+ ENDIF (_machine_ppc)
++STRING(REGEX MATCH "(sparc-*)" _machine_sparc "${MACHINE}")
++IF (_machine_sparc)
++    MESSAGE(STATUS "Found target Sparc")
++    SET(ARCH_SPARC 1)
++ENDIF (_machine_sparc)
++
++STRING(REGEX MATCH "(sparcv9-*)" _machine_sparcv9 "${MACHINE}")
++IF (_machine_sparcv9)
++    MESSAGE(STATUS "Found target Sparc v9")
++    SET(ARCH_SPARCV9 1)
++ENDIF (_machine_sparcv9)
++
++STRING(REGEX MATCH "(sparc64-*)" _machine_sparc64 "${MACHINE}")
++IF (_machine_sparc64)
++    MESSAGE(STATUS "Found target Sparc64")
++    SET(ARCH_SPARC64 1)
++    SET(ARCH64BIT 1)
++ENDIF (_machine_sparc64)
++
+ #convert any 64 bit build into generic 64 tag for below
+ IF (ARCH_X86_64) 
+   SET(ARCH64BIT 1)
This page took 0.114979 seconds and 4 git commands to generate.