]> git.pld-linux.org Git - packages/scribus.git/commitdiff
- updated to 1.5.6.1 auto/th/scribus-1.5.6.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 14 Dec 2020 05:31:12 +0000 (06:31 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 14 Dec 2020 05:31:12 +0000 (06:31 +0100)
- updated docs patch
- removed obsolete sparc,qt-5.15,poppler-*,gcc10 patches
- standard-font-paths patch seems obsolete too (scribus now uses fontconfig to discover fonts)

gcc10.patch [deleted file]
poppler-0.84.0.patch [deleted file]
poppler-0.86.0.patch [deleted file]
qt-5.15.patch [deleted file]
scribus-docs.patch
scribus-sparc.patch [deleted file]
scribus-standard-font-paths.patch [deleted file]
scribus.spec

diff --git a/gcc10.patch b/gcc10.patch
deleted file mode 100644 (file)
index ba7747c..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- scribus-1.5.5/scribus/plugins/import/pdf/slaoutput.h~      2020-08-01 12:12:08.000000000 +0200
-+++ scribus-1.5.5/scribus/plugins/import/pdf/slaoutput.h       2020-08-01 12:15:46.683302925 +0200
-@@ -229,7 +229,7 @@
\r
-       //----- image drawing\r
-       void drawImageMask(GfxState *state, Object *ref, Stream *str, int width, int height, GBool invert, GBool interpolate, GBool inlineImg) override;\r
--      void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg) override;\r
-+      void drawImage(GfxState *state, Object *ref, Stream *str, int width, int height, GfxImageColorMap *colorMap, GBool interpolate, int *maskColors, GBool inlineImg);\r
-       void drawSoftMaskedImage(GfxState *state, Object *ref, Stream *str,\r
-                                  int width, int height,\r
-                                  GfxImageColorMap *colorMap,\r
-@@ -261,8 +261,8 @@
-       //----- text drawing\r
-       void  beginTextObject(GfxState *state) override;\r
-       void  endTextObject(GfxState *state) override;\r
--      void  drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, Unicode * /*u*/, int /*uLen*/) override;\r
--      GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, Unicode * /*u*/, int /*uLen*/) override;\r
-+      void  drawChar(GfxState *state, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, double /*originX*/, double /*originY*/, CharCode /*code*/, int /*nBytes*/, Unicode * /*u*/, int /*uLen*/);\r
-+      GBool beginType3Char(GfxState * /*state*/, double /*x*/, double /*y*/, double /*dx*/, double /*dy*/, CharCode /*code*/, Unicode * /*u*/, int /*uLen*/);\r
-       void  endType3Char(GfxState * /*state*/) override;\r
-       void  type3D0(GfxState * /*state*/, double /*wx*/, double /*wy*/) override;\r
-       void  type3D1(GfxState * /*state*/, double /*wx*/, double /*wy*/, double /*llx*/, double /*lly*/, double /*urx*/, double /*ury*/) override;\r
diff --git a/poppler-0.84.0.patch b/poppler-0.84.0.patch
deleted file mode 100644 (file)
index 3c44024..0000000
+++ /dev/null
@@ -1,157 +0,0 @@
---- a/scribus/plugins/import/pdf/importpdf.cpp
-+++ b/scribus/plugins/import/pdf/importpdf.cpp
-@@ -74,7 +74,11 @@ PdfPlug::PdfPlug(ScribusDoc* doc, int flags)
- QImage PdfPlug::readThumbnail(const QString& fName)\r
- {\r
-       QString pdfFile = QDir::toNativeSeparators(fName);\r
-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)\r
-+      globalParams.reset(new GlobalParams());\r
-+#else\r
-       globalParams = new GlobalParams();\r
-+#endif\r
-       if (globalParams)\r
-       {\r
- #if defined(Q_OS_WIN32) && POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 62, 0)\r
-@@ -89,7 +93,9 @@ QImage PdfPlug::readThumbnail(const QString& fName)
-                       if (pdfDoc->getErrorCode() == errEncrypted)\r
-                       {\r
-                               delete pdfDoc;\r
-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
-                               delete globalParams;\r
-+#endif\r
-                               return QImage();\r
-                       }\r
-                       if (pdfDoc->isOk())\r
-@@ -133,11 +139,15 @@ QImage PdfPlug::readThumbnail(const QString& fName)
-                               image.setText("YSize", QString("%1").arg(h));\r
-                               delete dev;\r
-                               delete pdfDoc;\r
-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
-                               delete globalParams;\r
-+#endif\r
-                               return image;\r
-                       }\r
-                       delete pdfDoc;\r
-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
-                       delete globalParams;\r
-+#endif\r
-               }\r
-       }\r
-       return QImage();\r
-@@ -343,7 +353,11 @@ bool PdfPlug::convert(const QString& fn)
-               qApp->processEvents();\r
-       }\r
\r
-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)\r
-+      globalParams.reset(new GlobalParams());\r
-+#else\r
-       globalParams = new GlobalParams();\r
-+#endif\r
-       GooString *userPW = nullptr;\r
-       if (globalParams)\r
-       {\r
-@@ -385,7 +399,9 @@ bool PdfPlug::convert(const QString& fn)
-                                       if (progressDialog)\r
-                                               progressDialog->close();\r
-                                       delete pdfDoc;\r
-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
-                                       delete globalParams;\r
-+#endif\r
-                                       return false;\r
-                               }\r
-                               if (progressDialog)\r
-@@ -430,7 +446,9 @@ bool PdfPlug::convert(const QString& fn)
-                                                       progressDialog->close();\r
-                                               delete optImp;\r
-                                               delete pdfDoc;\r
-+#if POPPLER_ENCODED_VERSION < POPPLER_VERSION_ENCODE(0, 83, 0)\r
-                                               delete globalParams;\r
-+#endif\r
-                                               return false;\r
-                                       }\r
-                                       pageString = optImp->getPagesString();\r
-@@ -843,8 +861,12 @@ bool PdfPlug::convert(const QString& fn)
-               }\r
-               delete pdfDoc;\r
-       }\r
-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)\r
-+      globalParams.release();\r
-+#else\r
-       delete globalParams;\r
-       globalParams = nullptr;\r
-+#endif\r
\r
- //    qDebug() << "converting finished";\r
- //    qDebug() << "Imported" << Elements.count() << "Elements";\r
-diff --git a/scribus/plugins/import/pdf/importpdfconfig.h b/scribus/plugins/import/pdf/importpdfconfig.h
-index 9913ee382..5a7e0d216 100644
---- a/scribus/plugins/import/pdf/importpdfconfig.h
-+++ b/scribus/plugins/import/pdf/importpdfconfig.h
-@@ -58,4 +58,10 @@ for which a new license (GPL+exception) is in place.
- #define POPPLER_CONST_082\r
- #endif\r
\r
-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 83, 0)\r
-+#define POPPLER_CONST_083 const\r
-+#else\r
-+#define POPPLER_CONST_083\r
-+#endif\r
-+\r
- #endif\r
-diff --git a/scribus/plugins/import/pdf/slaoutput.cpp b/scribus/plugins/import/pdf/slaoutput.cpp
-index 5e4d32a55..ffcfa8450 100644
---- a/scribus/plugins/import/pdf/slaoutput.cpp
-+++ b/scribus/plugins/import/pdf/slaoutput.cpp
-@@ -3678,7 +3678,7 @@ QString SlaOutputDev::getAnnotationColor(const AnnotColor *color)
-       return fNam;\r
- }\r
\r
--QString SlaOutputDev::convertPath(GfxPath *path)\r
-+QString SlaOutputDev::convertPath(POPPLER_CONST_083 GfxPath *path)\r
- {\r
-       if (! path)\r
-               return QString();\r
-@@ -3688,7 +3688,7 @@ QString SlaOutputDev::convertPath(GfxPath *path)
\r
-       for (int i = 0; i < path->getNumSubpaths(); ++i)\r
-       {\r
--              GfxSubpath * subpath = path->getSubpath(i);\r
-+              POPPLER_CONST_083 GfxSubpath * subpath = path->getSubpath(i);\r
-               if (subpath->getNumPoints() > 0)\r
-               {\r
-                       output += QString("M %1 %2").arg(subpath->getX(0)).arg(subpath->getY(0));\r
-diff --git a/scribus/plugins/import/pdf/slaoutput.h b/scribus/plugins/import/pdf/slaoutput.h
-index 60fb90061..d928fada8 100644
---- a/scribus/plugins/import/pdf/slaoutput.h
-+++ b/scribus/plugins/import/pdf/slaoutput.h
-@@ -282,7 +282,7 @@ private:
-       void getPenState(GfxState *state);\r
-       QString getColor(GfxColorSpace *color_space, POPPLER_CONST_070 GfxColor *color, int *shade);\r
-       QString getAnnotationColor(const AnnotColor *color);\r
--      QString convertPath(GfxPath *path);\r
-+      QString convertPath(POPPLER_CONST_083 GfxPath *path);\r
-       int getBlendMode(GfxState *state);\r
-       void applyMask(PageItem *ite);\r
-       void pushGroup(const QString& maskName = "", GBool forSoftMask = gFalse, GBool alpha = gFalse, bool inverted = false);\r
---- a/scribus/plugins/import/pdf/slaoutput.cpp
-+++ b/scribus/plugins/import/pdf/slaoutput.cpp
-@@ -1189,6 +1189,11 @@ void SlaOutputDev::startDoc(PDFDoc *doc, XRef *xrefA, Catalog *catA)
-       catalog = catA;\r
-       pdfDoc = doc;\r
-       updateGUICounter = 0;\r
-+#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 84, 0)\r
-+      m_fontEngine = new SplashFontEngine(true, true, true, true);\r
-+#elif POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(0, 61, 0)\r
-+      m_fontEngine = new SplashFontEngine(globalParams->getEnableFreeType(), true, true, true);\r
-+#else\r
-       m_fontEngine = new SplashFontEngine(\r
- #if HAVE_T1LIB_H\r
-       globalParams->getEnableT1lib(),\r
-@@ -1199,6 +1204,7 @@ void SlaOutputDev::startDoc(PDFDoc *doc, XRef *xrefA, Catalog *catA)
-       true,\r
- #endif\r
-       true);\r
-+#endif\r
- }\r
\r
- void SlaOutputDev::startPage(int pageNum, GfxState *, XRef *)\r
diff --git a/poppler-0.86.0.patch b/poppler-0.86.0.patch
deleted file mode 100644 (file)
index 8200f64..0000000
+++ /dev/null
@@ -1,201 +0,0 @@
---- scribus-1.5.6/scribus/plugins/import/pdf/importpdf.cpp
-+++ scribus-1.5.6/scribus/plugins/import/pdf/importpdf.cpp
-@@ -792,14 +792,15 @@ bool PdfPlug::convert(const QString& fn)
-                                                               names = catDict.dictLookup("OpenAction");\r
-                                                               if (names.isDict())\r
-                                                               {\r
--                                                                      LinkAction *linkAction = nullptr;\r
-+                                                                      std::unique_ptr<::LinkAction> linkAction;\r
-                                                                       linkAction = LinkAction::parseAction(&names, pdfDoc->getCatalog()->getBaseURI());\r
-                                                                       if (linkAction)\r
-                                                                       {\r
--                                                                              LinkJavaScript *jsa = (LinkJavaScript*)linkAction;\r
-+                                                                              LinkJavaScript *jsa = static_cast<LinkJavaScript *>(linkAction.get());
-                                                                               if (jsa->isOk())\r
-                                                                               {\r
--                                                                                      QString script = UnicodeParsedString(jsa->getScript());\r
-+                                                                                      const GooString scriptGooString(jsa->getScript());
-+                                                                                      QString script = UnicodeParsedString(&scriptGooString);\r
-                                                                                       if (script.startsWith("this."))\r
-                                                                                       {\r
-                                                                                               script.remove(0, 5);\r
---- scribus-1.5.6/scribus/plugins/import/pdf/slaoutput.cpp
-+++ scribus-1.5.6/scribus/plugins/import/pdf/slaoutput.cpp
-@@ -324,7 +324,7 @@ LinkAction* SlaOutputDev::SC_getAddition
-               {\r
-                       Object actionObject = additionalActionsObject.dictLookup(key);\r
-                       if (actionObject.isDict())\r
--                              linkAction = LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI());\r
-+                              linkAction = (LinkAction::parseAction(&actionObject, pdfDoc->getCatalog()->getBaseURI())).release();\r
-               }\r
-       }\r
-       return linkAction;\r
-@@ -455,7 +455,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot
-                       POPPLER_CONST GooString *ndst = gto->getNamedDest();\r
-                       if (ndst)\r
-                       {\r
--                              LinkDest *dstn = pdfDoc->findDest(ndst);\r
-+                              std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);\r
-                               if (dstn)\r
-                               {\r
-                                       if (dstn->getKind() == destXYZ)\r
-@@ -499,7 +499,7 @@ bool SlaOutputDev::handleLinkAnnot(Annot
-                       POPPLER_CONST GooString *ndst = gto->getNamedDest();\r
-                       if (ndst)\r
-                       {\r
--                              LinkDest *dstn = pdfDoc->findDest(ndst);\r
-+                              std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);\r
-                               if (dstn)\r
-                               {\r
-                                       if (dstn->getKind() == destXYZ)\r
-@@ -516,8 +516,9 @@ bool SlaOutputDev::handleLinkAnnot(Annot
-       else if (act->getKind() == actionURI)\r
-       {\r
-               LinkURI *gto = (LinkURI*)act;\r
-+              const GooString uriGooString(gto->getURI());
-               validLink = true;\r
--              fileName = UnicodeParsedString(gto->getURI());\r
-+              fileName = UnicodeParsedString(&uriGooString);\r
-       }\r
-       if (validLink)\r
-       {\r
-@@ -929,8 +930,9 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Lact;\r
-                       if (jsa->isOk())\r
-                       {\r
-+                              const GooString scriptGooString(jsa->getScript());
-                               ite->annotation().setActionType(1);\r
--                              ite->annotation().setAction(UnicodeParsedString(jsa->getScript()));\r
-+                              ite->annotation().setAction(UnicodeParsedString(&scriptGooString));\r
-                       }\r
-               }\r
-               else if (Lact->getKind() == actionGoTo)\r
-@@ -967,7 +969,7 @@ void SlaOutputDev::handleActions(PageIte
-                               POPPLER_CONST GooString *ndst = gto->getNamedDest();\r
-                               if (ndst)\r
-                               {\r
--                                      LinkDest *dstn = pdfDoc->findDest(ndst);\r
-+                                      std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);\r
-                                       if (dstn)\r
-                                       {\r
-                                               if (dstn->getKind() == destXYZ)\r
-@@ -1019,7 +1021,7 @@ void SlaOutputDev::handleActions(PageIte
-                               POPPLER_CONST GooString *ndst = gto->getNamedDest();\r
-                               if (ndst)\r
-                               {\r
--                                      LinkDest *dstn = pdfDoc->findDest(ndst);\r
-+                                      std::unique_ptr<LinkDest> dstn = pdfDoc->findDest(ndst);\r
-                                       if (dstn)\r
-                                       {\r
-                                               if (dstn->getKind() == destXYZ)\r
-@@ -1039,7 +1041,8 @@ void SlaOutputDev::handleActions(PageIte
-               else if (Lact->getKind() == actionUnknown)\r
-               {\r
-                       LinkUnknown *uno = (LinkUnknown*)Lact;\r
--                      QString actString = UnicodeParsedString(uno->getAction());\r
-+                      const GooString actionGooString(uno->getAction());
-+                      QString actString = UnicodeParsedString(&actionGooString);\r
-                       if (actString == "ResetForm")\r
-                       {\r
-                               ite->annotation().setActionType(4);\r
-@@ -1082,8 +1085,9 @@ void SlaOutputDev::handleActions(PageIte
-               else if (Lact->getKind() == actionNamed)\r
-               {\r
-                       LinkNamed *uno = (LinkNamed*)Lact;\r
-+                      const GooString nameGooString(uno->getName());
-                       ite->annotation().setActionType(10);\r
--                      ite->annotation().setAction(UnicodeParsedString(uno->getName()));\r
-+                      ite->annotation().setAction(UnicodeParsedString(&nameGooString));\r
-               }\r
-               else\r
-                       qDebug() << "Found unsupported Action of type" << Lact->getKind();\r
-@@ -1096,7 +1100,8 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
-                       if (jsa->isOk())\r
-                       {\r
--                              ite->annotation().setD_act(UnicodeParsedString(jsa->getScript()));\r
-+                              const GooString scriptGooString(jsa->getScript());
-+                              ite->annotation().setD_act(UnicodeParsedString(&scriptGooString));\r
-                               ite->annotation().setAAact(true);\r
-                       }\r
-               }\r
-@@ -1110,7 +1115,8 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
-                       if (jsa->isOk())\r
-                       {\r
--                              ite->annotation().setE_act(UnicodeParsedString(jsa->getScript()));\r
-+                              const GooString scriptGooString(jsa->getScript());
-+                              ite->annotation().setE_act(UnicodeParsedString(&scriptGooString));\r
-                               ite->annotation().setAAact(true);\r
-                       }\r
-               }\r
-@@ -1124,7 +1130,8 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
-                       if (jsa->isOk())\r
-                       {\r
--                              ite->annotation().setX_act(UnicodeParsedString(jsa->getScript()));\r
-+                              const GooString scriptGooString(jsa->getScript());
-+                              ite->annotation().setX_act(UnicodeParsedString(&scriptGooString));\r
-                               ite->annotation().setAAact(true);\r
-                       }\r
-               }\r
-@@ -1138,7 +1145,8 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
-                       if (jsa->isOk())\r
-                       {\r
--                              ite->annotation().setFo_act(UnicodeParsedString(jsa->getScript()));\r
-+                              const GooString scriptGooString(jsa->getScript());
-+                              ite->annotation().setFo_act(UnicodeParsedString(&scriptGooString));\r
-                               ite->annotation().setAAact(true);\r
-                       }\r
-               }\r
-@@ -1152,7 +1160,8 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
-                       if (jsa->isOk())\r
-                       {\r
--                              ite->annotation().setBl_act(UnicodeParsedString(jsa->getScript()));\r
-+                              const GooString scriptGooString(jsa->getScript());
-+                              ite->annotation().setBl_act(UnicodeParsedString(&scriptGooString));\r
-                               ite->annotation().setAAact(true);\r
-                       }\r
-               }\r
-@@ -1166,7 +1175,8 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
-                       if (jsa->isOk())\r
-                       {\r
--                              ite->annotation().setC_act(UnicodeParsedString(jsa->getScript()));\r
-+                              const GooString scriptGooString(jsa->getScript());
-+                              ite->annotation().setC_act(UnicodeParsedString(&scriptGooString));\r
-                               ite->annotation().setAAact(true);\r
-                       }\r
-               }\r
-@@ -1180,7 +1190,8 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
-                       if (jsa->isOk())\r
-                       {\r
--                              ite->annotation().setF_act(UnicodeParsedString(jsa->getScript()));\r
-+                              const GooString scriptGooString(jsa->getScript());
-+                              ite->annotation().setF_act(UnicodeParsedString(&scriptGooString));\r
-                               ite->annotation().setAAact(true);\r
-                               ite->annotation().setFormat(5);\r
-                       }\r
-@@ -1195,7 +1206,8 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
-                       if (jsa->isOk())\r
-                       {\r
--                              ite->annotation().setK_act(UnicodeParsedString(jsa->getScript()));\r
-+                              const GooString scriptGooString(jsa->getScript());
-+                              ite->annotation().setK_act(UnicodeParsedString(&scriptGooString));\r
-                               ite->annotation().setAAact(true);\r
-                               ite->annotation().setFormat(5);\r
-                       }\r
-@@ -1210,7 +1222,8 @@ void SlaOutputDev::handleActions(PageIte
-                       LinkJavaScript *jsa = (LinkJavaScript*)Aact;\r
-                       if (jsa->isOk())\r
-                       {\r
--                              ite->annotation().setV_act(UnicodeParsedString(jsa->getScript()));\r
-+                              const GooString scriptGooString(jsa->getScript());
-+                              ite->annotation().setV_act(UnicodeParsedString(&scriptGooString));\r
-                               ite->annotation().setAAact(true);\r
-                       }\r
-               }\r
diff --git a/qt-5.15.patch b/qt-5.15.patch
deleted file mode 100644 (file)
index 5b9bc00..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- scribus-1.5.5/scribus/ui/scresizecursor.cpp~       2019-07-31 00:34:50.000000000 +0200
-+++ scribus-1.5.5/scribus/ui/scresizecursor.cpp        2020-08-01 12:08:46.353067959 +0200
-@@ -12,6 +12,7 @@
- #include <QDebug>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QPixmap>
- #include <QPen>
- #include <QBrush>
index 2635059d0819db3eab8367c101dd1196572145e5..19f92a648e1bbf0d3d78f9a7f9863c1d5ebb7145 100644 (file)
@@ -1,6 +1,6 @@
---- scribus-1.5.5/CMakeLists.txt~      2019-07-31 00:34:43.000000000 +0200
-+++ scribus-1.5.5/CMakeLists.txt       2020-08-01 11:43:01.688045033 +0200
-@@ -316,11 +316,11 @@
+--- scribus-1.5.6.1/CMakeLists_Directories.cmake.orig  2020-11-14 23:37:41.000000000 +0100
++++ scribus-1.5.6.1/CMakeLists_Directories.cmake       2020-12-13 06:30:34.902088690 +0100
+@@ -39,11 +39,11 @@
  if(WIN32 OR OS2)
        set(DOCDIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/")
  elseif(TAG_VERSION OR BUILD_OSX_BUNDLE)
diff --git a/scribus-sparc.patch b/scribus-sparc.patch
deleted file mode 100644 (file)
index 6ea3fdf..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
---- scribus-1.3.3.11/CMakeLists.txt.orig       2008-05-11 15:01:48.000000000 +0000
-+++ scribus-1.3.3.11/CMakeLists.txt    2008-05-11 15:06:05.000000000 +0000
-@@ -74,6 +74,25 @@
-     SET(ARCH_PPC 1)
- ENDIF (_machine_ppc)
-+STRING(REGEX MATCH "(sparc-*)" _machine_sparc "${MACHINE}")
-+IF (_machine_sparc)
-+    MESSAGE(STATUS "Found target Sparc")
-+    SET(ARCH_SPARC 1)
-+ENDIF (_machine_sparc)
-+
-+STRING(REGEX MATCH "(sparcv9-*)" _machine_sparcv9 "${MACHINE}")
-+IF (_machine_sparcv9)
-+    MESSAGE(STATUS "Found target Sparc v9")
-+    SET(ARCH_SPARCV9 1)
-+ENDIF (_machine_sparcv9)
-+
-+STRING(REGEX MATCH "(sparc64-*)" _machine_sparc64 "${MACHINE}")
-+IF (_machine_sparc64)
-+    MESSAGE(STATUS "Found target Sparc64")
-+    SET(ARCH_SPARC64 1)
-+    SET(ARCH64BIT 1)
-+ENDIF (_machine_sparc64)
-+
- #convert any 64 bit build into generic 64 tag for below
- IF (ARCH_X86_64) 
-   SET(ARCH64BIT 1)
diff --git a/scribus-standard-font-paths.patch b/scribus-standard-font-paths.patch
deleted file mode 100644 (file)
index bc1742a..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- scribus-0.8/scribus/scfonts.cpp.orig       Sun Sep 22 10:54:38 2002
-+++ scribus-0.8/scribus/scfonts.cpp    Thu Oct 24 11:53:26 2002
-@@ -1048,6 +1048,8 @@
-       char **fontpath=XGetFontPath(display,&pathcount);
-       for (i=0; i<pathcount; ++i)
-               addPath(fontpath[i]);
-+      addPath("/usr/share/fonts/Type1");
-+      addPath("/usr/share/fonts/TTF");
-       XFreeFontPath(fontpath);
- }
index d991ec59ac782c73fa758e9aabf544fa252f129e..fab47f241dbd669cc9d37a45e32233ea0070c72a 100644 (file)
@@ -6,24 +6,18 @@
 # Conditional build:
 %bcond_without cups    # CUPS support
 #
-%define        qt_ver  5.7.0
+%define        qt_ver  5.11.0
 Summary:       Scribus - Open Source Desktop Publishing
 Summary(pl.UTF-8):     Scribus - DTP dla Wolnego Oprogramowania
 Name:          scribus
-Version:       1.5.5
-Release:       3
+Version:       1.5.6.1
+Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Publishing
 Source0:       http://downloads.sourceforge.net/scribus/%{name}-%{version}.tar.xz
-# Source0-md5: 6a9ddc8c45356d3c6c741e4c7bb0565a
-Patch1:                %{name}-standard-font-paths.patch
-Patch2:                %{name}-docs.patch
-Patch3:                %{name}-sparc.patch
-Patch4:                qt-5.15.patch
-Patch5:                poppler-0.84.0.patch
-Patch6:                poppler-0.86.0.patch
-Patch7:                gcc10.patch
-URL:           http://www.scribus.net/
+# Source0-md5: 12700cd8c6f08ef02f50495d2ef2d3ce
+Patch0:                %{name}-docs.patch
+URL:           https://www.scribus.net/
 BuildRequires: GraphicsMagick-devel
 BuildRequires: Qt5Core-devel >= %{qt_ver}
 BuildRequires: Qt5Gui-devel >= %{qt_ver}
@@ -34,7 +28,7 @@ BuildRequires:        Qt5Widgets-devel >= %{qt_ver}
 BuildRequires: Qt5Xml-devel >= %{qt_ver}
 BuildRequires: boost-devel
 BuildRequires: cairo-devel >= 1.2.0
-BuildRequires: cmake >= 3.2.0
+BuildRequires: cmake >= 3.12.0
 %if %{with cups}
 BuildRequires: cups-devel
 %else
@@ -54,8 +48,7 @@ BuildRequires:        libicu-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libmspub-devel >= 0.1
 BuildRequires: libpagemaker-devel
-# disabled in 1.5.5
-#BuildRequires:        libpng-devel
+BuildRequires: libpng-devel >= 1.6
 BuildRequires: libqxp-devel
 BuildRequires: librevenge-devel
 BuildRequires: libstdc++-devel >= 6:4.7
@@ -162,13 +155,7 @@ Domyślne szablony dokumentów dostarczane wraz ze Scribusem.
 
 %prep
 %setup -q
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%patch6 -p1
-%patch7 -p1
+%patch0 -p1
 
 %build
 mkdir -p build
@@ -195,6 +182,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.{kn_IN,kn}.qm
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.{lt_LT,lt}.qm
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.{mn_MN,mn}.qm
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.{ms_MY,ms}.qm
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.{nb_NO,nb}.qm
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.{pl_PL,pl}.qm
 %{__mv} $RPM_BUILD_ROOT%{_datadir}/%{name}/translations/%{name}.{pt_PT,pt}.qm
@@ -263,6 +251,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}/doc/en
 %lang(de) %{_datadir}/%{name}/doc/de
 %lang(it) %{_datadir}/%{name}/doc/it
+%lang(ru) %{_datadir}/%{name}/doc/ru
 
 %files icc
 %defattr(644,root,root,755)
This page took 0.056495 seconds and 4 git commands to generate.