]> git.pld-linux.org Git - packages/samba.git/blob - samba.spec
- Updated %changelog
[packages/samba.git] / samba.spec
1 Summary:        SMB client and server
2 Summary(pl):    Klient i serwer SMB
3 Name:           samba
4 Version:        2.0.3
5 Release:        2
6 Copyright:      GPL
7 Group:          Networking/Daemons
8 Group(pl):      Sieciowe/Serwery
9 Source0:        ftp://samba.anu.edu.au/pub/samba/%{name}-%{version}.tar.gz
10 Source1:        %{name}.PLD.tar.bz2
11 Patch0:         %{name}-glibc2.1.patch
12 Patch1:         %{name}-config.patch
13 Patch2:         %{name}-cap.patch
14 Prereq:         /sbin/chkconfig 
15 Prereq:         fileutils
16 Requires:       pam >= 0.66 
17 #Requires:      krb5-lib >= 1.0.5
18 BuildRoot:      /tmp/%{name}-%{version}-root
19
20 %description
21 Samba provides an SMB server which can be used to provide
22 network services to SMB (sometimes called "Lan Manager")
23 clients, including various versions of MS Windows, OS/2,
24 and other Linux machines. Samba also provides some SMB
25 clients, which complement the built-in SMB filesystem
26 in Linux. Samba uses NetBIOS over TCP/IP (NetBT) protocols
27 and does NOT need NetBEUI (Microsoft Raw NetBIOS frame)
28 protocol.
29
30 This release is known as the "Locking Update" and has full
31 support for Opportunistic File Locking. In addition this update
32 includes native support for Microsoft encrypted passwords,
33 improved browse list and WINS database management.
34
35 Please refer to the WHATSNEW.txt document for fixup information.
36 This binary release includes encrypted password support.
37 Please read the smb.conf file and ENCRYPTION.txt in the
38 docs directory for implementation details.
39
40 %description -l pl
41 Samba udostêpnia serwer SMB, który mo¿e byæ u¿yty w celu dostarczenia
42 us³ug sieciowych (potocznie zwanych "Lan Manager"), dla klientów takich
43 jak MS Windows, OS/2 a tak¿e maszyn linuxowych.  W pakiecie znajduje siê
44 równie¿ oprogramowanie klienckie. Samba u¿ywa protoko³u NetBIOS po TCP/IP
45 (NetBT) i nie wymaga protoko³u NetBEUI. Ta wersja ma pe³ne wsparcie dla
46 blokowania plików, a tak¿e wsparcie dla kodowania hase³ w standardzie
47 MS i zarzadzania baz± WINS.
48
49 UWAGA: w przeciwieñstwie do wersji 2.0.2 aktualnie samba pozbawiona jest
50 mozliwo¶ci kontrolowania domeny NT.
51
52 %package -n swat
53 Summary:        Samba Web Administration Tool
54 Summary(pl):    Narzêdzie administracyjne serwisu Samba
55 Group:          Networking/Admin
56 Group(pl):      Sieciowe/Administacyjne
57 Requires:       %{name}
58
59 %description -n swat
60 swat allows a Samba administrator to configure the complex smb.conf
61 file via a Web browser. In addition, a swat configuration page has
62 help links to all the configurable options in the smb.conf file
63 allowing an administrator to easily look up the effects of any change.
64
65 swat is run from inetd
66
67 %description -n swat -l pl
68 swat pozwala na kompleksow± konfiguracjê smb.conf przy pomocy przegl±darki
69 internetowej.
70
71 %prep
72 %setup -q -a1
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76
77 %build
78 cd source
79 autoconf
80 LDFLAGS="-s" export LDFLAGS \
81     %configure \
82         --prefix=/usr \
83         --sysconfdir=/etc/samba \
84         --sbindir=/usr/sbin \
85         --bindir=/usr/bin \
86         --with-privatedir=/etc/samba \
87         --libdir=/etc/samba \
88         --localstatedir=/var \
89         --with-swatdir=/usr/share/swat \
90         --with-smbmount \
91         --with-smbwrapper \
92         --with-quotas \
93         --with-syslog \
94         --with-automount 
95 #       --with-krb5=/usr \
96         
97 make all smbwrapper bin/smbrun bin/debug2html
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT/etc/samba/codepages/src
104 install -d $RPM_BUILD_ROOT/etc/{logrotate.d,pam.d,sysconfig}
105 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
106 install -d $RPM_BUILD_ROOT/home/samba
107 install -d $RPM_BUILD_ROOT/lib/security
108 install -d $RPM_BUILD_ROOT/usr/{bin,sbin}
109 install -d $RPM_BUILD_ROOT/usr/man/{man1,man5,man7,man8}
110 install -d $RPM_BUILD_ROOT/var/lock/samba
111 install -d $RPM_BUILD_ROOT/var/log/samba
112 install -d $RPM_BUILD_ROOT/var/spool/samba
113 install -d $RPM_BUILD_ROOT/usr/share/swat/{include,images,help}
114
115 ( cd source;
116 make prefix=$RPM_BUILD_ROOT/usr \
117     BASEDIR=$RPM_BUILD_ROOT/usr \
118     BINDIR=$RPM_BUILD_ROOT/usr/bin \
119     SBINDIR=$RPM_BUILD_ROOT/usr/sbin \
120     LIBDIR=$RPM_BUILD_ROOT/etc/samba \
121     PRIVATEDIR=$RPM_BUILD_ROOT/etc/samba \
122     SWATDIR=$RPM_BUILD_ROOT/usr/share/swat \
123     VARDIR=$RPM_BUILD_ROOT/var \
124     install
125 )
126
127 install  source/codepages/codepage_def.* \
128     $RPM_BUILD_ROOT/etc/samba/codepages/src
129
130 install  packaging/PLD/smb.conf         $RPM_BUILD_ROOT/etc/samba
131 install  packaging/PLD/smbusers         $RPM_BUILD_ROOT/etc/samba
132 install  packaging/PLD/smbprint         $RPM_BUILD_ROOT/usr/bin
133 install  packaging/PLD/smbadduser       $RPM_BUILD_ROOT/usr/bin
134 install  packaging/PLD/findsmb          $RPM_BUILD_ROOT/usr/bin
135 install  packaging/PLD/smb.init         $RPM_BUILD_ROOT/etc/rc.d/init.d/smb
136 install  packaging/PLD/samba.pam        $RPM_BUILD_ROOT/etc/pam.d/samba
137 install  packaging/PLD/samba.log        $RPM_BUILD_ROOT/etc/logrotate.d/samba
138
139 install -s source/bin/*.so      $RPM_BUILD_ROOT/lib/security
140 install -s source/bin/{smbsh,smbrun,debug2html} $RPM_BUILD_ROOT/usr/bin
141
142 touch $RPM_BUILD_ROOT/var/lock/samba/{STATUS..LCK,wins.dat,browse.dat}
143
144 echo 127.0.0.1 localhost > $RPM_BUILD_ROOT/etc/samba/lmhosts
145
146 echo "NICELEVEL=+5" > $RPM_BUILD_ROOT/etc/sysconfig/samba
147
148 for i in 437 737 850 852 861 866 932 949 950 936; do
149 $RPM_BUILD_ROOT/usr/bin/make_smbcodepage c $i \
150 $RPM_BUILD_ROOT/etc/samba/codepages/src/codepage_def.$i \
151 $RPM_BUILD_ROOT/etc/samba/codepages/codepage.$i; done
152
153 gzip -9fn $RPM_BUILD_ROOT/usr/man/man[1578]/* \
154         README Manifest WHATSNEW.txt Roadmap docs/*.reg swat/README
155
156 %post
157 /sbin/chkconfig --add smb
158
159 %post -n swat
160 # Not for PLD
161 #if !( grep ^[:space:]*swat /etc/services > /dev/null ) then
162 #echo 'swat     901/tcp         # Swat service used via inetd' >> /etc/services
163 #fi
164
165 # Not for PLD 
166 #if !( grep ^[:space:]*swat /etc/inetd.conf > /dev/null ) then
167 #echo 'swat     stream  tcp     nowait.400      root    /usr/sbin/swat swat' >> /etc/inetd.conf
168 #killall -HUP inetd >&2
169 #fi
170
171 %preun
172 if [ $1 = 0 ]; then
173     /etc/rc.d/init.d/smb stop >&2
174     /sbin/chkconfig --del smb
175 fi
176
177 %preun -n swat
178 #if [ $1 = 0 ]; then
179 # Not for PLD 
180 #    cd /etc
181 #    tmpfile=/etc/tmp.$$
182 #    sed -e '/^[:space:]*swat.*$/d' /etc/inetd.conf > $tmpfile
183 #    mv $tmpfile inetd.conf
184 #    sed -e '/^[:space:]*swat.*$/d' /etc/services > $tmpfile
185 #    mv $tmpfile services
186 #fi
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %files
192 %defattr(644,root,root,755)
193 %doc README.gz Manifest.gz WHATSNEW.txt.gz
194 %doc Roadmap.gz docs/faq/*.html docs/*.reg.gz 
195
196 %attr(755,root,root) /usr/bin/*
197 %attr(755,root,root) /usr/sbin/nmbd
198 %attr(755,root,root) /usr/sbin/smbd
199
200
201 %dir /etc/samba
202 %config(noreplace) %verify(not size mtime md5) /etc/samba/smb.conf
203 %attr(600,root,root) %config(noreplace) %verify(not size mtime md5) /etc/samba/smbusers
204 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/samba/lmhosts
205
206 %attr(750,root,root) /etc/rc.d/init.d/smb
207 %attr(640,root,root) %config %verify(not size mtime md5) /etc/sysconfig/samba
208 %attr(640,root,root) /etc/logrotate.d/samba
209 %attr(640,root,root) /etc/pam.d/samba
210
211 %attr(755,root,root) /lib/security/*.so
212
213 /usr/man/man[157]/*
214 /usr/man/man8/nmbd.8.gz
215 /usr/man/man8/smbd.8.gz
216 /usr/man/man8/smbmnt.8.gz
217 /usr/man/man8/smbmount.8.gz
218 /usr/man/man8/smbpasswd.8.gz
219 /usr/man/man8/smbumount.8.gz
220
221 %dir /home/samba
222 /etc/samba/codepages
223
224 %dir /var/lock/samba
225 %ghost /var/lock/samba/*
226
227 %attr(0750,root,root) %dir /var/log/samba
228 %attr(1777,root,root) %dir /var/spool/samba
229
230 %files -n swat
231 %defattr(644,root,root,755)
232 %doc swat/README.gz
233 %attr(755,root,root) /usr/sbin/swat
234 /usr/share/swat
235 /usr/man/man8/swat.8.gz
236
237
238 %changelog
239 * Wed Apr 14 1999 Artur Frysiak <wiget@pld.org.pl>
240   [2.0.3-2]
241 - Changed group to Networking/Daemons
242 - Changed name of source1
243 - Added swat subpackage
244 - Used %%configure macro
245 - Correct one typo in configure args
246 - Added --with-syslog and --with-automount to configure
247 - Added /etc/sysconfig/samba (allow set nice level of [sn]mbd )
248 - Removed %%config from /etc/rc.d/init.d/smb
249 - Removed manuly install man and swat ( make install do it)
250 - Install smbrun and debug2html
251 - Fixed lmhosts files
252 - Added noreplace to config files
253 - Added %%ghost macro to state files 
254
255 * Sun Mar 28 1999 Ziemek Borowski <zmb@ziembor.waw.pl>
256 [2.0.3] 
257 - updated to 2.0.3 (change in samba.2.0.3.patch file)
258 - removed kerberos support
259
260 * Tue Jan 26 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
261   [2.2.0-1d]
262 - updated to new version,
263 - added Group(pl),
264 - added patch against GNU libc-2.1 -- prepared by Paul Laufer
265   http://www.cspupomona.edu/~pelaufer/samba,
266 - some other changes ...
267
268 * Wed Aug 05 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
269   [1.9.18p8-1d]
270 - build against glibc-2.1,
271   patch prepared by Paul Laufer <PELaufer@csupomona.edu>
272   http://www.netcom.com/~mlaufer/samba,
273 - translation modified for pl,
274 - build with Kerberos V support,
275 - moved %changelog at the end of spec,
276 - build from non root's acccount,
277 - changed permisions of binaries to 755,
278 - moved config files to /etc/samba instead /etc,
279 - added a sticky bit on /var/spool/samba,
280 - minor modifications of spec.
281
282 * Sat Jul 4 1998 John H Terpstra <jht@samba.anu.edu.au>
283   - changed classification of codepage source files
284   - altered installation of samba system files
285   - modified doc handling (removed attribute setting parameters)
286
287 * Sat Jun 13 1998 John H Terpstra <jht@samba.anu.edu.au>
288   - Added code pages 737 and 861 to files section
289   - Added auto-generation of empty /etc/lmhosts file if not exist
290   - Always zap and create empty /var/lock/samba/STATUS..LCK file
291
292 * Wed Jun 10 1998 John H Terpstra <jht@samba.anu.edu.au>
293   - Updated version info for 1.9.18p8 release
294   - updated codepage support for pages 737 861
295
296 * Sun Apr 26 1998 John H Terpstra <jht@samba.anu.edu.au>
297   - minor tidy up in preparation for release of 1.9.18p5
298   - added findsmb utility from SGI package
299
300 * Wed Mar 18 1998 John H Terpstra <jht@samba.anu.edu.au>
301   - Updated version and codepage info.
302   - Release to test name resolve order
303
304 * Sat Jan 24 1998 John H Terpstra <jht@samba.anu.edu.au>
305  - Many optimisations (some suggested by Manoj Kasichainula <manojk@io.com>
306   - Use of chkconfig in place of individual symlinks to /etc/rc.d/init/smb
307   - Compounded make line
308   - Updated smb.init restart mechanism
309   - Use compound mkdir -p line instead of individual calls to mkdir
310   - Fixed smb.conf file path for log files
311   - Fixed smb.conf file path for incoming smb print spool directory
312   - Added a number of options to smb.conf file
313   - Added smbadduser command (missed from all previous RPMs) - Doooh!
314   - Added smbuser file and smb.conf file updates for username map
This page took 0.076909 seconds and 3 git commands to generate.