]> git.pld-linux.org Git - packages/ruby-stud.git/commitdiff
new, version 0.0.21 auto/th/ruby-stud-0.0.21-1
authorElan Ruusamäe <glen@delfi.ee>
Tue, 25 Aug 2015 12:24:16 +0000 (15:24 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Tue, 25 Aug 2015 12:24:35 +0000 (15:24 +0300)
ruby-stud.spec [new file with mode: 0644]

diff --git a/ruby-stud.spec b/ruby-stud.spec
new file mode 100644 (file)
index 0000000..478446e
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Conditional build:
+%bcond_without tests           # build without tests
+
+%define        pkgname stud
+Summary:       stud - common code techniques
+Name:          ruby-%{pkgname}
+Version:       0.0.21
+Release:       1
+License:       GPL v2+ or Ruby
+Group:         Development/Languages
+Source0:       http://rubygems.org/downloads/%{pkgname}-%{version}.gem
+# Source0-md5: 3439c86e911782f21921ca2fc8c9c268
+URL:           https://github.com/jordansissel/ruby-stud
+BuildRequires: rpm-rubyprov
+BuildRequires: rpmbuild(macros) >= 1.656
+%if %{with tests}
+BuildRequires: ruby-insist
+BuildRequires: ruby-rspec
+%endif
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Small reusable bits of code I'm tired of writing over and over. A
+library form of my software-patterns Github repo.
+
+%prep
+%setup -q -n %{pkgname}-%{version}
+
+%build
+# write .gemspec
+%__gem_helper spec
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
+cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
+cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%{ruby_vendorlibdir}/%{pkgname}
+%{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.133799 seconds and 4 git commands to generate.