]> git.pld-linux.org Git - packages/ruby-pkg-config.git/blob - ruby-pkg-config.spec
33000caeda6bb41f34652b662324b9b45a77b1cf
[packages/ruby-pkg-config.git] / ruby-pkg-config.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname pkg-config
6 Summary:        pkg-config module for Ruby
7 Summary(pl.UTF-8):      Moduł pkg-config dla języka Ruby
8 Name:           ruby-%{pkgname}
9 Version:        1.1.5
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Development/Languages
13 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
14 # Source0-md5:  c32204c8d6f0d1cae84f6c67b3e0fd92
15 URL:            https://github.com/ruby-gnome2/pkg-config
16 BuildRequires:  pkgconfig
17 BuildRequires:  rpm-rubyprov
18 BuildRequires:  rpmbuild(macros) >= 1.656
19 %if %{with tests}
20 BuildRequires:  ruby-bundler
21 BuildRequires:  ruby-rake
22 BuildRequires:  ruby-test-unit
23 BuildRequires:  ruby-test-unit-notify
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 pkg-config module for Ruby.
30
31 %description -l pl.UTF-8
32 Moduł pkg-config dla języka Ruby.
33
34 %prep
35 %setup -q -n %{pkgname}-%{version}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{ruby_vendorlibdir}
40 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc NEWS README.rdoc
48 %{ruby_vendorlibdir}/%{pkgname}.rb
49 %{ruby_vendorlibdir}/%{pkgname}
This page took 0.04718 seconds and 2 git commands to generate.