]> git.pld-linux.org Git - packages/ruby-ncurses.git/blob - ruby-ncurses.spec
6d6bb1301dd2777ad046cdb2512e2bacd51747d5
[packages/ruby-ncurses.git] / ruby-ncurses.spec
1 %define pkgname ncurses
2 Summary:        Ruby interface to Ncurses
3 Summary(pl.UTF-8):      Interfejs Ncurses dla Ruby
4 Name:           ruby-%{pkgname}
5 Version:        1.3.1
6 Release:        3
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        https://sourceforge.net/projects/ncurses-ruby.berlios/files/%{pkgname}-ruby-%{version}.tar.bz2
10 # Source0-md5:  63fd3d09a51cdd745e1ed37f85621ea2
11 Patch0:         %{name}-utf8.patch
12 Patch1:         format-security.patch
13 Patch2:         ruby-ncurses-fix-missing-tz-prototypes.patch
14 URL:            https://sourceforge.net/projects/ncurses-ruby.berlios/
15 BuildRequires:  ncurses-devel
16 BuildRequires:  rpm-rubyprov
17 BuildRequires:  rpmbuild(macros) >= 1.665
18 BuildRequires:  ruby-devel
19 Provides:       ruby-Ncurses
20 Obsoletes:      ruby-Ncurses
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This ruby extension makes most functions, constants, and external
25 variables of the C library ncurses accessible from the Ruby
26 programming language.
27
28 All C functions are wrapped by module functions of a the module
29 "Ncurses", with exactly the same name. Additionally, C functions
30 expecting a WINDOW* as their first argument can also be called as
31 methods of the "Ncurses::WINDOW" class.
32
33 %description -l pl.UTF-8
34 Rozszerzenie do ruby, które umożliwia dostęp do większość funkcji,
35 stałych i zewnętrznych zmiennych biblioteki ncurses z poziomu języka
36 Ruby.
37
38 Wszystkie funkcje C są dostępne poprzez funkcje modułu "Ncurses" pod
39 dokładnie tymi samymi nazwami. Dodatkowo funkcje, które spodziewają
40 się mieć WINDOW* jako ich pierwszy argument mogą być także wywoływane
41 jako metody klasy "Ncurses::WINDOW".
42
43 %package rdoc
44 Summary:        HTML documentation for %{pkgname}
45 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
46 Group:          Documentation
47 Requires:       ruby >= 1:1.8.7-4
48
49 %description rdoc
50 HTML documentation for %{pkgname}.
51
52 %description rdoc -l pl.UTF-8
53 Dokumentacja w formacie HTML dla %{pkgname}.
54
55 %package ri
56 Summary:        ri documentation for %{pkgname}
57 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
58 Group:          Documentation
59 Requires:       ruby
60
61 %description ri
62 ri documentation for %{pkgname}.
63
64 %description ri -l pl.UTF-8
65 Dokumentacji w formacie ri dla %{pkgname}.
66
67 %prep
68 %setup -q -n %{pkgname}-ruby-%{version}
69 %patch0 -p1
70 %patch1 -p1
71 %patch2 -p1
72
73 %build
74 ruby extconf.rb \
75         --vendor
76
77 %{__make} \
78         CC="%{__cc}" \
79         CFLAGS="%{rpmcflags} -I/usr/include/ncursesw -fPIC"
80
81 rdoc --ri --op ri lib
82 rdoc --op rdoc lib
83 rm ri/created.rid
84 rm ri/cache.ri
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{ruby_ridir},%{ruby_rdocdir}}
89
90 %{__make} -j1 install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
94 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %files
100 %defattr(644,root,root,755)
101 %doc README
102 %{ruby_vendorlibdir}/ncurses.rb
103 %{ruby_vendorlibdir}/ncurses_sugar.rb
104 %attr(755,root,root) %{ruby_vendorarchdir}/ncurses_bin.so
105
106 %files rdoc
107 %defattr(644,root,root,755)
108 %{ruby_rdocdir}/%{name}-%{version}
109
110 %files ri
111 %defattr(644,root,root,755)
112 %{ruby_ridir}/Ncurses
This page took 0.030914 seconds and 2 git commands to generate.