]> git.pld-linux.org Git - packages/ruby-io-like.git/blob - ruby-io-like.spec
desc/summary from homepage
[packages/ruby-io-like.git] / ruby-io-like.spec
1 %define pkgname io-like
2 Summary:        IO::Like - in the Likeness of IO
3 Name:           ruby-%{pkgname}
4 Version:        0.3.0
5 Release:        1
6 License:        GPL v2+ or Ruby
7 Group:          Development/Languages
8 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
9 # Source0-md5:  7a16ea4dfd897a9af9855d19416f3e4a
10 URL:            http://io-like.rubyforge.org/
11 BuildRequires:  rpm-rubyprov
12 BuildRequires:  rpmbuild(macros) >= 1.656
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The IO::Like module provides all of the methods of typical IO
18 implementations such as File; most importantly the read, write, and
19 seek series of methods. A class which includes IO::Like needs to
20 provide only a few methods in order to enable the higher level
21 methods. Buffering is automatically provided by default for the
22 methods which normally provide it in IO.
23
24 %prep
25 %setup -q -n %{pkgname}-%{version}
26
27 %build
28 # write .gemspec
29 %__gem_helper spec
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
34 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
35 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %dir %{ruby_vendorlibdir}/io
43 %{ruby_vendorlibdir}/io/like.rb
44 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.065203 seconds and 3 git commands to generate.