]> git.pld-linux.org Git - packages/ruby-activerecord.git/blob - ruby-activerecord.spec
- fix time bug with all-zeroes times
[packages/ruby-activerecord.git] / ruby-activerecord.spec
1 %define ruby_rubylibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
2 %define ruby_ridir      %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"])')
3 %define ruby_version    %(ruby -r rbconfig -e 'print Config::CONFIG["ruby_version"]')
4 Summary:        Object-Relational mapping library for Ruby
5 Summary(pl):    Biblioteka odwzorowañ obiektowo-relacyjnych dla Ruby
6 Name:           ruby-ActiveRecord
7 %define tarname active_record
8 Version:        0.5
9 Release:        0.1
10 License:        Ruby-alike
11 Group:          Development/Languages
12 Source0:        http://rubyforge.org/download.php/358/%{tarname}-%{version}.tgz
13 # Source0-md5:  49768acdfed8b28f3c75fa5fec6e3f33
14 Patch0: %{name}-mysql.patch
15 URL:            http://activerecord.rubyforge.org/
16 BuildRequires:  ruby
17 Requires:       ruby
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This pachage contains Object-Relational mapping library for Ruby.
23
24 %description -l pl
25 Ten pakiet zawiera bibliotekê odwzorowañ obiektowo-relacyjnych dla
26 Ruby.
27
28 %prep
29 %setup -q -n %{tarname}-%{version}
30 %patch0 -p1
31
32 %build
33 rm lib/%{tarname}/fixtures.rb
34 rdoc --ri --op ri lib
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 mkdir -p $RPM_BUILD_ROOT/{%{ruby_rubylibdir},%{ruby_ridir}}
39 cp -a lib/* $RPM_BUILD_ROOT/%{ruby_rubylibdir}
40 cp -a ri/ri/* $RPM_BUILD_ROOT/%{ruby_ridir}
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc doc/*
48 %{ruby_rubylibdir}/*
49 %{_datadir}/ri/%{ruby_version}/ActiveRecord
This page took 2.796938 seconds and 4 git commands to generate.