]> git.pld-linux.org Git - packages/ruby-activerecord.git/blob - ruby-activerecord.spec
- up to 1.11.0
[packages/ruby-activerecord.git] / ruby-activerecord.spec
1 #
2 # TODO
3
4 # - rip out vendor libraries: mysql.rb, sqlite.rb, simple.rb
5 #
6 %define ruby_rubylibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
7 %define ruby_ridir      %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"])')
8 %define ruby_version    %(ruby -r rbconfig -e 'print Config::CONFIG["ruby_version"]')
9 Summary:        Object-Relational mapping library for Ruby
10 Summary(pl):    Biblioteka odwzorowañ obiektowo-relacyjnych dla Ruby
11 Name:           ruby-ActiveRecord
12 %define tarname activerecord
13 Version:        1.11.0
14 Release:        1
15 License:        Ruby-alike
16 Group:          Development/Languages
17 Source0:        http://rubyforge.org/frs/download.php/5111/%{tarname}-%{version}.tgz
18 # Source0-md5:  caaa795595cb012890a811167f184b3f
19 Patch0: %{name}-sanity.patch
20 uRL:            http://activerecord.rubyonrails.org/
21 BuildRequires:  ruby
22 Requires:       ruby
23 Requires: ruby-ActiveSupport
24 Requires: ruby-transaction-simple
25 #BuildArch:     noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This pachage contains Object-Relational mapping library for Ruby.
30
31 %description -l pl
32 Ten pakiet zawiera bibliotekê odwzorowañ obiektowo-relacyjnych dla
33 Ruby.
34
35 %prep
36 %setup -q -n %{tarname}-%{version}
37 %patch0 -p1
38
39 %build
40 rm lib/active_record/vendor -r
41 rdoc --ri --op ri lib
42 rdoc --op rdoc lib
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 mkdir -p $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir}}
47 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
48 cp -a ri/ri/* $RPM_BUILD_ROOT%{ruby_ridir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc rdoc README
56 %{ruby_rubylibdir}/*
57 %{ruby_ridir}/ActiveRecord
This page took 0.040653 seconds and 4 git commands to generate.