]> git.pld-linux.org Git - packages/ruby-activerecord.git/blob - ruby-activerecord.spec
- x32 rebuild
[packages/ruby-activerecord.git] / ruby-activerecord.spec
1 %define pkgname activerecord
2 Summary:        Object-Relational mapping library for Ruby
3 Summary(pl.UTF-8):      Biblioteka odwzorowań obiektowo-relacyjnych dla Ruby
4 Name:           ruby-%{pkgname}
5 Version:        3.2.19
6 Release:        2
7 License:        Ruby-alike
8 Group:          Development/Languages
9 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
10 # Source0-md5:  2e60941e3c5080df05c51de2e2d7b328
11 URL:            http://rubyforge.org/projects/activerecord/
12 BuildRequires:  rpmbuild(macros) >= 1.277
13 BuildRequires:  ruby >= 1:1.8.6
14 BuildRequires:  ruby-modules
15 %{?ruby_mod_ver_requires_eq}
16 Requires:       ruby-activesupport >= 3.2.0
17 Requires:       ruby-activemodel >= 3.2.0
18 Obsoletes:      ruby-ActiveRecord
19 Provides:       ruby-ActiveRecord
20 #BuildArch:     noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 # nothing to be placed there. we're not noarch only because of ruby packaging
24 %define         _enable_debug_packages  0
25
26 %description
27 This package contains Object-Relational mapping library for Ruby.
28
29 %description -l pl.UTF-8
30 Ten pakiet zawiera bibliotekę odwzorowań obiektowo-relacyjnych dla
31 Ruby.
32
33 %package rdoc
34 Summary:        Documentation files for ActiveRecord
35 Summary(pl.UTF-8):      Dokumentacja do biblioteki ActiveRecord
36 Group:          Documentation
37 Requires:       ruby >= 1:1.8.7-4
38
39 %description rdoc
40 Documentation files for ActiveRecord.
41
42 %description rdoc -l pl.UTF-8
43 Dokumentacja do biblioteki ActiveRecord.
44
45 %package ri
46 Summary:        ri documentation for %{pkgname}
47 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
48 Group:          Documentation
49 Requires:       ruby
50
51 %description ri
52 ri documentation for %{pkgname}.
53
54 %description ri -l pl.UTF-8
55 Dokumentacji w formacie ri dla %{pkgname}.
56
57 %prep
58 %setup -q -n %{pkgname}-%{version}
59
60 %build
61 # write .gemspec
62 %__gem_helper spec
63
64 rdoc --ri --op ri lib
65 rdoc --op rdoc lib
66 rm -rf ri/{Fixture*,I18n,MysqlCompat,PGresult,Test,YAML}
67 rm ri/created.rid
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
72
73 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
74 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
75 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{pkgname}-%{version}-%{release}
76
77 # install gemspec
78 install -d $RPM_BUILD_ROOT%{ruby_specdir}
79 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %doc CHANGELOG.md README.rdoc examples
87 %{ruby_rubylibdir}/active_record
88 %{ruby_rubylibdir}/active_record.rb
89 %{ruby_rubylibdir}/rails/generators/active_record.rb
90 %{ruby_rubylibdir}/rails/generators/active_record
91 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
92
93 %files rdoc
94 %defattr(644,root,root,755)
95 %{ruby_rdocdir}/%{pkgname}-%{version}-%{release}
96
97 %files ri
98 %defattr(644,root,root,755)
99 %{ruby_ridir}/ActiveRecord
This page took 0.339301 seconds and 4 git commands to generate.