]> git.pld-linux.org Git - packages/ruby-activerecord.git/blob - ruby-activerecord.spec
- up to 1.12.1
[packages/ruby-activerecord.git] / ruby-activerecord.spec
1 #
2 # TODO
3 # - rip out vendor libraries: mysql.rb, sqlite.rb, simple.rb
4 #
5 %define ruby_rubylibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
6 %define ruby_ridir      %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"])')
7 %define ruby_version    %(ruby -r rbconfig -e 'print Config::CONFIG["ruby_version"]')
8 Summary:        Object-Relational mapping library for Ruby
9 Summary(pl):    Biblioteka odwzorowañ obiektowo-relacyjnych dla Ruby
10 Name:           ruby-ActiveRecord
11 %define tarname activerecord
12 Version:        1.12.1
13 Release:        1
14 License:        Ruby-alike
15 Group:          Development/Languages
16 Source0:        http://rubyforge.org/frs/download.php/6569/%{tarname}-%{version}.tgz
17 # Source0-md5:  225d3df8fe7a554dfea1a75e91e2605d
18 Patch0:         %{name}-sanity.patch
19 URL:            http://activerecord.rubyonrails.org/
20 BuildRequires:  ruby
21 Requires:       ruby
22 Requires:       ruby-ActiveSupport
23 Requires:       ruby-transaction-simple
24 #BuildArch:     noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This pachage contains Object-Relational mapping library for Ruby.
29
30 %description -l pl
31 Ten pakiet zawiera bibliotekê odwzorowañ obiektowo-relacyjnych dla
32 Ruby.
33
34 %prep
35 %setup -q -n %{tarname}-%{version}
36 %patch0 -p1
37
38 %build
39 rm lib/active_record/vendor -r
40 rdoc --ri --op ri lib
41 rdoc --op rdoc lib
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir}}
46 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
47 cp -a ri/ri/* $RPM_BUILD_ROOT%{ruby_ridir}
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc rdoc README
55 %{ruby_rubylibdir}/*
56 %{ruby_ridir}/ActiveRecord
This page took 0.071419 seconds and 4 git commands to generate.