]> git.pld-linux.org Git - packages/ruby-activemodel.git/blob - ruby-activemodel.spec
- initial revision
[packages/ruby-activemodel.git] / ruby-activemodel.spec
1 %define pkgname activemodel
2 Summary:        Extracts common modeling concerns from ActiveRecord
3 Name:           ruby-%{pkgname}
4 Version:        3.0.0
5 Release:        0.beta.1
6 License:        Ruby-alike
7 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.beta.gem
8 # Source0-md5:  1e3d6f39257ff72c1861f74f110f3e38
9 Group:          Development/Languages
10 URL:            http://rubyforge.org/projects/activeresource/
11 BuildRequires:  rpmbuild(macros) >= 1.484
12 BuildRequires:  ruby >= 1:1.8.6
13 BuildRequires:  ruby-modules
14 Requires:       ruby-activesupport >= 3.0.0
15 %{?ruby_mod_ver_requires_eq}
16 #BuildArch:     noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 # nothing to be placed there. we're not noarch only because of ruby packaging
20 %define         _enable_debug_packages  0
21
22 %description
23 Extracts common modeling concerns from ActiveRecord to share
24 between similar frameworks like ActiveResource.
25
26 %package rdoc
27 Summary:        Documentation files for %{pkgname}
28 Group:          Documentation
29 Requires:       ruby >= 1:1.8.7-4
30
31 %description rdoc
32 Documentation files for %{pkgname}.
33
34 %package ri
35 Summary:        ri documentation for %{pkgname}
36 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
37 Group:          Documentation
38 Requires:       ruby
39
40 %description ri
41 ri documentation for %{pkgname}.
42
43 %description ri -l pl.UTF-8
44 Dokumentacji w formacie ri dla %{pkgname}.
45
46 %prep
47 %setup -q -c
48 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
49 find -newer README  -o -print | xargs touch --reference %{SOURCE0}
50
51 %build
52 rdoc --ri --op ri lib
53 rdoc --op rdoc lib
54 rm ri/created.rid
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
59
60 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
61 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
62 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{pkgname}-%{version}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc CHANGELOG README
70 %{ruby_rubylibdir}/active_model.rb
71 %{ruby_rubylibdir}/active_model
72
73 %files rdoc
74 %defattr(644,root,root,755)
75 %{ruby_rdocdir}/%{pkgname}-%{version}
76
77 %files ri
78 %defattr(644,root,root,755)
79 %{ruby_ridir}/ActiveModel
This page took 0.097891 seconds and 3 git commands to generate.