]> git.pld-linux.org Git - packages/rtmidi.git/blob - rtmidi.spec
new package
[packages/rtmidi.git] / rtmidi.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa            # build without ALSA backend
4 %bcond_without  jack            # build without Jack backend
5 #
6 Summary:        Common API for realtime MIDI input/output
7 Name:           rtmidi
8 Version:        3.0.0
9 Release:        1
10 License:        MIT
11 Group:          Applications
12 Source0:        http://www.music.mcgill.ca/~gary/rtmidi/release/%{name}-%{version}.tar.gz
13 # Source0-md5:  d22e3a5dee972fa0725c420923f1ce65
14 URL:            http://music.mcgill.ca/%7Egary/rtmidi/
15 %{?with_alsa:BuildRequires:     alsa-lib-devel}
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 %{?with_jack:BuildRequires:     jack-audio-connection-kit-devel}
19 BuildRequires:  libtool
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 RtMidi is a set of C++ classes (RtMidiIn, RtMidiOut and API-specific
24 classes) that provides a common API (Application Programming
25 Interface) for realtime MIDI input/output across Linux (ALSA & JACK),
26 Macintosh OS X (CoreMIDI & JACK), and Windows (Multimedia Library)
27 operating systems. RtMidi significantly simplifies the process of
28 interacting with computer MIDI hardware and software. It was designed
29 with the following goals:
30
31 - object oriented C++ design
32 - simple, common API across all supported platforms
33 - only one header and one source file for easy inclusion in
34   programming projects
35 - MIDI device enumeration
36
37 %package devel
38 Summary:        Header files for %{name} library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for %{name} library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki %{name}.
48
49 %package static
50 Summary:        Static %{name} library
51 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static %{name} library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka %{name}.
60
61 %prep
62 %setup -q
63
64 %build
65 #%%{__gettextize}
66 %{__libtoolize}
67 %{__aclocal}
68 %{__autoconf}
69 %{__automake}
70
71 %configure \
72         %{__with jack} \
73         %{__with alsa}
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README.md doc/html
92 %attr(755,root,root) %{_libdir}/librtmidi.so.4.*
93 %ghost %{_libdir}/librtmidi.so.4
94
95 %files devel
96 %defattr(644,root,root,755)
97 %doc doc/html
98 %{_libdir}/librtmidi.la
99 %{_libdir}/librtmidi.so
100 %{_includedir}/%{name}
101 %{_pkgconfigdir}/%{name}.pc
102
103 %files static
104 %defattr(644,root,root,755)
105 %{_libdir}/librtmidi.a
This page took 0.086497 seconds and 3 git commands to generate.